Jump to content

[GUIDE] Retail Snow Leopard Install on Asus EeePC 1000HE


  • Please log in to reply
436 replies to this topic

#101
tritron

tritron

    InsanelyMac Protégé

  • Members
  • Pip
  • 25 posts
Does any one have issues with 10.6.2 upgrade and video card ? Mine was working fine in 10.6.1 but with 10.6.2 I only get 800x600

#102
MoonDogg

MoonDogg

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 105 posts
  • Gender:Male
  • Location:Arkansas

Does any one have issues with 10.6.2 upgrade and video card ? Mine was working fine in 10.6.1 but with 10.6.2 I only get 800x600


How did you install 10.6.2? did the kernel swap?

#103
MoonDogg

MoonDogg

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 105 posts
  • Gender:Male
  • Location:Arkansas

Does any one have issues with 10.6.2 upgrade and video card ? Mine was working fine in 10.6.1 but with 10.6.2 I only get 800x600



Ok.. I just installed 10.6.2 and after much trouble finally back in it... no video problems...

#104
neoson

neoson

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
I went from 10.5.6 to 10.6.2, a clean install, and love it! SL is nice and snappy and everything works... but my audio! Took me a day to realize it. Any one else have this issue or remedy? I used the netbook installer cd and a retail disk to install. Any help would be greatly appreciated.

Thanks

#105
neoson

neoson

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
Oh, and I am running it on a 1000HE. If it helps

#106
MoonDogg

MoonDogg

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 105 posts
  • Gender:Male
  • Location:Arkansas

I went from 10.5.6 to 10.6.2, a clean install, and love it! SL is nice and snappy and everything works... but my audio! Took me a day to realize it. Any one else have this issue or remedy? I used the netbook installer cd and a retail disk to install. Any help would be greatly appreciated.

Thanks



What are the symtoms of the audio? Not working at all? Do you have any options under system preferences? Did you use any of my files? If not.. you can try the extentions.mkext that I provide...

#107
jonshu3000

jonshu3000

    InsanelyMac Protégé

  • Members
  • Pip
  • 18 posts
I'm facing a non-1000he specific issue.

I have a dell mini 9 running 10.5.8.

I'm following your guide and using the mini 9 to install snow leopard on a 16gb Kingston usb drive to test functionality on my 1000he before I format the main hard drive. I used disk utility to make the usb drive 1 partition, mac extended with GUID.

I have 2 problems:
1. I cannot remove packages prior to install (what you mention after step 2.4). When I try moving files to trash I get error code 61. I think it's a permissions issue. I can read & write for the main image, but on the mounted files I can only read.
2. (might be related to 1) My install fails after 30 minutes or so, 3 tries now. Not exactly sure at what stage but after it's copied the main files for sure.

Any help would be appreciated.

#108
MoonDogg

MoonDogg

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 105 posts
  • Gender:Male
  • Location:Arkansas

I'm facing a non-1000he specific issue.

I have a dell mini 9 running 10.5.8.

I'm following your guide and using the mini 9 to install snow leopard on a 16gb Kingston usb drive to test functionality on my 1000he before I format the main hard drive. I used disk utility to make the usb drive 1 partition, mac extended with GUID.

I have 2 problems:
1. I cannot remove packages prior to install (what you mention after step 2.4). When I try moving files to trash I get error code 61. I think it's a permissions issue. I can read & write for the main image, but on the mounted files I can only read.
2. (might be related to 1) My install fails after 30 minutes or so, 3 tries now. Not exactly sure at what stage but after it's copied the main files for sure.

Any help would be appreciated.


When I said I removed the printers and stuff, I meant in the installer itself. I did not remove the actual packages. If you actually removed any of the packages that is probably why your install failed. Try with a fresh virgin image.

#109
neoson

neoson

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
I no audio period, no output no input devices, and nothing shows up in the audio devices in the hardware info about this "Mac". I'll have to try your extentions.mkext later today, but any pointers on top of that would be appreciated. I was never comfortable about tweaking mac, I've botched too many installs of it.

How would I install the extentions.mkext? Its probably a simple question, but I'd like to do it right the first time.

#110
MoonDogg

MoonDogg

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 105 posts
  • Gender:Male
  • Location:Arkansas

I no audio period, no output no input devices, and nothing shows up in the audio devices in the hardware info about this "Mac". I'll have to try your extentions.mkext later today, but any pointers on top of that would be appreciated. I was never comfortable about tweaking mac, I've botched too many installs of it.

How would I install the extentions.mkext? Its probably a simple question, but I'd like to do it right the first time.


Just copy it into the Extra folder on your boot partition.

#111
jonshu3000

jonshu3000

    InsanelyMac Protégé

  • Members
  • Pip
  • 18 posts

When I said I removed the printers and stuff, I meant in the installer itself. I did not remove the actual packages. If you actually removed any of the packages that is probably why your install failed. Try with a fresh virgin image.


OK, pretty stupid of me. Thanks.

I now have netbookinstaller problem:
first of all, I only get a "install dell mini 9 extensions" choice. I don't have a "general extensions" oniee. Maybe it's because I'm running it from a dell mini 9?
Second, more important, it keeps crashing on me. I've restarted twice, and tried safe mode too.

any ideas?

OK, pretty stupid of me. Thanks.

I now have netbookinstaller problem:
first of all, I only get a "install dell mini 9 extensions" choice. I don't have a "general extensions" oniee. Maybe it's because I'm running it from a dell mini 9?
Second, more important, it keeps crashing on me. I've restarted twice, and tried safe mode too.

any ideas?


Update: solved the crash issue by upgrading the dell mini 9 itself to netbookinstaller 0.8.3.
Still don't have a general extensions option. Will try proceeding with the install using only the chameleon bootloader option and rerunning it once I put the HD back in the 1000he.

#112
neoson

neoson

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
I do not see the Extra folder, I found the same file in System/Library/ but its slightly bigger in size. Would I replace that file?

#113
Tenoq

Tenoq

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
I've got 10.6.2 working on my eeePC 1000H. I followed the directions more or less to the letter - but I put the extensions.mkext in the System/Library folder, because I couldn't find anything called 'Extras'.

Sound works, LAN, Wi-fi, BT - all great.

VoodooHDA.prefpane does NOT work. When I try to load it I get the following errors:
Error: Can't map Memory (x2)
VoodooHDA: ERROR
Left hand drop box is blank, selecting 'Item 2' or 'Item 3' gives the Can't map Memory error again.


Any ideas on how to fix it?
Is it because I couldn't find the Extras folder? Please help! Feel like such an amateur with this Mac stuff. :fiery:

#114
neoson

neoson

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
I tried to replace the one in System/library as for the post above but still no luck. In the about this mac it claims there is no built in audio hardware.

#115
jonshu3000

jonshu3000

    InsanelyMac Protégé

  • Members
  • Pip
  • 18 posts
could there be a problem with the extensions.mkext file?

the only way i could load osx on the 1000he is when i run netbook installer selecting the bootloader option and the "install dell mini 9 extensions," as well as the "install old mirror friendly GMA kext."

(Netbook Installer is too smart and only gives "dell mini 9 extensions" option because I'm running it on a hackintosh mini 9. Once I load OSX on the 1000he and run netbookinstaller there I get and option that says general extensions)

Whenever i replace theextensions.mkext file that's already in the extra folder with the file in the guide, I cannot load osx and get a message saying i need to reboot. if i leave the original, it loads fine. After replacing it and getting the reboot screen, I reconnect the HD through USB to the mini9 and ran netbookinstaller again using mini9 extensions - and it worked again.

In other words, putting the extensions.mkext file from the guide doesn't let me load osx (step 4 of the 5 steps). I haven't looked into it yet, but I suspect a lot of stuff is not working properly given that it runs with the mini 9 extensions. I also didn't install the 3 post-install yet.

Moondogg, would love your input and thanks for the great guide.

#116
MoonDogg

MoonDogg

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 105 posts
  • Gender:Male
  • Location:Arkansas

could there be a problem with the extensions.mkext file?

the only way i could load osx on the 1000he is when i run netbook installer selecting the bootloader option and the "install dell mini 9 extensions," as well as the "install old mirror friendly GMA kext."

(Netbook Installer is too smart and only gives "dell mini 9 extensions" option because I'm running it on a hackintosh mini 9. Once I load OSX on the 1000he and run netbookinstaller there I get and option that says general extensions)

Whenever i replace theextensions.mkext file that's already in the extra folder with the file in the guide, I cannot load osx and get a message saying i need to reboot. if i leave the original, it loads fine. After replacing it and getting the reboot screen, I reconnect the HD through USB to the mini9 and ran netbookinstaller again using mini9 extensions - and it worked again.

In other words, putting the extensions.mkext file from the guide doesn't let me load osx (step 4 of the 5 steps). I haven't looked into it yet, but I suspect a lot of stuff is not working properly given that it runs with the mini 9 extensions. I also didn't install the 3 post-install yet.

Moondogg, would love your input and thanks for the great guide.



It is possible that the mkext file is corrupted for some reason.. maybe in transfer... try downloading it again and try... if it still does not work I will reupload it. Also what does it do when it does not load. Does it give you any kernel panic info in the background?

#117
jonshu3000

jonshu3000

    InsanelyMac Protégé

  • Members
  • Pip
  • 18 posts

It is possible that the mkext file is corrupted for some reason.. maybe in transfer... try downloading it again and try... if it still does not work I will reupload it. Also what does it do when it does not load. Does it give you any kernel panic info in the background?


Just redownloaded. still no go. I get a screen saying I need to restart my computer, and below it the top line says

panic(cpu 0 caller 0x2a76e6): "version mis match between kern and CPU PM"@/sourcecache...

Let me suggest a guess. the extensions.mkext file you uploaded supposedly also solves the 10.6.2 issue with the CPU atom. perhaps it only works for 10.6.2 but not for 10.6 (which is what I'm running now)?

#118
Ryutso

Ryutso

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts
I have a similar NetBook, the 1000HD. Could this guide be used on that machine as well?

#119
neoson

neoson

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
If it helps, I had to use this guide http://osx.mechdrew....ides/nbi3.shtml because I do not have a big enough usb drive.

#120
shortbus123

shortbus123

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
UPDATE - figured it out. The extra file can be found here:

Extra


"Copy this extensions.mkext to the Extra's folder of the OS X drive and let it overwrite all files."

Please help. I am not sure why I am having trouble with this step but I can't find the "Extra's folder"

I cant see it anywhere.

It seems like such a stupid question because I am not a mac or pc newbie.

Any help appreciated with explaining what this folder is, where it is located, and if I have to create it etc.

TIA





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy