Jump to content

[GUIDE] Retail Snow Leopard Install on Asus EeePC 1000HE


  • Please log in to reply
436 replies to this topic

#61
MoonDogg

MoonDogg

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 105 posts
  • Gender:Male
  • Location:Arkansas

to MoonDogg: Which hardware is different? CPU? Yes i upgrade ralink wifi card with AirPort Wifi Card from ebay :) (BCM94321MC) works great. So, which hardware maybe don't work? Bluetooth i thinks work, GMA work, Sound? I need fully working with MIC :), so? And i don't have second HDD. I want to try install it over this weekend. I Backup all files, so i can do experiments. :) If don't work, i install Leopard again. :) Please tell me about hardware differencies, THANK YOU :)

... and can work some kext for Leopard under Snow Leopard? Like Bluetooth?


I am not sure if the hardware is different.. I am just saying it can be.. and other people on this forum (not this thread) have had issues with the 1000H the wifi and ethernet might have different chipsets but you have taken care of that with the airport.. the sound card may be different but prolly works with voodohda anyways... I am just saying becarefull and have a backup plan because I have not tested it with that system. Good luck.. I hope it works perfectly for you.

Hi Guys,
Thanks for the guide, it's helped me get a lot further with this install! I have to say it's a little more complicated patching your own disc (compared to the zillions of pre-built discs for 10.5) but the results are much more rewarding!

However, I would like to ask a few questions! (saw that coming eh? :P) Is anyone else experiencing crackly sound? It seems to stop after music has been playing for a few seconds, but it's a little annoying on sound effects. The other major problem I seem to be having is VERY slow ethernet. I have another hackintosh which is running Leopard with no issues, but when I try copy from it onto the Eee, it freaks out and starts transferring at about 1Kb/sec!
One other issue I'd like to point out is I can't seem to get some of the function buttons working. Screen brightness and the sleep button work great, however I can't change the volume from the keyboard. I'm not sure if I'm just missing something obvious, but I don't remember having problems with my MSI Wind in this area.
Thanks for all the hard work guys, it's great to have Snow Leopard on here at last! :)

Sam


hmm lets see.. sound yeah sorta... I have herd it crackel on ocassion.. and my volume is kinda low... I have been looking for any other sound methods and have not found any yet.. I wil diffedently post if it I do..

Ethernet... No mine works perfect.. fast as any other ethernet I have.. I was moving files at 30MB/s (yeah thats megabytes) the other day.. did you install the kext in the S/L/E folder or use the extra's updater? cause I saw the same issues when it was not in the S/L/E.

FN keys do not work... there are scripts you can use to make them work but I have not experimented with them as I don't use the FN keys... except for brightness I have also not found a solution the make them work nativily (with out running external scripts or apps)

#62
Mitch Malone

Mitch Malone

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
  • Gender:Male
  • Location:Sydney, Australia

Mitch Malone: Catchoftheday? :P
I bought one too, been fiddling around with it and I'm having pretty much the same issues. Ethernet was going after I installed the kext, as is Bluetooth, however I'm having no luck at all with the wireless. Are you having the same issues with the blue fn keys?
Frustrating...it's so close yet I know I'll probably keep getting annoyed at it if I can't resolve the keyboard. The wireless I may end up just doing a card swap.


Shambler - totally catchoftheday. I only bought it because I was told it was the easiest netbook around to Hackintosh. I finally got my wireless working after some messing around but if I am honest I am not even quite sure how. All I have left is the Bluetooth, function keys and I am in business. Would love to hit you up on IM and share some experiences if you like?

#63
mozartsql

mozartsql

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts
I realized that the fan is running loudly, do you realize that?

#64
OzTraveller

OzTraveller

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts

Shambler - totally catchoftheday. I only bought it because I was told it was the easiest netbook around to Hackintosh. I finally got my wireless working after some messing around but if I am honest I am not even quite sure how. All I have left is the Bluetooth, function keys and I am in business. Would love to hit you up on IM and share some experiences if you like?


Likewise. I got mine two days ago because of the suitability to run SL and I now pretty much have it stable and working on SL 10.6.1.

Status of things (+working, - not working)
+ Screen 1024x600
+ On board ethernet
+ Native wi-fi (ralink)
+ Keyboard
+ Touchpad (incl two finger scrolling. Very sensitive though)
+ Bluetooth
+ Camera
+ Microphones
+ Speakers
- Function keys at the top
- Hibernate mode (Chameleon won't restore it.)
- Sleep (screen did not come back though more testing necessary)
- Battery and AC power (VoodooBattery is not getting good data or not using it correctly)

I am trying to fix the Battery as a priority and then look at Functions and/or Hibernate. Funny thing one function key that works is ZZZ! But hibernate does not return.

Feedback on any of these things welcome.

I also used a different method to build my image but once working assuming the same boot loader (Chameleon in my case) it does not really matter how you got here. Happy to help out on any info you'd like.

I realized that the fan is running loudly, do you realize that?


Go to Lagoon's site Voodoo kext Files and grab the VoodooPower command-line utility. There is an option in it to report CPU temperatures. Check what they are and maybe look to cool the unit to see it this improves things for you.

Possibly your unit is running hot and the fans are simply working overtime or you may have faulty/noisy fan.

#65
MacVador

MacVador

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts
  • Gender:Male
  • Location:Switzerland
Hi

first, thanx alot for your guide...

now the question... :( i done all that on my 1000H not HE and have issue with sleep.. can restart, power off, can put to sleep BUT when i wakes up it wont power on the display.. can see what's on the screen when bringing some light on the screen can use ma machine by remote from another one but that's all... ;)

noticed just now ... have no options with power button....

could you please help me with that ?

#66
Eagle 4

Eagle 4

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
Thanks for all.

It's working great on OCZ Vertex FW.1.41 :)

Very fast boot...

#67
calimansi

calimansi

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
So I have almost everything working perfectly on my 1000he.

My issue is bluetooth...

Bluetooth works great up until the computer goes to sleep. After that, in order to get bluetooth back I need to restart.

I have installed the IOBluetoothFamily kext.

I read somewhere to try a utility called hid2hci... got it to run, but doesn't change anything.

Any other hints/suggestions to try out?

#68
Amoroso

Amoroso

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts
Thank's for all info!

Almost Perfect!
My boot volume don't show up on desktop; Can any one help?

Thank's

#69
MoonDogg

MoonDogg

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 105 posts
  • Gender:Male
  • Location:Arkansas

So I have almost everything working perfectly on my 1000he.

My issue is bluetooth...

Bluetooth works great up until the computer goes to sleep. After that, in order to get bluetooth back I need to restart.

I have installed the IOBluetoothFamily kext.

I read somewhere to try a utility called hid2hci... got it to run, but doesn't change anything.

Any other hints/suggestions to try out?


How did you install the IOBluetoothFamily kext?


Thank's for all info!

Almost Perfect!
My boot volume don't show up on desktop; Can any one help?

Thank's


Go to Finder Preferences.. Then look under general.. and check Hard Drive under Show these items on desktop.

#70
Amoroso

Amoroso

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts

How did you install the IOBluetoothFamily kext?




Go to Finder Preferences.. Then look under general.. and check Hard Drive under Show these items on desktop.


That´s it! Thank you!

(I Also fixed drivers icons with OrangeHDIconFix files)

#71
Amoroso

Amoroso

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts
Hi

My Asus 1000HE is booting with a external USB disk!

How to make it boot from my internal hard drive?

Thank you

#72
calimansi

calimansi

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
Nevermind. I ran "pmset -g log" and figured out it was Missing Sync causing the 30 second delay. I guess I need to switch over to the iphone to get rid of that one huh...

Thanks for all your hard work!

How did you install the IOBluetoothFamily kext?




Go to Finder Preferences.. Then look under general.. and check Hard Drive under Show these items on desktop.


OK. I just re-copied IOBluetoothFamily and now it works like a charm.

Another problem has risen though...

It's not a big deal, but when I try and put the 1000he to sleep, it takes about 30 seconds to fully execute. This wasn't the case when I first installed SL, but its there now.

If I re-install the extra, iobluetoothfamily and attansicl kext's, it the 30 second wait goes away for a little while, then it comes back.

Any hints?



#73
Abee

Abee

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts
Hi everybody,
Thanks for this guide. I installed SL on a 1000H on external HDD. All is working exept sound. I tried different ktext but no sound.
Do you have an idea ?
Thanks,
Abee

#74
calimansi

calimansi

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
OK Gang,

One more issue.

I don't know if anyone else is experiencing hard drive clunks when the heads on the hard drive park, but I do. I've tried to fix this using a tool called ClunKiller.

On the author's website it mentions that if you are not able to get it to work after installation, then you need to verify that a file called "mach_kernel.ctfsys" exists in / (root directory).

I didn't have a mach_kernel.ctfsys in my root directory so I downloaded the one the author posted on the ClunKiller website. Viewing the system.log it mentions that it cannot run. Here are the details, "

Nov 4 07:14:41 ns-Mac com.apple.SystemStarter[21]: Starting ClunKiller
Nov 4 07:14:42 ns-Mac com.apple.SystemStarter[21]: dtrace: failed to compile script /Library/StartupItems/ClunKiller/Thireus_Trace: "/usr/lib/dtrace/darwin.d", line 282: thread_id is not a member of struct thread
Nov 4 07:14:42 ns-Mac com.apple.SystemStarter[21]: ClunKiller crashed

"

Does anybody out there running a 1000he with snow leopard 10.6.1 have the file mach_kernel.ctfsys in their root directory able to send it over to me?

Thanks.

#75
Amoroso

Amoroso

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts

Hi everybody,
Thanks for this guide. I installed SL on a 1000H on external HDD. All is working exept sound. I tried different ktext but no sound.
Do you have an idea ?
Thanks,
Abee


Hello,

install the VoodooHDA.prefpane just unzip and run file it will install in System Preferences.
Then go to System Pref's VoodooHDA and check the level's for Speaker, set PCM and Output Gain to max.

Good Luck

Carlos

#76
Amoroso

Amoroso

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts
Trackpad Problem.

Trackpad Preferences (Synaptics Trackpad, is this the correct?) don´t work, mouse preferences are controlling the trackpad.

Help!!!!

Thank's

#77
parken

parken

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts

Trackpad Problem.

Trackpad Preferences (Synaptics Trackpad, is this the correct?) don´t work, mouse preferences are controlling the trackpad.

Help!!!!

Thank's


Have a look here and here ; both solutions do not work for me...
If you decide to experiment, you must have a USB mouse and keyboard handy and do not forget to update mkext and clear up cashes.
Let us know.

#78
Abee

Abee

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts

Hello,

install the VoodooHDA.prefpane just unzip and run file it will install in System Preferences.
Then go to System Pref's VoodooHDA and check the level's for Speaker, set PCM and Output Gain to max.

Good Luck

Carlos

Thanks, but after install of VoodooHDA, when I open, it says : Error, can't get registry-entry path. And when after I try to set gain to max, it says : Error Can't open IO Service.
Any other idea ?
Thanks,
Abee

#79
Amoroso

Amoroso

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts

Thanks, but after install of VoodooHDA, when I open, it says : Error, can't get registry-entry path. And when after I try to set gain to max, it says : Error Can't open IO Service.
Any other idea ?
Thanks,
Abee


voodoohda.prefpane need voodoohda.kext installed to work.
Install the file voodoohda.kext then you don´t get the error!

You can do this with either with kexthelper or just copy it over the orginal and then run kext utility.

(Follow the guide, get the files and tools - link's for download)
Tell if work's!

Thanks, but after install of VoodooHDA, when I open, it says : Error, can't get registry-entry path. And when after I try to set gain to max, it says : Error Can't open IO Service.
Any other idea ?
Thanks,
Abee


Let me quote the guide:

"4-Copy this extra folder to the root of the OS X drive and let it overwrite all files. I have updated this with voodoohda.kext that works with the voodoohda.prefpane that you will need to get the mic working."

#80
mandrean

mandrean

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts
  • Gender:Male
  • Location:Göteborg, Sweden

Hi

My Asus 1000HE is booting with a external USB disk!

How to make it boot from my internal hard drive?

Thank you

Download SuperDuper! from http://www.shirt-poc...com/SuperDuper/ and install it to "Finder -> Applications" when booted from the external HDD.

Launch SuperDuper! Choose "Copy: [your external HDD] to: [your internal HDD] using: Restore - all files". Make sure it is from the external TO the internal and not the other way around. Then press "Copy Now".

When finished, rerun NetbookInstaller but this time choose the internal HDD from the drop down list and only choose "Install Chameleon 2 RC3". Nothing else. Press "Install".

When finished, copy, paste and overwrite this folder to the root of your internal HDD.





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy