Jump to content

Asus P6T SE Retail Snow Leopard Installation Guide [FLASHDRIVE] [UPDATED JUN. 28]]


  • Please log in to reply
1278 replies to this topic

#1221
tweak41

tweak41

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 247 posts
  • Gender:Male
  • Location:Los Angeles, CA

Hi Fabio,
Kind of n00b here..
I did the update as you wrote it, but I cannot boot after updating to 10.6.8
The machine just hangs on the grey load screen (with the apple logo) and a "not entry" sign.

Do you have something I can try doing?



Here is a picture of the boot screen in safe mode:


Remove SleepEnabler!

#1222
nudelholz

nudelholz

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts

Update to 10.6.8...

(Some picture show AD2000B because the steps are the same as my other motherboard but the P6T SE have a ALC1200 controller)

1) Update your 10.6.x to 10.6.8 with a combo update dmg file.
Posted Image

2) When the combo update process are finalized, no restart.

3) fireup your terminal /Applications/Utilities/Terminal.app
and enter the following sudo perl -pi -e 's|\x85\x08\xec\x10|\x88\x08\xec\x10|g' /System/Library/Extensions/AppleHDA.kext/Contents/MacOS/AppleHDA
Posted Image

4) Download the Archive it contain 2 file.
Posted Image

5) Navigate to your AppleHDA.kext
Posted Image
right click on that kext and next on Show package/contents
Posted Image

6) A new window will open, navigate into the Contents/Resources folder
Posted Image

7) replace/overwrite the two file from the downloaded archive.

8) Delete the ALC1200.kext (or P6TSE.kext) file from Extra/Extensions
So in your Extra/Extensions you have only FakeSMC.kext :)

9) Use >>THIS<< set of .plist
rename it into Info.plist and replace:
- Yukon2
/System/Library/Extensions/IONetworkingFamily.kext/Contents/PlugIns/AppleYukon2.kext/Contents/Info.plist

- AppleAHCIPort
/System/Library/Extensions/AppleAHCIPort.kext/Contents/Info.plist

- IOAHCIBlockStorage
/System/Library/Extensions/IOAHCIFamily.kext/Contents/PlugIns/IOAHCIBlockStorage.kext/Contents/Info.plist

- JMicronATA
/System/Library/Extensions/JMicronATA.kext/Contents/Info.plist

10) Run Kext utility or similar... (repair disk permission, privilege, caches..)

Done.

PS.. Maybe tweak41 can explain how too in a more and comprensive english.

Fabio




Hi, this is my first post in this forum (it's fantastic!) but I got some questions to all this points (Got an P6T SE and a working 10.6.8 SL)

3) big perl command why should I do this?

4) - 9) I have loaded the patched files (from site 1, was easier and no kernel panics). What have you changed in all this files and why?


10) followed to run the kext utility. All working fine.....but I've got a formated EFI partion with all necessary files from /Extra folder. My external hard disk over JMicron is connected via eSata.
When booting during plugged in, it is shown on the Apple Desktop as a "grey icon" (not orange), so I think it is not "hotplugged" (in BIOS it is on AHCI).
On the EFI Partion I've got the eSata.kext for the JMicron (from "#####"). So when SL boots via Chameleon it seems to load the driver from /System/Library instead from EFI Partition? How can I control that, delete file from /System/Library and try different .kexts in /EFI?

Sorry for my bad english.....but this is my first good working SL on PC! Thanks for help!

#1223
ErmaC

ErmaC

    127.0.0.1

  • Supervisors
  • 4,751 posts
  • Gender:Male
  • Location:Canary Islands
Off topic.
I made a guide for LION (ITALIAN)
http://www.insanelym...howtopic=261334
based on tseug scrips installation method.
http://www.insanelym...howtopic=259068
End Off topic

Fabio

#1224
echoz

echoz

    InsanelyMac Protégé

  • Members
  • Pip
  • 20 posts
  • Gender:Male
  • Location:Singapore
Finally have access to my machine.

Updated from 10.6.7 to 10.6.8. Replaced offending AppleHDA.kext, repaired kext caches and rebooted.

** had to remove RadeonMonitor.kext as it kept kp'ing.

#1225
the_serb

the_serb

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
Alright, so I can't seem to figure this out, so I guess I'll ask. Here is the screenshot of where it hangs.

Posted Image

Here is my setup:

Memory: 2GBx3 OCZ
Mobo: ASUS P6T SE
Video Card: XFX HD4870 1G DDR5
CPU: i7 920 2.66G

I followed the guide exactly. Updated the BIOS, set the proper settings. What I think it may be, is a kext issue or me not setting the values in the boot.plist file correctly. I am using the latest DSDT v3.4 and I tried setting the EnableGraphics in the boot.plist to y (which resulted in a scrambled screen) and to n (where I am right now). The other two or three errors near the end there I think are a result of the onboard devices being enabled.

Let me know if I need to provide any further information. Any help would be greatly appreciated!

#1226
Jaball

Jaball

    InsanelyMac Protégé

  • Members
  • Pip
  • 20 posts
  • Gender:Male

Let me know if I need to provide any further information. Any help would be greatly appreciated!


Boot with -x at chameleon prompt. If that works, prolly You will be needing LegacyATI4800Controller.kext with correct dev id's for that 4870 in SLE and GraphicsEnabler=Y. Also, deleting ATI4500Controller and ATI4600Controller kexts from SLE is sometimes required. Rebuild cache and fix permissions after that and reboot.

#1227
_Wolverine_

_Wolverine_

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 138 posts
  • Gender:Male
  • Location:Brazil
Lion works PERFECTLY using THIS_GUIDE

Thanks Ermac

#1228
tweak41

tweak41

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 247 posts
  • Gender:Male
  • Location:Los Angeles, CA

The instructions are poorly written it does not mention how they got that 3+GB Lion.APP file I just have this "Mac OS X Install ESD" what am I supposed to do with that?


*ehem*

You SHOULD buy that app through the app store. Lion was released yesterday.

It was in {censored} Italian, so blame google for the "poorly written" instructions. Ass.

In the mean time, this looks like an intriguing way of upgrading:

http://tonymacx86.bl...x-107-lion.html

#1229
akhenamenra

akhenamenra

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 189 posts

*ehem*

You SHOULD buy that app through the app store. Lion was released yesterday.

It was in {censored} Italian, so blame google for the "poorly written" instructions. Ass.

In the mean time, this looks like an intriguing way of upgrading:

http://tonymacx86.bl...x-107-lion.html



vie tried the itallian job but it keep failing at chamelion/install.pkg??? vie legally copped lion so cant see why i should hit a snag…..il try again failing that fall back and wait a few weeks for some clever clogs to hit me with something

#1230
andrew79

andrew79

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 110 posts
  • Gender:Male
  • Location:Greece
For Lion installation, just follow any guide in this forum to restore the Lion image in a usb flashdrive, download the latest chameleon, install it on the usb flash drive (usb flash partition table must be Guid). Then put in usb flash-> extra folder your dsdt. BE CAREFUL latest dsdt provided here DOES NOT work in 32bit. If you need 32bit you have to find an older dsdt version provided here.I have Lion kernel in 32bit mode because my external soundcard, does not have 64 bit drivers. I don't know if this method works with ati cards because i have an Nvidia. I think that people with ati GPU must search for more information.

After installation, boot with the usb again and choose your lion installation. You can install new chameleon on your hard disk and move your extra folder there.

Kexts in extra folder are the usual. You can search for newer version of Fakesmc.kext.
For onboard sound install this kext with kext utility (in system/library/extensions folder) Attached File  AppleHDA.kext.zip   1.73MB   23 downloads

Have not tested firewire. Sleep works fine. Everything seems ok.

#1231
akhenamenra

akhenamenra

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 189 posts

For Lion installation, just follow any guide in this forum to restore the Lion image in a usb flashdrive, download the latest chameleon, install it on the usb flash drive (usb flash partition table must be Guid). Then put in usb flash-> extra folder your dsdt. BE CAREFUL latest dsdt provided here DOES NOT work in 32bit. If you need 32bit you have to find an older dsdt version provided here.I have Lion kernel in 32bit mode because my external soundcard, does not have 64 bit drivers. I don't know if this method works with ati cards because i have an Nvidia. I think that people with ati GPU must search for more information.

After installation, boot with the usb again and choose your lion installation. You can install new chameleon on your hard disk and move your extra folder there.

Kexts in extra folder are the usual. You can search for newer version of Fakesmc.kext.
For onboard sound install this kext with kext utility (in system/library/extensions folder) Attached File  AppleHDA.kext.zip   1.73MB   23 downloads

Have not tested firewire. Sleep works fine. Everything seems ok.



FIXED IT fully working now….just a quick question do i have to do the 10mb partition or can i just instal over snow/l??

#1232
andrew79

andrew79

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 110 posts
  • Gender:Male
  • Location:Greece

FIXED IT fully working now….just a quick question do i have to do the 10mb partition or can i just instal over snow/l??


You mean the EFI partition? If you use an EFI partition for booting snow leopard you can do the same for Lion BUT NOT on the same disk.

#1233
akhenamenra

akhenamenra

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 189 posts

You mean the EFI partition? If you use an EFI partition for booting snow leopard you can do the same for Lion BUT NOT on the same disk.



sorted mate , just need to figure out my 470 gtx, ( at the moment im floating with the 260gtx)

#1234
Multisaft

Multisaft

    InsanelyMac Protégé

  • Members
  • PipPip
  • 74 posts
  • Gender:Male
  • Location:Germany
back again
still on 10.5.7

My usb-installation boots up with myhack 1.1 (2.0 dont work on my 10.5.7 installation system). But the system don't boot into the installation procedure. I get a gray screen with the spinball of death after myhack has loaded all the kexts. Graphicsenabler yes with Vesa 3.0 driver.
I think that this is a problem with my gtx260 graphic-card right? What must I do to get it working?

Attached Files



#1235
starobrno1

starobrno1

    InsanelyMac Legend

  • Banned
  • PipPipPipPipPipPipPip
  • 930 posts
  • Gender:Male
If you have a working os x installation already and you want to install SL to a new hdd you can do it without an usb flashdrive. Just restore SL to your desktop and mount it and then open terminal and copy paste cd /Volumes/Mac\ OS\ X\ Install\ DVD/System/Installation/Packages then copy paste open OSInstall.mpkg (in to terminal) and install to your SL harddrive. When its done install the chameleon you want to your SL harddrive and the fakesmc.kext and the other kext from this thread (first post) to the extra/extensions folder and reboot. Press F8 and choose your SL harddrive you installed to and finnish the installation. For your video card you need to find the solution yourself so thats the next step for you but if you have a card that works but not 100% its just a matter of reading up on stuff.

#1236
Multisaft

Multisaft

    InsanelyMac Protégé

  • Members
  • PipPip
  • 74 posts
  • Gender:Male
  • Location:Germany
i want to install snow leopard on my running os x 10.5.7 system - same partition! because of that i need the flashdrive. something is missing in my kext folder (yes i've used the fakesmc and the p6t-se kext etc....)

#1237
akhenamenra

akhenamenra

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 189 posts

i want to install snow leopard on my running os x 10.5.7 system - same partition! because of that i need the flashdrive. something is missing in my kext folder (yes i've used the fakesmc and the p6t-se kext etc....)



bro the 260 works out of the box
just follow the instructions to the t
if you get the grey screen do -v and let us know where it hangs



on a side note how can i turn this into a .plist can any one help please it should help my 470 woes

many thanks in advance

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com...yList-1.0.dtd">
<plist version="1.0"><dict>
<key>PciRoot(0x0)/Pci(0x3,0x0)/Pci(0x0,0x0)</key>
<dict>
<key>@0,AAPL,boot-display</key>
<string></string>
<key>@0,can-hot-plug</key>
<string></string>
<key>@0,compatible</key>
<string>NVDA,NVMac</string>
<key>@0,device_type</key>
<string>display</string>
<key>@0,name</key>
<string>NVDA,Display-A</string>
<key>@1,can-hot-plug</key>
<string></string>
<key>@1,compatible</key>
<string>NVDA,NVMac</string>
<key>@1,device_type</key>
<string>display</string>
<key>@1,name</key>
<string>NVDA,Display-B</string>
<key>AAPL,aux-power-connected</key>
<string>0x00000001</string>
<key>AAPL,backlight-control</key>
<string>0x00000000</string>
<key>AAPL,gart-width</key>
<integer>64</integer>
<key>AAPL00,blackscreen-preferences</key>
<string>0x00000000</string>
<key>AAPL01,blackscreen-preferences</key>
<string>0x00000000</string>
<key>IONVRAMProperty</key>
<true/>
<key>NVCAP</key>
<data>
BAAAAAAAAwAcAAAAAAAACgAAAAA=
</data>
<key>NVDA,Features</key>
<string>0x108006ff</string>
<key>NVPM</key>
<data>
AQAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA==
</data>
<key>VRAM,totalsize</key>
<string>0x50000000</string>
<key>device_type</key>
<string>NVDA,GeForce</string>
<key>model</key>
<string>GeForce GTX 470</string>
<key>rm_board_number</key>
<data>
AAAAAA==
</data>
<key>rm_multiboard_capable</key>
<data>
AQAAAA==
</data>
<key>rom-revision</key>
<string>70.00.35.00.00</string>
<key>subsystem-id</key>
<string>0x00001080</string>
</dict>

#1238
Multisaft

Multisaft

    InsanelyMac Protégé

  • Members
  • PipPip
  • 74 posts
  • Gender:Male
  • Location:Germany

bro the 260 works out of the box
just follow the instructions to the t
if you get the grey screen do -v and let us know where it hangs


it hangs after all the kexts are loaded correctly (i think so, need to make photos of the last promts) and then first blue background image, then the grey one and after some seconds the loading spinball of os x - also called the spinball of death

#1239
Multisaft

Multisaft

    InsanelyMac Protégé

  • Members
  • PipPip
  • 74 posts
  • Gender:Male
  • Location:Germany
Screenshot with the last lines displayed before the screen change to the grey screen. I've used MyHack1.1, because the flashdrive don't boot with Chameleon.

Attached File  Bootup_myhack1.1.jpg   1.14MB   8 downloads

#1240
tweak41

tweak41

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 247 posts
  • Gender:Male
  • Location:Los Angeles, CA

Screenshot with the last lines displayed before the screen change to the grey screen. I've used MyHack1.1, because the flashdrive don't boot with Chameleon.

Attached File  Bootup_myhack1.1.jpg   1.14MB   8 downloads


Have you ever tried installing chameleon manually on the flash drive? I find it so bizarre that you're unable to boot the flash drive when so many other people can without problems. Makes me think there's user error somewhere along the line.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy