Jump to content

PC EFI V10.3 Released by Netkas


  • Please log in to reply
52 replies to this topic

#41
KariNeko

KariNeko

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 232 posts
  • Gender:Female
  • Location:Buenos Aires, Argentina

Now I'd like to know why RC3 didn't work, is it beacuse of this PCI root thing?


Probably, because you got it working with PCEfi 10.3 that has PCI root=1 as default option and Chameleon 2 RC3 uses 0 as default.

#42
morfy

morfy

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 890 posts
I tried different options
USBBusFix = yes
USB high speed and are recognized only 1 time out of 10: why?

P5W DH enabled legacy usb = auto and EHCI Hand-off = enable.

The usb only work if the file AppleHPET.kext gate.

#43
121fred

121fred

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 110 posts
Any chance somebody could upload netkas pci 10.3 the download link on his site is currently not working

thanks

#44
Arial

Arial

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 176 posts

Any chance somebody could upload netkas pci 10.3 the download link on his site is currently not working

thanks

PC-EFI_V10.3.zip ~492KB
http://www.mediafire.com/?tzlyhieybyl
- boot_PC-EFI-V10.3_PCI0.zip <-- for default PCI0, recompiled by mitch_de
- boot_PC-EFI-V10.3_PCI1.zip <-- original by Netkas. default PCI1, for PCI0 boot with: -pci0

#45
aliasa_anderson

aliasa_anderson

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 171 posts

PC-EFI_V10.3.zip ~492KB

http://www.mediafire.com/?tzlyhieybyl
- boot_PC-EFI-V10.3_PCI0.zip <-- for default PCI0, recompiled by mitch_de
- boot_PC-EFI-V10.3_PCI1.zip <-- original by Netkas. default PCI1, for PCI0 boot with: -pci0



Hi All,

I get KP pertaining to EFIRuntime.kext and NVRam.kext if i use EFI 10.3
Chameleon 2 RC3 is working fine.All i did was to rename the old boot file and copied the attached boot file to root partition.
i have HP dv6114 tx laptop with Intel Core Duo@1.6Ghz

Kindly Suggest.

#46
eberts

eberts

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 138 posts

I tried different options
USBBusFix = yes
USB high speed and are recognized only 1 time out of 10: why?

P5W DH enabled legacy usb = auto and EHCI Hand-off = enable.

The usb only work if the file AppleHPET.kext gate.


morfy, have a look at the hardware (other) thread on projectosx. Slice's IOPCIFamily.kext did it for me (in leopard) but he made a snow leo version too.

#47
mitch_de

mitch_de

    InsanelyMacaholic

  • Retired
  • 2,902 posts
  • Gender:Male
  • Location:Stuttgart / Germany

Hi All,

I get KP pertaining to EFIRuntime.kext and NVRam.kext if i use EFI 10.3

Kindly Suggest.


I dont use BOTH -not in my 10.5 not in 10.6 !
I delete them since 10.4 time .
For my knowledge they are both not needed on OSX86 systems / may give problems if installed.

but it would be nice if someone with good (real!) OSX backgound can tell us more of those 2 .kext.

#48
aliasa_anderson

aliasa_anderson

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 171 posts

I dont use BOTH -not in my 10.5 not in 10.6 !
I delete them since 10.4 time .
For my knowledge they are both not needed on OSX86 systems / may give problems if installed.

but it would be nice if someone with good (real!) OSX backgound can tell us more of those 2 .kext.



i deleted the efiruntime kext and now,it boots perfectly.No more KP.
Thanks for pointing out that they are not needed.
i used the boot file compiled by you.
works perfectly.
:(

#49
Astaga

Astaga

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 147 posts
  • Gender:Male
  • Location:Italy, Rome
I can't start in 32 bit mode with pc efi v10.3. Which is the kernel flag I have to use?

Thank in advance

#50
BladeRunner

BladeRunner

    InsanelyMac Legend

  • Donators
  • 688 posts
  • Gender:Male
  • Location:New York

I can't start in 32 bit mode with pc efi v10.3. Which is the kernel flag I have to use?

Thank in advance



arch=i386

#51
Astaga

Astaga

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 147 posts
  • Gender:Male
  • Location:Italy, Rome
Thanks,
now with pcefi v10.3 i can boot in 32 bit mode with this flags

<key>Kernel Flags</key>
<string>-pci0 arch=i386</string>

best regards
(sorry for bad english)

#52
AppleIIGuy

AppleIIGuy

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 349 posts
  • Gender:Male
  • Location:San Diego, CA

To find you pciroot value, use this osx terminal command:
ioreg -l | grep -15 “AppleACPIPCI\ ” | grep UID


That doesn't return me anything.
I get

Last login: Tue Oct 13 20:51:46 on ttys000
HTPC-2:~ appleiiguy$ ioreg -l | grep -15 “AppleACPIPCI\ ” | grep UID
HTPC-2:~ appleiiguy$

#53
mitch_de

mitch_de

    InsanelyMacaholic

  • Retired
  • 2,902 posts
  • Gender:Male
  • Location:Stuttgart / Germany
You will find 0 or 1 for PCI root also using the IOREGISTRY EXPLORER, select IODevice tree and look for PCI.
Attached my GA-EP35 - i have PCI 0 - so i need an patched EFI PC version (default pci 0) or must use -pci0 with orig. version.

HINT: New version 10.4 out, also patched here. Look at the 10.4 thread.

Attached Files







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy