Jump to content

lifehacker-install will not boot in 32-bit mode


  • Please log in to reply
7 replies to this topic

#1
stephanchen

stephanchen

    InsanelyMac Protégé

  • Members
  • PipPip
  • 91 posts
hi,

i have installed my hackintosh with lifehacker-methode.

after boot, all works fine, but my d-link dwa-547 card isnt working....because the atheros driver 5008 isnt 64bit ready.

if i edit my com.aaple.Boot.plist with ach=i386 so that my hackintosh must start in 32 bit mode.......the restart fails .....

whats the problem of the lifehacker installation with 32bit mode?

cu
stephanchen

#2
captcrunch24

captcrunch24

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
I also am experiencing the same issue...I would like to boot into 32-bit mode and the suggestion of editing the com.apple.boot.list file does not work and neither does using the few utilities (i.e. 32- or 64-bit Kernel Startup Mode Selector) The Boot kernel changes to 32-bit mode but the system kernal remains 64-bit. I cannot run Parallels or some of the plugins I use for Photoshop in the 64-bit mode until their respective applications are updated to 64-bit.

Any suggestion on how to boot into 32-bit mode would be greatly appreciated.

(I am a NOOB at this so it probably explains why I can't figure this out on my own :-)

#3
CBAnthony

CBAnthony

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts
I am also wondering if anyone has figured this out. The boot.plist.com is not like the ones described in other guides.

Thanks for any help.

#4
tbob22

tbob22

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts
I had this problem, one of my SATA controllers is not supported with the x64 kernel.

Here is what you need to do:

Open up the terminal and type:
sudo nano /extra/com.apple.Boot.plist

Then change:

<key>Kernel Flags</key>
<string></string>

to
<key>Kernel Flags</key>
<string>arch=i386</string>


Then Save (ctrl o) and exit (ctrl x)

Reboot and it should now be in 32 bit mode.. To check click on apple > About This Mac > More Info > Software and under "64-bit Kernel and Extensions" it should say "No".

#5
Dougw6

Dougw6

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts

hi,

i have installed my hackintosh with lifehacker-methode.

after boot, all works fine, but my d-link dwa-547 card isnt working....because the atheros driver 5008 isnt 64bit ready.

if i edit my com.aaple.Boot.plist with ach=i386 so that my hackintosh must start in 32 bit mode.......the restart fails .....

whats the problem of the lifehacker installation with 32bit mode?

cu
stephanchen


I have the same problem. I changed the plist flag to ach=i386 and now I'm stuck in an endless reboot. I don't know how to get back into 64 bit if I can't boot back up can someone please help.

#6
naluvs01

naluvs01

    InsanelyMac Protégé

  • Members
  • Pip
  • 27 posts

I have the same problem. I changed the plist flag to ach=i386 and now I'm stuck in an endless reboot. I don't know how to get back into 64 bit if I can't boot back up can someone please help.


It pretty easy actually. All you need to do is 1. put your hard drive in a firewire enclosure 2. go to your extras folder 3. open the boot.plist file in text edit 4. delete the arch=i386 that you typed and then save it. Also you may need to copy it to your desktop in order to make the changes.

On another note, you could also put your hard drive in another computer and do the same thing. But no matter what method you choose, it will allow you to delete the command that you had previously typed.

This happened to me and guarantee this will get you back...hope this helps!!!!

#7
nekkron99

nekkron99

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts

I had this problem, one of my SATA controllers is not supported with the x64 kernel.

Here is what you need to do:

Open up the terminal and type:
sudo nano /extra/com.apple.Boot.plist

Then change:

<key>Kernel Flags</key>
<string></string>

to
<key>Kernel Flags</key>
<string>arch=i386</string>


Then Save (ctrl o) and exit (ctrl x)

Reboot and it should now be in 32 bit mode.. To check click on apple > About This Mac > More Info > Software and under "64-bit Kernel and Extensions" it should say "No".


DUDE!!! I love you! Thanks!!!

#8
organik

organik

    InsanelyMac Protégé

  • Members
  • Pip
  • 33 posts
Tried all of this and still booting 64bit. Anything I could be missing? I just need NTFS-3G to work, and it's doesn't with 64 bit kernel.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy