Jump to content

Vaio P Snow Leopard


  • Please log in to reply
145 replies to this topic

#1
jsoryu

jsoryu

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
Link to previous forum:
http://www.insanelym...p;#entry1165697



Ryuu, Here are the additional things that I've found:
- Power Management, Leaving sleep HDD on will freeze the entire system. (Make sure to turn off sleep / display options).
- In System Profile, Battery cycle count is not measured.
- My Vaio P is keep losing battery charge even after shut down (In very noticeable amount) . Is this normal for non-mac computers?

#2
padebije

padebije

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
I express my gratitude to ryuu123 for his/her all efforts...
Finally I succeeded in installing Snow Leopard on my Vaio P. I'm not familiar with Mac nor sure that my steps are correct, but at least it works fine (of course there are still some problems such as "About this Mac"). I hope the following is helpful for those who are still in their effort.

[Preparation]
1. ryuu123's files (vaiop20090910)
2. Chameleon 2 RC3 with installer
3. Kext Helper b7
4. USB Memory A 8GB above
5. USB Memory B
6. OS 10.6 DVD

[Making Installation Disk]
1. Format USB Memory A (HFS+, MBR)
2. Restore OSX DVD on USB Memory A
3. Install Chameleon 2 RC3 on USB Memory A
4. Copy ryuu123's files to USB Memory A
/boot
/DSDT.aml
/Extra

[Preparation USB Memory B]
1. Copy ryuu123's files to USB Memory B
/System
2. Copy Chameleon 2 RC3 with installer to USB Memory B
3. Copy Kext Helper b7 to USB Memory B

[Installation]
1. F11 -> Boot from USB Memory A
2. Install -> Reboot
3. F11 -> Boot from HDD/SSD with "cpus=1 -v -f"
4. Set up
5. Insert USB Memory B
6. Install Chameleon 2 RC3 on OSX
7. Open Terminal
8. Copy the following files/folders as superuser
/boot
/DSDT.aml
/Extra

Now you can boot without USB Memory A.

9. Install 2 kexts (GMA500BacklightDisplay.kext and VoodooHDA.kext) with Kext Helper b7
10. Open Terminal
11. Delete AppleHDA.kext as superuser

For dual boot (OSX10.5.6 and W7), I used PC_EFI V9 Chameleon 1.0.12 (UInstaller). I'm not sure it still works fine on Snow Leopard. I really love my OSX on Vaio P, and deleted Windows :D

#3
galb

galb

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
Hi.I installed SL with your advices on a european Sony Vaio P11.
Do you no if there is a solution about caps lock auto turn on.
How can i Install English Layout?
Also can i reduce screen brightness with fn keys combination?
Thanks for help.

#4
padebije

padebije

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts

Hi.I installed SL with your advices on a european Sony Vaio P11.
Do you no if there is a solution about caps lock auto turn on.
How can i Install English Layout?
Also can i reduce screen brightness with fn keys combination?
Thanks for help.


ryuu123's patch is customized for Japanese keyboard layout. I'm not so sure but how about installing ApplePS2Controller.kext instead of VoodooPS2Controller? Or you can find solution from ryuu123's post (#127 on previous forum).

http://www.insanelym...p...t&p=1259982

I don't have any problem about caps lock auto turn on, and can toggle on/off with Ctrl-Caps Lock key.

Brightness is fixed. Could you check GMA500BacklightDisplay.kext? When I installed Leopard with ryuu123's patches, brightness was fixed 50%, and I could change it by rewriting info.plist of GMA500FB.kext.

I hope this answer is helpful...

#5
zwmg

zwmg

    InsanelyMac Protégé

  • Members
  • Pip
  • 22 posts
I wanted to run Mac OS from internal SSD. Now, making an image doesn't work because then Disk Utility says it's not scanned. When I try to activate the image or just open it (I thinkt then it's scanned) there are always errors at the end. I can't make or get a right image from the usb stick Mac OS.

I tried copying everything manually to the hdd. But when booting from internall SSD it says "missing mach_kernel" ...

What do I have to do EXACTLY to get Mac OS running on internal HDD?

Thx.

#6
galb

galb

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts

ryuu123's patch is customized for Japanese keyboard layout. I'm not so sure but how about installing ApplePS2Controller.kext instead of VoodooPS2Controller? Or you can find solution from ryuu123's post (#127 on previous forum).

http://www.insanelym...p...t&p=1259982

I don't have any problem about caps lock auto turn on, and can toggle on/off with Ctrl-Caps Lock key.

Brightness is fixed. Could you check GMA500BacklightDisplay.kext? When I installed Leopard with ryuu123's patches, brightness was fixed 50%, and I could change it by rewriting info.plist of GMA500FB.kext.

I hope this answer is helpful...

Thank you for the fast answer.
Do you know what exactly should I change in g500 plist file?
What about a wwan driver?

#7
zwmg

zwmg

    InsanelyMac Protégé

  • Members
  • Pip
  • 22 posts
Got it working now (with 10.6.1).

Is it possible to have WLAN activated but no BT?

If I turn the Wireless Button on both are activated (I can't deactivate just BT), if I turn it off both are deactivated.

EDIT: And how can you make the booting faster (takes some seconds at the beginning to just enter startup, before the Apple Logo appears)?

#8
RyanL

RyanL

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
Dear all,

For those who would like to use the US Keyboard instead of the Japanese one, I have made the one for VoodooPS2Controller ktext. Try to use this one and should be fine. I tested this with my VGN-P15G

Attached File  VoodooPS2Controller.kext.zip   72.35KB   286 downloads

#9
vimcat

vimcat

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
Thanks for the kext. How did you install it? I tried overwriting the one in Extra/Extensions1, but that didn't work. Then I deleted it and used Kext Helper b7 to install it. It still doesn't work. My keys are all wrong. I get a '^' where there should be a '=' and a bunch of other randomness. Also the caps lock will turn itself on and is stuck on. It's annoying I haven't been able to find a way to turn it off other than rebooting.

Dear all,

For those who would like to use the US Keyboard instead of the Japanese one, I have made the one for VoodooPS2Controller ktext. Try to use this one and should be fine. I tested this with my VGN-P15G

Attached File  VoodooPS2Controller.kext.zip   72.35KB   286 downloads



#10
galb

galb

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts

Thanks for the kext. How did you install it? I tried overwriting the one in Extra/Extensions1, but that didn't work. Then I deleted it and used Kext Helper b7 to install it. It still doesn't work. My keys are all wrong. I get a '^' where there should be a '=' and a bunch of other randomness. Also the caps lock will turn itself on and is stuck on. It's annoying I haven't been able to find a way to turn it off other than rebooting.

I am using ctrl key to turn caps lock on-off
I also did copy the new kext in /Extensions1 in /Extra folder , but i does not seem to work

#11
vimcat

vimcat

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
Thank you for figuring out how to turn off caps lock.

I found out how to view my keyboard settings, it's definitely set to Japanese AND sadly the _ key is not available since the key is missing (between the / and shift on the right side).

I am using ctrl key to turn caps lock on-off
I also did copy the new kext in /Extensions1 in /Extra folder , but i does not seem to work



#12
jsoryu

jsoryu

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts

Thank you for figuring out how to turn off caps lock.

I found out how to view my keyboard settings, it's definitely set to Japanese AND sadly the _ key is not available since the key is missing (between the / and shift on the right side).


One of the Last-Resort solution is to transfer the extension to HDD Boot by installing Chameleon.
I recommend manual terminal install.

Keyboard will be re-mapped to english after restart.

Oh~ to run extra.sh (will CHMOD and CHOWN for you after extension correction) by dragging file to terminal.

#13
vimcat

vimcat

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
It's working now! I forgot to run extra.sh.

Thank you!! :)

One of the Last-Resort solution is to transfer the extension to HDD Boot by installing Chameleon.
I recommend manual terminal install.

Keyboard will be re-mapped to english after restart.

Oh~ to run extra.sh (will CHMOD and CHOWN for you after extension correction) by dragging file to terminal.



#14
fr3z3rburn

fr3z3rburn

    InsanelyMac Protégé

  • Members
  • Pip
  • 45 posts
Thanks RyanL for the keyboard kext. haven't tried it yet, but im so glad someone did that.

fr3z3rburn

#15
fr3z3rburn

fr3z3rburn

    InsanelyMac Protégé

  • Members
  • Pip
  • 45 posts
So I used ryanL's kext and it works flawlessly. Thanks alot man. Now i dont have to hunt for symbols. ;)

fr3z3rburn

#16
Serbijan

Serbijan

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts

So I used ryanL's kext and it works flawlessly. Thanks alot man. Now i dont have to hunt for symbols. :wacko:

fr3z3rburn



Hi evrbdy! snowleo is also working on my p11zr but i cant use itunes - no sound and no quicktime playback? i:ve installed gamdisplay.kext and voodoohda. what should i do? thks!

#17
Serbijan

Serbijan

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts

So I used ryanL's kext and it works flawlessly. Thanks alot man. Now i dont have to hunt for symbols. :wacko:

fr3z3rburn



Hi evrbdy! snowleo is also working on my p11zr but i cant use itunes - no sound and no quicktime playback? i:ve installed gamdisplay.kext and voodoohda. what should i do? thks!

#18
RyanL

RyanL

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
Try the following:

Delete AppleHDA.kext as superuser

You need to do that first and reboot before you can get sound working.

Hi evrbdy! snowleo is also working on my p11zr but i cant use itunes - no sound and no quicktime playback? i:ve installed gamdisplay.kext and voodoohda. what should i do? thks!



#19
Serbijan

Serbijan

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts

Try the following:

Delete AppleHDA.kext as superuser

You need to do that first and reboot before you can get sound working.


it is working now!!!!!
great thanks RyanL


two more questions

what about videoplayback?

and keyboard works not correct - for example ctrl key is caps lock and etc.

great thanks RyanL

#20
zwmg

zwmg

    InsanelyMac Protégé

  • Members
  • Pip
  • 22 posts

Try the following:

Delete AppleHDA.kext as superuser

You need to do that first and reboot before you can get sound working.


What do I have to do exactly to get it deleted? I'm not that into this stuff.

Got WWAN working, but not BT anymore. Got brightness keys working.

Only stuff missing is BT again, sleep mode and of course Audio.

And a better graphic driver would be cool (this is the first netbook where I can't watch iTunes movies on a Mac OS because it's stuttering all the time, even the MSI Wind played it perfectly, I know GMA500....).





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy