Jump to content

[Guida] Snow Leopard su M2N-SLI DELUXE


  • Please log in to reply
134 replies to this topic

#1
Giorgio_multi

Giorgio_multi

    InsanelyMac V.I.P.

  • Gurus
  • 9,514 posts
  • Gender:Male
  • Location:Ferrara, Italy
  • Interests:Elettronica in genere, informatica e Sistemi Operativi in particolare. Cani da slitta e Sleddog....
Premessa: questa è una guida, non un tutorial su problemi banali. Per poterla utilizzare occorrono conoscenze minime del mondo Hackintosh.

NON risponderò a domande generiche del tipo: "come si fa a flashare il bios" "come faccio a mettere l'id della mia scheda nel kext" etc, etc.

tali domande non verranno degnate di risposta senza alcuna spiegazione.



Scrivo questa guida per quanti mi hanno chiesto informazioni sull'installazione di Snow Leopard su questa motherboard con scheda grafica (o schede grafiche) Nvidia

Cosa vi serve:

1) il file immagine snowleopard_10A432_userdvd.dmg

2) Il pacchetto M2N-E SLI Deluxe SL di kext, kernel e utility preparato da me:
http://www.megaupload.com/?d=TJNZ4XXV

3) Una versione di Leopard funzionante

4) Una partizione primaria libera su HD GUID formattata Mac OSX (journaled) e denominata Snow (che può essere sullo stesso HD dove avete Leopard se questo HD è GUID)

- Cominciate aprendo snowleopard_10A432_userdvd.dmg sul Desktop della versione di Leopard già installata

- Col cursore sulla finestra appena aperta premete mela + shift + G e si aprirà una finestra di ricerca percorso

- Digitate nella finestra: /Mac OS X Install DVD/System/Installation/Packages

- Si aprirà una cartella da cui avviate col doppio click OSInstall.mpkg ed installatelo sulla partizione GUID
vuota che avrete chiamato Snow deselezionando stampanti, X11 e le lingue che non servono; alla fine dell'installazione chiudete la cartella e smontate il dmg

- Dalla cartella scaricata installate dalla cartella Utility Chameleon 2 RC3 su Snow

- Dalla cartella scaricata copiate su Snow la cartella Extra, DSDT.aml, mach_kernel, smbios.plist

- Dalla cartella scaricata copiate Nvinject.kext + i 2 kext che trovate in S/L/E in /Snow/System/Library/Extensions

- Andate in Utility Disco e col tasto destro del mouse su Snow scegliete Informazioni

- Si aprirà una finestra: copiate il valore dopo identific. universale

- incollate il valore copiato in: a) smbios.plist, b] com.apple.Boot.plist (che è in Extra) e c) nell'info.plist di PlatformUUID.kext (in /Extra/Extensions)

- Riavviate il PC dal HD su cui avete installato Snow in verbose e arriverete al filmato di presentazione ed alle operazioni preliminari, poi entrerete in Snow Leopard

- Aprite snowleopard_10A432_userdvd.dmg sul Desktop di Snow Leopard

- Col cursore sulla finestra appena aperta premete mela + shift + G e si aprirà una finestra di ricerca percorso

- Digitate nella finestra: /Mac OS X Install DVD/System/Installation/Packages

- Si aprirà una cartella da cui avviate col doppio click BSD.pkg ed installatelo

- Dalla cartella scaricata avviate Kext Utility e lasciatele fare il suo lavoro (se appare una finestra vuota significa che non c'è nulla da riparare)

Riavviate sempre dal HD di Snow in verbose e buon Snow Leopard.

Per l'audio installate con kexthelper voodooHDA.kext.

Nota: Il sistema è ovviamete a 32 bit avendo chipset e processore AMD quindi non core 2 duo.

Potete avviare Snow da un altro HD su cui avete Leopard a patto di installarci Chameleon 2.0 RC3.

Potete mettere 2 schede Nvidia, anche diverse, ma con la stessa dotazione di RAM e potrete usare 4 monitor.

Se il Nvinject allegato (modificato per 2 schede video) non dovesse funzionare, cancellatelo e mettete la Efistring per la vostra scheda video nel com.apple.Boot.plist presente in /Extra.

Buon lavoro, Giorgio

#2
williamwallace

williamwallace

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 2,133 posts
  • Gender:Male
  • Location:BG
Gran bel lavoro......SUPERGIORGIO :)

#3
smith3d

smith3d

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 144 posts
GRANDE GIORGIO!!!
Ora devo solo provare!!!
Grazie 10000 x il tempo.... e ti ripaghero x bene al PUB :(
Smith3d

#4
smith3d

smith3d

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 144 posts
Eccolo!
preso dal momento, ho fatto le mie prove......
Tutto ok fino a questo punto:


Riavviate sempre dal HD di Snow in verbose e buon Snow Leopard
;)
Da quel momento ritorna il famoso
Still waiting for root device
Ho controllato tutto e tutto sembra ok.
N.B. quando ho installato snow, non mi funzionava l'audi e la res. del monitor...forse e' normale?
Grazie di tutto e corro a dormire!

...a domani, o meglio a dopo! :)
Smith3d

#5
smith3d

smith3d

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 144 posts
Risolto :)
e' tardi e lascio..
Al momento non mi funziona l'audio e la scheda video, ma penso che sia sempre il solito motivo....
Domani completero l'opera!!
Grazie
Smith3d..un po stanco, ma felice :)

#6
Giorgio_multi

Giorgio_multi

    InsanelyMac V.I.P.

  • Gurus
  • 9,514 posts
  • Gender:Male
  • Location:Ferrara, Italy
  • Interests:Elettronica in genere, informatica e Sistemi Operativi in particolare. Cani da slitta e Sleddog....

Risolto :)
e' tardi e lascio..
Al momento non mi funziona l'audio e la scheda video, ma penso che sia sempre il solito motivo....
Domani completero l'opera!!
Grazie
Smith3d..un po stanco, ma felice :wacko:


Per l'audio devi installare voodooHDA.kext (me ne ero dimenticato, adesso aggiungo).

Per la scheda video se con NVinject non funziona, cancella NVinject e metti la EFIstring per la tua scheda video nel com.apple.Boot.plist in /Extra.

Attenzione che Snow Leopard non ti da il messaggio di Core Image Hardware Accelerato e Quartz Extreme supportato: ti accorgi se QE/CI sono attivati dalla possibilità di effettuare il cambio di risoluzione e dalla rotazione supportata.

Giorgio

#7
smith3d

smith3d

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 144 posts

Per l'audio devi installare voodooHDA.kext (me ne ero dimenticato, adesso aggiungo).

Per la scheda video se con NVinject non funziona, cancella NVinject e metti la EFIstring per la tua scheda video nel com.apple.Boot.plist in /Extra.

Attenzione che Snow Leopard non ti da il messaggio di Core Image Hardware Accelerato e Quartz Extreme supportato: ti accorgi se QE/CI sono attivati dalla possibilità di effettuare il cambio di risoluzione e dalla rotazione supportata.

Giorgio


OK!!
Sono sicuro che questa sera funzionera da paura!!!
MITICO e SUPER GIORGIO!!!!!
....ma che giornatina INCOMATATA :P

Smith3d

#8
smith3d

smith3d

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 144 posts
Ciao!
Sto scrivendo dal mio nuovo leo 10.6.1 :)

Ho un paio di domande dopo pochissimo tempo che la sto usando.....quindi chiedo scusa ma non ho fatto cerca....

Itunes, si apre ma non mi permette di fare nulla, o meglio se provo a fare una qualsiasi operazione si chiude subito :D

Se provo a installare un programma di grafica , mi dice : XYZ for OS X requires 64-bit Intel macintosh :(
Sulla 10.5.8, nessun problema
Ho notato che se faccio About this mac, non mi riconosce il modello del processore Unknown :(

Per finire, ho usato osx86tools x la scheda video ma per errore ho salvato il boot da li :) , e non ho copiato come dicevi tu Giorgio la EFIstring nel com.apple.Boot.plist in /Extra.
Funziona, ma e' giusto??

Grazie a tutti
Smith3d

News:
ore 3.00 am......ho provato a installare altri prog......nessuno a buon esito!! :)
Sicuramente e' il kernel, ma quale devo usare???
Haribo
smith3d

#9
Giorgio_multi

Giorgio_multi

    InsanelyMac V.I.P.

  • Gurus
  • 9,514 posts
  • Gender:Male
  • Location:Ferrara, Italy
  • Interests:Elettronica in genere, informatica e Sistemi Operativi in particolare. Cani da slitta e Sleddog....

Ciao!
Sto scrivendo dal mio nuovo leo 10.6.1 :)

Ho un paio di domande dopo pochissimo tempo che la sto usando.....quindi chiedo scusa ma non ho fatto cerca....

Itunes, si apre ma non mi permette di fare nulla, o meglio se provo a fare una qualsiasi operazione si chiude subito :D

Se provo a installare un programma di grafica , mi dice : XYZ for OS X requires 64-bit Intel macintosh :(
Sulla 10.5.8, nessun problema
Ho notato che se faccio About this mac, non mi riconosce il modello del processore Unknown :(

Per finire, ho usato osx86tools x la scheda video ma per errore ho salvato il boot da li :) , e non ho copiato come dicevi tu Giorgio la EFIstring nel com.apple.Boot.plist in /Extra.
Funziona, ma e' giusto??

Grazie a tutti
Smith3d

News:
ore 3.00 am......ho provato a installare altri prog......nessuno a buon esito!! :)
Sicuramente e' il kernel, ma quale devo usare???
Haribo
smith3d


HAi QE/CI attivati?

Giorgio

#10
smith3d

smith3d

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 144 posts

HAi QE/CI attivati?

Giorgio


Ciao Giorgio!!!!
Tu dicevi questo:
Attenzione che Snow Leopard non ti da il messaggio di Core Image Hardware Accelerato e Quartz Extreme supportato: ti accorgi se QE/CI sono attivati dalla possibilità di effettuare il cambio di risoluzione e dalla rotazione supportata.

Ho attivato QE/CI con OSX86Tools, al secondo reboot (abitudine), e ora non riesco piu' a disattivarlo!
Ho provato a cambiare risoluzione (nessun problema) ma quando provo a fare le rotazioni, vedo il mouse ruotare, ma il desktop resto nero.
Dimmi che ho fatto una minchiata e che devo formattare tutto, e mi rendi la persona piu' felice del mondo ;) :) :)
Grazie10000!
Smith3d

#11
Francesco75

Francesco75

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
  • Gender:Male
Buongiorno a tutti, sono un possessore di una Mainboard ASUS M2N32SLI Deluxe, e dopo vari tentativi di crearmi un hackintosh, ahimè tutti andati non a buon fine (ho utilizzato varie versioni di iDeneb) scopro l'esistenza di questo thread!!! :(
Addirittura sembrerebbe possibile installare non solo Leopard ma addirittura SnowLeopard!!!! non ci posso credere!!!! Dunque ero io a sbagliare qualcosa (sicuramente nella scelta dei pacchetti).
La mia configurazione hardware è la seguente:

Mainboard: ASUS M2N32SLI Deluxe BIOS 2101 (dovrei upgradare all'ultimo 2208 ma aggiunge solo supporto a CPU più recenti)
CPU: AMD ATHLON X2 6000+
RAM: GEIL DDR2@800Mhz
SCHEDA VIDEO: NVIDIA 88000GTS 320MB RAM
SCHEDA AUDIO: CREATIVE SOUNDBLASTER AUDIGY PCI (NON UTILIZZO L'AUDIO ONBOARD)
HARD DISK IDE
CDROM IDE
Tastiera USB con USB Port Replicator (Logitec G15)
Mouse Logitech USB Wireless (il Ricevitore è USB, Logitec MX700)

Con una simile configurazione sono riuscito ad installare la Ideneb 1.6.1058 Lite con Chameleon V2 e Kernel 9.8.0 Qoopz, arrivando a bootare il Desktop (o Dashboard che di si voglia) ma con il mouse immanovrabile (anche se durante l'installazione funzionava alla perfezione) nel senso che gli assi sembrano lavorare al contrario e la velocità del cursore è ingestibile (anche dopo essere riuscito a settarla al minimo dalla apposita utility). Ovviamente niente Audio (ma questo è secondario...) e la Lan mi ha funzionato una volta sola....

A questo punto chiedo il vostro aiuto su quale release partire (credo a questo punto la iDeneb 1.5.1057 full) e con quali pacchetti da selezionare per poi cercare di upgradare a SnowLeopard e vedere se i miei problemi migliorano

Grazie mille dell'aiuto che vorrete darmi!

Un saluto,

Francesco

#12
smith3d

smith3d

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 144 posts

Mainboard: ASUS M2N32SLI Deluxe BIOS 2101 (dovrei upgradare all'ultimo 2208 ma aggiunge solo supporto a CPU più recenti)
CPU: AMD ATHLON X2 6000+
RAM: GEIL DDR2@800Mhz
SCHEDA VIDEO: NVIDIA 88000GTS 320MB RAM
SCHEDA AUDIO: CREATIVE SOUNDBLASTER AUDIGY PCI (NON UTILIZZO L'AUDIO ONBOARD)
HARD DISK IDE
CDROM IDE
Tastiera USB con USB Port Replicator (Logitec G15)
Mouse Logitech USB Wireless (il Ricevitore è USB, Logitec MX700)

Francesco


Ciao francesco!
io ho la tua stessa bambina :) , e ho sempre fatto funzionare benissimo leopard :)
In questo momento ti posso dire 2 cose:
Io comincio sempre con la iso ideneb 10.5.5 e poi passo alla 10.5.8
Leopard 10.5.8 funziona benissimo....dal quello che ho capito solo io ho un problema con i DVD (IDE/SATA) ma l'ho risolto usandoli tutti e due (uno x masterizzare e il secondo per leggere )
Snow, e' il giochetto di ora....
Funziona quasi tutto dopo pochi giorni di uso
A me resta da capire il non funzionamento di Itunes e il non riconoscimento del mio processore su about this mac/more info/hardware utile x certi programmi di grafica.
Il genio/signor Giorgio e' la persona gusta x problemi come si dice profondi.....x quelli basi, chiedi pure :)
Ciao e ben venuto
Smith3d

Info x 10.5.5

AMD Patch
audio 1988 x la scheda come dici tu ONBOARD
AppleNForceATA
9.2.0
Fix:
SMBIOS 800
NVIDIA 320 mb


Ho provato le altre ISO, ma non riesco a installarle....poi passo direttamente alla 10.5.8, e ora snow :)
Giorgio ha vari metodi ma io x pigrizzia resto fedele alla mia originale :)
Se ho sbagliato Giorgio, sono a memoria e chiedo scusa

#13
Giorgio_multi

Giorgio_multi

    InsanelyMac V.I.P.

  • Gurus
  • 9,514 posts
  • Gender:Male
  • Location:Ferrara, Italy
  • Interests:Elettronica in genere, informatica e Sistemi Operativi in particolare. Cani da slitta e Sleddog....

Buongiorno a tutti, sono un possessore di una Mainboard ASUS M2N32SLI Deluxe, e dopo vari tentativi di crearmi un hackintosh, ahimè tutti andati non a buon fine (ho utilizzato varie versioni di iDeneb) scopro l'esistenza di questo thread!!! ;)
Addirittura sembrerebbe possibile installare non solo Leopard ma addirittura SnowLeopard!!!! non ci posso credere!!!! Dunque ero io a sbagliare qualcosa (sicuramente nella scelta dei pacchetti).
La mia configurazione hardware è la seguente:

Mainboard: ASUS M2N32SLI Deluxe BIOS 2101 (dovrei upgradare all'ultimo 2208 ma aggiunge solo supporto a CPU più recenti)
CPU: AMD ATHLON X2 6000+
RAM: GEIL DDR2@800Mhz
SCHEDA VIDEO: NVIDIA 88000GTS 320MB RAM
SCHEDA AUDIO: CREATIVE SOUNDBLASTER AUDIGY PCI (NON UTILIZZO L'AUDIO ONBOARD)
HARD DISK IDE
CDROM IDE
Tastiera USB con USB Port Replicator (Logitec G15)
Mouse Logitech USB Wireless (il Ricevitore è USB, Logitec MX700)

Con una simile configurazione sono riuscito ad installare la Ideneb 1.6.1058 Lite con Chameleon V2 e Kernel 9.8.0 Qoopz, arrivando a bootare il Desktop (o Dashboard che di si voglia) ma con il mouse immanovrabile (anche se durante l'installazione funzionava alla perfezione) nel senso che gli assi sembrano lavorare al contrario e la velocità del cursore è ingestibile (anche dopo essere riuscito a settarla al minimo dalla apposita utility). Ovviamente niente Audio (ma questo è secondario...) e la Lan mi ha funzionato una volta sola....

A questo punto chiedo il vostro aiuto su quale release partire (credo a questo punto la iDeneb 1.5.1057 full) e con quali pacchetti da selezionare per poi cercare di upgradare a SnowLeopard e vedere se i miei problemi migliorano

Grazie mille dell'aiuto che vorrete darmi!

Un saluto,

Francesco


Ovviamente il primo consiglio è di provare a sostituire mouse e Keyboard con altri 2 sempre USB, meno sofisticati, ad es a filo, per vedere se è un problema di Leopard sul tuo hardware o delle periferiche logitech (che comunque danno problemi).

Snow lo puoi installare tranquillamente. Ovviamente occorre un HD SATA (su cui ho fatto la guida), ma puoi comunque provare su HD IDE.

Giorgio

Giorgio

#14
Guest: cavallo_*

Guest: cavallo_*
  • Guests

Ciao francesco!
io ho la tua stessa bambina :) , e ho sempre fatto funzionare benissimo leopard :)
In questo momento ti posso dire 2 cose:
Io comincio sempre con la iso ideneb 10.5.5 e poi passo alla 10.5.8
Leopard 10.5.8 funziona benissimo....dal quello che ho capito solo io ho un problema con i DVD (IDE/SATA) ma l'ho risolto usandoli tutti e due (uno x masterizzare e il secondo per leggere )
Snow, e' il giochetto di ora....
Funziona quasi tutto dopo pochi giorni di uso
A me resta da capire il non funzionamento di Itunes e il non riconoscimento del mio processore su about this mac/more info/hardware utile x certi programmi di grafica.
Il genio/signor Giorgio e' la persona gusta x problemi come si dice profondi.....x quelli basi, chiedi pure :P
Ciao e ben venuto
Smith3d

Info x 10.5.5

AMD Patch
audio 1988 x la scheda come dici tu ONBOARD
AppleNForceATA
9.2.0
Fix:
SMBIOS 800
NVIDIA 320 mb


Ho provato le altre ISO, ma non riesco a installarle....poi passo direttamente alla 10.5.8, e ora snow :)
Giorgio ha vari metodi ma io x pigrizzia resto fedele alla mia originale :)
Se ho sbagliato Giorgio, sono a memoria e chiedo scusa


io quando avevo l''amd con nfoce provai ad installare come chipset quello del raid (sothbridge e/o sata che nel mio caso era silicon image), scopri cosi che ci potevo installare qualsiasi scheda grafica ed avrei avuto il qe/ci invece di ostinarmi con l'nforce (che mi mandava sempre in crash il network) oltre a non farmi funzionare le nvdia 8400 8500, tranne che con il kext della ideneb 1.1 fino a quando spegnevo.

#15
smith3d

smith3d

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 144 posts

io quando avevo l''amd con nfoce provai ad installare come chipset quello del raid (sothbridge e/o sata che nel mio caso era silicon image), scopri cosi che ci potevo installare qualsiasi scheda grafica ed avrei avuto il qe/ci invece di ostinarmi con l'nforce (che mi mandava sempre in crash il network) oltre a non farmi funzionare le nvdia 8400 8500, tranne che con il kext della ideneb 1.1 fino a quando spegnevo.


Grazie Cavallo!
Provero questa sera!

Spero tanto di poter risolvere il problema Itunes!
Nessuno di voi ha questo problema???
Ho letto che potrebbe risolversi con Marvin's AMD Utilities, patchando:
/System/Library/QuickTime/
and
/System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/CarbonCore.framework/Versions/A/
Provato, ma con esiti negativi.... :(
o forse sbagliato??? CONSIGLI??

Per tutto il resto, confermo il funzionamento con questa fantastica guida!
Haribo
Smith3d

#16
Guest: cavallo_*

Guest: cavallo_*
  • Guests

Grazie Cavallo!
Provero questa sera!

Spero tanto di poter risolvere il problema Itunes!
Nessuno di voi ha questo problema???
Ho letto che potrebbe risolversi con Marvin's AMD Utilities, patchando:
/System/Library/QuickTime/
and
/System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/CarbonCore.framework/Versions/A/
Provato, ma con esiti negativi.... :(
o forse sbagliato??? CONSIGLI??

Per tutto il resto, confermo il funzionamento con questa fantastica guida!
Haribo
Smith3d


come tutte le guide del Giorgione

#17
Giorgio_multi

Giorgio_multi

    InsanelyMac V.I.P.

  • Gurus
  • 9,514 posts
  • Gender:Male
  • Location:Ferrara, Italy
  • Interests:Elettronica in genere, informatica e Sistemi Operativi in particolare. Cani da slitta e Sleddog....

.... :D ....Purtroppo non sono riuscito a cavare un ragno dal buco....
Ecco le prove che ho fatto:
Ho utilizzato una Ideneb 1.5.1057 come base di partenza (la 1055 purtroppo non sono riuscito a trovarla)
Ho selezionato le seguenti opzioni:
Chameleon V2
APPLE SMBIOS 800
Kernel 920 + AMD PATCH
CHIPSET NFORCE ATA
NVDARWIN 320mb
NESSUNA SCHEDA DI RETE SELEZIONATA (Tanto per vedere se almeno riuscivo a fare il boot)

Il risultato è una installazione che sembra andare a buon fine ma al riavvio rimango fermo allo screen bianco con la mela....

N.B. Ho provato anche a reinstallare utilizzando il Kernel 9.7.0 Qoopz ovviamente senza l'AMD PATCH
ma il risultato non cambia...

Aiutoooo


Sezione sbagliata, questa è la Guida per Snow Leopard

Giorgio

#18
Francesco75

Francesco75

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
  • Gender:Male

Sezione sbagliata, questa è la Guida per Snow Leopard

Giorgio


Scusami tanto Giorgio, hai ragione....ho eliminato il reply....

#19
smith3d

smith3d

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 144 posts
Ok, posso finalmente dirlo:
Dopo 3 giorni di prove e prove di vario genere...
FUNZIONA!!!
Ho risolto il problema Itunes e altri vari problemi con con Marvin's AMD Utilities, selezionando la cartella /System.
Grazie a tutti!!!!
Smith3d

#20
fra_c

fra_c

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
Ciao a tutti,

sono nuovo, vorrei chiedere se c'è il modo di installare snow leopard senza l'uso di un "leopard funzionante", ovviamente utilizzando l'Asus M2NSLI DELUXE??

Grazie e complimenti!!





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy