Jump to content

[GUIDE] Retail Snow Leopard Install on eeepc 901


  • Please log in to reply
288 replies to this topic

Poll: Guide Works (80 member(s) have cast votes)

Is this guide working on your eeepc 901?

  1. Yes. Perfectly. I'm in eeepc Nirvana. (50 votes [62.50%])

    Percentage of vote: 62.50%

  2. Yes, but I had to install additional drivers. (13 votes [16.25%])

    Percentage of vote: 16.25%

  3. No (17 votes [21.25%])

    Percentage of vote: 21.25%

Vote Guests cannot vote

#261
raph38130

raph38130

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
I have a 10.6.2 version (patched kernel) on an EEE901/32G SSDruncore/ralink wifi ; sound BT trackpad everything is ok but :
- if gma950 is ok on lcd (1024x60x32), connecting the external vga freezes the netbook
- I can't update to 10.6.3 via wizard (do not find any update...)

on an external hd, I have 10.6.3 version but can't get 1024x600 resolution
If I boot in safe mode, I have 1024x600 but some kexts are not loaded and I do not have network, wifi,...

can somebody share its experience with eee901 sl 10.6.3 GMA950 configuration ... does anybody got successfully 1024x600x32 in lcd and external high res. vga ?


do you use dsdt.aml ? which one ? device-properties in com.apple.Boot.plist ?

#262
wiredworld

wiredworld

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
  • Gender:Male
Installed 10.6.1 using mk500's guide.

Sleep works perfectly when SL booted from external USB HDD.

However, sleep does not work when the internal HDD is used to boot 10.6.1 (same disk image as external USB HDD). Note:SSDs removed and replaced with Samsung HS082HB HDD (uses Mini PCI-e to ZIF adapter).
Also, booted from original SSD and got same same sleep problem as when booting from internal HDD - screen goes black, system lights remain on.

It's curious that the 901 will sleep when booted from external USB HDD (even puts internal HDD to sleep).

Any idea why this would happen?

#263
grassmudhorse

grassmudhorse

    InsanelyMac Protégé

  • Members
  • Pip
  • 29 posts
For those who updated to 10.6.3 and claim everything works perfect, do you have any bluetooth problems? My BT panel load extremely slow and there are tons of unconnected devices.

I uploaded a screenshot here:
http://www.insanelym...howtopic=220260

If you don't have any problem with your BT, do you mind share your dsdt with me?

Thanks!

#264
Powers67

Powers67

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
I've followed these instructions exactly, but haven't managed to get it to boot OSX SL off the external HDD. After choosing the drive in Chameleon, it just sits with a blinking white cursor. I tried multiple times, leaving it 10-20 mins each time with no luck. A complete format and reinstall onto the external also did not help.

I'm on the stock 2103 bios. Anyhelp would be greatly appreciated.

#265
digbybare

digbybare

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
Hey, I followed this guide exactly and right now I'm stuck on the wifi. I downloaded the dmg from Ralink but there's only installers for 10.3, 10.4 and 10.5. I tried using the installer for 10.5, but it gives me an error saying the kext cannot be installed.

Anyone know what I should be doing?

#266
Suomy Nona

Suomy Nona

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
Many thanks to mk500 and everyone else who has contributed to this guide!  The instructions were easy to follow, and it was a great help to have everything zipped and available for download in a single file.  Well, except for the Ralink driver, but that's understandable.

If I could make one suggestion to help clarify the guide, it would be to point out that the Ralink site does not list 10.6 for the RT2860/RT2790 driver.  Obviously it works, but a note to reassure newbies might help prevent questions about it being posted here.

Thanks again!!!

#267
HomdfK

HomdfK

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
Hi,

my fan is running very fast. So I guess the cpu works at the maximum.
Is there any option-like it is in WinXP- to set down the speed of the cpu?
While reading on the internet XP usually didn't activate the fan at all. now it is at full speed and the batterie lasts for 3-4 hours instead of 6-7??

Using 901 & 10.6.0 installed with NetbookCD

#268
skywalker3

skywalker3

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
Hi at all. I've installed SL on my eeepc and runs great. I only have two or three problems. 1) option "About this mac" isn't available. 2) Conection vga out: When I connect my eeepc to monitor or tv the image is distorted,no works well. When I disconnect the monitor or tv returns to works well on my eeepc. Any solution for this? And one curiosity, when I run any program and the window expand, this windows exceed the display and and not let me see the whole window. Thanks in advanced

#269
Cryptopsy

Cryptopsy

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
Hey Guys, this Tutorial worked great for me and my eeepc 901go...
the only thing is the wifi, i cannot get it to work!
i tried the ralink drivers, and the .kext in the folder from the first page, nothing worked!
the eeepc is from europe (i get it in austria) i dont know if this is importent?!

maybe some of you can help me!
thanks you!

#270
orjfor

orjfor

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts

Hey Guys, this Tutorial worked great for me and my eeepc 901go...
the only thing is the wifi, i cannot get it to work!
i tried the ralink drivers, and the .kext in the folder from the first page, nothing worked!
the eeepc is from europe (i get it in austria) i dont know if this is importent?!

maybe some of you can help me!
thanks you!


I also had problems installing ralink drivers. I figured out that I had to go to System settings/network and delete all network connections. After that I uninstalled all earlier tries to install ralink driver. I tried version 10.3, 10.4, 10.5. It's 10.5 you should use. Then I rebooted the computer and installed the ralink driver. Then, I think, I went to system settings network and a new interface was found. Activated it and opened the ralink app for setting up the wifi connection. After that it worked for me.

Anyway I went out on Ebay and found used Apple airport card so now I don't need to use the Ralink app. It only cost me $ 15 including shipping and it works better than the Ralink card. So I recommend a visit on Ebay to pick up an airport card.

Also I have upgrade to 10.6.4 and it works just as well as 10.6.1.
To install 10.6.4 I started with an SL upgrade disk I ordered from Apple. It was an 10.6.3 version of OSX. I followed this excellent guide by mk500 only difference was the OSX version. I downloaded new versions of AppleIntelGMA950.kext and AppleIntelIntegratedFramebuffer.kext and replaced the ones included in Extensions in mk500's zip file. You find them here: http://www.mediafire.com/?ulmbgzonbi3 . Then I downloaded the patched mach_kernel from this link: http://www.insanelym...p...197020&st=0 . Then you need a new SleepEnabler. I downloaded it from http://www.kexts.com...for_10.6.4.html replace this one with the one included in the /Extra/Extensions folder from mk500:s zip file. After that you need the patched kernel for 10.6.3 found here: http://www.insanelym...p...197020&st=0. I needed this to get the 10.6.3 version going first. Then I used Gothnet's guide to get the kernel the right. It can be found in this thread but I quote it here for you:

"Download teateam kernel and 10.6.x SleepEnabler.
Go to terminal,
sudo cp /user/<yourusernamehere>/Downloads/mach_kernel_atom /mach_kernel_atom
sudo chown root:wheel /mach_kernel_atom
sudo rm -r /Extra/Extensions/SleepEnabler.kext
sudo cp -R /User/<yourusernamehere>/Downloads/SleepEnabler.kext /Extra/Extensions/

Then run the kext utility to fix up permissions. No idea if this is necessary but it makes me feel safer.
Then run the appel update to 10.6.3

When it's done, at the Chameleon boot screen type mach_kernel_atom to boot the teateam kernel. When t boots go back to the terminal and -

sudo mv /mach_kernel /mach_kernel_vanilla
sudo mv /mach_kernel_atom /mach_kernel!"

After that I booted the USB disk on my Eee 901. Then I upgraded to 10.6.4. Now I put the disk back to my macbook and replaced the mach_kernel to a patched one for 10.6.4 also I replaced AppleIntelGMA950.kext and AppleIntelIntegratedFramebuffer.kext. Finally I plugged the disk back in the 901 and ran the KextUtility.

If you go from 10.6 directly to 10.6.4 you don't need this 10.6.3 step I did go direct from 10.6 to 10.6.4 the important thing is to use the right mach_kernel SleepEnabler.kext, AppleIntelGMA950.kext and AppleIntelIntegratedFramebuffer.kext. I use the same versions for 10.6.4 as I did for 10.6.3 of appleIntelGMA950.kext and AppleIntelIntegratedFramebuffer.kext the SleepEnabler.kext says it works for 10.6.x.

I tried to write this down because it seems that this thread kind of died and it is a lot of info out there. I tired the Netbookinstaller but i couldn't get that right with the 901. This is how I managed to get 10.6.4 running on the 901. :(

#271
macmal

macmal

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts

Hey Guys, this Tutorial worked great for me and my eeepc 901go...
the only thing is the wifi, i cannot get it to work!
i tried the ralink drivers, and the .kext in the folder from the first page, nothing worked!
the eeepc is from europe (i get it in austria) i dont know if this is importent?!

maybe some of you can help me!
thanks you!



eeepc 901go don't mount a Realtek wirles card, but atheros ar5007eg.
This hardware is not compatible whit OSX, actually i don't have a solution.
let me know if you find any solution.

Thenks.

#272
windtaker

windtaker

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts

eeepc 901go don't mount a Realtek wirles card, but atheros ar5007eg.
This hardware is not compatible whit OSX, actually i don't have a solution.
let me know if you find any solution.

Thenks.



Hi there! I bought a BROADCOM WI-FI MINI PCI-E CARD HP DELL DW 1390 AIRPORT on ebay. works like a charm! founded wifi´s that are out of reach with my MBP 17" on my work. it dont needs any drivers. recognizes like original. ( or maybe from some kext in extras, I´m not wuite sure. but i have not to do something extraordinary magic. )

Thanks for the tutorial btw! Exsellent and easy. i only dont get Bluetouth to work.. but its ok for me =) Dont need it

#273
moly82

moly82

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 212 posts
hi guys, I'm currently on 10.6.6 with stock 1808 bios (no DSDT)

everything is working, but it seems sometimes the eeepc got very very hot, and suddenly shut down (I think because of the safety thermal control)

do you know why? Should I try a different bios (maybe 2503)? But then BT doesn't work and I really need it..

anyone has a patched DSDT file for 1GB memory?


thanks in advance bye

#274
moly82

moly82

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 212 posts
nobody is using SL on the eeepc 901 anymore? cna't believe that.. has this project ended? :(


by the way I've also tried bios 2503 and it seems that the eee is still getting very hot soon, dunno why.. but maybe my fan is not working anymore at all (I can never hear it starting so I think it doesn't work..)

bye!

#275
moly82

moly82

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 212 posts
problem fixed :)

the fan was not working indeed, but after opening the eeepc completely checking connections etc and re-closing it it started to work again :D


running on 10.6.6 fully working now!


byeeeeeeeee

#276
moly82

moly82

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 212 posts
I've been asked in pvt how to get 10.6.6 up and running on the eee901.. here is what I did.. please don't PM me use this thread instead..


-installed hazard 10.6.2 (installer options: kernel 10.6.2 atom, chameleon RC4, voodoo battery, voodoo monitor, voodooPS2trackpad, voodoo power, open halt restart and PS2 fix)

- removed SleepEnabler.kext and rebooted

- updated to 10.6.6 (downloaded the combo update from apple.com, not used the Software Update)

- installed TeaTeam kernel 10.6.0 before reboot

- installed kexts from this thread via Kext Utility: natit, AppleIntelGMA950, IntelIntegratedFramebuffer

- installed 10.6.0 compatible SleepEnabler.kext found on the web via kext utility (http://www.insanelym...dpost&p=1622363)


.....that's all ;)

bye!!

#277
otropatolucas

otropatolucas

    InsanelyMac Protégé

  • Members
  • Pip
  • 28 posts
Hi Moly82,

Sorry but I can't find these options in my hazard 10.6.1-10.6.2 iso: chameleon RC4, open halt restart and PS2 fix. Are you sure is this version?

Do you use 2503 original bios, don't you? Because I need this bios for a dual os with windows 7.

Thanks for your help.

#278
moly82

moly82

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 212 posts
hi, you are the second person who tells me this, that in their 10.6.1-10.6.2 hazard disc they can't find those options.. actually my dvd is called:

"Snow Leopard Client Server 10.6.2 SSE2/SSE3 Intel AMD by Hazard"


while I think yours is:
"Snow Leopard 10.6.1-10.6.2 Intel AMD made by Hazard"


..so very probably we have different discs..

by the way you should be able to proceed with the installation anyway, just select a different chameleon bootloader (and without the PSX2FIX you may need to connect an external usb mouse and keyboard, so get those first). You can install those kext/fix also later..


about the bios, I use the 1502 patched bios by kabyl, with no dsdt.aml file.
Also 2503 will work (and even better during the install as you will see all the screens properly, while with 1502 the visualization is not correct, I have to select some options without seeing them, "blind") but when everything is set up you should have bluetooth problems if you don't install a proper dsdt.aml file :unsure:

bye!



@ EVERYONE: can somebody post his working dsdt.aml file for bios 2503 and RAM=2 GB? THANKS!

#279
otropatolucas

otropatolucas

    InsanelyMac Protégé

  • Members
  • Pip
  • 28 posts
Hi,
Thanks for your fast response. I'm going to search your hazard iso and I'll try with 2503 bios, becasuse I don't need bluetoth (in fact, usually I put it off).

regards

#280
otropatolucas

otropatolucas

    InsanelyMac Protégé

  • Members
  • Pip
  • 28 posts
Hello moly82
Thanks for your instructions, now that works great. Only a question: Do you know how to acces to the LeoHazard install DVD options? Default options are: 64 bit EFI, 64 bit kernel boot, 32 bit processor and 32 bit kernel. I'd like to modify the kernel boot and efi to 32 bit (typing -v arch=i386 before installation) but access with pf8 doesn't work.

thanks





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy