Jump to content

10.6 on a notebook HP nx7400


  • Please log in to reply
27 replies to this topic

#21
cynop

cynop

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 5 posts
hey guys...it's good to see there are people here still messing around with the nx7400. I'm a noob in all the osx86 stuff, though fairly expirienced on linux and windows. Anyway heres the thing: I' downloaded, booted and installed Snow_Leopard_10.6.1-10.6.2_SSE2_SSE3_Intel_AMD_by_Hazard and all i get is kernel panics. Tried booting with cpus=1, arch=i386, -x nothing works. I always fail with the message

""a kext releasing a(n) OSArray has corrupted the registry."@/SourceCache/xnu/xnu-1456.1.25/libkern/c++/OSObject.pp:244

and after some lines i get a message about a problem with com.apple.iokit.IOACPIfamily(1.3.0) and org.tgwbd.driver.elliottforcelegacyRTC
In the bios all the options in Device Configurations are "enable" and the HDD translation mode in "bit-shift". There are no usb devices plugged in.
The installation finished just fine, but i haven't managed to boot correctly once.any ideas?

#22
JuiCe_pl

JuiCe_pl

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts

I have NX7400- with OSX 10.6 and both cores working


How can You have both cores working if You have cpus=1 in your plist?

#23
chris found

chris found

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts

Finally got 10.6.4 working on NX7400 so I wanted to post how I got there maybe it will help someone else.

Here is the procedure I used to get things to work.

1. I downloaded and installed Snow_Leopard_10.6.1-10.6.2_SSE2_SSE3_Intel_AMD_by_Hazard
and installed with 10.6.2 upgrade.

2. Install Chamelion 2 rc4 on the partition where the SL was installed (Part of Hazard install)

3. Download "nx7400.zip" (in post upper, thanks to Al-Baby) and place the kext into folders and did REPAIR PERMISION on KEXT Utility

4. After boot not that much was working just had vga screen and no network at all.

5. Update to SL 10.6.4 with MacOSXUpdCombo10.6.4.dmg and ##### following upgrade procedure at:
http://tonymacx86.bl...ac-os-x-on.html

6. After upgrade the Intel GMA 950 graphics card was working correctly.

7. Bought WG111v3 at Best Buy for 39.00 and loaded Netgear Wlan Client Utility from
http://kb.netgear.co...etail/a_id/2640 . and followed the procedure from
http://wiki.osx86pro...10.6.3#Wireless

Below are still some issues:

1. On board Broadcom never got to work.

2. Cpu gets extremely hot.

3. Still could not get to work with cpus=2

Thanks for all the posts here an other locations to get this working could not have done it without the forums.
You guys are great.


hi
Sorry to bother you, but what settings did you use for the hazard install, I could never get it to install.

Many thank
Chris

#24
Al-Baby

Al-Baby

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts

I don't think you're running on two cores. The com.apple.Boot.plist file is configured for cpus=1. Try changing it to cpus=2 and you'll get to enjoy all the unstability as previous.

Regardless I'm happy to be using a retail install of snow leopard even if it's only with a single core.

You are quite right -I do only have one core working its just that the "About this Mac" says its 2 core. But when I use cpus=2 -it does not boot.
On the other hand the performance with a single core- is faster than my Dual Core Macbook Pro (2.15GHz). When tested with Xbench it has result of 145 with hard disk option switched off. The Macbook Pro has a result of 135.
Also I now have the CPU temperature running at a low value of 41'C .Funny thing -I have done nothing to it since it was running at 80'C-so I can not tell you what has changed.
For the rest its runs as a normal Mac except it does not sleep(can anyone help).
For your information the only hardware change has been - to an Dell Airport board and an upgraded 400Gb HD-when first starting this project.

I don't think you're running on two cores. The com.apple.Boot.plist file is configured for cpus=1. Try changing it to cpus=2 and you'll get to enjoy all the unstability as previous.

Regardless I'm happy to be using a retail install of snow leopard even if it's only with a single core.

You are quite right -I do only have one core working its just that the "About this Mac" says its 2 core. But when I use cpus=2 -it does not boot.
On the other hand the performance with a single core- is faster than my Dual Core Macbook Pro (2.15GHz). When tested with Xbench it has result of 145 with hard disk option switched off. The Macbook Pro has a result of 135.
Also I now have the CPU temperature running at a low value of 41'C .Funny thing -I have done nothing to it since it was running at 80'C-so I can not tell you what has changed.
For the rest its runs as a normal Mac except it does not sleep(can anyone help).
For your information -I changed to an Dell Airport board when first starting this project.

#25
Metroid Quest

Metroid Quest

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts
Noob here!
I installed SL 10.6 by Hazard on my nx7400 with 2.5GB RAM.
When installing, I selected 'Customize' on the install and chose only 10.6.2 Combo and Chameleon RC3 10.5. The install completed successfully.

When the computer boots up from the HDD, I get the hazard flashy apple logo followed by a kernel panic.

Sorry again for being such a noob, but can someone show me a step-by step?

BTW, I'm happy with just 1 core

Thanks.

#26
Denken

Denken

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts
Hi! Get rid off NullCPUPowerManagment.kext to have cool stone. And I have 1 core... Still!

#27
jchan

jchan

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts

I'm on the same problem!

Did any of you figured out how to solve the cpus=1 problem?



#28
jchan

jchan

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts

I also have problems with AppleIntelGMA950.kext. It looks like it had no bright. I have to switch it to a external display, because I can't see anything







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   Web hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy