Jump to content

WiFi Card Support in 64-bit Snow Leopard


  • Please log in to reply
10 replies to this topic

#1
robotfactory

robotfactory

    InsanelyMac Protégé

  • Members
  • Pip
  • 26 posts
I know this topic has been kicked around in a few threads, but it seems as though there is still no answer. From my research, this does not seem like an isolated issue, it seems like everyone that is trying to use a PCI Wifi card in 64-bit SL is having no luck.

My card worked great (recognized as Airport right out of the box) in both 10.5.8 and it works out of the box in 10.6.1 32-bit, but if i load into 64-bit mode, the card no longer appears/works.

Just thought it might be helpful to create a thread to try to solve this issue collectively. I would love to run 64-bit, but this is the only thing holding me back!

I am using a D-Link DWA-542 Rangebooster N PCI card.

#2
Jib51

Jib51

    InsanelyMac Protégé

  • Members
  • Pip
  • 32 posts
  • Gender:Male
  • Location:France
As far as I know, your card is based on the same Atheros chipset than my DWA-457 from Dlink. And there's no 64 bits drivers for this chipset yet. We'll need to wait...

#3
himac59

himac59

    InsanelyMac Protégé

  • Members
  • PipPip
  • 59 posts
With the (Netkas) Atheros21, 32/64bits, see www.netkas.com its from beta 10.6.2
http://www.sendspace.com/file/9zpo4a

Added also the DWA 556 with 168,3a70 worked for me DWA-556

Put it in the IO80211Family.kext now fully working "Airport" in menu

i didnt use the installer(kext helper) i used drag and drop

in Systemprofiler:

Softwareversions:
Menu-extra: 6.0 (600.22)
configd-plugin: 6.0 (600.27)
Systemprofile: 6.0 (600.9)
Networkpref: 6.0 (600.22)
AirPort-config.: 5.4.2 (542.23)
IO80211-family: 3.0 (300.20)
Interfaces:
en1:
Type card: AirPort Extreme (0x168C, 0x3A70)
Firmwareversion: Atheros 5416: 2.1.8.7
Language: Unknown
Landcode:
Supported PHY-modi:: 802.11 b/g/n
Supported channels: 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13
Status: Connected
==========================================
DWA-547-Atheros 5416/AR5008
DWA-552-Atheros 5416/AR5008
DWA-556-Atheros 5418/AR5008E id168c-23 or 168c-24/ 168c,1a/ 168c,3a69
for me its 168c,3a70

AR5418+AR5133
AR5416+AR5133
AR5416+AR2133
AR9160/AR9280/AR9281

DWA-547 and DWA-552 are identical

also see:
http://www.insanelym...20#entry1244185

#4
fullthrottle3360

fullthrottle3360

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts
Hmm what do you mean by

AR5418+AR5133
AR5416+AR5133
AR5416+AR2133
AR9160/AR9280/AR9281




....?



Oh and do you happen to know how to get the Atheros ar9285 working?

#5
garmone

garmone

    InsanelyMac Protégé

  • Members
  • Pip
  • 41 posts
I'm particularly interested in this topic as well. I have a DWA 542 and despite a successful 10.6.2 install, the system doesn't recognize any Airport card. Any ideas?

#6
himac59

himac59

    InsanelyMac Protégé

  • Members
  • PipPip
  • 59 posts

I'm particularly interested in this topic as well. I have a DWA 542 and despite a successful 10.6.2 install, the system doesn't recognize any Airport card. Any ideas?



Try this AirportAtheros21.kext. Is Snow Leopard 32/64bit

http://www.kexts.com..._wireless_.html

#7
treeml

treeml

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts

Try this AtherosFix.kext. Is Snow Leopard 32/64bit

http://www.insanelym...t=#entry1325245



I don't know about anyone else, but every time i try this i get a panic.

even if i change to my device id in the plist within the kext.

I wish I could work this out, its the only thing left for my almost perfect system :)

#8
raven2004

raven2004

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
anyone find a fix for this card in 64 10.6.2? I am having the same issues with the card not showing up in 10.6.2 64bit. thanks guys

#9
Komano

Komano

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 175 posts
Maybe you guys might want to try this. :(

Attached File  AtherosFix.kext.zip   3.36KB   83 downloads

#10
Dradis

Dradis

    InsanelyMac Protégé

  • Members
  • PipPip
  • 66 posts
I don't mean to be that d-bag who says "get a chevy" because you asked how to fix a ford, but if you can't find a solution for your atheros i would suggest a broadcom card. In my experience broadcoms are usually plug n play and recognized as airport with no need for kexts. The only tricky part can be determining which cards use which chipsets, but google can help with that.

In either case, for the sake of everyone else with the same issue, let us know how you solve your problem.

#11
Komano

Komano

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 175 posts

I don't mean to be that d-bag who says "get a chevy" because you asked how to fix a ford, but if you can't find a solution for your atheros i would suggest a broadcom card. In my experience broadcoms are usually plug n play and recognized as airport with no need for kexts. The only tricky part can be determining which cards use which chipsets, but google can help with that.

In either case, for the sake of everyone else with the same issue, let us know how you solve your problem.


Sure, my explanation is on my worklog. It can be found here under the entries section.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy