Jump to content

Snow Leopard si avvia solo con opzione -f -v


  • Please log in to reply
7 replies to this topic

#1
Rik26

Rik26

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 254 posts
Salve a tutti, non so se posso postare qui ma ho un problemino strano con l'avvio di Snow Leopard. Ho due hard disk, nel primo è installato leopard con il Chameleon 2 Rc1 e sul secondo ho installato Snow leopard con il Chameleon v 1012 come spiegato nella guida postata da EmptySkull. Allora.. Se all'avvio faccio partire il disco di Snow leopard dal Chameleon 2 ottengo un KP ma, leggendo nel forum ho capito che è normale. Allora all'avvio scelgo il disco di Snow da Bios e mi parte Darwin con i suoi 5 secondi di attesa. Se non do altri comandi mi compare la mela e subito un bel Kp. L'unico modo x farlo avviare in maniera corretta è con l'opzione -f -v da Darwin. Come si spiega sta cosa? E' come se lui non riuscisse a caricare i kext o qualcosa del genere... Senza -f -v mi da KP in un nanosecondo...

#2
BarboneNet

BarboneNet

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 1,414 posts
  • Gender:Male
  • Location:Italy - Parma

Salve a tutti, non so se posso postare qui ma ho un problemino strano con l'avvio di Snow Leopard. Ho due hard disk, nel primo è installato leopard con il Chameleon 2 Rc1 e sul secondo ho installato Snow leopard con il Chameleon v 1012 come spiegato nella guida postata da EmptySkull. Allora.. Se all'avvio faccio partire il disco di Snow leopard dal Chameleon 2 ottengo un KP ma, leggendo nel forum ho capito che è normale. Allora all'avvio scelgo il disco di Snow da Bios e mi parte Darwin con i suoi 5 secondi di attesa. Se non do altri comandi mi compare la mela e subito un bel Kp. L'unico modo x farlo avviare in maniera corretta è con l'opzione -f -v da Darwin. Come si spiega sta cosa? E' come se lui non riuscisse a caricare i kext o qualcosa del genere... Senza -f -v mi da KP in un nanosecondo...

hai inserito il file extesions.mkext? se si, prova a toglierlo!

#3
Rik26

Rik26

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 254 posts

hai inserito il file extesions.mkext? se si, prova a toglierlo!

Ciao! Ti riferisci a quello in Extra o a quello in system/library/extension? Nella cartella Extra non ce l ho, ho provato a crearlo x vedere se cambiava qualcosa ma nulla... Mi è venuto il sospetto ke all avvio non vengano caricati in automatico i kexts presenti in extra, x quello il sistema va in tilt.. È strano ke si avvii solo con il caricamento forzato dei kext. Il verbose penso c entri nulla. Chiedo il vs aiuto, son abbast testardo e devo farlo funzionare a tutti i costi;)

#4
geminimac

geminimac

    Italian Staff Squad

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 1,417 posts
  • Gender:Male
  • Location:Modena

Ciao! Ti riferisci a quello in Extra o a quello in system/library/extension? Nella cartella Extra non ce l ho, ho provato a crearlo x vedere se cambiava qualcosa ma nulla... Mi è venuto il sospetto ke all avvio non vengano caricati in automatico i kexts presenti in extra, x quello il sistema va in tilt.. È strano ke si avvii solo con il caricamento forzato dei kext. Il verbose penso c entri nulla. Chiedo il vs aiuto, son abbast testardo e devo farlo funzionare a tutti i costi;)



reinstalla il chamelon così ti crea la cartella extra e poi dentro a questa cartella ci metti i tuoi kext hardware

saluti

#5
desmogix

desmogix

    InsanelyMac Legend

  • Donators
  • 810 posts
  • Gender:Male
  • Location:Rome
la flag -f cancella il file della cache delle extensions, se ti parte solo in -f siglinifica che nella tua cache c'è qualcosa che non va (credo quindi anche nei kext che usi, ma potrei sbagliare).
Barbone si riferisce a quello che carica l'OS all'avvio, se usi chameleon è in /Extra/ altrimenti in /Library/Preferences/SystemConfiguration/.

Seguirei il consiglio di gemini cmq ...
ciao

#6
Rik26

Rik26

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 254 posts

reinstalla il chamelon così ti crea la cartella extra e poi dentro a questa cartella ci metti i tuoi kext hardware

saluti

Ciao! Forse mi sono espresso male... La cartella Extra già ce l ho con dentro i kext. Quello ke manca è Extension.mkext

#7
geminimac

geminimac

    Italian Staff Squad

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 1,417 posts
  • Gender:Male
  • Location:Modena

Ciao! Forse mi sono espresso male... La cartella Extra già ce l ho con dentro i kext. Quello ke manca è Extension.mkext



rigenera mkext allora e risolvi...esiste l'utility

saluti

#8
BarboneNet

BarboneNet

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 1,414 posts
  • Gender:Male
  • Location:Italy - Parma
la cache dei dei kext dovrebbe essere proprio mkext......boh!





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy