Jump to content

Upgrade ideneb 10.5.8: IntelPRO100 KO ![RISOLTO in parte]


  • Please log in to reply
10 replies to this topic

#1
HAL9064

HAL9064

    InsanelyMac Protégé

  • Members
  • Pip
  • 33 posts
Ciao a tutti,

è da un pò che non mi cimento con osx su PC.
Ho ripreso in mano la ideneb 10.5.4 e l'ho installata sul notebook in firma.

Tutto ok.

Poi ho eseguito l'upgrade con idenem combo all 10.5.8, tutto ok (boot con kernel voodoo) tranne che la scheda di rete.

E' la classica IntelPRO100VE che prima funzionava a meraviglia con la sua patch, ora nulla.
Ho provato a reinstallare il pkg dalla 10.5.4 , il kext AppleIntel8255 si carica (anche con il kextload a mano) ma la scheda di rete non funge.

Idee?

Grazie

AGGIORNAMENTO: Prob IntelPRO 100 risolto eliminando AppleHPET.kext e boot -f, altri problemucci :
- mount usb mass storage solo se già inserite al boot (poi sembrano funzionare sia umount che mount)
- orologio sempre avanti 2 ore
- Hibernate image too old al boot

#2
H&C

H&C

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 110 posts
è simile al mio problema....abbiamo la stessa scheda...

ti rimando anche alla mia discussione dove mi hanno consigliato di cancellare un kext e qui (LINK) puoi leggere i risultati "positivi" (per modo di dire) magari con te funziona... 

#3
H&C

H&C

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 110 posts
volevo informarti che a me con la 10.5.7 (iAtkos ma non cambia con l iDeneb) togliendo il kext AppleHPET.kext e riavviando SEMPRE (e qui sta la rottura di palle) in -f funziona tutto...ora sto provando con iDeneb 1.6 10.5.8 e ti faccio sapere se funziona....

#4
H&C

H&C

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 110 posts
AGGIORNAMENTO:

ho installato la iDeneb 1.6 (10.5.8) e come previsto l ethernet non veniva rilevato (anche installando la patch) allora ho cancellato l AppleHPET.kext, riavviato in -f e tutto funziona (non in DHCP mi pare) e cmq NON è NECESSARIO RIAVVIARE OGNI VOLTA IN -f. BASTA LA PRIMA SOLTANTO.

ENJOY MAC :)

#5
HAL9064

HAL9064

    InsanelyMac Protégé

  • Members
  • Pip
  • 33 posts

AGGIORNAMENTO:

ho installato la iDeneb 1.6 (10.5.8) e come previsto l ethernet non veniva rilevato (anche installando la patch) allora ho cancellato l AppleHPET.kext, riavviato in -f e tutto funziona (non in DHCP mi pare) e cmq NON è NECESSARIO RIAVVIARE OGNI VOLTA IN -f. BASTA LA PRIMA SOLTANTO.

ENJOY MAC :D


Grazie per le info a tutti, ora provo eliminando HPET ... Ma poi, perchè eliminarlo? Cioè, di cosa si occupa HPET? Non è magari basta modificarlo/downgradarlo ecc...

#6
HAL9064

HAL9064

    InsanelyMac Protégé

  • Members
  • Pip
  • 33 posts
Aggiornamento:

- Ho copiato AppleIntel8255.kext della 10.5.4 (installata in /System/Library/Extension/) in /Sytem/Library/IOnetworkingFamily.kext/Contents/Plugins/ dove c'era ancora il vecchio AppleIntel8255 senza l'identificativo della mia scheda in Info.plist --- Nessun risultato

- Ho rinominato AppleHPET.kext, boot -f ---- Tutto ok, sono in rete (anche con dhcp)

- Non ho ancora provato un boot normale, più tardi ci provo.

- Ho notato che senza HPET il mio hackintosh è molto più reattivo e veloce !!! Può essere o è solo una impressione?

Altra cosuccia che magari possono aiutare i "gurus":

- facendo il kextload di AppleIntel8255 (prima di rimuovere HPET) mi dava questo errore:

bash-3.2# kextload /Library/Extensions/AppleIntel8255x.kext
/System/Library/Extensions/System.kext/PlugIns/Unsupported.kext/Unsupported: Undefined in symbol set: _sha1_hardware_hook
kextload: /Library/Extensions/AppleIntel8255x.kext loaded successfully

Infine 3 altre cose che devo riuscire a sistemare:

- Ad ogni boot mi compare la dicitura: Hibernate Image too old, use ForceWake=y
- l'orologio di sistema è sempre 2 ore in avanti, se lo regolo poi me lo ritrovo sballato in ubuntu :-)
- Non mi compare l'icona della batteria in alto a destra nonostante l'abbia selezionata nelle preferences (al momento di selezionarla comapre per una frazione di secondo e poi scompare)


Grazie a tutti.


Aggiornamento:

- Ho copiato AppleIntel8255.kext della 10.5.4 (installata in /System/Library/Extension/) in /Sytem/Library/IOnetworkingFamily.kext/Contents/Plugins/ dove c'era ancora il vecchio AppleIntel8255 senza l'identificativo della mia scheda in Info.plist --- Nessun risultato

- Ho rinominato AppleHPET.kext, boot -f ---- Tutto ok, sono in rete (anche con dhcp)

- Non ho ancora provato un boot normale, più tardi ci provo.

- Ho notato che senza HPET il mio hackintosh è molto più reattivo e veloce !!! Può essere o è solo una impressione?

Altra cosuccia che magari possono aiutare i "gurus":

- facendo il kextload di AppleIntel8255 (prima di rimuovere HPET) mi dava questo errore:

bash-3.2# kextload /Library/Extensions/AppleIntel8255x.kext
/System/Library/Extensions/System.kext/PlugIns/Unsupported.kext/Unsupported: Undefined in symbol set: _sha1_hardware_hook
kextload: /Library/Extensions/AppleIntel8255x.kext loaded successfully

Infine 3 altre cose che devo riuscire a sistemare:

- Ad ogni boot mi compare la dicitura: Hibernate Image too old, use ForceWake=y
- l'orologio di sistema è sempre 2 ore in avanti, se lo regolo poi me lo ritrovo sballato in ubuntu :-)
- Non mi compare l'icona della batteria in alto a destra nonostante l'abbia selezionata nelle preferences (al momento di selezionarla comapre per una frazione di secondo e poi scompare)


Grazie a tutti.


Aggiungo pure che non mi monta più (proprio non le rileva) chiavette e disk USB, li monta solo se inseriti al boot!!!

Ma, a questo punto mi sorge un dubbio, non è che dopo l'upgrade devo installare qualche patch particolare con il tool fornito da iDeneb Combo? Ho dato un occhio ma non saprei....

Grazie ancora

#7
The Stig94

The Stig94

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 126 posts
per le chiavi e hd usb devi usare l'usbfix, cerca su google, mentra x l'orologio io ho il tuo stesso prolema

#8
H&C

H&C

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 110 posts
io installato la iDeneb 1.6 (quindi non l aggiornamento) e sul mio pc in firma dopo aver selezionato le patch per USB e Battery e mi funziona tutto...a dire il vero non ho provato a bootare da windows per vedere se mi sballa l ora..
ora provo e vi faccio sapere...

PS: anche a me ha dato l impressione di essere più reattivo togliendo l HPET :boooooh:

#9
HAL9064

HAL9064

    InsanelyMac Protégé

  • Members
  • Pip
  • 33 posts

per le chiavi e hd usb devi usare l'usbfix, cerca su google, mentra x l'orologio io ho il tuo stesso prolema


Ok, trovato e scaricato... ma ho in testa un pò di confusione sulla procedura (derivata da differenti versioni lette per la rete) visto che è un kext, non mi basta sostituirlo al vecchio, sistemata ai permessi e boot -f ???

Thanks

#10
Mr AdO

Mr AdO

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 201 posts
  • Gender:Male
  • Location:Vicenza
Per delucidazioni su cosa serva AppleHPET.kext vi rimando a questo link:

http://www.insanelym...p;#entry1138445

#11
frankolo

frankolo

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 238 posts
A me va a tratti.. cioè alle volte si.. altre no... :D (la LAN)
Bisonga avviare sempre in -f?
Avete editato il kext 8255 o solo rimosso l'HPET? Se non ricordo male io con iDeneb avevo solo l'8254 :D





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy