Jump to content

[Guida] Installare SnowLeopard 10.6 ORIGINALE con il Boot-132


  • Please log in to reply
205 replies to this topic

#181
PacStealer

PacStealer

    InsanelyMac Protégé

  • Members
  • PipPip
  • 85 posts
ho provato a far partire Snowleopard in verbose per capire il problema:
in pratica iniziano le righe su schermo e poi si ferma su questa: "ioapic version 0x20 vectors 64:87"
dopodiche non succede altro... resta fermo li..(facendolo partire normalmente invece esce la mela ma non la rotellina e resta fermo li)
cosa puo essere??
vi prego rispondetemi!!!

#182
righella

righella

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts
Salve a tutti e innanzi tutto grazie per l'ottima guida, tramite la quale ho installato Snow sulla mia MB ASUS P5K-E Deluxe Wifi ed.
L'unico problemino è che andando in aggiornamento software, non trova nessun aggiornamento di sistema (10.6.1 e proprio oggi 10.6.2), mentre ha trovato altri updates, tipo Itunes 9.0.2 e Ilife vari.
Inoltre la versione di Safari installata è la 4.0 e non riesce ad aggiornarmela alla 4.0.3 dandomi un errore di incompatibilità e di conseguenza Itunes Stores non funzia!

Per il resto va che è una meraviglia!!! Appena riesco metto nella firma le mie caratteristiche tecniche.

Grazie in anticipo per chi mi potrà aiutare!!!

Ciao!!!!

#183
johnny28

johnny28

    InsanelyMac Protégé

  • Members
  • PipPip
  • 56 posts
Salve! Ho seguito la tua guida e sono riuscito ad installare S.L. 10.6 ed anche l'aggiornamento alla 10.6.1, e per questo ti ringrazio.

Ho tentato l'aggiornamento alla 10.6.2, ma al riavvio mi va in kernel panic, nonostante abbia cancellato il file SleepEnabler.kext.

Ho l'impressione che il problema risieda nel UID della partizione di avvio da inserire in com.apple.Boot.plist, visto che è questo il problema che mi si pone quando reinstallo tutto con l'immagine creata con Time Machine!

Solo che, in questo caso, riesco a far partire comunque il sistema operativo con il disco di Boot-132 e quindi ad inserire l'UID giusto in com.apple.Boot.plist mentre dopo l'aggiornamento alla 10.6.2 non ne vuol proprio sapere di avviarsi, anche con opzione -f o -s .

Grazie.

#184
NeXtor

NeXtor

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 294 posts
Anche io ho avuto il tuo stesso problema e per risolverlo bisogna aggiornare il file SleepEnabler.

Installa questo http://www.insanelym...p...st&id=61206

#185
johnny28

johnny28

    InsanelyMac Protégé

  • Members
  • PipPip
  • 56 posts

Anche io ho avuto il tuo stesso problema e per risolverlo bisogna aggiornare il file SleepEnabler.

Installa questo http://www.insanelym...p...st&id=61206


Purtroppo è una cosa che ho già fatto, ed ottengo comunque un kernel panic. ;)

#186
NeXtor

NeXtor

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 294 posts
devi avviare in -v e postare la schermata che ti esce...così non so da cosa possa dipendere.

#187
johnny28

johnny28

    InsanelyMac Protégé

  • Members
  • PipPip
  • 56 posts

devi avviare in -v e postare la schermata che ti esce...così non so da cosa possa dipendere.


Scusami se non ho risposto subito, ma sono stato impegnato in altre faccende e purtroppo non potrò a breve postare la schermata; mi riprometto però di farlo al più presto. Grazie comunque delle risposte.

#188
rosumella

rosumella

    InsanelyMac Protégé

  • Members
  • PipPip
  • 65 posts

Questa guida per installare SnowLeopard 10.6 Originale tramite il BOOT-132 è stata testata su ASUS P5K Deluxe/WiFi Ed. con HDD SATA AHCI e controller Jmicron DISABILITATO

Occorrente:
1) DVD di SnowLeopard 10.6
2) Il file cdboot.iso e il Bootloader Chameleon 2.0RC2 con alcuni files Extra da aggiugere scaricabile da QUI.

Come installare:
Masterizzate con qualunque programma su qualunque OS in un CD-RW (va bene anche un CD normale) il file cdboot.iso
Riavviate il sistema, quindi avviate dal lettore CD vi troverete nella schermata del bootloader chameleon. Estraete il CD, inserite il DVD di SnowLeopard e premete F10: a questo punto dovrebbe riconoscere il DVD. Quando lo riconosce come "Mac OS X Install DVD" digitate -v e premete INVIO.Adesso inizia il caricamento del DVD di SnowLeopard, pazientate ci vorrà un po'...................


Oggi ho provato ad reinstallare SL usando questa guida (che avevo già usato con successo) ma ho un problema già al punto riportato sopra, un problema un po' stupido ma bloccante:

premendo il tasto per espellere il cd di boot quello non ne vuol sapere di uscire! ho premuto mille volte, premuto e aspettato minuti, ricaricato aspettato minuti e poi premuto il tasto di apertura, ma niente non trovo il modo di mettere il DVD di SL

Qualcuno sa aiutarmi?

#189
TyTnMonz

TyTnMonz

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 114 posts
  • Gender:Male
Sullo sportellino del lettore dvd dovresti avere un piccolissimo buchino che serve da "apertura di sicurezza", prendi una graffetta, aprila e infilala dentro il buchino, spingendo un po' il cassettino viene forzato ad aprirsi.

Io avevo invece intenzione di fare un po' di pulizia sul mio pc formattando tutto sostituendo anche vista con seven già che c'ero, il tutto sul pc in firma.
Avrei però una domanda: ho modificato e installato il VoodooHDA per far funzionare tutte le linee sia in ingresso che in uscita seguendo una guida qui sul forum (linee che ora funzionano correttamente), solo che da quando l'ho installato ogni tanto all'avvio il sistema mi da qualche Kernel Panic.
Mi hanno detto che è possibile mettere praticamente tutte le stesse cose che ci sono nei kext all'interno del file DSDT e che così facendo sia molto meglio...mi potreste spiegare cosa posso effettivamente metterci e come?
Grazie mille per le eventuali risposte!

#190
rosumella

rosumella

    InsanelyMac Protégé

  • Members
  • PipPip
  • 65 posts

Sullo sportellino del lettore dvd dovresti avere un piccolissimo buchino che serve da "apertura di sicurezza", prendi una graffetta, aprila e infilala dentro il buchino, spingendo un po' il cassettino viene forzato ad aprirsi.

Io avevo invece intenzione di fare un po' di pulizia sul mio pc formattando tutto sostituendo anche vista con seven già che c'ero, il tutto sul pc in firma.
Avrei però una domanda: ho modificato e installato il VoodooHDA per far funzionare tutte le linee sia in ingresso che in uscita seguendo una guida qui sul forum (linee che ora funzionano correttamente), solo che da quando l'ho installato ogni tanto all'avvio il sistema mi da qualche Kernel Panic.
Mi hanno detto che è possibile mettere praticamente tutte le stesse cose che ci sono nei kext all'interno del file DSDT e che così facendo sia molto meglio...mi potreste spiegare cosa posso effettivamente metterci e come?
Grazie mille per le eventuali risposte!


volevo fare così ma dal rumore sembra che il cd dentro stia girando e ho paura di scassare tutto usando l'apertura manuale....

#191
Pandino80

Pandino80

    InsanelyMac Protégé

  • Members
  • Pip
  • 20 posts
  • Gender:Male
  • Location:Italy - Treviso
Guida molto interessante, peccato che ho dei problemucci quasi all'inizio.

Sto provando ad installare SL con boot cd sul mio Samsung Q45. Premetto che avevo provato ad installare Leo 10.5.6 ma mi si reboottava la macchina senza far partire il dvd di installazione se non ricordo male.

Metto il cd di boot, riavvio il pc, alla schermata di chamaleon levo il cd e metto dvd snow, aspetto che la lucina si fermi, premo F5, mi sposto sopra alla voce corretta, scrivo -v -x (il -x l'avevo letto in un'altra guida ma non so di preciso a cosa serva) e tutto sembra partire, però dopo alcuni minuti ecco il risultato:
Posted Image

Se provo senza opzioni ecco il risultato:
Posted Image

Avete qualche idea su cosa può aver generato quel kernel panic (se così può esser definito) e come risolvere?

Grazie.

Alberto

#192
scrax

scrax

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,704 posts
  • Gender:Male

Avete qualche idea su cosa può aver generato quel kernel panic (se così può esser definito) e come risolvere?

Grazie.

Alberto

Secondo me questo:

Disk1s3 Unsupported mode

#193
Pandino80

Pandino80

    InsanelyMac Protégé

  • Members
  • Pip
  • 20 posts
  • Gender:Male
  • Location:Italy - Treviso

Secondo me questo:

Disk1s3 Unsupported mode


Grazie per la pronta risposta.

Quindi a questo punto c'è qualcosa che non va nelle impostazioni sul bios. La cosa strana è che questo portatile non ha nessuna impostazione per il controller, il disco è sata, sono sicuro xkè l'ho verificato togliendolo e ne ho preso uno + grande da usare per SL + XP, quindi credo che dovrebbe già essere impostato come AHCI, sarebbe strano che un controllore sata non sia configurabile in quella modalità.

Verificherò se c'è qualche aggiornamento bios. Ma secondo te disk1s3 è l'hard disk oppure il cd-rom? (tieni conto che quel test l'ho fatto con l'hard disk originale del pc che ha due partizioni ntfs di cui una con vista e l'altra contenente l'immagine di ripristino e spazio per bck dati, il ripristino non viene fatto con la solita partizione "nascosta")

#194
sagitter58

sagitter58

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts
[quote name='NeXtor' date='Sep 7 2009, 02:13 PM' post='1255445']
La tua scheda è compatibile, sicuramente dovrai aggiungere qualche kext alla iso e se leggi bene la guida ho anche spiegato come fare per creare una iso personalizzata...


Salve !
è la prima volta che scrivo su questo forum
Ho provato la guida ma non trova gli hd e non ho un sistema osx installato come posso risolvere !!
Mabo Asus P5K-E
GRAZIE

qualcuno ha il cdboot.iso per questo hardware
asus p5k-e
ati readeon hd5770
io non ho proprio idea di come si fa
GRAZIE

#195
johnny28

johnny28

    InsanelyMac Protégé

  • Members
  • PipPip
  • 56 posts
Sono alle prese con l'aggiornamento a 10.6.4. Credo che il KP al riavvio, nonostante SleepEnabler.kext sia stato cancellato dall'HD, sia dovuto al Preboot.img del CD di Boot 132, che ha al suo interno il file incriminato.
Occorrerebbe fare una versione dell'ISO del CD Boot 132 senza SleepEnabler.kext. Ho provato con UltraISO e MagicISO (sotto windows), ma non sono riuscito ad ottenere un cd bootable funzionante!

Potete aiutarmi per favore! Grazie.

#196
johnny28

johnny28

    InsanelyMac Protégé

  • Members
  • PipPip
  • 56 posts
Scusami non ho capito una cosa, ma con il tuo disco di boot, il controller dei dischi rigidi nel BIOS è stato impostato in AHCI o IDE?

Ciao a tutti, finalmente sono riuscito a sfangarla con tutti i problemi che avevo, adesso ho finalmente Snow Leopard su P5K-E WIFI AP (non ho ancora upgradato a 10.6.1).
Intanto cerco di fare chiarezza sul problema che avevo prima.
Sostanzialmente io ho un masterizzatore sata che non "sopporta" gli errori EBIOS, infatti dopo un po' di errori ebios si blocca... questo è ciò che ho fatto:
Ho ricreato il cd per avviare leopard, e dentro di ho messo un file preboot.dmg con partizione unica e tabella GUID.
Poi creavo la iso, e masterizzandola con ExpressBurn, riuscivo ad ottenere una iso senza alcun errore ebios.
(mentre se il file preboot.dmg era fatto con partizione singola - tabella partizioni MBR, saltavano fuori errori ebios con tutti i masterizzatori, cd-rw e programmi di masterizzazione (per win e osx) che possiedo in casa)
Quindi riuscivo a vedere lo chameleon avviato dal masterizzatore sata. Toglievo il cd riscrivibile, mettevo dentro il DVD di snow leopard, e appena lo avviavo ottenevo altri errori ebios, e mi si bloccava ugualmente.
Quindi per l'ebios, ho deciso di usare il lettore dvd collegato al jmicron piuttosto che il masterizzatore.
Ho inizialmente usato la iso scaricata aggiungendoci solo la kext jmicron, e qui mi si manifesta il problema di prima:
lo schermo mi restava nero, ciò è dovuto al fatto che osx è senza driver grafici per la mia scheda, quindi ho riscritto le efi strings, però SOLO per la scheda video (nvidia GTX260 core 216), mentre prima avevo fatto le efi strings per scheda video e per scheda di rete, e non so come ma facevano confusione, e faceva come se non ce le avesse.
Quindi ricapitolando:
ho risolto usando la iso scaricata dal forum, ci ho aggiunto la kext jmicronata, e poi ho messo le efi strings per la mia scheda video. Quindi ho masterizzato la iso modificata, l'ho messa nel lettore dvd, e poi ho avviato snow leopard da lì.
Quindi ho installato il sistema operativo.
Poi ho rifatto un'altra prova: ho ricreato per la terza volta la iso da capo. Ho scaricato dal sito chameleon la rc3, poi ho posizionato i file e ho creato il dmg (questa volta direttamente partizione singola - tavola partizioni guid).
Dentro ci ho messo le stesse kext della iso del forum + jmicronata.
Quindi ho creato il file iso da masterizzare.
Anche questo cd, messo nel lettore dvd, per quanto dia i solito ebios error, avvia snow leopard.




Sì, a volontà.
1. Il jmicron abilitato o disattivato non sembra avere nessuna influenza sull'avvio di snow leopard. L'unità ottica che stai usando fa come la mia, non riesce ad ignorare gli errori ebios e si pianta.
2. Se hai un'altra unità interna, collegata al jmicron, usala, basta che aggiungi la kext jmicronata nel file Preboot.dmg (nella cartella Extra\Extensions). La kext la trovi nel sito indicato da nextor per le kext 32/64bit).
Una volta fatto questo, puoi mettere anche il jmicron su AHCI, io ho installato con il jmicron su AHCI.
3. Se hai un lettore/masterizzatore esterno usb, usa quello per installare snow leopard (sperando che non ti capiti fra le mani un lettore/masterizzatore esterno che non ignora gli errori ebios).
4. Cosa hai usato per attivare l'accelerazione sulla tua scheda video fin'ora? Che scheda video hai? Ti consiglio anche di preparare delle efistring per la tua scheda grafica.
5. Ultimo. Ti consiglio di ricreare da zero il tuo cd boot, usando i file dal sito chameleon... ti lascio una guidina fatta a razzo, spero vada bene.
1. Ottenere i dati: download chameleon rc3 http://cham el eon.o sx8 6.h u/file_dow nlo ad/37/Chameleon-2.0-RC3-r658-bin.tar.gz (rimuovi gli spazi)
download file allegato al primo post di questo thread.
2. Estrai tutti gli archivi, e crea una nuova cartella in qualsiasi posto. Adesso, nella nuova cartella, crea una sotto cartella, chiamala nuovaiso. Qui copiaci il file cdboot, che trovi nella cartella i386 estratta dal file tar.bz dello chameleon.
3. Crea una sottocartella nella cartella nuovaiso con nome Extra .
4. Adesso copia il file com.apple.Boot.plist preso dalla cartella cdboot/Extra proveniente dal file scompattato del forum.
5. Adesso inserisci le tue efi strings nel file com.apple.Boot.plist, ma SOLO per la scheda video.
6. Apri Utility Disco, e vai su Nuova Immagine, quindi metti nei campi: registra col nome: Preboot
Nome: Preboot
Scegli prima formato: mac os esteso (non journaled, nè esteso, nè altro, solo così come ho scritto)
Dimensioni: 5mb (al limite, se ti resta grigio, scegli 10mb).
Codificazione: Nessuna
Partizioni: Partizione singola - Mappa delle partizioni Master Boot Record
Formato immagine: immagine disco lettura/scrittura
Dai crea.
7. Adesso, salvato nella cartella che hai specificato troverai un file Preboot.dmg, aprilo. Mac os x te lo monterà, e lo visualizzerà come una penna usb. Adesso apri il nuovo dispositivo che vedi, e creaci una cartella con nome Extra, dentro essa un'altra con nome Extensions. Qui dentro copiaci le kext che ti servono. (secondo me ti basta il jmicron se lo userai, fakesmc.kext, IOAHCIBlockStorageInjector.kext, NullCPUPowerManagement.kext, SleepEnabler.kext, OpenHaltRestart.kext, IOGraphicsFamily.kext.
8. Adesso dovrebbe essere tutto pronto, smonta l'unità Preboot, quindi copia il file dmg dentro alla cartella nuovaiso/Extra.
9. Usa il comando: sudo su
inserisci la tua pass
cd (mettici uno spazio) e adesso trascina la cartella che contiene la sottocartella nuovaiso nel terminate, premi invio
hdiutil makehybrid -o nuovaiso.iso nuovaiso/ -iso -hfs -joliet -eltorito-boot nuovaiso/cdboot -no-emul-boot -hfs-volume-name "SLboot132" -joliet-volume-name "SLboot132"
10. Masterizza l'immagine con qualsiasi programma.
So che può sembrare un po' lungo.... se vuoi allego parte del lavoro già fatto, senza efistrings.

Spero di non aver saltato nulla, nè di aver scritto le cose in maniera "ingrarbugliata"
Ciao a tutti.



#197
tommy6x

tommy6x

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
  • Location:Italy

Scusami non ho capito una cosa, ma con il tuo disco di boot, il controller dei dischi rigidi nel BIOS è stato impostato in AHCI o IDE?

Se non mi ricordo male, mi pare che il controller intel (ich9r) fosse settato su AHCI, e il controller Jmicron pure, su AHCI... è passato del tempo, e io la capoccia non ce l'ho ottima...

#198
mariooo

mariooo

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 5 posts
ciao ragazzi, ho una p5k-deluxe (BIOS 1005) e ho provato tutte le guide esistenti per installare SL, trovando questa speravo di riuscire ma anche qua qualcosa non va,vi spiego la situazione, ho un HD sata e un lettore DVD sata collegati alle prese 5 e 6 della scheda madre. Se avvio il bootcd dal disco sata ottengo una serie di errori ebios,fortunatamente ho un lettore usb e con quello il dvd parte....inizia a caricare e dp un po si ferma, succede dopo che ha caricato la rete, non ho individuato errori o warning, l'ultima riga dice:
ACPI_SMC_PLATFORMPLUGIN::start - waitforservice(resourcemaching(AppleIntelCpuPowerManagement)) timed out

dopodiche resta li all'infinito....cosa posso fare ? può essere un problema della scheda video (ati x1900xt) ?

provo ad allegare l'immagine
Posted Image

#199
buoo

buoo

    The Prodigal Son

  • Moderators
  • 4,517 posts
  • Gender:Male
  • Location:Italy

dopodiche resta li all'infinito....cosa posso fare ? può essere un problema della scheda video (ati x1900xt) ?


Prova ad avviare con -x ...se va allora era la scheda video :)

#200
mariooo

mariooo

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 5 posts
niente....stesso problema...





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   Web hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy