Jump to content

Snow Leopard 10.6 Retail on HP Mini 1000


  • Please log in to reply
20 replies to this topic

#1
Ego_OSX

Ego_OSX

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 112 posts
Has anyone managed to successfully install and boot into Snow Leopard on an HP mini 1000?

I've gotten past the installer and was successful in a vanilla install.

I used PC EFI v9, DSTS patch, modified boot. But I keep getting a Kernal Panic while booting. I'm not sure if I'm not sure if i need to remove any kext or if I need new kexts for the retail version of SL.

I'm not using kexts for 10.5.x

Any help would be appreciated :)

#2
Frogking

Frogking

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
I'd like to know if anyone has had any success with this, as well. I tried a few methods but always get a kernel panic after just a few seconds of powering up. I've been scanning the forums at myhpmini.com but so far no guides have been posted for the mini 1000.

I guess I'm sticking to 10.5.x until someone cracks this nut!

#3
hackedintosh

hackedintosh

    InsanelyMac Protégé

  • Members
  • Pip
  • 36 posts
I am also very interested in this too.

Have you tried "cpus=1 -x -v" ? that way you can make sure it isnt related to your dsdt.aml

Also what version chameleon and efi are you using? Have you tried 2.0 RC1 with EFI 10.1? That generally is the best combo.

#4
Ego_OSX

Ego_OSX

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 112 posts
I've been able to boot up using -x32 -v -f -x, but most of the kexts i'm using don't work. When I normal boot I just hang. i.e.
VoodooPS2 = fail
VoodooHDA = fail
IntelGMA950 = fail
IOFamily811x = fail

I'm using pc_efi9. It's a retail install with vanilla kernel.

#5
mcroger

mcroger

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
Got it working following this guide: http://www.mydellmin...l-official.html

Basically very simple:

- install Snowy using a sub-package, on an external USB drive

- use Netbookbootmanager

- plug the USB HD and boot the mini

For the moment I have not copied this install onto my internal HD (with Superduper), still waiting for the hereunder mentionned issues to be solved:

- sleep, sound and speedstep not yet working

#6
hackedintosh

hackedintosh

    InsanelyMac Protégé

  • Members
  • Pip
  • 36 posts

Got it working following this guide: http://www.mydellmin...l-official.html

Basically very simple:

- install Snowy using a sub-package, on an external USB drive

- use Netbookbootmanager

- plug the USB HD and boot the mini

For the moment I have not copied this install onto my internal HD (with Superduper), still waiting for the hereunder mentionned issues to be solved:

- sleep, sound and speedstep not yet working


thanks mcroger

I will try this soon and post results. Even with leopard retail dvd install i have not yet been able to get it to sleep.. at least while wifi is also working.. every method it seems has a functionality missing

#7
louden

louden

    InsanelyMac Protégé

  • Members
  • Pip
  • 25 posts
  • Gender:Male
  • Location:Seattle, Washington (Fremont)
I've used NetbookBootMaker and think it's a great idea. It's almost perfect for use with the Mini. It really makes the process of building an updatable Hackintosh simple.

That said, I've had an issue with the Mini 100 (1035NR). I've tried using NetbookBootMaker and my install of Snow Leopard to the internal drive fails/stalls with 10 minutes to go (this happened three times). I'm not sure why it happened as there's no great deal of info in the install log. I even re-created my install disk image from the installation DVD to ensure my installation media wasn't corrupt in some way. I wound up quitting the install when it died. When I restarted the mini off the USB stick, I could see that it would allow me to select the internal partition to boot from (not boot up from the hard drive on its own). I therefore just installed NetbookBootMaker to the hard drive and now it's its working fine, other than the issues with sleep and sound. I've got a 32 GB MTron SSD in my mini, and the SL install doesn't even take up half my storage, and I've already installed all the development tools and the iPhone SDK.

On top of that it's very snappy. If sleep and sound aren't important to you, I'd move up now.

#8
etx

etx

    InsanelyMac Protégé

  • Members
  • PipPip
  • 54 posts
Gonna give this a shot on my mini 1000 asap, thanks for the jump start!

#9
Ego_OSX

Ego_OSX

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 112 posts
Ok, I finally got SL installed on my mini 1000. After about 50+ attempts I think I found a fairly quick and easy way to install.
Install from DVD using osinstall.mpkg to your desired drive.
Customize the install and remove, printers, x11, and additonal languages.
After install use NetbookInstaller select the drive you installed SL to and install Chameleon, general kext. You can select any of the other options except DSTS (dsts will stall).
Patch DSTS using dsts patcher.

reboot into SL drive.
Now you'll have SL retail.

Remove appleHDA.kext and install VoodooHDA.kext and voodoo prefpane.
repair permissions

reboot.
now everything should work except sleep.

Ok, I finally got SL installed on my mini 1000. After about 50+ attempts I think I found a fairly quick and easy way to install.
Install from DVD using osinstall.mpkg to your desired drive.
Customize the install and remove, printers, x11, and additonal languages.
After install use NetbookInstaller select the drive you installed SL to and install Chameleon, general kext. You can select any of the other options except DSTS (dsts will stall).
Patch DSTS using dsts patcher.

reboot into SL drive.
Now you'll have SL retail.

Remove appleHDA.kext and install VoodooHDA.kext and voodoo prefpane.
repair permissions

reboot.
now everything should work except sleep.



I am noticing something odd though, my internal hdd is being reported as an external. really odd.

anyone else experience this?

#10
mcroger

mcroger

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts

I am noticing something odd though, my internal hdd is being reported as an external. really odd.

anyone else experience this?


Yes, everyone using the netbookbootmanager installation.


But this is only the icon that is orange, you cannot eject it, thus it is not really considered as an external drive.  

It is pretty easy to change, Option-I on the HD icon, and on the upper left corner, paste the drive icon you want.

Personnaly, I copied the icon of my Mac Pro's desktop using Apple remote desktop control.

Posted Image

#11
Ego_OSX

Ego_OSX

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 112 posts

Yes, everyone using the netbookbootmanager installation.


But this is only the icon that is orange, you cannot eject it, thus it is not really considered as an external drive.

It is pretty easy to change, Option-I on the HD icon, and on the upper left corner, paste the drive icon you want.

Personnaly, I copied the icon of my Mac Pro's desktop using Apple remote desktop control.

Posted Image


thanks for the info. I'll change my icon.

Also, anyone happen to get sleep working?

#12
louden

louden

    InsanelyMac Protégé

  • Members
  • Pip
  • 25 posts
  • Gender:Male
  • Location:Seattle, Washington (Fremont)
sleep please :(

#13
GlassjawX

GlassjawX

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts
Hi Everyone!

I'm new here and I just bought a HP mini 1030CA. I installed Snow Leopard Retail with the netbookmaker.

I've got sound, webcam, but I can't get to make the wifi and LAN working. I also have the sleep issue.

I tried to use OSxtool to install the kext BCM43xx with OSxTool with no succes. OSxtool don't want me to click on the file!!

Anyone have suggestion?

by the way I deleted the appleHDA file and replace it with the voodoo one.

#14
Ego_OSX

Ego_OSX

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 112 posts
does anyone know if any progress has been made on Sleep?

#15
mcroger

mcroger

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
Yes, look at here.

But still not 100% stable. dpassmor has uploaded his modded dsdt file, works for his mini 1000, not for all of us.

#16
pwolfe

pwolfe

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
Guys have any more luck getting sleep working?

#17
franktis

franktis

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts

Guys have any more luck getting sleep working?


Wondering the same thing. It's the only issue I'm having. It's not a huge deal, but it would be nice not to have to shut down and restart before and after every class (where I'm primarily using the machine).

#18
josh256

josh256

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 202 posts
Happy to report sleep is working on my Mini 1000 (2GB, F13 bios)

Installed Snow using the infamous mini 9's netbook installer.. Originally I used the pre-compiled dsdt.aml from the myhpmini thread (linked above) and was not able to sleep [for more than 5 minutes].. Since then something has corrected the issue. Work done:

- Applied all system updates

- Installed VoodooPS2, relocated to /Extra/Extensions and corrected ownership/permissions in Contents/Plugins dir
Install and checked trackpad driver (install completes w/ a system kext can not be loaded error)
sudo mv /System/Library/Extensions/VoodooPS2Controller.kext /Extra/Extensions
sudo chown root:wheel /Extra/Extensions/VoodooPS2Controller.kext/Contents/Plugins
sudo chmod 755 /Extra/Extensions/VoodooPS2Controller.kext/Contents/Plugins
(recursive changes unnecessary, just Plugins directory permissions were off)

- Removed AppleACPIPS2Nub [else kernel panic when combined with VoodooPS2] and ApplePS2Controller from /Extra/Extensions

- dsdt.aml (from myhpmini.com) in both / and /Extra (sorry, not sure which location is preferred/correct)

- Manual rebuild of kernel extensions' caches:
kextcache -v 1 -t -m /Extra/Extensions.mkext /Extra/Extensions/ /System/Library/Extensions/
kextcache -v 1 -t -m /System/Library/Caches/com.apple.kext.caches/Startup/Extensions.mkext /System/Library/Extensions/

Sleeping for 12 hours w/o hibernation seemed to have very little drain on the battery (I have pmset hibernate to 0 and hibernate free ratio to 5). Will attempt hibernation tonight but I *really like* how fast the sleep resumes so I would keep hibernate free ratio no higher than 5%. Also going to install Snow on a second Mini 1000 tonight (1GB RAM).. will post sleep results..

#19
donpro

donpro

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts

Has anyone managed to successfully install and boot into Snow Leopard on an HP mini 1000?

I've gotten past the installer and was successful in a vanilla install.

I used PC EFI v9, DSTS patch, modified boot. But I keep getting a Kernal Panic while booting. I'm not sure if I'm not sure if i need to remove any kext or if I need new kexts for the retail version of SL.

I'm not using kexts for 10.5.x

Any help would be appreciated :)


I have been able to install and boot into Snow Leopard on an Hp mini 1000 using Netbootmaker and Netbootinstaller here is the link http://www.meklort.c.../?p=114&cpage=1

I hope this helps.

#20
GabooN

GabooN

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts

Has anyone managed to successfully install and boot into Snow Leopard on an HP mini 1000?

I've gotten past the installer and was successful in a vanilla install.

I used PC EFI v9, DSTS patch, modified boot. But I keep getting a Kernal Panic while booting

I am trying to do a SL install on my gf's HP mini 210-1079CA and I have followed the methods using USB drive and mounting the SL install image to it and patching with Netbookbootmaker .83, restoring the OSinstall.pkg and I also put the VoodooHPA in

I can't get very far once I'm on the HP though. I hit F9 and select the USB drive, and interupt the darwin countdown which brings me to a screen with the boot drives. I hit the down arrow and can select from verbose, single user, etc.. if i boot in verbose i get a grey screen with some Loading HFS+ file messages but a few lines down it just says 'patching kernel mach_kernel'

Am I supposed to put in a modded kernel for atom processor or something? I'm not sure what I am doing wrong here, any insight would be helpful.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   Web hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy