Jump to content

Snow Leopard on Inspiron 530


  • Please log in to reply
153 replies to this topic

#141
amzor

amzor

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts

Did you need to do anything? reset/reload kext's - Fix audio?

Or did you simply use apple's software updater and reboot?



Just software update for me.

#142
LatinMcG

LatinMcG

    Insanely digesting DSDT

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 2,509 posts
  • Gender:Male
  • Location:Tampa, Florida
to get AHCI Also known as RAID in this Dell mobo.. inject ESB2 device id 2681 in dsdt. then set bios to RAID.
replace BOTH SAT0 AND SAT1 WITH THIS CODE

[codebox] Device (SATA)
{
Name (_ADR, 0x001F0002)
OperationRegion (PCI, PCI_Config, 0x40, 0x20)
Field (PCI, DWordAcc, NoLock, Preserve)
{
ITM0, 16,
ITM1, 16,
SIT0, 4,
SIT1, 4,
Offset (0x08),
UDC0, 2,
UDC1, 2,
Offset (0x0A),
UDT0, 8,
UDT1, 8,
Offset (0x14),
ICF0, 2,
ICF1, 2,
, 6,
WPPE, 1,
, 1,
FAS0, 2,
FAS1, 2
}

Method (_DSM, 4, NotSerialized)
{
Store (Package (0x02)
{
"device-id",
Buffer (0x04)
{
0x81, 0x26, 0x00, 0x00
}
}, Local0)
DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))
Return (Local0)
}
}
// ENDS HERE
Device (SBUS)
{
Name (_ADR, 0x001F0003)
Method (_DSM, 4, NotSerialized)
{
Store (Package (0x04)
{
"name",
"pci8086,3a30",
"device-id",
Buffer (0x04)
{
0x30, 0x3A, 0x00, 0x00
}
}, Local0)
DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))
Return (Local0)
}

OperationRegion (PBAS, PCI_Config, 0x20, 0x02)
Field (PBAS, ByteAcc, NoLock, Preserve)
{
BAS0, 16
}

Method (SMBB, 0, NotSerialized)
{
And (BAS0, 0xFFFE, Local0)
Return (Local0)
}
}[/codebox]

for windows.. install ahci drivers for ich9.

for sleep to work the _OS line for "windows 2001" or the 2006 needs to be changed to "Darwin"
also if u have a cheap wanabe 8400 GS devce id 10c3 forget it..!! (turbocache and audio chip)
get a 9500 gt. or 8600 gt or 9800gt or 250gs or 260gt or..

#143
jeepville

jeepville

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts

for sleep to work the _OS line for "windows 2001" or the 2006 needs to be changed to "Darwin"
also if u have a cheap wanabe 8400 GS devce id 10c3 forget it..!! (turbocache and audio chip)
get a 9500 gt. or 8600 gt or 9800gt or 250gs or 260gt or..



I am interested where you edit that to get sleep to work.
I am on a vostro 200 slim with a retail install of 10.6.6 upgraded to 10.6.8. and I cannot get sleep to work.
I have tried s1 and s2
I have 10.6.8 sleepenabler.kext and it doesnt work
I have nullcpupowermanagement.kext and it doesnt help

I hit sleep and nothing happens when I move the mouse again audio blips and everything works as normal.

#144
LatinMcG

LatinMcG

    Insanely digesting DSDT

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 2,509 posts
  • Gender:Male
  • Location:Tampa, Florida
what video card u have ?
ill post here the codes to be edited

#145
jeepville

jeepville

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
I am planning on using an asus geforce 8400 gs 512mb which is in the mail. It was hard finding a slim form factor card that people have had success with.

So I guess I will come back to the issue of sleep after I have that installed and working.

Thanks for the quick reply and the help.

#146
LatinMcG

LatinMcG

    Insanely digesting DSDT

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 2,509 posts
  • Gender:Male
  • Location:Tampa, Florida
i hope its not device id 10c3 . they work but not native supported.. graphicsenabler might work.
inspiron 530 i did 5 months ago
http://www.mediafire...x00v8ycmdzmd9l9

#147
jeepville

jeepville

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
it looks like I ended up with a 10de graphics card what do I install to get it working after 10.6.8 upgrade.

#148
LatinMcG

LatinMcG

    Insanely digesting DSDT

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 2,509 posts
  • Gender:Male
  • Location:Tampa, Florida
10de is vendor nvidia.. u mean device id 10c3 .. last i tried it would not let inspiron 530 sleep. i changed it for a supported model 9500gs

#149
jeepville

jeepville

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
your right i was just coming back to edit my post and you already replied it is a 10c3 asus 8400gs 512mb silent

#150
LatinMcG

LatinMcG

    Insanely digesting DSDT

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 2,509 posts
  • Gender:Male
  • Location:Tampa, Florida
i heard u can add the string to the info.plist of the nvidia files. but dunno how far that goes.

#151
jeepville

jeepville

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
Thanks LatinMcG and Everyone else. I got everything fully working today.
Vostro 200 Slim
Core2 E5700
4 gig of Ram
500 gb HD
Asus 8400gs 512mb ddr3
Magic mouse and wireless keyboard via dlink dbt-120
10.6.8
App store works.

Sleep and everything else works great couldnt have done it without this thread and all your help.

#152
LatinMcG

LatinMcG

    Insanely digesting DSDT

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 2,509 posts
  • Gender:Male
  • Location:Tampa, Florida
nice.. so the trick to add the id to info.plist worked .. or u used a chameleon2.1 with support for 10c3 ?

#153
jeepville

jeepville

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
I found an nvinject.kext for 10c3 and edited the info plist on nvdm50 and that made it work.
I have had to do some editing on the info.plist of voodoohda.kext to get the mic and volume to work properly as well the mic is still way to quiet but atleast useable.
I started the project looking for a challenge and it has been an exciting one.

I am using Chamelon wizard and just installing the latest version from the buildbot that is in the wizard.
Sleep doesnt do it automatically and it doesnt wake from wireless kb or magic mouse but I am using an old bt adapter so I didnt expect that.

#154
LatinMcG

LatinMcG

    Insanely digesting DSDT

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 2,509 posts
  • Gender:Male
  • Location:Tampa, Florida
i was able to do the wired usb keyboard.. maybe in bios settings

or iobluetooth classmustnotseize for the vendor/device id in info.plist
or http://www.insanelym...dpost&p=1594881

check into voodoohda 2.7.3





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy