Jump to content

[GUIDA] Installare Snow Leopard Retail/GM su Asus F3S


  • Please log in to reply
29 replies to this topic

#1
Azzo94

Azzo94

    Uno che Dona..Si VEDE!

  • Donators
  • 330 posts
  • Gender:Male
  • Location:Firenze - Italy
Salve ragazzi, come tutti sanno adesso il forum ÔŅĹ∆’¬® pieno di guide su come installare snow leopard.

Oggi voglio proporvene una io che ho trovato OTTIMA per la famiglia del mio Notebook Asus.

Funziona tutto, ovvio no wi fi :D, tranne la scheda Video (solo su f3sv) dato che i drvier non vanno e non supporta le efi strings. (Ma ci sto lavorando).

Requisiti Fondamentali:

- File .iso di Snow Leopard (10A432 GM) o DVD di Installazione.
- Hard Disk vuoto formattato in GUID.
- Installazione Funzionante di Leopard da cui eseguire la guida.
- Il mio "PacchettAzzo" v2 (AGGIORNATO)(:D ) personalmente creato con i kext per Snow.
  • - Kext Verdi = Necessari per l'avvio del sistema.
  • - Kext Rossi = Drivers vari. (Non obbligatori e personalizzabili a seconda dell' HW).
_____________________________________________________


Formattare l'Hard Disk SNOW HD SNOW HD = Hard Disk formattato per Snow Leopard

- Aprire Disk Utility.
- Selezionare l' Hard Disk che volete utilizzare per SNOW.
- Selezionare la scheda Partizioni.
- Schema Partizione: 1 Partizione -> Chiamatela "SNOW HD"
- Cliccare su Opzioni e Selezioare GUID Partition Table ed infine Cliccare Applica e Partiziona.

Posted Image

Installazione:

- Montare la .iso oppure inserire il DVD nel drive.
- Chiudere tutte le finestre del Finder e premere "ALT+CMD (bandiera Winzozz)+G" e scrivere:

  • Volumes/Mac OS X Install DVD/System/Installation/Packages

Posted Image

- Premere Invio ed aprire il file "OSInstall.mpkg" nella cartella che compare.
- Come drive di destinazione install. scegliere SNOW HD.
- Premere dunque AD HOC in basso e selezionare : "X11, Italiano in Languages". Il resto ÔŅĹ a piacere.
- Adesso possiamo Installare.

Posted Image

__________________________

Ad installazione terminata andremo ad aprire UInstaller presente nel PacchettAzzo.

- Selezionare in alto SNOW HD:
  • - Boot Resolution: 1280x800 (A seconda del vostro PC)
  • - Timeout Boot: 5 Secondi
  • - EFI STRINGS per la vostra scheda video (Non necessario per chi non le supporta).
  • - Bootloader Chamaleon (Qualunque)
  • - Install KEXTS from HD e selezionare tutti quelli presenti in PacchettAzzo/KextVari
-Possiamo adesso premere Install, dare la password ed aspettare che finisca.
____________________________

- Aprite il file "Hidden Files" in App Utili di PacchettAzzo e selezionate "Show Files".
- Esplorate SNOW HD e sostituite il file .boot che trovate li con il file in "PacchettAzzo/Chamaleon".
____________________________

Benissimo, possiamo provare a riavviare il PC, premiamo ESC (O altri tasti che permettono di selezionare la perifericha da avviare) e selezioniamo l hard disk dove ÔŅĹ∆’¬® presente SNOW HD ed aspettiamo. Se non da nessun Kernel Panic (Non dovrebbe ;) avremo Snow Leopard funzionante.

Se l'audio non dovesse funzionare provvederÔŅĹ∆’¬≤ a postarvi il nuovo kext.

AVVIARE IN MODALITA' BIT DIFFERENTI ALL' AVVIO INSERIRE: (Senza Virgolette)
  • 32 Bit : "-x32" o "arch=i386"
  • 64 bit : "-x64" o "arch=x86_64"

Spero che la guida sia stata di vostro gradimento, provvederÔŅĹ∆’¬≤ SUBITO ad inserire le immagini.

Ecco come dovrebbe apparire il vostro Snow dopo aver seguito questa piccola guida:
Posted Image

UPDATE 1: Per riparare i permessi, vista l'impossibilitÔŅĹ basterÔŅĹ aprire l'applicazione Kext Utility in PacchettAzzo/App Utili direttamente da Snow Leopard, dare la password ed attendere.

UPDATE 2: Per risolvere il problema dei Drive visualizzati come Cartelle basterÔŅĹ rimontare la iso/reinserire il DVD, esplorare fino a Volumes/Mac OS X Install DVD/System/Installation/Packages (Vedi in alto come fare) ed installare il file BSD.pkg (Grx Williamwallace ;))


Grazie dell'attenzione. ~Azzo94 :D :P

#2
geminimac

geminimac

    Italian Staff Squad

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 1,415 posts
  • Gender:Male
  • Location:Modena
ciao Azzo94,

scusa l'intrusione nella tua guida...
dovresti correggere la dicitura x84_64 in x86_64...giusto per evitare possibili noie future :D

saluti

geminimac

#3
Azzo94

Azzo94

    Uno che Dona..Si VEDE!

  • Donators
  • 330 posts
  • Gender:Male
  • Location:Firenze - Italy
Certo scusami.. ^^ Grazie mille per avermi fatto notare l'errore!

#4
frtommy

frtommy

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 420 posts
  • Gender:Male
  • Location:Italy
Bravo Azzo. Bella Guida.

#5
Azzo94

Azzo94

    Uno che Dona..Si VEDE!

  • Donators
  • 330 posts
  • Gender:Male
  • Location:Firenze - Italy
Grazie ragazzi.. aspetto che qualcuno la testi e mi faccia sapere!

#6
BarboneNet

BarboneNet

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 1,414 posts
  • Gender:Male
  • Location:Italy - Parma

Grazie ragazzi.. aspetto che qualcuno la testi e mi faccia sapere!



come hai risolto il problemi di kp che avevi??

#7
Azzo94

Azzo94

    Uno che Dona..Si VEDE!

  • Donators
  • 330 posts
  • Gender:Male
  • Location:Firenze - Italy
il KP nanosecond al primo avvio??

#8
BarboneNet

BarboneNet

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 1,414 posts
  • Gender:Male
  • Location:Italy - Parma

il KP nanosecond al primo avvio??

si....da cosa dipendeva??? mi pare che ti assillasse, no?

#9
Azzo94

Azzo94

    Uno che Dona..Si VEDE!

  • Donators
  • 330 posts
  • Gender:Male
  • Location:Firenze - Italy
Si mi assillava di brutto.. perchè installavo su Esterno senza IOATAFamily

#10
edu89

edu89

    InsanelyMac Protégé

  • Members
  • Pip
  • 37 posts
  • Gender:Male
  • Location:Rome
Allora Azzo..eccomi qui..il mio problema è questo. Io sto tentando da gionri di installare Leopard. Ho un processore AMD quindi ho seguito tutte le guide possibili immaginarie. Ho scaricato Leo4all, Kalyway 10.5.2 e iPc OSx86. Nessuno dei tre funziona. Kalyway quando gli do "-v" parte per poi fermarsi a "still waiting for root device"...e me lo ripete un sacco di volte. iPc mi è andato in kernel panic ti allego la foto.

L'unica cosa che non ho fatto è modificare il BIOS

Attached Files



#11
Azzo94

Azzo94

    Uno che Dona..Si VEDE!

  • Donators
  • 330 posts
  • Gender:Male
  • Location:Firenze - Italy
Mi puoi dare il nome preciso del tuo pc?

#12
edu89

edu89

    InsanelyMac Protégé

  • Members
  • Pip
  • 37 posts
  • Gender:Male
  • Location:Rome
il nome??? :) :blink: :blink:

è tutto scritto nella firma...!

#13
Azzo94

Azzo94

    Uno che Dona..Si VEDE!

  • Donators
  • 330 posts
  • Gender:Male
  • Location:Firenze - Italy
Ma è un notebook o un fisso..che scheda madre ha se fisso!!

#14
edu89

edu89

    InsanelyMac Protégé

  • Members
  • Pip
  • 37 posts
  • Gender:Male
  • Location:Rome
è un fisso e queste sono le caratteristiche :)

Processore AMD Athlon 64 X2 4000+;
Video NVIDIA GeoForce 6600 (256 MB) PCI-E;
Realtek HD Audio output;
HDD Maxtor 6L080P0 (76 Gb) (Windows XP), Unità #2 - ST340016A (37 GB) (vuoto);
Rete TP-LINK 11b/g Wireless Adapter, Ethernet
RAM 2 GB
Scheda Madre ALiveNF5

Uhm..senti.. la scheda madre?? Perchè puo variare il tutto dalla scheda madre!



Scheda Madre ALiveNF5-eSATA2+ (sinceramente...eSATA2+ non so cosa voglia dire)..

#15
Azzo94

Azzo94

    Uno che Dona..Si VEDE!

  • Donators
  • 330 posts
  • Gender:Male
  • Location:Firenze - Italy
Scusa avevo sbagliato.. comunque.. lo still waiting for root device l'hai dopo l'installazione o prima?

#16
edu89

edu89

    InsanelyMac Protégé

  • Members
  • Pip
  • 37 posts
  • Gender:Male
  • Location:Rome

Scusa avevo sbagliato.. comunque.. lo still waiting for root device l'hai dopo l'installazione o prima?


prima...e si ripete in continuazione...dopo un po' mi sn stufato e ho resettato tutto per poi scriverti a te

#17
Azzo94

Azzo94

    Uno che Dona..Si VEDE!

  • Donators
  • 330 posts
  • Gender:Male
  • Location:Firenze - Italy
Uhm.. potresti provare ad avviare in -v -x -legacy

#18
edu89

edu89

    InsanelyMac Protégé

  • Members
  • Pip
  • 37 posts
  • Gender:Male
  • Location:Rome
si ci provo..!

allora...è uguale..nn succede niente..nel senso questo è quello ch succede!!!!

Attached Files



#19
Azzo94

Azzo94

    Uno che Dona..Si VEDE!

  • Donators
  • 330 posts
  • Gender:Male
  • Location:Firenze - Italy
mmm.. da quello che vedo è un problema veramente da Hard Disk..non saprei.. c'è che era un problema di Hard Disk gia lo sapevo..ma ....mm.. aspettiamo un mio amico che dovrebbe darti una mano!

Che purtroppo gli "wait for root device" non sono così semplici da risolvere!

#20
Guest: freemaximus_*

Guest: freemaximus_*
  • Guests
Complimenti per i kext e la guida!!!! diciamo che io non ho seguito al 100% la tua guida ma mi sono limitato a prenderne quello che mi serviva ovvero il pacchetto kext e la parte di guida inerente l'installazione con l'Uinstaller. Io ho scaricato la snowOSX presente sui torrent, masterizzata, installata su sata mbr e fin qui tutto ok, al primo riavvio un bel kernel panic legato ai kext ioatafamily, e acpi, decido dunque tramite una partizione di leo funzionante di eliminare tutti i kext che servono a Snow per funzionare e sostituirli con il tuo pacchetto appunto azzo seguendo quella parte di guida, al riavvio snow si Ť avviato e ho potuto vedere la presentazione di mac osx con l'audio, ce da dire che prima di installare su disco ho provato ad installare su usb 8gb, ma sempre poi con messaggio still waiting root device non so se puo' servire d'aiuto a qualcuno. Avviato snow mi sono accorto che tutto funziona alla perfezione video,lan (installato attansicL2), wifi, audio avvolte a scatti, riavvio spegnimento molto lento(risolto con reimpostazioni usb nel bios) infine ho aggiornato alla 10.6.1 e tutto Ť andato bene........





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   Web hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy