Jump to content

D945GCLF2 Snow Leopard


  • Please log in to reply
247 replies to this topic

#181
THe KiNG

THe KiNG

    InsanelyMac Legend

  • Gurus
  • 674 posts
  • Gender:Male
@ ugokind and all, you may wanna check THIS

Enjoy and Marry Xmas!

#182
DamienValentine

DamienValentine

    InsanelyMac Protégé

  • Members
  • PipPip
  • 63 posts
Well done. Thank you for sharing.
I want to continue your work and I hope you don't mind. But I see you've got too far with sound injection and I wonder maybe you can share your bookmarks dedicated to D945GCLF2 datasheets or another FAQs.

#183
THe KiNG

THe KiNG

    InsanelyMac Legend

  • Gurus
  • 674 posts
  • Gender:Male
All I used was ICH7 specs, provided Macmini2,1 ioreg, and ACPI specs, nothing else except my brain...
As I said in dedicated topic, fell free(you or anyone else) to continue my work, I don't have this board anymore so can't provide any more patches for it.

#184
EnzoFX

EnzoFX

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 280 posts
The King,
What was your installation method? Boot-132? From existing install to a usb hdd, or other?

So is there no need for the patched/old IOATAFamily kext?

Thanks

#185
THe KiNG

THe KiNG

    InsanelyMac Legend

  • Gurus
  • 674 posts
  • Gender:Male
At some point I tried DVD install, it works, but since is so damn slow, and I do lot of installs for tests, I prefer to use a restored DVD image (hdd or USB flash) with Chameleon and all Extra stuff on it, much faster...

PATA panic is fixed in DSDT.

#186
EnzoFX

EnzoFX

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 280 posts
Wow very good to know. I will give it a shot with my usb installer (also a restored image with proper cham/kexts) and your given dsdt/kexts.

Thanks

EDIT:
Thanks again for the comprehensive files The King,
I plan on adding a PCI graphics card, to get better performance, is it necessary for me to remove the graphics injection in the DSDT?

After initial setup, system would KP after trying to boot the 10.6.0 installer with HT on. I figure disabling, and re-enabling it after 10.6.2 is necessary. Also, I could not boot without NullCPUPowerManagement.kext, resulting in KP without it. Perhaps the dsdt doesn't suit my board as well?

Lastly, did you ever try installing via another system, to usb HDD (OSInstall.mpkg method). Configuring it/updating it fully, then just plugging it in to the Atom system to boot for the first time?

#187
eri4

eri4

    InsanelyMac Protégé

  • Members
  • Pip
  • 14 posts
  • Gender:Male
Here are the guys from the creation of the Slice with working microphone =)))))( tested current
under 10.5.6)
ALC 662 for Intel D945GCLF2 functional FINALLY!!

Attached Files



#188
ugokind

ugokind

    InsanelyMac Deity

  • Donators
  • 1,712 posts
  • Gender:Male
  • Location:10100
  • Interests:Apicoltura
    Mac
    Linux
    Homebrew
    Australia
    Spremermilcervello
where can I find slice experiences? because in google I see slice mods on over a lot of motherboards...
I'd like to listen it's method

#189
ugokind

ugokind

    InsanelyMac Deity

  • Donators
  • 1,712 posts
  • Gender:Male
  • Location:10100
  • Interests:Apicoltura
    Mac
    Linux
    Homebrew
    Australia
    Spremermilcervello
quote

#190
balderdashian

balderdashian

    InsanelyMac Protégé

  • Members
  • Pip
  • 32 posts

Great success!
Took a 250GB USB, Installed 10.6 on it on my MacBook, updated it to 10.6.2.
Ran, Chameleon 2 RC3, copied over PC-EFIv10.5/boot to the root.
copied DSDT.aml into root
Removed mach_kernel and copied the "Atom mach_kernel" from mach_kernel_10.2.0_patched in the root(mach_kernel, in the zipfile)
com.apple.Boot.plist smbios.plist into /Extra
Loaded EvOreboot, fakesmc, NullCPUPowerManagement, PlatformUUID and SleepEnabler into Extra/Extensions/
Loaded VoodoHDA into S/L/E and removed AppleHDA
Made the Partition active, and booted from it on my Intel machine!


About this Mac sees it as an "1.69 GHz Intel Core 2 Duo", With HTT on in the Bios I get 4 threads, but only two shows activity on the Activity Monitor, with it off it shows 2 both with activity!

Link to files: http://www.mediafire.com/?nyjmin3yx44


Thanks a million for this mini guide. I had been running 10.5.8 (with the 10.5.6 kernel for Hyperthreading) as my main machine for about a year now. Using this as a guide (and all the other things people here contributed) I was able to get SL on there and working pretty easily.

With my old Leo install, performance was an absolute joke (even with HT enabled). Even this site had trouble loading. Safari or FF made no difference. If I watched a low-quality FLash video from YouTube or something, I'd be lucky to get 5 frames per second. Now with SL it's incredibly faster. I can even watch high quality Flash videos on Hulu with the full frame rate - okay maybe a hiccup every minute or so but it's very smooth for the most part.

#191
buschi2626

buschi2626

    InsanelyMac Protégé

  • Members
  • PipPip
  • 85 posts
  • Location:GERMANY
  • Interests:Hackintosh:
Hi,
I try to install SL on my D945GCLF2! But fail every time after update to 10.6.2. :P
I boot up with chameleon via USB Stick, and install from SL image on second partition!
I can boot SL 10.6.1 with Stick, then update to 10.6.2 - after that I want to install Chameleon,
but cant boot->message: No Bootable Device!
I`m not shure what I´m doing-How can I install Chameleon alright or how can I run my Installation perfectly?
Install via MAC over USB-> same result.
Can someone give me a little detailed guide, so I can figur out my failure!?!?!??
I try lifterus short guide, but I am not shure with some points I do!
THX

#192
broken

broken

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 127 posts
  • Gender:Male
  • Location:Cincinnati, OH
Any known problems with the D945GCLF2 supporting large hard drives? Like 1.5 or 2TB HDs?

#193
g3power

g3power

    InsanelyMac Protégé

  • Members
  • Pip
  • 14 posts

Any known problems with the D945GCLF2 supporting large hard drives? Like 1.5 or 2TB HDs?

I have been using my D945GCLF2 first with a 1TB Samsung EcoGreen and then with a 1.5TB for more than a year now. It's working fine and even more stable than my G5 used to be. The old Chameleon (1.0.12?) I am using has not been causing trouble even when booting from a partition on the very end of the LBA space. There are supposed to be fixes for large disks in recent Chameleon versions. Experiencing no issues I didn't try those.

Edit: It seems that those experiencing problems are using a single partition, while those without problems use separate system and data partitions.

#194
demoniac

demoniac

    InsanelyMac Protégé

  • Members
  • PipPip
  • 58 posts
  • Gender:Male
  • Location:Norway
Anyone have a simple "step-by-step" install for the D945GCLF2?

I thought it was a bit hard to see what to do in this guide.

Anyone up to making a "iPC"-like DVD for D945GCLF2 with Snow Leopard? That would be awsome! Like a OEM-disc for this motherboard...

#195
Methanoid

Methanoid

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 114 posts
  • Location:Brittania
http://www.insanelym...howtopic=138881
and
http://www.insanelym...p...p=1156630

Both good guides but for Leopard. I've not found a well written Snow Leopard guide for this board. Hopefully someone soon will write one!

#196
Zaiden

Zaiden

    InsanelyMac Protégé

  • Members
  • PipPip
  • 53 posts
Hi, I'm using the DSDT posted here but even if I'm currently able to change resolution, I'm not getting video-accel (menu bar transparency, effects when adding dashboard widgets, or decent video performance in full screen).

The thing is that without using the DSDT I do have video-acceleration, but I'm stuck on 1024x768 instead of 1280x768.

I'm on a vanilla 10.6.2

Any ideas?

#197
Zaiden

Zaiden

    InsanelyMac Protégé

  • Members
  • PipPip
  • 53 posts
After several hours of trying different configurations, I've realized that the problem was only happening when I was starting the PC with my TV connected as a monitor.

Using the custom DSDT and booting with a regular monitor and, once OS X has booted up, connecting the TV I'm finally being able to have both 3D acceleration and resolution changing.

Very weird, but I'm lucky because of having a spare monitor :huh:

#198
bcotnam

bcotnam

    InsanelyMac Protégé

  • Members
  • Pip
  • 18 posts
i have 10.6.2 working pretty good now, the only thing i don't have working which i would like is sleep in 32bit mode.

I am using TeaTeam's kernel which has native power management, so i am NOT using nullcpupowermanagement.kext. Restart and shutdown work fine, but still having problems with sleep.

When i put the computer to sleep, it will sleep fine, when i hit the keyboard to wake the computer it just restarts like a normal boot up. Is there anything else i need to add to get sleep working?

Right now, i am NOT using sleepenabler.kext and nullcpupowermanagement.kext. I can list the kexts i am using if that makes things easier to figure out, but i am not on my hackintosh right now, so i can post this up later.

#199
rebels

rebels

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts

i have 10.6.2 working pretty good now, the only thing i don't have working which i would like is sleep in 32bit mode.

I am using TeaTeam's kernel which has native power management, so i am NOT using nullcpupowermanagement.kext. Restart and shutdown work fine, but still having problems with sleep.

When i put the computer to sleep, it will sleep fine, when i hit the keyboard to wake the computer it just restarts like a normal boot up. Is there anything else i need to add to get sleep working?

Right now, i am NOT using sleepenabler.kext and nullcpupowermanagement.kext. I can list the kexts i am using if that makes things easier to figure out, but i am not on my hackintosh right now, so i can post this up later.


Can you tell me the kext you use?

I can't change the resolution in 10.6.2, that's the only problem so far...

Thnx.

#200
bcotnam

bcotnam

    InsanelyMac Protégé

  • Members
  • Pip
  • 18 posts

Can you tell me the kext you use?

I can't change the resolution in 10.6.2, that's the only problem so far...

Thnx.


If i am not mistaking the resolution for graphics is handled by your dsdt.aml file, maybe its broken. Which one are you using?

Here are the kexts i am currently using though:

VoodooHDA.kext
PlatformUUID.kext
fakesmc.kext
OSXRestart.kext
EvOreboot.kext
IOATAFamily.kext

Cheers..





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy