Jump to content

Dell d630 kext pack


  • Please log in to reply
15 replies to this topic

#1
slickslick

slickslick

    InsanelyMac Protégé

  • Members
  • Pip
  • 18 posts
hi guys,
here is kext pack for DELL D630.

http://www.infinitem...ext-pack-t3840/

#2
xover

xover

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
This is great -- I want to try it tonight! Did you install Snow Leopard from scratch, or as a 10.5 upgrade? And is there a guide you can recommend?

#3
slickslick

slickslick

    InsanelyMac Protégé

  • Members
  • Pip
  • 18 posts

This is great -- I want to try it tonight! Did you install Snow Leopard from scratch, or as a 10.5 upgrade? And is there a guide you can recommend?


Hi im installed new (fresh) install of Snow.
Here is nice how to by SaCleoCHeater
http://www.infinitem...-on-a-pc-t3137/

Enjoy_

#4
xover

xover

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
Failed so far -- SL ended up just spinning the cursor while trying to boot the first time. I'll boot verbose next try and attempt to figure out the problem.

#5
Icer One

Icer One

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts

Failed so far -- SL ended up just spinning the cursor while trying to boot the first time. I'll boot verbose next try and attempt to figure out the problem.



I was able to get almost everything working. Wireless Works, Graphics Card works, bluetooth works, time machine appears to work. I attempted to play DVD's as well as High Def movies and they play back perfectly. I attempted several different guides to get SL installed on my machine, it was a pain in the butt, but so far my D830 works great. What's not working so far is shutdown and sleep don't function, and the ethernet does not work either. I really don't care about the ethernet, it would be nice to get sleep to work properly but it's not really a deal braker. Also I used the 64bit drivers so I am running SL in 64 bit. Hopefully soon I can find the battery in 64 bit, the ethernet in 64 bit, and eventually get the sleep/shutdown/restart to function properly.

Btw, on a side note, my laptop does not bootup unless I do a -f upon booting up, I am not really sure why, but it's the only way I can get my system to start.

#6
cNone

cNone

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts
i tried kext pack over fresh and clean installation but whatever i tried the intel gma doesn't work at all ;) what am i supposed to do?

#7
youngrandy

youngrandy

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts

I was able to get almost everything working. Wireless Works, Graphics Card works, bluetooth works, time machine appears to work. I attempted to play DVD's as well as High Def movies and they play back perfectly. I attempted several different guides to get SL installed on my machine, it was a pain in the butt, but so far my D830 works great. What's not working so far is shutdown and sleep don't function, and the ethernet does not work either. I really don't care about the ethernet, it would be nice to get sleep to work properly but it's not really a deal braker. Also I used the 64bit drivers so I am running SL in 64 bit. Hopefully soon I can find the battery in 64 bit, the ethernet in 64 bit, and eventually get the sleep/shutdown/restart to function properly.

Btw, on a side note, my laptop does not bootup unless I do a -f upon booting up, I am not really sure why, but it's the only way I can get my system to start.


Dell D830 here

had to swap intel wireless for dell wireless still no known driver for intel wirless.

blutooth working internet working , native graphics working , battery working,

shutdown and restart working with modified DSDT.

native audio working with DSDT mods.

do you have a working intel wireless?

#8
Edkroket

Edkroket

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 170 posts
  • Gender:Male
  • Location:Amsterdam
  • Interests:Music, I'm a bass player

Dell D830 here


shutdown and restart working with modified DSDT.


Hi I was wondering how you edit your dsdt to shutdown en restart to work properly??

I have a dell 630 with everything working but restart and shutdown.

Ed

#9
voonwah

voonwah

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
I just updated to thr 10.6.5 but have a kernel panic....can anyone guide what to do next? Im newbie in this.. :mellow:



Thanks in advance ;)

#10
almiller5

almiller5

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts

I just updated to thr 10.6.5 but have a kernel panic....can anyone guide what to do next? Im newbie in this.. :(



Thanks in advance :D


OK I am a total Newbie to Mac also but the last 5 days have been the most fun I've had since my TRS 80 got a 16K RAM card. This all started as a New Years day project to install Snow Leopard on a Dell D630 that I had sitting around. 500 boots later I'm close.

You don't give much information in your post but from what little I have seen in the last 5 days if you are using the D620/D630/D820 Kext pack and installer provided by slic at the top of this post the most likely guess is the sleep enable kext. is causing your panic At your boot prompt use -v for a verbose listing of the boot process. When it dumps look at the stack dump and it seems to say which kext killed it. For me the Sleep has killed it every time. There is probably an updated sleep kext but I haven't worried about sleep yet.

I have a D630 with the X3100 video. Running 10.6.5 with Cameleon boot loader 2.3? I have everything running ie smooth track pad, sound, wired eithernet, firewire, modem, CD/DVD but somewhere along the line my USB ports died. I'm about to wipe the drive and start over (20th time?) from 10.6.2 and go step by step to see where I kill the USB. I think it happens when I load the combo pack to 10.6.5. At one point I had everything including bluetooth and USB wireless but no native keyboard or trackpad. I hope its not a situation of keyboard/trackpad or USB as that is a hard choice neither of which is good.

Voonwah if you want to work together PM me to see if we can get over the top. Anybody else if you could throw me a USB bone I'd be most appreciative. Ive tried backdating the IOUSBFamily and IOUSBMassStore to no avail. Im afraid I'm about to learn about DSTS editing.

#11
Dellmantt

Dellmantt

    STILL LEARNING

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,122 posts
  • Gender:Male
  • Location:AUSTRALIA

. Running 10.6.5 with Cameleon boot loader but somewhere along the line my USB ports died. I'm about to wipe the drive and start over (20th time?) from 10.6.2 and go step by step to see where I kill the USB. I think it happens when I load the combo pack to 10.6.5.

You don't need to re-install. Just do some research. If you had you would have found that it is common problem (10.6.5 & usb)
To fix http://www.insanelym...p...t&p=1583392

And apparently 10.6.6 update fixes the USB problem

#12
almiller5

almiller5

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts

You don't need to re-install. Just do some research. If you had you would have found that it is common problem (10.6.5 & usb)
To fix http://www.insanelym...p...t&p=1583392

And apparently 10.6.6 update fixes the USB problem


Actually the post you cite is what I meant by back dating the IOUSBMassStore and IOUSBFamily kext. That seemed logical to me so I did that several times. Unfortunately for me it didn't fix anything. I do like the idea of 10.6.6 fixing it. Ill try that next Thanks.

#13
Dellmantt

Dellmantt

    STILL LEARNING

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,122 posts
  • Gender:Male
  • Location:AUSTRALIA

Actually the post you cite is what I meant by back dating the IOUSBMassStore and IOUSBFamily kext. That seemed logical to me so I did that several times. Unfortunately for me it didn't fix anything. I do like the idea of 10.6.6 fixing it. Ill try that next Thanks.

Woops, yes sorry, I did not read the post thoroughly. Hope 10.6.6 works for you

#14
freakyuno

freakyuno

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts

I was able to get almost everything working. Wireless Works, Graphics Card works, bluetooth works, time machine appears to work. I attempted to play DVD's as well as High Def movies and they play back perfectly. I attempted several different guides to get SL installed on my machine, it was a pain in the butt, but so far my D830 works great. What's not working so far is shutdown and sleep don't function, and the ethernet does not work either. I really don't care about the ethernet, it would be nice to get sleep to work properly but it's not really a deal braker. Also I used the 64bit drivers so I am running SL in 64 bit. Hopefully soon I can find the battery in 64 bit, the ethernet in 64 bit, and eventually get the sleep/shutdown/restart to function properly.

Btw, on a side note, my laptop does not bootup unless I do a -f upon booting up, I am not really sure why, but it's the only way I can get my system to start.


I'm in a similar situation. Currently I'v got a 99% working d630. I had to replace the Intel Wireless (4956) with a dell 1505 wireless card from ebay ($13 USD). I've got everything working except my Shutdown / Restart. It Wont restart at all, and when I use shutdown it restarts. Not sure how to fix this, so looking for advice. I know it requires a DSDT edit, but this makes me nervous so I've lived with it for now.

For the record, I also need to use -f to get the system to boot properly. if I don't use the -f option on boot, it boots to the osx desktop, but it does not initialize graphics.

I'm looking for information on how to fix this

#15
almiller5

almiller5

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts

Actually the post you cite is what I meant by back dating the IOUSBMassStore and IOUSBFamily kext. That seemed logical to me so I did that several times. Unfortunately for me it didn't fix anything. I do like the idea of 10.6.6 fixing it. Ill try that next Thanks.



Update:

Success. 97% perfect Dell D630 running 10.6.6. (no sleep or shutdown) Myproblem turned out to be AppleHPET.kext. Took that out and USB function was immediately restored. I am actually a little ashamed of how long it took to get to this stage. Of course part of it was spent on basic knowledge base like how to navigate what plist and aml files are l where files are kept on MACs etc. Thanks for the 1000's of posts that others have been good enough to post and for the guides. This would have been a real mans job in 2007/2008 before there was such a body of knowledge.

Now on to dual boot my dell M4500

#16
Openminded

Openminded

    InsanelyMac Protégé

  • Members
  • Pip
  • 28 posts

Dell D830 here

had to swap intel wireless for dell wireless still no known driver for intel wirless.

blutooth working internet working , native graphics working , battery working,

shutdown and restart working with modified DSDT.

native audio working with DSDT mods.

do you have a working intel wireless?


Hi,

Can you explain what you modded to your DSDT to make the audio work and with what driver?
It does not work on my D830.

Thank you





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy