Jump to content

All OpenCL Benches: RAYTRACING/Galaxies/Grass/qJulia/Displacement...


  • Please log in to reply
124 replies to this topic

#101
MaLd0n

MaLd0n

    ...filling veins with juice of chaos...

  • Moderators
  • 11,137 posts
  • Gender:Male
  • Location:Rio de Janeiro
Thankssssssssssssss

;)

#102
mitch_de

mitch_de

    InsanelyMacaholic

  • Retired
  • 2,885 posts
  • Gender:Male
  • Location:Stuttgart / Germany
In next few days an new SLG Version will be available - major updates in raytracing speed and some OpenCL enhancements done.

#103
MaLd0n

MaLd0n

    ...filling veins with juice of chaos...

  • Moderators
  • 11,137 posts
  • Gender:Male
  • Location:Rio de Janeiro
OK

I'll be waiting for it

: D

Thank you very muchPosted Image

#104
mitch_de

mitch_de

    InsanelyMacaholic

  • Retired
  • 2,885 posts
  • Gender:Male
  • Location:Stuttgart / Germany
Update to V170 (always same link )
http://www.macupdate...632/smallluxgpu
Major update with console tab (you can see informations the gui also shows but now even more + errors)
Happy benching (times type 0 no changes, type 1 maybe little faster)

#105
sch8mid

sch8mid

    Lenz

  • Members
  • PipPipPipPip
  • 224 posts
  • Gender:Male
  • Location:Germany
Hi Mitch
greetz from Suebia

new 1.7

HD 5770 (10.6.4) :

Midrange GPU :8,9 sec.
Highend GPU: 14,8 sec.
UltraHigh GPU :39,6 sec.

#106
mitch_de

mitch_de

    InsanelyMacaholic

  • Retired
  • 2,885 posts
  • Gender:Male
  • Location:Stuttgart / Germany
Soon there will be an update to V171, which has slg V1.62Dev insie and also some fixes.
I removed High gpu only bench and added UltraHigh Sponza gpu only.
Would be fine if you check new Sponza Benchmark.
I uploaded the V171 to RS for getting some reference benchmark times. No major changes in known Luxball UltraHigh benchmark .

http://rapidshare.co...luxGPU_V171.zip

Attached Files



#107
sch8mid

sch8mid

    Lenz

  • Members
  • PipPipPipPip
  • 224 posts
  • Gender:Male
  • Location:Germany
Hi Andreas

V171 :

here are the results of the Sigmaringen Jury:

midrange: 8,6sec
ultra high: 34,9
sponza:44,8

5770 is recognized with 725 MHz and 512 MB RAM here
__

and slightly off topics , but I know you are the man: :(

got the 5770 to work with netkasdrivers without a hitch on 10.6.4

seems all work : resolutions-quartz-dual monitors with second display on hdmi

but:

extremely low performance in opengl extension viewer :
card is recognized as ATI Radeon HD 5770 OpenGl Engine
all 120 extensions are there

but only 200 fr. in benchmark /ffsa 4 mode
2900 fr in normal mode
remember our ati 3850 with 4500 fr. in normal mode ?

Any thoughts ?

best
armin

#108
mitch_de

mitch_de

    InsanelyMacaholic

  • Retired
  • 2,885 posts
  • Gender:Male
  • Location:Stuttgart / Germany
Thanks your results will be references in next final 1.7.1. (monday/tuesday)
200 fr with 4*fssa is real low if non fssa is 2900+ frames !
Maybe the driver cant setup fsaa correct and you must wait for later (official ) drivers.

#109
@ROBASEFR

@ROBASEFR

    InsanelyMac Geek

  • Members
  • PipPipPipPipPip
  • 323 posts
  • Gender:Male
  • Location:France

Thanks your results will be references in next final 1.7.1. (monday/tuesday)
200 fr with 4*fssa is real low if non fssa is 2900+ frames !
Maybe the driver cant setup fsaa correct and you must wait for later (official ) drivers.



Hello,

Here a my benchmarks wilth 1.7.1

Smallux 1.7.1 SmalluxGPU v1.6beta1 OSX 10.6.4
Luxbal glass scene 640x480
All tests with Optimized Type 1
4 Cores CPU + All GPUs
Intel Core i7 CPU 920@2.67GHz 2800MHz
ATI 4850 GS Gainward 510Mb 750MHz

Benchmark Modes OPENCL GPU only
Luxbal Midrange : 2,3s
Sponza Ultrahigh : 50,9s
Luxbal Ultrahigh : 1,9s

and CPU+GPU
Luxbal Midrange GPU: 10,7s
Sponza Ultrahigh GPU only : 49,9s
Luxbal Ultrahigh GPU only : 4,0s

Benchmark GPU with OpenCL pixel filtering
Filter none: 795,38M
Filter Preview: 200,47,M
Filter Gaussian: 82,10M
;)

#110
mitch_de

mitch_de

    InsanelyMacaholic

  • Retired
  • 2,885 posts
  • Gender:Male
  • Location:Stuttgart / Germany
Benchmark Modes OPENCL GPU only
Luxbal Midrange : 2,3s
Sponza Ultrahigh : 50,9s
Luxbal Ultrahigh : 1,9s

and CPU+GPU
Luxbal Midrange GPU: 10,7s
Sponza Ultrahigh GPU only : 49,9s
Luxbal Ultrahigh GPU only : 4,0s

First to say there is no CPU+GPU Benchmark.
The lest side of the slg GUI (where you can select GPU, CPU+GPU) is the interactive mode, which shows the rendering and supports a few scenes. All the settings there are independend from the middle Benchmark gui part.
Only that settings are used with fixed scenes and fixed resolutions.

Your Ultrahigh Luxball benchmark (always gpu only) times look a bit fast.
Please check the console tab (within the GUI) and look for some errors.
OpenCL does automatic use the CPU and not GPU if some gpu device fails (mostly driver probs).
Therefor (gpu fails) fast i7 cpu will perform much faster as ATI 4850 GS.
You can also check that - if you can run real gpu only benches - if you start luxball scene (or other)
in the interactive mode (left side of gui).
You would see your GPU speed informations (Rays/Sec) in the interactive render window beside the cpu threads info (shown as native .... ) or alone.
If you only see native .... fnormation lines and no gpu information line the gpu fails and cpu works insted, even setting gpu only.

I attached an screenshoot which shows interactive mode running CPU+GPU. Please post your screen also to compare. If gpu works, you will see also an information line (Cypress=GPU) for GPU below that cpu thread lines (native...)

If we also GPU information line i can put some extra code to investigate the problem of the to fast Ultrahigh Luxcall results.
But first we have to look after your interactive speed results (native+ gpu XXXk Rays/sec).

Attached Files



#111
sch8mid

sch8mid

    Lenz

  • Members
  • PipPipPipPip
  • 224 posts
  • Gender:Male
  • Location:Germany
Hi Andreas
as you changed the terminology slightly in 1.7.1 here the results again :

ATI 5770 @750
_____________



bench luxball midrange : 8,6 sec.
bench ultrahigh :33,4 sec
bench sponza :44,8 sec.


EDIT : CPU@ 3,2 GHz

mid: 7,0
sponza: 36,8






________________

opencl pixelfiltering :

error on ati cpus

best
armin

#112
mitch_de

mitch_de

    InsanelyMacaholic

  • Retired
  • 2,885 posts
  • Gender:Male
  • Location:Stuttgart / Germany
Thanks !
OpenCL Pixelfillter for ATI 57/58xx isnt implemented in the OS X ATI OpenCL driver - so that error is "normal".
I will upload an Final 1.7.1 today here , with some new instances scene (130 Mill triangles! to reytrace) and SPPM raytracing Method switch in the GUI ( beside Type 0, Type 1 - glass looks very nice). Times will not change by this update .

Attached 130 milllions triangles object raytraced. ( Most other scenes have less than 50.000 triangles)
Will need >= 3GB RAM to run fast (also when run in gpu only). On 2 GB systems the raytracing may run slower/stall because of memory swappings.

Attached Files



#113
sch8mid

sch8mid

    Lenz

  • Members
  • PipPipPipPip
  • 224 posts
  • Gender:Male
  • Location:Germany
like it very much
best
armin

#114
mitch_de

mitch_de

    InsanelyMacaholic

  • Retired
  • 2,885 posts
  • Gender:Male
  • Location:Stuttgart / Germany
Now 1.7.1 preFinal V3:
DL 55 MB: 171V3 with benchmark instances scene (8800GTX = 150 sec)
[url="http://"DL%2055%20MB:<a%20href="http://rapidshare.com/files/410151278/smallluxGPU171_V3.zip""%20target="_blank">http://rapidshare.co...mal...71_V3.zip"</a>"]http://rapidshare.com/files/410151278/smallluxGPU171_V3.zip[/url]

- removed OpenCL Code Type selector (0/1) from Benchmark. Always use now Type 1.
- added SPPM Method Type - special raytracing method in OpenCL. Glass / lights look mostly better, but more cpu usage
- added intances 130 Mill Scene (fixed res / special OpenCL Code = no res+no Type selector for that scene)
Instances 130 Million (triangles) may NOT work on ATI OS X GPUs.
At least on Windows the ATI OpenCL drivers fail, Nvidia drivers can run that scene on Win/OS X
Also huge RAM usage, therefore 3GB RAM needed to perform fast. I would NOT run that GPU only on lowend GPUs.
- added again CPU cores count selector (2 or 4 cores) for interactive scenes

#115
mitch_de

mitch_de

    InsanelyMacaholic

  • Retired
  • 2,885 posts
  • Gender:Male
  • Location:Stuttgart / Germany
Looks :
Attached File  Bildschirmfoto_2010_07_31_um_10.47.48.jpg   385.77KB   19 downloads

#116
@ROBASEFR

@ROBASEFR

    InsanelyMac Geek

  • Members
  • PipPipPipPipPip
  • 323 posts
  • Gender:Male
  • Location:France

Hi Andreas
as you changed the terminology slightly in 1.7.1 here the results again :

ATI 5770 @750
_____________


opencl pixelfiltering :

error on ati cpus

best
armin


Perhaps you should install latest update for Imac 10.6.4 wich is taking charge of latest ATI Radeon HD 5670 or ATI Radeon HD 5750 !

perhaps you could after this update with latest ATI buffer
http://netkas.org/?cat=7
:(

#117
mitch_de

mitch_de

    InsanelyMacaholic

  • Retired
  • 2,885 posts
  • Gender:Male
  • Location:Stuttgart / Germany
Yep, maybe the iMac Mid 2010 OpenCL Framework update (ATI OpenCL Framework updated onyl) may help - otherwiese 10.6.5 in the future. In the OS X past, ATI OpenCL drivers were oft a bit problematic (until updated each 10.6.x - Nvidia mostly working.

#118
sch8mid

sch8mid

    Lenz

  • Members
  • PipPipPipPip
  • 224 posts
  • Gender:Male
  • Location:Germany

Yep, maybe the iMac Mid 2010 OpenCL Framework update (ATI OpenCL Framework updated onyl) may help - otherwiese 10.6.5 in the future. In the OS X past, ATI OpenCL drivers were oft a bit problematic (until updated each 10.6.x - Nvidia mostly working.



Hi Mitch , you may correct HD 5770 results :-)

mid : 7,0 sec.

Sponza : 36 sec.


Attached File  Bildschirmfoto_2010_09_02_um_12.05.03.png   54.51KB   10 downloads

#119
rushko

rushko

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
My results:

Attached File  Screen_shot_2010_09_04_at_05.53.36.png   125.58KB   30 downloadsAttached File  Screen_shot_2010_09_04_at_05.52.56.png   79.9KB   18 downloadsAttached File  Screen_shot_2010_09_04_at_05.49.44.png   83.07KB   13 downloadsAttached File  Screen_shot_2010_09_04_at_05.51.09.png   83.95KB   20 downloads

Thanx Mitch_de!

#120
marashz

marashz

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts
Asus EAH5850  Attached File  Screen_shot_2010_10_16_at_10.27.14_AM.png   57.34KB   32 downloads





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy