Jump to content

[Risolto] Problema scheda audio AD1988B con snow


  • Please log in to reply
12 replies to this topic

#1
francesco9312

francesco9312

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
  • Gender:Male
  • Location:Acquaviva delle Fonti
Salve dopo un giorno intento a cercare di installare snow sul mio pc...ieri sera sono riuscito a farlo avviare.
In modalità 64 bit ogni tanto mi esce una schermata nera che mi dice di riavviare il pc, ma non succede sempre.
Ho visto che alcune periferiche vengono riconosciute altre no. Per esempio la mia scheda audio non viene riconosciuta, qualcuno mi potrebbe dire come fare a farla funzionare? Io prima usavo anche leopard, lì mi funzionava tutto inclusa la scheda audio, ora non so se usare lo stesso kext di leopard per snow!

#2
kpkp

kpkp

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 433 posts

Salve dopo un giorno intento a cercare di installare snow sul mio pc...ieri sera sono riuscito a farlo avviare.
In modalità 64 bit ogni tanto mi esce una schermata nera che mi dice di riavviare il pc, ma non succede sempre.
Ho visto che alcune periferiche vengono riconosciute altre no. Per esempio la mia scheda audio non viene riconosciuta, qualcuno mi potrebbe dire come fare a farla funzionare? Io prima usavo anche leopard, lì mi funzionava tutto inclusa la scheda audio, ora non so se usare lo stesso kext di leopard per snow!

Puoi dirmi che kext usi e quale boot loader?
La soluzione migliore è il dsdt.aml.

PS: anche io avevo i KP ma adesso sono stabile dopo aver eliminato il IONetworkingFamily.kext (quello modificato che faceva andare la LAN) dalla cartella Extra di Chameleon.

#3
francesco9312

francesco9312

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
  • Gender:Male
  • Location:Acquaviva delle Fonti

Puoi dirmi che kext usi e quale boot loader?
La soluzione migliore è il dsdt.aml.


Non ho fatto altro che seguire la guida di BarboneNet e al primo colpo è partito.

#4
kpkp

kpkp

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 433 posts

Non ho fatto altro che seguire la guida di BarboneNet e al primo colpo è partito.

Ma la LAN, il sleep (stop) funzionano?

Io uso i kext allegati... per il souno io proverei con il VoodooHDA a 64bit, sembra che funzioni, non perfettamente ma è il modo più semplice (non sono sicuro se devi rimuovere il AppleDHA anche in SL, aspetta qualche conferma se non te la senti di rischiare).

E poi dovresti aggiungere QUESTO per la LAN e anche il AHCIPortInjector.kext per il Chipset.

Attached Files

  • Attached File  Kext.zip   136.29KB   13 downloads


#5
francesco9312

francesco9312

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
  • Gender:Male
  • Location:Acquaviva delle Fonti

Ma la LAN, il sleep (stop) funzionano?


Sisi. La LAN e lo sleep funzionano perfettamente. Vabbè anche la scheda wifi non funziona, ma non mi serve e neanche su leopard funzionava. Ora sto provando altri kext e provo anche il VoodooHDA.kext.

#6
kpkp

kpkp

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 433 posts

Sisi. La LAN e lo sleep funzionano perfettamente. Vabbè anche la scheda wifi non funziona, ma non mi serve e neanche su leopard funzionava. Ora sto provando altri kext e provo anche il VoodooHDA.kext.

La trovi QUI.
Piccola guida in inglese:
How to:
1. Download the zip
2. Copy the application Voodoo HDA Helper to /Applications/Utilities/
3. Copy the folder VoodooHDA to Your_OS_X_disk/Library/
4. Add application Voodoo HDA Helper to list of login items in
System Preferences > Accounts > Login Items

Controlla anche come ti viene riconosciuto il controller SATA.

#7
francesco9312

francesco9312

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
  • Gender:Male
  • Location:Acquaviva delle Fonti

La trovi QUI.
Piccola guida in inglese:

How to:
1. Download the zip
2. Copy the application Voodoo HDA Helper to /Applications/Utilities/
3. Copy the folder VoodooHDA to Your_OS_X_disk/Library/
4. Add application Voodoo HDA Helper to list of login items in
System Preferences > Accounts > Login Items

Controlla anche come ti viene riconosciuto il controller SATA.


Il controller SATA l'ho impostato nel BIOS in ACHI, se no all'installazione di snow non mi riconosceva gli hd SATA. Ora provo quello che mi hai mandato. Grazie dell'aiuto!

#8
kpkp

kpkp

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 433 posts

Il controller SATA l'ho impostato nel BIOS in ACHI, se no all'installazione di snow non mi riconosceva gli hd SATA. Ora provo quello che mi hai mandato. Grazie dell'aiuto!

No, intendevo nel system profiler, se viene rilevato come intel AHCI.... o unknown AHCI...

#9
francesco9312

francesco9312

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
  • Gender:Male
  • Location:Acquaviva delle Fonti

La trovi QUI.
Piccola guida in inglese:

How to:
1. Download the zip
2. Copy the application Voodoo HDA Helper to /Applications/Utilities/
3. Copy the folder VoodooHDA to Your_OS_X_disk/Library/
4. Add application Voodoo HDA Helper to list of login items in
System Preferences > Accounts > Login Items

Controlla anche come ti viene riconosciuto il controller SATA.


Ho fatto quello che mi hai suggerito ma non trova la scheda audio. E poi nel system profiler il controller SATA me lo vede come unknown AHCI Standard Controller




Ho fatto quello che mi hai suggerito ma non trova la scheda audio. E poi nel system profiler il controller SATA me lo vede come unknown AHCI Standard Controller



Ora non so come ho fatto però funziona l'audio. E tutto grazie a VoodooHDA.kext. Grazie!

#10
kpkp

kpkp

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 433 posts

Ho fatto quello che mi hai suggerito ma non trova la scheda audio. E poi nel system profiler il controller SATA me lo vede come unknown AHCI Standard Controller
Ora non so come ho fatto però funziona l'audio. E tutto grazie a VoodooHDA.kext. Grazie!

:(
Sono contento per te, io non l'ho mai provato, pero ho letto che funziona...
Per il controller dovresti installare il AHCIPortInjector, se te la senti... (anche questo non l'ho testato ma solo letto in giro).

Se lo provi fa mi sapere perché servirà ancora a tanti :)

PS: metti anche "Risolto" nel titolo del topic

Download AHCIPortInjector

#11
francesco9312

francesco9312

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
  • Gender:Male
  • Location:Acquaviva delle Fonti

;)
Sono contento per te, io non l'ho mai provato, pero ho letto che funziona...
Per il controller dovresti installare il AHCIPortInjector, se te la senti... (anche questo non l'ho testato ma solo letto in giro).

Se lo provi fa mi sapere perché servirà ancora a tanti :D

PS: metti anche "Risolto" nel titolo del topic


Ora ho provato AHCIPortInjector e funziona.

Attached Files



#12
frtommy

frtommy

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 420 posts
  • Gender:Male
  • Location:Italy
Ciao.
Magari se scrivi come risolvi, sarebbe anche gradito.
Così può essere d'aiuto a altre persone invece di aprire un nuovo topic.
Ciao ciao.

#13
francesco9312

francesco9312

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
  • Gender:Male
  • Location:Acquaviva delle Fonti

Ciao.
Magari se scrivi come risolvi, sarebbe anche gradito.
Così può essere d'aiuto a altre persone invece di aprire un nuovo topic.
Ciao ciao.


Hai ragione! Semplicemente ho aggiunto VoodooHDA.kext e dopo il riavvio ha funzionato alla grande.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy