Jump to content

[Mini Guide] SL working on Gigabyte G41M-ES2L


  • Please log in to reply
933 replies to this topic

#281
cybercap

cybercap

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 126 posts
  • Gender:Male
  • Location:Strasbourg, France
Ridgeline,

thanks for taking care of me

here is my feedback

I set my bios exactly like yours and i use your latest dsdt for Q6600
Hac boots ok and pstate are same values that i had when eist, c1E and all that stuff was disabled.
cpu still indicates in pstate that it lowers its speed and voltage when idle (this was also the case with all stuff disabled)

what is NO good for me is the cpu vcore AUTO setting because since i overclock the mobo sets voltage accordingly and bios reads around 1,34-1,36v and even speedstep my idle temps (istat measures) are +5°C on each core than before
1- with manual vcore setting : set 1,20, bios read 1,18v
idlle : 40-40-35-35°, load 56-56-51-51
2- with AUTO vcore : bios read 1,34v
idle : 46-46-40-40° , load 62-62-57-57
3- back to manual vcore setting : set 1,20, bios read 1,18v but with C1E,EIST Enabled : NO change in temps (like 1) and pstate readings

conclusion : Enabling C1E, EIST in bios hasn't changed anything, seems to be like you said that whatever speedstep bios settings it is overriden with chameleon, EFI, dsdt, or so. BUT vcore setting seems not to be completly managed by pstate. Though pstate shows a max of 1,28v (same as my manual vcore), the high temps must be based on vcore jumping automatically to 1,34v because of oc.

Hac Sleep mode still does not work automatically :(
but will work when forced manually

should i check kext like nullcpupowermangement, sleepenabler, and try something with them, what could i try?

As far as i can remember using sleepenabler on a former install had proven successful but it worked at random. sometimes it went off and the next time it wouldn't :)

thanks

#282
ridgeline

ridgeline

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 532 posts
  • Gender:Male
  • Location:Cape Coral, FL
Cybercap you sir are an anomaly as I have had just about everyone but you have success with this the only thing I can think of is no one is overclocked but you. I am not sure where to go from here.

On a side note I will be updating the installer again with a few more dsdt files, as well as the AppleHDA 10.6.2 from Tonymac I will also be adding a wireless category that will have the TP Link installer for those that are running that card. If you are using another card and would be willing to send me the files that you installed as well as the card info I will see what I can do about making an installer for it to simplify the process for everyone.

For those who got an error using my more recent installer can you please tell me what the error was and when it occurred? I have tried it with no issue but it was built on my machine

#283
cybercap

cybercap

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 126 posts
  • Gender:Male
  • Location:Strasbourg, France
Ridgeline


Great to hear from you.

For my sleep problem, do not worry, i'll find out sooner or later and i can put it to sleep manually so it's not that annoying.

I'm happy to see that you're always trying to improve your installer, thank you so much!

If you would be kind enough to include my wifi dongle chipset drivers in the installer, that would be great.
It is a RALINK RT2870 chipset which is a well known one.

here are :
- the installer file
- the kext file
- the pref panes files : enabling the nice airport icon
- the link to the official driver (30mb) : http://www.ralinktec...support.php?s=3
- the link to the topic on this forum : http://www.insanelym...p...68984&st=40

i hope you can sort these files out and keep what's needed

let me know of you need more information

thanks :compress:

Attached Files



#284
tacticalt

tacticalt

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
My error, like Robie's, said there is no software to install when I clicked the install button after selecting options. However, I just tried it without any options selected, and it installed fine. I also noticed, atleast in the 1.4 version, that the Gigabyte theme is extracted to the Themes directory directly-- not in a Default or Gigabyte folder. Finally, this isn't big at all-- but the file is named 1.6 but the inside the installer it states 1.5.

I'll let you know if I find anything else. Thanks for making this installer, it's much appreciated!!

(PS I'm not trying to 'complain'... the installer is GREAT, just letting you know of things I've found.)

#285
Luthraz

Luthraz

    InsanelyMac Protégé

  • Members
  • PipPip
  • 71 posts
  • Gender:Male
  • Location:USA
First of all, a big thank you goes out to everyone involved in this mini guide.

Second of all, it has inspired me to build my own machine based around this motherboard model.

I would very much appreciate it if someone could go over my component list to make sure everything should work without a hitch. Below you'll find the newegg links along with pricing info. I also would like some recommendations on a nice video card. I edit HD video and plan on playing some of the Valve Steam releases (if Steam for mac comes out in the next week or so haha). Also I have a ghetto monitor I will use for the time being until I can purchase a decent one.

Lastly, I have a bluetooth keyboard/mouse I would like to use with this setup. Can I get an OS X compatible add on for this mobo, or would it be better to get a usb dongle? Any and all help would be appreciated!!!



Specified Mobo (Dur) - 54.99


4 Gig Corsair Memory - 103.99


Core 2 Duo E8500 3.16 Ghz - 189.99


HEC 63RABB Black Steel ATX Mid Tower Computer Case


hec HP485D 485W ATX12V Power Supply CACACACombo Deal (Case+Power Supply) - $44.98


TOTAL = $406.84 Shipped

I have about $150 of wiggle room for the video card / anything else you all can think of. The case comes with a fan but I'm not really sure if that will be enough to cool this system or not. Also I have some thermal paste but I am also not sure if that will be necessary either.

This is my first post here so I hope you guys go easy on me. :-)

P.S. I am definitely familiar with running OS X on my Dell Mini9 (see image below) so the software side of all of this should be pretty easy for me to go through, and I have an OEM copy of Snow Leopard!

Attached File  97191452.jpg   72.91KB   19 downloads

#286
tacticalt

tacticalt

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
Well definitely don't go ATI haha... I have a 4830 and I'm lucky to be where I'm at now, and I'm still not satisfied completely. I love the card itself, but it has been the biggest pain ever. If I had a graphics card that was simple to setup, installing SL with Ridgeline's installer would be the easiest thing ever.

Also-- My computer won't automatically go to sleep. Is this related to what Cybercap is having problems with?? I'm not too worried about it as I usually manual sleep anyway, and I don't think the auto sleeps works on my other partition with Hazard and sleepenabler either. It would be nice, though. I haven't tried any applications... I'm sure there's something out there can could solve it.

Thanks again for all your work Ridgeline!

#287
dumpav

dumpav

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
anyone know is there any where i can find the AHCI option to set for this motherboard?

thanks

#288
Luthraz

Luthraz

    InsanelyMac Protégé

  • Members
  • PipPip
  • 71 posts
  • Gender:Male
  • Location:USA

Well definitely don't go ATI haha... I have a 4830 and I'm lucky to be where I'm at now, and I'm still not satisfied completely. I love the card itself, but it has been the biggest pain ever. If I had a graphics card that was simple to setup, installing SL with Ridgeline's installer would be the easiest thing ever.


I think I may go with this card, the GeForce 9500 GT 1GB.
http://www.newegg.co...N82E16814150322

I will be ordering this stuff on Monday (when I have the money). I'm hoping I can get some more feedback before then.

#289
tacticalt

tacticalt

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts

anyone know is there any where i can find the AHCI option to set for this motherboard?

thanks


Just set the Sata mode to enhanced I think it is. It won't say AHCI specifically in BIOS but in the manual it says that's AHCI mode.

#290
newdisplayname

newdisplayname

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
thank for fixing the DSDT for the board. finally got everything working, including sleep.

g41m-es2l (rev1.1)
e3300 celeron
8400gs
2gb mem

the attached is the patched dsdt for e3300 based on e5200 dsdt. the only change is the pstate numbers.

Attached Files



#291
ridgeline

ridgeline

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 532 posts
  • Gender:Male
  • Location:Cape Coral, FL
Thanks for the update I will add it to the next installer

#292
hawaii50

hawaii50

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 125 posts
Ridgeline,

First, thank you for this mini guide. This was the easiest install I've ever done. The only thing that is not working is sleep. I'm hoping that the problem is the p-states that you have written about. I don't know how to edit the DSDT to change the data for my CPU. I have attached a screenshot of the p-states for a Q8400. I'd appreciate any help you can provide.

Best regards,

h50

Attached Files



#293
hawaii50

hawaii50

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 125 posts
Ridgeline:

I see you are accumulating p-state screenshots for various CPUs. I've attached a screenshot for a Pentium Dual Core E6300.

h50

Attached Files



#294
tacticalt

tacticalt

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts

Ridgeline:

I see you are accumulating p-state screenshots for various CPUs. I've attached a screenshot for a Pentium Dual Core E6300.

h50


Looks like you need to attach another screenshot with the window scrolled down if I'm not mistaken.

#295
hawaii50

hawaii50

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 125 posts
tacticalt

You are correct! The application does not seem to let me resize the window, so I am posting a second image to show the portion of the window with the scrollbar pulled all the way down.

h50

Attached Files



#296
ridgeline

ridgeline

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 532 posts
  • Gender:Male
  • Location:Cape Coral, FL
Thanks guys I wll do what i can shortly and update as I go.

#297
seleven

seleven

    InsanelyMac Protégé

  • Members
  • Pip
  • 44 posts
  • Location:Here and there
Wow, it's been a while since I posted anything, not since the Jas installer days on my Pentium M lapdog. ;)

Ridgeline, I want to thank you for all the work you have done so far. Getting a tweaked DSDT like you have generously provided is something that is not easy work, and it's amazing how well it does work.

However, I will chime in with the problem running the 1.6 post install package stating there is no software found to install when customizing it for my particular setup (32-bit at the moment, no extra network driver, E7500 DSDT).

I have a fresh install of 10.6.3 from a retail DVD (picked it up myself) on a freshly formatted drive. As I have a working install now from the first page of this thread, I'm going to wait for the next version of the installer and use that. I'm not in any rush, and if I can help with testing anything, let me know, I'm glad to help (after all, I've got nothing to loose if I break something on the new drive :wacko:).

#298
Luthraz

Luthraz

    InsanelyMac Protégé

  • Members
  • PipPip
  • 71 posts
  • Gender:Male
  • Location:USA
Does anyone know if the onboard graphics card will work on this mobo? I ended up getting everything but a video card for my build so now I'm wondering if I'll even be able to use it... :rolleyes:

#299
seleven

seleven

    InsanelyMac Protégé

  • Members
  • Pip
  • 44 posts
  • Location:Here and there

Does anyone know if the onboard graphics card will work on this mobo? I ended up getting everything but a video card for my build so now I'm wondering if I'll even be able to use it... ;)

I've only seen one post anywhere that says that the on board graphics were able to be used with some DSDT modifications, but there were some limitations, such as DVD playback not working correctly and no acceleration.

IMO, you would be better off finding a cheap 8500 or better and using that, or even a 7500 or better, but would be limited to 32-bit because, from what I understand, the 64-bit drivers for the 7000 series cards is known to have a bug or two.

#300
Luthraz

Luthraz

    InsanelyMac Protégé

  • Members
  • PipPip
  • 71 posts
  • Gender:Male
  • Location:USA
Ok that's what I figured. I guess I'll either try and borrow one from a friend or buy one at my local shop, or just deal with windows till I have the money.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy