Jump to content

965P-DS4 Success with Retail 10.6 - 64 Bit


  • Please log in to reply
133 replies to this topic

#21
timdafweak

timdafweak

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 123 posts
  • Gender:Male
  • Location:New York

does someone have answer to this? I find it unlikely since I have taken this route before and did not notice any difference but then again I did it just for fun and never used it any longer! :D

I have a 965P-DS3 / Q6600 / 8800GT, and just getting itchy to try this out as soon as my copy of snow leopard arrives (from uTorrent). :P
(sorry I am planning to buy SL soon from Amazon as well.


Well not KPs but rather messed up permissions. Disk Utility won't correct them within Snow Leopard. However, as a few astute board gurus noticed, you can solve this issue by installing BSD.pkg on the Install DVD from Snow Leopard.

#22
Sabr

Sabr

    Well, it was fun while it lasted.

  • Retired
  • 3,883 posts
  • Gender:Male
  • Location:United Kingdom.

does someone have answer to this? I find it unlikely since I have taken this route before and did not notice any difference but then again I did it just for fun and never used it any longer! :(

I have a 965P-DS3 / Q6600 / 8800GT, and just getting itchy to try this out as soon as my copy of snow leopard arrives (from uTorrent). :P
(sorry I am planning to buy SL soon from Amazon as well.


I installed SL onto a brand new drive this way and it would kernel panic - but all I had to do was set the correct permissions on kexts and rebuild mkexts and it's running fine now. I left it running all day/night and it has no problems at all. I also had to reinstall BSD.pkg but apart from that, it's fine. :)

#23
timdafweak

timdafweak

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 123 posts
  • Gender:Male
  • Location:New York
So finally I got SL as my primary and only OS on my system. I followed the USB Stick/Partition containing the SL image installation method detailed by noob766 in his generic post. It worked like a charm somewhat. Be warned though, keep ONLY the fakesmc, nullcpupowermanagement, and openhaltrestart kexts in there. Any Vanilla kexts that you modify and keep on the USB /E/E folder WILL cause the installation to panic. MANY many KPs later here I am. Finally on SL. Stable and fine :)

#24
Terence Loh

Terence Loh

    InsanelyMac Protégé

  • Members
  • Pip
  • 30 posts

Do you not have it working? I'm using the 965P-DS3 and have my ALC883 audio working through a patched AppleAzaliaAudio.kext. It only allows for stereo output though, so it's not the most elegant solution...


Hi retired,
Could you point me to the same directions for the patched AppleAzaliaaudio.kext. Does it work in 64bit mode?
Thank you.

#25
parkersmith

parkersmith

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
Sorry for the double post. I hit new topic by mistake...

Hi guys,

Thanks for all your work here and for all the instructions I have read for the past 48 hours... I finally got my 965P DS3 board running with 10.6. I have one major issue left and that is I can't get my VIA IDE working on the MoBo. I had it working in my 10.5.8 install and I have put 10.6 on a new drive. I tried copying my old AppleVIA.Kext over from the 10.5.8 drive and that did not work. I have also downloaded AppleVIAATA.Kext and still no luck I have run the Kext Utility to fix permissions and still nothing. I see other's here have it working, could someone please point me in the right direction?

I also got my audio working via the 883 driver package and am outputting SPDIF. Has anyone figured out how to keep the audio from sleeping and cutting off the 1st second of audio? Is there anyway to control the SPDIF volume with the volume control? I can only use the volume on my speakers for now and would like to use the keyboard volume keys.

#26
Innerz

Innerz

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 280 posts
Here a "generic" archive for the motherboard GA-965P-DS4 (rev.2 & rev.3.3)

Changes/Add from previous archive:

- Remove unnecessary kexts
- a compiled DSDT.aml with:
  • Marvell 8056 + Time Machine Fix (DSDT)
  • ALC888 (DSDT)
  • Reset BIOS Fix
  • UHCI/EHCI (Wake After Sleep Fix)
  • No GFX you have to add gfx string in com.apple.Boot.plist or use a .kext

Posted Image


Attached File  965p_ds4_Extra.zip   166.92KB   775 downloads

Enjoy ! ;)

#27
deckert

deckert

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
  • Gender:Not Telling

Here a "generic" archive for the motherboard GA-965P-DS4 (rev.2 & rev.3.3)

Changes/Add from previous archive:

- Remove unnecessary kexts
- a compiled DSDT.aml with:

  • Marvell 8056 + Time Machine Fix (DSDT)
  • ALC888 (DSDT)
  • Reset BIOS Fix
  • UHCI/EHCI (Wake After Sleep Fix)
  • No GFX you have to add gfx string in com.apple.Boot.plist or use a .kext

Posted Image


Attached File  965p_ds4_Extra.zip   166.92KB   775 downloads

Enjoy ! ;)


Would this work with the GA-965P-DS3P rev 3.3?

#28
Innerz

Innerz

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 280 posts

Would this work with the GA-965P-DS3P rev 3.3?



Yes i think the DSDT.aml should fit your configuration. The GA-965P-DS3P rev 3.3 is very close to the GA-965p-DS4, their chipsets are the same :

GA-965P-DS3P

GA-965P-DS4

You're lucky, i also have a 8800GTS 320Mo : My Attached File  DSDT.aml.zip   6.97KB   220 downloads
  • Marvell 8056 + Time Machine Fix (DSDT)
  • ALC888 (DSDT)
  • Reset BIOS Fix
  • UHCI/EHCI (Wake After Sleep Fix)
  • GeForce 8800 GTS 320Mo (DSDT)


#29
deckert

deckert

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
  • Gender:Not Telling

Yes i think the DSDT.aml should fit your configuration. The GA-965P-DS3P rev 3.3 is very close to the GA-965p-DS4, their chipsets are the same :

GA-965P-DS3P

GA-965P-DS4

You're lucky, i also have a 8800GTS 320Mo : My Attached File  DSDT.aml.zip   6.97KB   220 downloads

  • Marvell 8056 + Time Machine Fix (DSDT)
  • ALC888 (DSDT)
  • Reset BIOS Fix
  • UHCI/EHCI (Wake After Sleep Fix)
  • GeForce 8800 GTS 320Mo (DSDT)


Thanks, I'll give it a go and see what happens.
One thing, is quartz extreme working for you?
It was working in leopard until recently (don't know what I have done to kill it) now things like itunes coverflow don't work

EDIT nevermind got it working again, deleted my DSDT.aml are recreated it and quartz extreme is working again

#30
Innerz

Innerz

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 280 posts

One thing, is quartz extreme working for you?


Of course it's working. You can also test this DSDT.aml with Leopard.

#31
parkersmith

parkersmith

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts

Thanks, I'll give it a go and see what happens.
One thing, is quartz extreme working for you?
It was working in leopard until recently (don't know what I have done to kill it) now things like itunes coverflow don't work

EDIT nevermind got it working again, deleted my DSDT.aml are recreated it and quartz extreme is working again



Deckert,

Can you show me exactly what you have in your Extra/Extensions folder and attach a copy of your DSDT.aml file? I have the exact same setup as you with the 8800 GTS 640Mb. Everything is working on mine except the IDE ports. I cant seem to get the VIA drivers to load. I loaded the driver's from the post from Innerz, but I kept crashing on com.apple.driver.AppleHDAController and com.apple.iokit.Apple.Yukon2.

It all works on my drive with 10.5.8. I've tried using that DSDT.aml file and using the same contents of my Extra/Extensions folder, but no luck... Is your DSDT in root or the Extra folder?

Thanks,

Parker

#32
deckert

deckert

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
  • Gender:Not Telling

Deckert,

Can you show me exactly what you have in your Extra/Extensions folder and attach a copy of your DSDT.aml file? I have the exact same setup as you with the 8800 GTS 640Mb. Everything is working on mine except the IDE ports. I cant seem to get the VIA drivers to load. I loaded the driver's from the post from Innerz, but I kept crashing on com.apple.driver.AppleHDAController and com.apple.iokit.Apple.Yukon2.

It all works on my drive with 10.5.8. I've tried using that DSDT.aml file and using the same contents of my Extra/Extensions folder, but no luck... Is your DSDT in root or the Extra folder?

Thanks,

Parker


Hi, I am still using Leopard atm (haven't tried snow yet).
Not currently using any of the kexts Innerz posted
My DSDT.aml is in /Extra and is currently unmodified from what was generated by DSDT Patcher 1.0.1e
If you have the same motherboard as I do, the IDE port is controlled by the JMicron chip along with the two purple SATA ports, so you shouldn't need to load any VIA related kexts.
I don't use the IDE port at all so I don't know if it is working how my system is set up


/Extra
- DSDT.aml
- Extensions
- Extensions.mkext
- Themes
- com.apple.Boot.plist
- smbios.plist

/Extra/Extensions
- AHCIPortInjector.kext
- ATAPortInjector.kext
- AppleACPIButtons.kext
- AppleACPIEC.kext
- AppleACPILPC.kext
- AppleACPIPCI.kext
- AppleACPIPlatform.kext
- AppleACPIPowerSource.kext
- AppleAHCIPort.kext
- AppleDecrypt.kext
- ApplePCIConfigurator.kext
- Disabler.kext
- IOAHCIBlockStorage.kext
- IOAHCIBlockStorageInjector.kext
- IOAHCIFamily.kext
- IOAHCISerialATAPI.kext
- JMicronATA.kext
- JMicronATAInjector.kext

Attached Files



#33
parkersmith

parkersmith

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts

Hi, I am still using Leopard atm (haven't tried snow yet).
Not currently using any of the kexts Innerz posted
My DSDT.aml is in /Extra and is currently unmodified from what was generated by DSDT Patcher 1.0.1e
If you have the same motherboard as I do, the IDE port is controlled by the JMicron chip along with the two purple SATA ports, so you shouldn't need to load any VIA related kexts.
I don't use the IDE port at all so I don't know if it is working how my system is set up


/Extra
- DSDT.aml
- Extensions
- Extensions.mkext
- Themes
- com.apple.Boot.plist
- smbios.plist

/Extra/Extensions
- AHCIPortInjector.kext
- ATAPortInjector.kext
- AppleACPIButtons.kext
- AppleACPIEC.kext
- AppleACPILPC.kext
- AppleACPIPCI.kext
- AppleACPIPlatform.kext
- AppleACPIPowerSource.kext
- AppleAHCIPort.kext
- AppleDecrypt.kext
- ApplePCIConfigurator.kext
- Disabler.kext
- IOAHCIBlockStorage.kext
- IOAHCIBlockStorageInjector.kext
- IOAHCIFamily.kext
- IOAHCISerialATAPI.kext
- JMicronATA.kext
- JMicronATAInjector.kext


Thanks! That gives me something new to go investigate. Maybe the JMicron driver will do the trick.

#34
NeoZG

NeoZG

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
Hi,

Can't get audio to work using legacy kext as audio is 883, have to use voodoo kext. Tried compiling dsdt.aml at no avail. I've got 512mb on my gfx, is there a way to modify your attached dsdt to reflect this by recompiling it and changing a value in dsdt.dtl? I see nvidia values in there but not sure what to change under vram...? Can't run in 64bit mode as no drivers for atheros yet, so no wireless, bah. :)

Thanks,

#35
Slither2008

Slither2008

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 125 posts
  • Gender:Male
  • Location:Australia

Hi,

Can't get audio to work using legacy kext as audio is 883, have to use voodoo kext. Tried compiling dsdt.aml at no avail. I've got 512mb on my gfx, is there a way to modify your attached dsdt to reflect this by recompiling it and changing a value in dsdt.dtl? I see nvidia values in there but not sure what to change under vram...? Can't run in 64bit mode as no drivers for atheros yet, so no wireless, bah. :thumbsdown_anim:

Thanks,


Hi NeoZG,

I'm not expert on audio but I have dabbled with my GA-965P-S3, which also has an ALC883, and had great success.

Please try my patched audio kext pack. Please note that since you have a different mobo it's quite possible that our ALC883 chips don't have the same Pin configuration.

For Digital Surround: link

For Analog 7.1 Surround : link (Download and just use the 3 Legacy kexts from the /Extra/Extensions)

Regards,

Slither2008

#36
Space18

Space18

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
I have the same motherboard as u. Ga965p-DS4. Which bios version do u have on it?

#37
Innerz

Innerz

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 280 posts
@Space18 I don't know if you're talking to me, anyway... i'm using the last BIOS F12 for GA-965P-DS4 (rev.3.3).

#38
NeoZG

NeoZG

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts

Hi NeoZG,

I'm not expert on audio but I have dabbled with my GA-965P-S3, which also has an ALC883, and had great success.

Please try my patched audio kext pack. Please note that since you have a different mobo it's quite possible that our ALC883 chips don't have the same Pin configuration.

For Digital Surround: link

For Analog 7.1 Surround : link (Download and just use the 3 Legacy kexts from the /Extra/Extensions)

Regards,

Slither2008


You are my Hiro! ;)

Works great! Have it all configured. Used the hdef string of your dsdt and placed it into mine, as well as the three kexts.

The remaining issue I have is with the gfx. For some reason I was unable to create a dsdt for my card (no idea what framebuffer it uses) so I used one created for 8800 GTS 320MB. I have Core and Quarz but I am not too happy with the performance. Mind you it is not just about the MB but the architecture is supposed to be different as well.

The other thing is with my PIONEER DVD-RW DVR-215D. I can't burn a DVD successfully or a CD for that matter. I keep getting the 0x8002022 error. I tried changing the drive but same thing happens. It was the case on Leo and now the same thing in Snow. Tried everything, same thing happens in Toast. Any ideas?

Thanks,

Neo

#39
timdafweak

timdafweak

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 123 posts
  • Gender:Male
  • Location:New York

@Space18 I don't know if you're talking to me, anyway... i'm using the last BIOS F12 for GA-965P-DS4 (rev.3.3).


Many many thanks for your DSDT. It works like a charm!! Ethernet as well as Sound! Genius. Thank you m8!

#40
Innerz

Innerz

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 280 posts

Many many thanks for your DSDT. It works like a charm!! Ethernet as well as Sound! Genius. Thank you m8!


I'm glad I could help :)





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy