Jump to content

SMBIOS Final Cut Pro Fix


  • Please log in to reply
32 replies to this topic

#1
macwanabe

macwanabe

    InsanelyMac Protégé

  • Members
  • PipPip
  • 85 posts
Hi All

I am using Chameleon 2 with EFI 10.1 and SMBIOS.plist. Yet I still have the same error with Final Cut Pro and Log and Transfer crashing. I used to use Netkas SMBIOS and this fixed the problem no more crashes on Leopard. I tried the kext on Snow and it fixes the Log and transfer but then I get random kernel panics, so I am back with Snow SMBIOS and no log and transfer.

Does anyone know how to fix this with smbios.plist or do we need a new 10.6 SMBIOS patch.

Thanks

#2
dodusman

dodusman

    InsanelyMac Protégé

  • Members
  • Pip
  • 48 posts
hi

Have you qe/ci with your radeon 3870 ?

#3
macwanabe

macwanabe

    InsanelyMac Protégé

  • Members
  • PipPip
  • 85 posts
I am using 8800 GT for now 3870 does not work in Snow

#4
pipsvk

pipsvk

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts

Hi All

I am using Chameleon 2 with EFI 10.1 and SMBIOS.plist. Yet I still have the same error with Final Cut Pro and Log and Transfer crashing. I used to use Netkas SMBIOS and this fixed the problem no more crashes on Leopard. I tried the kext on Snow and it fixes the Log and transfer but then I get random kernel panics, so I am back with Snow SMBIOS and no log and transfer.

Does anyone know how to fix this with smbios.plist or do we need a new 10.6 SMBIOS patch.

Thanks



i have the same problem running on 10.6 snow leopard, on 10.5 the smbios patch worked like a charm but i just gave up after googleing for 6 hours to get it work and testing different smbios.kexts and plists but none worked i even disabled my audio but extensions repair in extra folder worked it out,

I dont know what to do, i have the same log and transfer crash it just quits without any error after selecting avchd folder (it's same with FCP2 and 3) i think we need new smbios kext patch for snow leo or something oh and btw the log gives this...
9/11/09 10:00:24 PM Final Cut Pro[287] -[NSProgressIndicator animationDelay] is deprecated.
9/11/09 10:00:24 PM [0x0-0x23023].com.apple.FinalCutPro[287] error: Error getting a reference to /options.
9/11/09 10:00:24 PM com.apple.launchd.peruser.501[81] ([0x0-0x23023].com.apple.FinalCutPro[287]) Exited with exit code: 1

and i know that when u delete AVCHD.Radplug from final cut pro package it will not crash but it wil not import the footage too

#5
macwanabe

macwanabe

    InsanelyMac Protégé

  • Members
  • PipPip
  • 85 posts
DVD player also quits when trying to lay a video_ts folder from a hard drive. I cannot believe that there is no general outcry for a fix for this, is it working for others? On Netkas site I am being ignored with no reply to my questions.

#6
pipsvk

pipsvk

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts
if u find a solution write in this thread i will do the same, maybe if we bump this enough it will be noticed by someone who can do something. just don't spam.

#7
sucosaigon

sucosaigon

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts

if u find a solution write in this thread i will do the same, maybe if we bump this enough it will be noticed by someone who can do something. just don't spam.



I have the same problem if I use 64 bit kernel, but work well in 32bit. Do you guys use 32 or 64bit kernel?

#8
pipsvk

pipsvk

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts

I have the same problem if I use 64 bit kernel, but work well in 32bit. Do you guys use 32 or 64bit kernel?


i use 64bit kernel and everything is working in 64 except final cut :P i did not try the x32 but i guess macwanabe is using 64 too

#9
MacProUser83

MacProUser83

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 142 posts
  • Gender:Male
  • Location:::1
Why oh why is people OBSESSED with booting the 64bit kernel?? You dont need it yet. Its on early development stages anyway. Not even iphone USB tethering works in 64 bit.

#10
rest assured son

rest assured son

    InsanelyMac Protégé

  • Members
  • PipPip
  • 93 posts

Why oh why is people OBSESSED with booting the 64bit kernel??


They are uninformed. They dont realize that you need 32 gb of ram the REAL performance of 64-bit comes into fruition. That is why the only Macs that use 64 bit right now are Xserve servers (the ones that actually use 32gb of ram!).

Its on early development stages anyway.


No, its in Xserve Servers, that would mean that it is released and not in development stage.

#11
pipsvk

pipsvk

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts

They are uninformed. They dont realize that you need 32 gb of ram the REAL performance of 64-bit comes into fruition. That is why the only Macs that use 64 bit right now are Xserve servers (the ones that actually use 32gb of ram!).


No, its in Xserve Servers, that would mean that it is released and not in development stage.


booted to x32 nothing changed, i dont know what i need to do if i need old plist or smbios.kext but its quitting on log&transfer

#12
YoMuS

YoMuS

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 199 posts
  • Location:Valencia
I solved the DVD Player crashes when loading VIDEO_TS folders by using chameleon 2 rc1 and netkas pc_efi 10.1.

Don't know if it'll solve the FCP problem, though.

#13
macwanabe

macwanabe

    InsanelyMac Protégé

  • Members
  • PipPip
  • 85 posts
I am using 32 bit , because I need it for my 32 bit drivers, Sil3132. I have used Chameleon 2 RC2 and netkas pc_efi 10.1. and have crashes will try with RC1 and see if this helps.

Thanks

#14
sucosaigon

sucosaigon

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
hey macwanabe,

how about this! I used chameleon rc2 but don't remember which "boot' is used. I never use DSDT, run vanilla, and only have fakesmc and openhalrestart. kexts in E/extensions folder. Try to use my smbios,kext. also use kext utilities to fix permissions and then place a new extensions.mkext in Extra folder too. Good luck.Attached File  AppleSMBIOS.kext.zip   34.07KB   128 downloads

#15
macwanabe

macwanabe

    InsanelyMac Protégé

  • Members
  • PipPip
  • 85 posts
Hi I tried but Final Cut still crashes. Using Chameleon 2 RC3 now, I get less kernel panics with RC3 compared to EFI 10.1, with EFI I get mds kernel panics from time to time. Could you perhaps upload your boot file for me to test?

#16
sucosaigon

sucosaigon

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
this is what i use.

Attached Files

  • Attached File  boot.zip   195.81KB   41 downloads


#17
BLARGiAMdEAD

BLARGiAMdEAD

    InsanelyMac Protégé

  • Members
  • Pip
  • 49 posts
I get the DVD Player bug too. I know that my Final Cut Express (not pro) crashes on startup, but I think that's because I just coy-and-pasted the .app from my laptop...

I'm kind of a noob at this, so I'd rather not go screwing up my chameleon and booting stuff, because I just got the machine to actually boot reliably...

#18
dacodo

dacodo

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
  • Gender:Male
I too was using an early RC of Chameleon. I was having all sorts of KP's and FCP would crash on launch. I did a reinstall and transfer of all my files from a time machine backup using Chameleon 2 RC3. and It's all working in 64bit now (other than onboard sound, using USB).

---------
Mini 9 | 1.6GHz Atom | 2GB RAM | 16GB RunCore SSD + 16GB SDHC | OSX 10.6.1 | Apple Airport Wireless-N |
G4 Case | 2.5GHz Core 2 Duo | GA-G31M-ES2L | 4GB RAM | 1.5TB | GeForce 9800 GT+ 512MB | OSX 10.6.1 |

#19
macwanabe

macwanabe

    InsanelyMac Protégé

  • Members
  • PipPip
  • 85 posts
Ok so I decided to try with my onboard ICH9 controller and 64 bit, I have two Sil3132 controllers to add 4 extra SATA ports to my system, I used to use them for my system drive because even after point upgrades I would not need to worry about waiting for root device. Thats why I have only been using it in 32 bits.

Surprise, Final Cut Log and Transfer work in 64 bit kernel and not with 32 bit kernel. This is with Chameleon RC3 and the latest EFI from netkas. Is there something wrong with the 32 bit SMBIOS implementation or is it the SIL 3132 driver? Yet it works perfectly under Leopard.

#20
pipsvk

pipsvk

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts

Ok so I decided to try with my onboard ICH9 controller and 64 bit, I have two Sil3132 controllers to add 4 extra SATA ports to my system, I used to use them for my system drive because even after point upgrades I would not need to worry about waiting for root device. Thats why I have only been using it in 32 bits.

Surprise, Final Cut Log and Transfer work in 64 bit kernel and not with 32 bit kernel. This is with Chameleon RC3 and the latest EFI from netkas. Is there something wrong with the 32 bit SMBIOS implementation or is it the SIL 3132 driver? Yet it works perfectly under Leopard.



WHAT? how to hell did u get it to work? i think im using the same config as you still cant run log&transfer, can you get me your's smbios.plist smbios.kext or something that could be related to it? i really need to get it working, please :(





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2017 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy