Jump to content

[AMD] Installing Snow Leopard 10A432 on AMD System


  • Please log in to reply
181 replies to this topic

#21
TrueMagnum

TrueMagnum

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts
Thanks for all the help as I got my AMD laptop booting snow leopard.

For some reason I can't get any of my kexts that i used on my previous 10.5.2 install to work.

(sound, wifi, trackpad & keyboard, native graphics, internal drives)

Would there be any reason that none of them would work correctly?

#22
CrimsonAngel

CrimsonAngel

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 103 posts
  • Gender:Male

its look like the boot file ir wrong... are you sure u have replace the boot file?



what is your chipset.. if you have AHCI mode.. use AHCI mode..
if not.. use your chipset driver from leo..


for nForceATA user you can try : this

you canplace it in E/E or S/L/E

I have an nforce chipset asus a8n-sli mobo Ill give this a whirl in a little bit.
I was just wondering though If you could give me a little help with the DSDT
Every time I try compiling it fails.
I think it is because of the underscore before NVRAIDBUS which when I remove I only get 4 warnings Instead of an error and 4 warnings
Here is the DSDT File I force compiled

Attached Files



#23
chris928cn

chris928cn

    InsanelyMac Protégé

  • Members
  • Pip
  • 14 posts
THX ,now I have some problem, itune can't work in cover flow mode
My graphic card is Nv8600GT,I had add EFI string in com.apple.boot.plist,screen saver work,so any idea?
I didn't use DSDT.aml
marvin's amd tool didn't work very well,so I can't patch the system,anybody send the cpuid.txt if the tool worked on your system?

#24
arya

arya

    InsanelyMac Protégé

  • Members
  • PipPip
  • 65 posts
  • Gender:Male
  • Location:Indonesia

THX ,now I have some problem, itune can't work in cover flow mode
My graphic card is Nv8600GT,I had add EFI string in com.apple.boot.plist,screen saver work,so any idea?
I didn't use DSDT.aml
marvin's amd tool didn't work very well,so I can't patch the system,anybody send the cpuid.txt if the tool worked on your system?



you have to tun marvin on your snow/ you cant do it in leopard with voodoo kernel installed.

first you need to create patcher package this will make u have the cpuid. the 2nd step is patch all cpuid with cpuid file.

if you still cant do it.. let me know i will send the patched file...

I have an nforce chipset asus a8n-sli mobo Ill give this a whirl in a little bit.
I was just wondering though If you could give me a little help with the DSDT
Every time I try compiling it fails.
I think it is because of the underscore before NVRAIDBUS which when I remove I only get 4 warnings Instead of an error and 4 warnings
Here is the DSDT File I force compiled


try this :

Attached Files



#25
chris928cn

chris928cn

    InsanelyMac Protégé

  • Members
  • Pip
  • 14 posts
I tried but got error in snow too

#26
CrimsonAngel

CrimsonAngel

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 103 posts
  • Gender:Male
omg it worked,
Im typing this message in snow leopard right now.
However I am having two problems.

one my graphics.
I entered my graphics card info into the DSDT why didn't it work?
im stuck at 1024x768 and no QE

Two my internet.
it seems to be running a little slow but that can be caused by the graphics I think.

#27
arya

arya

    InsanelyMac Protégé

  • Members
  • PipPip
  • 65 posts
  • Gender:Male
  • Location:Indonesia

omg it worked,
Im typing this message in snow leopard right now.
However I am having two problems.

one my graphics.
I entered my graphics card info into the DSDT why didn't it work?
im stuck at 1024x768 and no QE

Two my internet.
it seems to be running a little slow but that can be caused by the graphics I think.


good to hear its work.. may be u can use efi string for your NVIDIA card.

or you can use injector from your leopard.....

#28
CrimsonAngel

CrimsonAngel

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 103 posts
  • Gender:Male

good to hear its work.. may be u can use efi string for your NVIDIA card.

or you can use injector from your leopard.....

Well I got the graphics working good but the internet is still dragging quite bad. Im using a netgear ethernet card because on leopard the built in nforce ethernet had problems running.

#29
maya77

maya77

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 108 posts

Has anybody had any luck using the Voodoo kernel instead?

Voodoo (based) kernels will not work on SL.

I've tried them all from 9.5.0 to 9.8.0 and none of them works (Voodoo, AnV, qoopz).

There are few AMD kernels for SL currently available but only Modbin's test7 works for me. Dmitrik's kernel and other Modbin kernels does not work on 432.

Be noted that all these are actually patched Vanilla binaries, NOT built from sources. This means there is no on-the-fly opcode patching for AMD implemented, no 64-bit support, no TSC patch, etc...

So SL will work on AMD but you'll experience several problems until someone make better kernel.

I entered my graphics card info into the DSDT

Is there some tutorial on how to add Graphic card info into DSDT to avoid EFI strings in com.apple.boot or injectors?

Two my internet.
it seems to be running a little slow

Same problem here.

No problems with my 8800GT but internet is definitely slower. I think it has something with the bad kernel.

#30
CrimsonAngel

CrimsonAngel

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 103 posts
  • Gender:Male

Voodoo (based) kernels will not work on SL.

I've tried them all from 9.5.0 to 9.8.0 and none of them works (Voodoo, AnV, qoopz).

There are few AMD kernels for SL currently available but only Modbin's test7 works for me. Dmitrik's kernel and other Modbin kernels does not work on 432.

Be noted that all these are actually patched Vanilla binaries, NOT built from sources. This means there is no on-the-fly opcode patching for AMD implemented, no 64-bit support, no TSC patch, etc...

So SL will work on AMD but you'll experience several problems until someone make better kernel.

Is there some tutorial on how to add Graphic card info into DSDT to avoid EFI strings in com.apple.boot or injectors?

Same problem here.

No problems with my 8800GT but internet is definitely slower. I think it has something with the bad kernel.


Well I can definitely confirm the internet is slower MUCH slower.
just ran a speed test
20 ping d/l speed .73 Mb/s u/l speed .78 Mb/s
Normally I get
6 ping d/l speed 9 Mb/s u/l speed 3 Mb/s
under leopard and windows

Also I noticed problems with programs like VLC, movies will just freeze out of nowhere and then the program will freeze. I believe this is caused, like you said by not having on-the-fly opcode patching which can probably be fixed by using Marvin's AMD utility. I really hope a new kernel is released soon.

Also you asked on a tutorial on how to add graphics card info into the DSDT. I don't have the link on hand but heres the PDF

Attached Files



#31
g_h

g_h

    InsanelyMac Protégé

  • Members
  • Pip
  • 40 posts
NoGo on an Asus M2A32-MVP.
Hi - did the installation on a clean disk (with chameleon RC2.640, replaced "boot", and test7-kernel).
Very early I get:

**/dev/rdisk0s3
Can't initialize disk cache
/dev/rdisk0s3 (hfs) EXITED WITH SIGNAL 8

I get the same error when I boot into single user and do a "fsck".

Mobo: Asus M2A32-MVP de luxe (SB600)
10.5.6 is running fine here.....

any idea - apart from "switch to Intel" (which I might do sooner or later..)
G.H.

#32
CrimsonAngel

CrimsonAngel

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 103 posts
  • Gender:Male
I have another problem that I didn't post yet, when I try to repair permissions with disc utility i get the error.
"error: no installer packages can be found for this disc"

#33
arya

arya

    InsanelyMac Protégé

  • Members
  • PipPip
  • 65 posts
  • Gender:Male
  • Location:Indonesia

I have another problem that I didn't post yet, when I try to repair permissions with disc utility i get the error.
"error: no installer packages can be found for this disc"


yes this is a common problem if you installed from leo.. just mount the installer disk and install BSD.pkg it will fix the repair permission in disk utility..

location : /Volumes/Mac OS X Install DVD/System/Installation/Packages/BSD.pkg

you dont get this err if you installed from a working snow... lol

#34
CrimsonAngel

CrimsonAngel

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 103 posts
  • Gender:Male

yes this is a common problem if you installed from leo.. just mount the installer disk and install BSD.pkg it will fix the repair permission in disk utility..

location : /Volumes/Mac OS X Install DVD/System/Installation/Packages/BSD.pkg

you dont get this err if you installed from a working snow... lol

well i have done this and repaired permissions, but it took only about 15 seconds and at the end there were no permissions that need repairing. Is that strange?

#35
arya

arya

    InsanelyMac Protégé

  • Members
  • PipPip
  • 65 posts
  • Gender:Male
  • Location:Indonesia
nope is not strange... as i read the repair permission is not touching S/L/E anymore.. so we must be careful when installing kext to S/L/E i prefer to put extra kext in /E/E/

#36
CrimsonAngel

CrimsonAngel

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 103 posts
  • Gender:Male
another thing is that none of my video will play in quicktime player X. it says it cannot be opened because it isn't a format that quicktime player understands.

Also VLC player will play a video for a few minutes and then the video will freeze and audio will continue playing.

#37
arathur

arathur

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
@ arya:

"its look like the boot file ir wrong... are you sure u have replace the boot file?"

I did replace the boot file. Anyways, I ran the Chameleon RC2 r640 installer again, and then replaced the boot file again. Now, whenever I try to boot into Snow Leopard, instead of a kernel panic, the computer reboots right away. Every time I try to go to Snow Leopard now, it reboots.

#38
noob766

noob766

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 367 posts
what boot file did you use in this ayra? because it is able to boot the retail dvd

#39
arya

arya

    InsanelyMac Protégé

  • Members
  • PipPip
  • 65 posts
  • Gender:Male
  • Location:Indonesia

what boot file did you use in this ayra? because it is able to boot the retail dvd


i got it from modbin... i have try to use it to boot installer using this boot file and is work... i m gonna try to make clean install without using my my leopard...... :(

i dont know what boot is that.. but its work for me...

#40
spammon

spammon

    InsanelyMac Protégé

  • Members
  • PipPip
  • 91 posts
  • Gender:Male

Does this guide can help others, that aren't on AMD, but with no core2 processors, like me with a Pentium D 920?


I can confirm that this method worked for me on a non-AMD system. I have two systems, one that can run Vanilla and one that could not. The 945GZ platform is unable to use the vanilla preboot at this time.

Note: I cannot get 64bit with this kernel. I personally prefer the 32bit kernel but anyone who is looking to go 64bit will have to wait until another kernel or method is released.

MB: ECS 945GZT-M v1.0
CPU: 1.8 Ghz Pentium Dual-Core E2160
GPU: 512 Mbyte nVidia 9400GT
RAM: 2 Gbytes
Drives: 80gb SATA, 80gb PATA, DVD+RW PATA





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy