Jump to content

GA-G31M-S2L


  • Please log in to reply
32 replies to this topic

#21
ricky_kid

ricky_kid

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
I have the same board (the g31m-S2L) and have followed the same procedure for installing. However, I am having network issues. Is your networking all right? And what version of the bios are you using? (I have a suspicion that a newer bios version may fix the network problem I have, since I have the F2 version and it seems to be a very low level problem.)

#22
ricky_kid

ricky_kid

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
I just wanna throw out there that the dsdt.aml included in the zip file in post 10 also contains Firewire and presumably something to help with my network problem as well. (It still goes wonky in 64 bit kernel mode, but who needs that? Apps still run in 64 so I don't see the need!) Thanks for sharing!

#23
King Leper

King Leper

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts
Does anyone have sound working in 64 bit mode? I have tried voodooHDA 64 bit and I get a sound icon, but no sound is actually played. I have tried the Gigabyte ALC662 kexts in and the ones mentioned in post 10 both in 32 and 64 bit mode. (The DSDT in post 10 simply causes my GA-G31M-S2L to kernel panic on boot). I see a lot of people having both success and failures trying to get sound on this board in snow leopard, anyone have any suggestions?

#24
excitedguy

excitedguy

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts

Does anyone have sound working in 64 bit mode? I have tried voodooHDA 64 bit and I get a sound icon, but no sound is actually played. I have tried the Gigabyte ALC662 kexts in and the ones mentioned in post 10 both in 32 and 64 bit mode. (The DSDT in post 10 simply causes my GA-G31M-S2L to kernel panic on boot). I see a lot of people having both success and failures trying to get sound on this board in snow leopard, anyone have any suggestions?


The kext works great, however I cannot mute, anyone know how to fix this?

#25
demented_angel

demented_angel

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
I've tried the aforementioned process of installing the ALC662.Kext; However, It will not function.

I'm using a Asus P5KPL-AM/PS board, Intel E5200, Geforce 8400GS

any light on this situation would be greatly appreciated.

edit: I get a KP at appleHDA.kext

#26
redfez

redfez

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 110 posts
ever tried this?:
http://www.insanelym...p;#entry1310628

nothing worked for me
maybe updating bios will fix it

#27
Pietruszka

Pietruszka

    InsanelyMac Protégé

  • Members
  • PipPip
  • 98 posts
  • Gender:Male

I am also running this board as a second system. Try the attached zip file. Replace your dsdt.dsl in /Extra with the one in the zip file and put the ALC662.kext in /Extra/Extensions. Rebuild the Extensions.mkext in /Extra (if your using Chameleon 2).



this kext doesn't work after 10.6.2 update :laser:

any updated version of this kext????

#28
The-F

The-F

    InsanelyMac Protégé

  • Donators
  • 14 posts
  • Gender:Male
  • Location:Japan
Yes, not work anymore. Is there any update?

#29
H-kon

H-kon

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
I got the same board with an E8400, 2GB with the F6 bios and did a clean install with Chamelion RC4 and the retail dvd. Everything works, even the onboard graphics in 64-bit mode except for sound. (only1024 though). Got an ATI HD4650 available that i can try, but i am not sure if i can install this card after the install of OS 10.6.

Any hope?

I also got a G41M-ES2L board. Is this a better board for running Snow?

Could anyone point me to any guides with regards to dsdt etc. I have no clue what this is or what i should do to after the install process so that i can f.ex boot from the HD.

#30
iTux

iTux

    InsanelyMac Protégé

  • Members
  • PipPip
  • 60 posts
Anybody know? how to up gma x3100

#31
nyolc8

nyolc8

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 802 posts
  • Gender:Male
  • Location:Budapest, Hungary

The kext works great, however I cannot mute, anyone know how to fix this?

Is there any fix for this mute problem? :)

#32
tomasd1

tomasd1

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
ive updated mac osx to version 10.6.4...and in 32 bit version i can get sound working when istalling Alc 662 package... ive recently noticed that it was running in 32 bit mode so when using utlity called "macpilot" i just click there to set it to 64 bit mode...
then my audio stops working and the audio icon is "grey"..... i tried multiple kexts (that are labeled Green"...
in Leopard version i was using Voodoo HDA to get sound working..
in snow leopard .. i was using .... azalia audio pkg.... to get it to work.... (only works for me in 32 bit mode)
so please if anyone knows how to get it to work...and helps me out i would be really thankfull


im using:
G31 MX motherboard with intergrated sound ..i belive its ALC 662.. (at least on official web page specications says so) (from FOXCONN)
everything else is working great... and 32 bit mode was flawless (except i had audio onlly output 2 chanell stereo)

i also have a : sound blaster x fi extreme music ...inside computer.... but i read nothing about getting it to work.... in windows that was easy to make it work....
i would rather see soundblaster x fi working....but i would be more then happy if we could get to work on board audio

much appriciated..please help me out... i will be always gratefull

computer : core 2 duo 2.33 ghz 4mb cache
foxconn g31 mx
nvidia gt 240 1 GB DDR 3
1.5 T hard drive
2 GB Ram 800 Mhz
original apple keyboard
Dual Monitors with Full HD
sound : ALC 662 (in leopard working with voodoo hda) in snow leopard 32 bit working with : AzaliaAudio.pkg / but no sound in 64 bit mode

i have all the tools like : OSX 86 tools or UI installer or kext helper ...or kext utility 64 bit version......
i can upload any screen shot or anything..just please help me get to fix the sound..


thank you for all the answers.... best wishes

#33
MaLd0n

MaLd0n

    ...filling veins with juice of chaos...

  • Moderators
  • 11,141 posts
  • Gender:Male
  • Location:Rio de Janeiro
http://www.insanelym...howtopic=235523





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2015 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy