Jump to content

Atheros AR8131/AR8132


  • Please log in to reply
314 replies to this topic

#161
jbronstein

jbronstein

    InsanelyMac Protégé

  • Members
  • Pip
  • 24 posts
15 minute working without any trouble, using the "release" kext in my Asus 1201N, great job reader02!!!! Im very grateful! THANKS!

#162
reader02

reader02

    InsanelyMac Protégé

  • Members
  • PipPip
  • 63 posts

can someone help me instal the kext with some instructions im am currently on iatkos v7 10.5.7
(soon to be snow leopard reatail) please and thank you


about leopard 10.5.x , i havn't build environment.
please download the source from svn ,and build it to 32-bit by XCODE.

#163
ajuzzzz

ajuzzzz

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
hahahh

it works.......ive been waiting for this for a long time..
reader02 your my thunder......!!!!!! Thanks so much

#164
reader02

reader02

    InsanelyMac Protégé

  • Members
  • PipPip
  • 63 posts

I got an issue...the ethernet was not working after wakeup my laptop from sleep.


try slove sleep issue.

Attached Files



#165
jinnggoff

jinnggoff

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 133 posts
  • Gender:Male
  • Location:hackintosh

try slove sleep issue.

Thank you, you are the legend :P ....Works great here. After wakeup from sleep, the ethernet is working great :D :D

#166
doabit

doabit

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 6 posts

try slove sleep issue.

Thank you very much for your work! my asus n61 can work fine! thank you!

#167
asstastic

asstastic

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 318 posts
  • Gender:Male
  • Location:Austin, TX
Kext works fine so far. no noticeable errors in 30mn of use.

try slove sleep issue.



#168
catimimi

catimimi

    InsanelyMac Protégé

  • Members
  • Pip
  • 33 posts

about leopard 10.5.x , i havn't build environment.
please download the source from svn ,and build it to 32-bit by XCODE.

OK, I'll try to do that, it will be my first build with XCODE.
But which svn ?
Regards.
Michel

#169
reader02

reader02

    InsanelyMac Protégé

  • Members
  • PipPip
  • 63 posts

Thank you, you are the legend :thumbsup_anim: ....Works great here. After wakeup from sleep, the ethernet is working great :D :D

to jinnggoff:
Thank you again and again to test, and the result is frustrating. I almost give up, if you are not so diligent submit the log.

Of course also thank others, guaIni ,td524, wolodya , asstastic.
this cooperation is very pleasant, although the failure of too many times.

OK, I'll try to do that, it will be my first build with XCODE.
But which svn ?


http://iats.googleco...trunk/sl/atl1c/

#170
guaIni

guaIni

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
Thank you very much reader02, the driver fully working. My System using 32 bit Debug version compilled from Xcode, My laptop connect to cable network not stopped after several minutes. In first reboot the driver must load manually, but after next reboot the driver loaded automaticcally. Sorry If my english not good :D

#171
joemix

joemix

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
Thanks reader02, your kext works great on my Compaq mini CQ10-110SL.

#172
pincopanco

pincopanco

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 265 posts
thx !!!
aspire one d250 work :thumbsup_anim:

#173
td524

td524

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts

to jinnggoff:
Thank you again and again to test, and the result is frustrating. I almost give up, if you are not so diligent submit the log.

Of course also thank others, guaIni ,td524, wolodya , asstastic.
this cooperation is very pleasant, although the failure of too many times.



http://iats.googleco...trunk/sl/atl1c/


Thanks reader02, It is successful!!!

In addition to AR8131, I have a wireless card AR9285 (10.6.3)
Will the wireless and wired network card debug difference big?
I am only a little programming base, but I want to debug wireless kext, it is very difficult?
Please give me some suggestions and I'm appreciated.

#174
VFR_Pilot

VFR_Pilot

    InsanelyMac Protégé

  • Members
  • PipPip
  • 59 posts
  • Gender:Male

to jinnggoff:
Thank you again and again to test, and the result is frustrating. I almost give up, if you are not so diligent submit the log.

Of course also thank others, guaIni ,td524, wolodya , asstastic.
this cooperation is very pleasant, although the failure of too many times.


reader02, that's absolutely brilliant. I honestly believed I'd never see a working Ethernet on my 1005HA, but you worked some serious magic. Congratulations on your success and I'm happy to add my voice to all those who have expressed their appreciation for a truly great effort. It works perfectly.

My EEE MacBook Mini is complete. :thumbsup_anim:

All the best dude!

#175
catimimi

catimimi

    InsanelyMac Protégé

  • Members
  • Pip
  • 33 posts
@reader02

Hello,

I've installed xcode3.1 on my leopard system and tried to build atl1c.
I get 641 errors and 119 warnings. A lot of them are due to "unsupported architecture", it seems thet __i386__ is not defined but when I redefine it I'm told that it is already defined.

I'm ready to give up, any idea ?

Regards.
Michel.

Continued :

1 - I declared __i386__ in all the .cpp files
2 - there is a problem in libkern.h which I solved by forcing __i386__ inside
3 - Now I get only 2 errors for each cpp file :

- cast from 'queue_entry' to 'integer_t' loses precision -> in queue.h:235
- size of array '__NEED_TO_CHANGE_CAST_DOWN' is negative -> vm_param.h:230

Can you help me to solve these two remaining errors ?

Thanks.
Michel.

#176
maggico

maggico

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts
Outstanding job, reader02! Thank you so much for you extraordinary effort! I am writing from my Macbook 1101HA using ethernet adapter AR8132! :-)



try slove sleep issue.



#177
ms37

ms37

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts

@reader02

Hello,

I've installed xcode3.1 on my leopard system and tried to build atl1c.
I get 641 errors and 119 warnings. A lot of them are due to "unsupported architecture", it seems thet __i386__ is not defined but when I redefine it I'm told that it is already defined.

I'm ready to give up, any idea ?

Regards.
Michel.


First, thank you very much reader02 and others who achieved such a great kext!
I'm using the x64 version of the kext posted #102 on hp mini 110(AR8132, 1969, 1062) without errors.
It works even after sleep.

I also tried to build the kext from the source.
When I compile with 10.6 i386 environment on Snow Leopard, I could build without errors.
However, compiling with 10.5 i386 environment either on Snow leopard(10.6.0) or Leopard(10.5.6) fails.
I'm sorry but I can't remember the version of XCode I used.

Looking at the error messages, it seems that errors come from IO80211 things.
If I remember correctly, the IO80211Family.kext chenged drastically after 10.5.8 and 10.6.0.
So, there may be a chance with 10.5.8 environment. Excuse me if I'm wrong.

Thanks, again,

Smith

#178
catimimi

catimimi

    InsanelyMac Protégé

  • Members
  • Pip
  • 33 posts

First, thank you very much reader02 and others who achieved such a great kext!
I'm using the x64 version of the kext posted #102 on hp mini 110(AR8132, 1969, 1062) without errors.
It works even after sleep.

I also tried to build the kext from the source.
When I compile with 10.6 i386 environment on Snow Leopard, I could build without errors.
However, compiling with 10.5 i386 environment either on Snow leopard(10.6.0) or Leopard(10.5.6) fails.
I'm sorry but I can't remember the version of XCode I used.

Looking at the error messages, it seems that errors come from IO80211 things.
If I remember correctly, the IO80211Family.kext chenged drastically after 10.5.8 and 10.6.0.
So, there may be a chance with 10.5.8 environment. Excuse me if I'm wrong.

Thanks, again,

Smith


Thanks, have a look at my modified post, two errors are remaining while compiling the module sources.

Michel.

#179
eric76

eric76

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 275 posts
  • Gender:Male
Bravo reader02 !!!

excellent job, the respect !!! :(

FRenchv

#180
reader02

reader02

    InsanelyMac Protégé

  • Members
  • PipPip
  • 63 posts

1 - I declared __i386__ in all the .cpp files
2 - there is a problem in libkern.h which I solved by forcing __i386__ inside
3 - Now I get only 2 errors for each cpp file :

- cast from 'queue_entry' to 'integer_t' loses precision -> in queue.h:235
- size of array '__NEED_TO_CHANGE_CAST_DOWN' is negative -> vm_param.h:230

Can you help me to solve these two remaining errors ?


xcode project file is different for leopard .
replace the project file , and try again.

Attached Files







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy