Jump to content

[Guide] Vanilla Retail 10.6.x with Chameleon v2 for Gigabyte GA-EP45-DS3L


  • Please log in to reply
3675 replies to this topic

#3581
blackosx

blackosx

    InsanelyMacaholic

  • Coders
  • 3,054 posts
  • Gender:Male
  • Location:UK

Don't get too much sun!

Lol. Don't worry. There's no too much of it over here in England. :blink:

We don't want you to fry your hackintosh brain! We need your brain to help us! LOL

.
You could all still happily run your rigs without me here.. All I do is read, test and collate all relevant info from around the scene and pass it on here.

I just upgraded to 10.6.8... Up until now my board was immune to the no sound issues after system upgrades as it has ALC889a... well the board has no sound after the 10.6.8 upgrade!

Tmongkol's thread has that answered for you.

System seems to be running a little faster.

Yes. I agree with that.

Blackosx, I tried using the terminal command diskutil list, and it does not show the usb drive. I don't know why it comes up in the system profiler though. Everything was perfect on 10.6.7.
My keyboard and mouse still work. I tried the atheros fix from 10.6.7 from netkas' website, but that didn't seem to do the trick.
When I boot with my network card in, the computer still operates very very slow and sluggish. The airport is showing as active but says "The status of your wireless connection is unknown.

Hi pane2k

hmmm. It's not looking good for you. Looks like something didn't go right with the update.

Maybe I should try reinstalling the 10.6.8 combo?
Also, I'm using a really old version of Chameleon 2.0 rc3 I think. Could these two things have anything to do with it?

Yes.
Maybe - but I would definitely upgrade to the latest Chameleon.

I have a time machine backup, if I can't solve the problem I may just restore from time machine, that is..if I can get my usb ports to work when I use a boot cd with a 10.6. disk.

Lol.. Hopefully that will work.
Failing that. Create a small partition at the end of your HDD, an re-install Snow Leopard to that from your retail DVD. It might only be 10.6.0 or 10.6.3 but at least you will able to test if the USB drives mount in that. If they do then maybe update that to 10.6.8 and see what happens (using the combo updater). But like I say with every point update - Always apply it first to a secondary OS X installation on your machine before running against your main system. This gives you a chance to test it out and see if you have any hardware issues etc.

Just wanted to drop a quick thank you to BOSX, you are a gentlemen and a scholar. After the 10.6.8 update my usual method of getting sound back by restoring the old AppleHDA.kext from Time Machine didn't work so I followed your guide in an earlier post about patching AppleHDA etc....and low and behold sound is back and better than ever.

Hi JC

Thank you for the kind words and I am happy to know that cparms audio solution posted here helped you out. It worked again for me also with the Lion GM release.

10.6.8 brought dual monitor support for my HIS ATI HD4760 (been waiting a long time for that) now my machine actually sleeps (well atleast with a standard hardrive).

Did it? Cool. I only have one screen here so can only dream of that..

For some reason sleep doesn't work with my Crucial C300 SSD. But no way I would trade sleep for the speed I get with my drive.

Strange. Did your mahcine sleep with 10.6.7 with the Crucial SSD?

Anyway Thanks again Black for sharing your knowledge with the rest of us. It is much appreciated.

YW. But like I said to Johnny V - I'm just sharing info which I've read from the real hero's in this game :(

Enjoy

#3582
muitommy

muitommy

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 737 posts
  • Interests:Piano x Mac OS X
I have installed a lion GM fresh install and I can say it's working really great! A lot responsive.

Haven't yet try to install it on my main install, few issues need to be sorted out:

- Not sure how it works on raid install (i suppose it's okay as long as chameleon supports it)
- the audio layout in lion, mine is ALC888, i used the cparm's method, but can't get the same layout as I did in SL, that utilize all the front panel and digital audio.
- my Qnap server hasn't updated to support time machine in lion.

I will report the progress soon. Any help would be appreciated. :P

#3583
BatcOuntrY

BatcOuntrY

    InsanelyMac Protégé

  • Validating
  • PipPip
  • 96 posts
  • Gender:Male
  • Location:Los Angeles

Strange. Did your mahcine sleep with 10.6.7 with the Crucial SSD?

Enjoy


I never tried with 10.6.7 cuz my 4670 didn't sleep so no use trying. 10.6.8 fixed that so then I tried sleep on my Cloned system which has a laptop hard drive and sleep worked perfectly. Then I tried it on the SSD system, and I thought it worked, but when I woke from sleep the computer rebooted instead. Oh well no biggie I'll hunt around and see if anyone else is having that issue.

#3584
muitommy

muitommy

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 737 posts
  • Interests:Piano x Mac OS X
Report for reference:

After 1 day of trying, my lion is finally up. Now it's running in a raid install, superb fast!

Some info for ALC888 user:
1. dsdt seems not a must for the sound (i'm using catri bios, not sure if it's related)
all i need to do is patch the applehda according to blackosx's link which link to cparm's method.
There is a deficient of this method, which is no headphone support, all appear to be line out.
Oh but hang on, I remove the legacyhda from the S/L/E, and use the legacyhda provided by targua dropping it in E/E,
and now it works with speaker + line out + headphone + digital out. I'm happy now, I attached my legacyhda for others' convenience.

Attached Files



#3585
blackosx

blackosx

    InsanelyMacaholic

  • Coders
  • 3,054 posts
  • Gender:Male
  • Location:UK
Hi muitommy

Thanks for sharing your findings. Good work. I'll try your recommendation later.

I only use line out to my stereo speakers so have never looked at what else was supported with the method cparm posted. I was just happy to have sound out :unsure:

----------------------------------

Something I've just learned and worth keeping an eye out for is a recent change to Chameleon.

/Extra/org.chameleon.Boot.plist

As of commit 1105, /Extra/com.apple.Boot.plist will now be known as /Extra/org.chameleon.Boot.plist.

EDIT:
There are more changes to come too so anybody testing the latest builds of Chameleon will need to read the CHANGES file in the source.

#3586
muitommy

muitommy

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 737 posts
  • Interests:Piano x Mac OS X
hey blackosx,

I struggle a lot for the headphone and hesitate from updating. cparm method just didn't tackle the prob of output at all, i really have a hard time to testing this out, reboot and reboot ..... but right now, it's good.

safari is just blinking fast! i hope it works well, so i can drop chrome. Safari is still the perfect match with mac.

#3587
blackosx

blackosx

    InsanelyMacaholic

  • Coders
  • 3,054 posts
  • Gender:Male
  • Location:UK
Well done. It's a sweet feeling when everything working as you want it. :dance_24:
And yes, Safari is all I ever use with OS X. It does everything I need and it does feel faster under Lion.

----------------------------------

Thank you John Lafave for clicking my dropbox link. That was very kind of you :unsure:

#3588
pane2k

pane2k

    InsanelyMac Protégé

  • Members
  • Pip
  • 14 posts
Blackosx,
I was able to fix my problem. After closely looking at my kextstat, I realized that USBMassStorageClass kext was not loading. When I tried to force load it in terminal I got an error. I installed the one from my 10.6.7 and rebooted. Viola, it loaded and my usb drives were mounting.
Then I plugged my Atheros wifi card back in, and that was still locking up my machine, and it was also causing my USB drives not to mount.
Someone had posted the fix on netkas. It was the bundle from 10.6.7, I had installed it and it must have been corrupt, because I downloaded it from another post on another forum and rebooted, and everything started working.
So it seems like I got my 10.6.8 completely working. Sound, time machine and all.
Thanks for the help.

#3589
blackosx

blackosx

    InsanelyMacaholic

  • Coders
  • 3,054 posts
  • Gender:Male
  • Location:UK
pane2k - Well done for fixing your problem.

#3590
-iCE!HACKER-

-iCE!HACKER-

    InsanelyMac Protégé

  • Members
  • PipPip
  • 78 posts
  • Gender:Male
  • Location:Earth
@muitommy @blackosx

just got a copy of Lion GM would like to install it can i get some directions pls. TIA

#3591
D-an-W

D-an-W

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 417 posts

@muitommy @blackosx

just got a copy of Lion GM would like to install it can i get some directions pls. TIA


Page #174 will help you :unsure:

#3592
blackosx

blackosx

    InsanelyMacaholic

  • Coders
  • 3,054 posts
  • Gender:Male
  • Location:UK
@-iCE!HACKER-
The instructions I posted back in April are old now and could do with being refined by a few things like removing the text about the XPC bootloader as although that can still be used, Chameleon will more than likely be the bootloader of choice for most here. And updating the procedure to now mention the requirement to also copy the mach_kernel to the root of the base installer which wasn't required with older developer previews.

So it will be wise to have a look at these topics for up to date info for now:
http://www.insanelym...howtopic=256729
http://www.insanelym...howtopic=259068

#3593
RaMaDaSa

RaMaDaSa

    InsanelyMac Protégé

  • Members
  • Pip
  • 22 posts
  • Gender:Male
Hi blackosx,

maybe v10.6.8 was the final major update for Snow (as v10.5.8 for Leo). So I think it would be very helpful for all users of your GA-EP45-DS3L-Guide if you would update the Support Files (v1.4.4) on the front page to the current state. What do you think?

Thanks again for your excellent support in this thread, which is one of the best I've ever seen... :guitar:

#3594
blackosx

blackosx

    InsanelyMacaholic

  • Coders
  • 3,054 posts
  • Gender:Male
  • Location:UK
Hi RaMaDaSa

Yes it would be good idea to update the Support Files though I feel the PDF's would have to be revised/updated to match. For now though, I have quickly thrown together a Support Files v1.4.5b1 for testing.

Please Note: I haven't worked through an install process using these files to make sure everything is absolutely correct so some testing will be needed before I post the final version of this archive on the front page and as I said above, the guide PDF's will probably have to change to match these files.

Download link: Support Files v1.4.5b1
Removed as Support Files v1.4.5 are now on the front page.

Here's the list of changes:
Changes from v1.4.4 to v1.4.5b1• Updated FakeSMC.kext and plugins to rev493 (Thanks to Slice for the new builds)• Added patched AppleHDA for 10.6.5 (which can be used for 10.6.6 and 10.6.7), and 10.6.8• Added ALC888.kext to be used instead of LegacyHDA.kext. I now use this in /System/Library/Extensions• Revised SMBIOS.plist to use SMmanufacturer and SMboardmanufacturer to coincide with recent Chameleon changes.• Tweaked the generic EP45-DS3L DSDT	• Removed Name (_S1… as OS X doesn't seem to support it  and change package to three to suit ACPI spec (Thanks DHP).	• Added secondary PIT to Device (TIMR) as per Intel's ICH10 datasheet. (Thanks for MasterChief for the tip).	• Fixed a length discrepancy in BUF0 in Method _CRS as the latest iAsl gave an error with previous Gigabyte value.	* Added ECHI ownership fix (Thanks THe KiNG - [url="http://www.projectosx.com/forum/index.php?showtopic=888)"]http://www.projectosx.com/forum/index.php?showtopic=888)[/url].	• Added the revised Device (HDEF) to suit audio for 10.6.8 and 10.7 (Thanks cparm).[s]• Added Chameleon RC5 r688 from Kabyl's branch which include extra capabilities for newer ATI cards.[/s]• Removed Disabler.kext from Part 2/1B/EXTRA for USB/Extra/Extensions as it only blocked AppleUpstreamUserClientDriver so not essential.• Renamed com.apple.Boot.plist to org.chameleon.Boot.plist to suit latest Chameleon changes.• Added Chameleon v2 RC5 r1156 to Part 2/1B/Chameleon and Part 3/Chameleon. Note the boot0 file is boot0hfs, just named boot0.


#3595
D-an-W

D-an-W

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 417 posts
Cheers black for the updates!

Even though I have different hardware your files are invaluable.

(Fancy tweaking my DSDT! :P)

#3596
rednous

rednous

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 345 posts
  • Gender:Male
  • Location:Galaxy: Milky Way
  • Interests:graphic design, mac, progressive and house

Here's the list of changes:

Changes from v1.4.4 to v1.4.5b1

	• Removed Name (_S1… as OS X doesn't seem to support it  and change package to three to suit ACPI spec (Thanks DHP).
	• Added secondary PIT to Device (TIMR) as per Intel's ICH10 datasheet. (Thanks for MasterChief for the tip).
	• Fixed a length discrepancy in BUF0 in Method _CRS as the latest iAsl gave an error with previous Gigabyte value.

blackosx, great DSDT amendments :( . Can you give me more light where to search for the above in my DSDT? Your & mine Device (TIMR) are with exact DSDT sections. thanx in advance :P


here's mine Device TIMR:
Device (TIMR)
				{
					Name (_HID, EisaId ("PNP0100"))
					Name (_CRS, ResourceTemplate ()
					{
						IO (Decode16,
							0x0040,			 // Range Minimum
							0x0040,			 // Range Maximum
							0x00,			   // Alignment
							0x04,			   // Length
							)
						IO (Decode16,
							0x0050,			 // Range Minimum
							0x0050,			 // Range Maximum
							0x00,			   // Alignment
							0x04,			   // Length
							)
					})
				}

my Lion DSDT for reference -> Attached File  DSDT_rednous.zip   3.59KB   3 downloads

#3597
RaMaDaSa

RaMaDaSa

    InsanelyMac Protégé

  • Members
  • Pip
  • 22 posts
  • Gender:Male

Hi RaMaDaSa

Yes it would be good idea to update the Support Files though I feel the PDF's would have to be revised/updated to match. For now though, I have quickly thrown together a Support Files v1.4.5b1 for testing.

Please Note: I haven't worked through an install process using these files to make sure everything is absolutely correct so some testing will be needed before I post the final version of this archive on the front page and as I said above, the guide PDF's will probably have to change to match these files.

Download link: Support Files v1.4.5b1

Here's the list of changes:

Changes from v1.4.4 to v1.4.5b1• Updated FakeSMC.kext and plugins to rev493 (Thanks to Slice for the new builds)• Added patched AppleHDA for 10.6.5 (which can be used for 10.6.6 and 10.6.7), and 10.6.8• Added ALC888.kext to be used instead of LegacyHDA.kext. I now use this in /System/Library/Extensions• Revised SMBIOS.plist to use SMmanufacturer and SMboardmanufacturer to coincide with recent Chameleon changes.• Tweaked the generic EP45-DS3L DSDT	• Removed Name (_S1… as OS X doesn't seem to support it  and change package to three to suit ACPI spec (Thanks DHP).	• Added secondary PIT to Device (TIMR) as per Intel's ICH10 datasheet. (Thanks for MasterChief for the tip).	• Fixed a length discrepancy in BUF0 in Method _CRS as the latest iAsl gave an error with previous Gigabyte value.	* Added ECHI ownership fix (Thanks THe KiNG - [url="http://www.projectosx.com/forum/index.php?showtopic=888)"]http://www.projectosx.com/forum/index.php?showtopic=888)[/url].	• Added the revised Device (HDEF) to suit audio for 10.6.8 and 10.7 (Thanks cparm).[s]• Added Chameleon RC5 r688 from Kabyl's branch which include extra capabilities for newer ATI cards.[/s]• Removed Disabler.kext from Part 2/1B/EXTRA for USB/Extra/Extensions as it only blocked AppleUpstreamUserClientDriver so not essential.• Renamed com.apple.Boot.plist to org.chameleon.Boot.plist to suit latest Chameleon changes.• Added Chameleon v2 RC5 r1156 to Part 2/1B/Chameleon and Part 3/Chameleon. Note the boot0 file is boot0hfs, just named boot0.


Blackosx, thanks for the update!! I'll test the files within the next days. It's good to have now a common base again :(

#3598
blackosx

blackosx

    InsanelyMacaholic

  • Coders
  • 3,054 posts
  • Gender:Male
  • Location:UK

Blackosx, thanks for the update!! I'll test the files within the next days. It's good to have now a common base again :D

Can I suggest you wait a bit longer as I am updating the Support Files further still and in the middle of revising the PDF guides. ;)

#3599
RaMaDaSa

RaMaDaSa

    InsanelyMac Protégé

  • Members
  • Pip
  • 22 posts
  • Gender:Male

Cheers black for the updates!

Even though I have different hardware your files are invaluable.

(Fancy tweaking my DSDT! ;))


...I agree with you D-an-W! I've used Blacks Support Files several times also for other Hacks as a really good basis :D

#3600
blackosx

blackosx

    InsanelyMacaholic

  • Coders
  • 3,054 posts
  • Gender:Male
  • Location:UK

Can you give me more light where to search for the above in my DSDT? Your & mine Device (TIMR) are with exact DSDT sections. thanx in advance :D

I got the Device (TIMR) info from this post by MasterChief. Your DSDT looks to already have the fix.

...I agree with you D-an-W! I've used Blacks Support Files several times also for other Hacks as a really good basis ;)

Thanks for the support guys, but the files I use / put in the Support Files are all available in these forums. It's just from reading and testing that I get to know what works and what doesn't.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy