Jump to content

VoodooPS2 and VoodooHDA (now 0.2.2 with prefPane) drivers for snow leopard 32/64 bit


  • Please log in to reply
64 replies to this topic

#61
Chaos Scorpion

Chaos Scorpion

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 5 posts

hi,it's not working for me too......it's type:
Last login: Mon Nov 29 19:18:54 on ttys000
/Library/VoodooHDA/voodoohdahelper ; exit;
li-gangbinmatoMacBook-Pro:~ ligangbin$ /Library/VoodooHDA/voodoohdahelper ; exit;
Found a device of class VoodooHDADevice: IOService:/AppleACPIPlatformExpert/PCI0@0/AppleACPIPCI/HDAC@1B/VoodooHDADevice

settings file path: /Users/ligangbin/Library/Preferences/VoodooHDA.settings
error: 2 can't read the settings file
restoring saved settings...
logout
Can you help me check it ....thank you very much


Same error, the path search in Users/chaosscorpion+/library/preferences/VoodooHDA.settings but the correct name is "chaosscorpion", how i can fix this?

#62
JahRastaMaN

JahRastaMaN

    InsanelyMac Protégé

  • Members
  • PipPip
  • 92 posts
  • Gender:Male
  • Location:Brasil
Thank you! in my board dg965wh works fine! i'm run snow leo 10.6.7.
:P


Something to clarify here:

I'm not the developer of VoodooHDA and VoodooPS2Controller. I just did the compilation job for snow leopard. Thus I actually have no idea what could be the reason for any non-working things caused to you.

Any further request and debug information should go to: forum.voodooprojects.org

Also Slice is actively developing VoodooHDA (now 0.2.42) and added mic autodetect function. Check it here. As rals2007 requested, here is the first version of 0.2.35 source code (need nodes patch to get mic work) edited for 32/64 bit compilation:

These two kexts are recompiled for snow leopard, support both 32/64 bit kernel. The PS2 source code is from Chun-nan (now eureka?) and recompiled by me. The HDA is from VoodooProjects and recompiled by avian from their forum.


Update [2009-08-24]:
fassl from the VoodooProject released VoodooHDA_Pref source code two days ago. Thanks for that, I now compiled it for snow leopard 32/64. This version solved the low max volume problem on my laptop, thus I did not edit the file Table.c. Use VoodooHDA.prefPane for configuration. To reload the configuration at each boot, put voodoohdahelper into your startup item.



Thank you! works fine on dg965wh and SL10.6.7, VoodooHDA_Pref.zip. =)

#63
DBH0921

DBH0921

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts
Finally got this working.. my touchpad and keyboard work once more.

My only issue is..

I have a dell latitude D630 and I love my little blue mouse I can use (similar to what the Lenovo/IBM laptops have that is red) and I can't think of what it is called.. and that does not work. How can I fix this?

#64
caguars

caguars

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
I have ga-73vm-s2 mobo gigabyte, sound works with voodoo hda, but still no 5.1 sound. Any ideas ?

#65
davidm71

davidm71

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 167 posts
  • Gender:Male
Hi,

I am sorry I am responding to an old thread but have a question regarding the VoodooPS2 controller kext that is bundled into #####. I had ps2 keyboard support until I used a dsdt. Now my keyboard doesnt work but usb keyboard works fine. Anyone know if there is a dsdt edit for the voodoops2 keyboard?


Thanks





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy