Jump to content

Mac OS X 10.6 Snow Leopard


  • Please log in to reply
146 replies to this topic

#121
_nate_

_nate_

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
i just installed this according to these instruction osx86.fujilives.com/. installed fine and starts fine. no audio and some other various problems. seems to have random kernel panics when opening apps. noticed my bios was reset after that too. took out everything, i think it even under clocked my cpu which was previously over clocked. prior to reading this thread i was a little worried and had no idea why my bios kept reseting.

#122
masri01

masri01

    InsanelyMac Protégé

  • Members
  • Pip
  • 26 posts

delete appleintelcpupowermanagement.kext
I also got that message.
odd
I googled the error and in one apple forum it says that you are missing the basesytem.pkg in /library/reciepts/

some claimed success just installing this in the receipt folders
others said they had to do a reinstall
none worked for me



ok i deleted the kext and it worked :D the only thing thats annoying me at the moment is my bios, it keeps corrupting but I saved a profile so every time i boot, I'll just select my profile and no worries.

Thanks for your help man!

Now I need audio to work, I'm using alc889 chipset.. does anyone know how I can get the alc889 to work?

Thanks!

#123
masri01

masri01

    InsanelyMac Protégé

  • Members
  • Pip
  • 26 posts
Check it out!

Posted Image

#124
userx

userx

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 124 posts

Check it out!

Posted Image


Nice job, way to go!

#125
Diwad

Diwad

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 120 posts
Damn! After installing pcefi darwin bootloader doesn't recognize my second hdd :thumbsup_anim:" i've tried changing options in bios with no success:/ I had no problems with 10.5.6 and now...ehhh

whats your diagnose guys?:/

EDIT: Ok, i got it... i had one partition with windows but the partition was guid so i though it will work:/ now im installing SL from osimnstall. thanks for everything guys!

Ill post some screenshots after completing instal;)

#126
SP1950

SP1950

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts

panic(cpu 0 caller 0x2a6a95) - it looks like /System/Library/Caches/com.apple.kext.caches/Startup/Extensions.mkext might be outdated or missing. Apparently loading kexts without Extensions.mkext isn't working yet.



If you get a KP after the "mig_table_max_displ = XX" line, then you should really make sure you have a vaild mkext


thanks for the tip :) , but my snow leopard is still not working

i tried creating the extensions.mkext in both /s/l/ and /s/l/caches/com.apple.kext.caches/startup, but still no luck for me

the :( ing thing just still creates its own mkext at boot (already skip the -f flag), ignoring what i had made

it is the same kp, and i have no clue on the problem at all

i guess i should wait for the september release, get an upgrade dvd and try again

and is there anyone with an atom netbook got snow leo running?

#127
vani

vani

    InsanelyMac Protégé

  • Members
  • Pip
  • 42 posts
  • Interests:Vanilla!

the :( ing thing just still creates its own mkext at boot

I think this is the root of the problem. How did you create your mkext? (I guess you need to create it using a SL system...)

#128
Casimir99

Casimir99

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
The price of the upgrade is €8.85 if you buy a Mac on or after June 8th (source: Apple France). BTW, is a380 the final build or just another build on the way to the gold one?

#129
ugokind

ugokind

    InsanelyMac Deity

  • Donators
  • 1,712 posts
  • Gender:Male
  • Location:10100
  • Interests:Apicoltura
    Mac
    Linux
    Homebrew
    Australia
    Spremermilcervello
maybe the real improvement is to discover where is the check of partition scheme type.. and fake it.

#130
eren70

eren70

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts
How is the easiest to install snow leopard?

#131
BlackCH

BlackCH

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,615 posts
  • Gender:Male
  • Location:BCN
Working OK on a P5K-VM:

modded BIOS DMI data reading OK (without SMBIOS injection). CPU freq/bus not correct
Attached File  Screenshot_on_2009_06_12_at_1.30.07_PM.png   47.9KB   494 downloads

QE/CI via DSDT still working fine:
Attached File  Screenshot_on_2009_06_12_at_1.32.06_PM.png   54.46KB   532 downloads

AHCI works OOTB faking ICH10 dev ID via DSDT (although I get a fs error message 'unknown-device' I still need to track down)
Jmicron working with the old LegacyJmicron.kext

it wont boot without a custom DSDT ('cannot find the driver for this platform /ACPI' message)
Restart/shutdown/sleep not working (is mostly working with custom DSDT on 10.5) but does not corrupt the CMOS settings.
No sound (legacy kexts are not good anymore)

No kernel panics so far.
Feels faster/snappier than 10.5.7; but geekbench 64bit score is only 70 point over.


EDIT:
I get 'jnl: unknown-dev: flushing fs disk buffer returned 0x05' message every 30 secs for around 6 minutes after booting. Then stops. Is not related with AHCI discs as it happens anyway without having them connected.
HD shown as folders on the desktop?? WTF... DVD drive too...

Restart/Shutdown works with new OpenHaltRestart.kext....

EDIT 2: successfully modified stock AppleHDA.kext; All channels working. Notice Im using HDEF injection by DSDT (no Enabler.kext). System profiler shows two extra non-existing 'line out'

OK, here are the ALC 883 LegacyHDA kexts for SL I've made (are based on stickpin ones):
Attached File  ALC883_LegacyHDA_SnowLeopard.zip   14.66KB   1637 downloads
You will need the new HDEFEnabler.kext, device-properties strings or DSDT injection to make them load

#132
mitch_de

mitch_de

    InsanelyMacaholic

  • Local Moderators
  • 2,880 posts
  • Gender:Male
  • Location:Stuttgart / Germany

maybe the real improvement is to discover where is the check of partition scheme type.. and fake it.



Take a look here for my modded 10A380 OSInstall.mpkg - allowing also MBR partition scheme type installs :D

http://www.insanelym...howtopic=170378

#133
Bob Ajob

Bob Ajob

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 116 posts
  • Gender:Male
  • Location:Leeds, UK
  • Interests:tinkering with hackintoshes .... obviously :)

.........
What early Mac mini owners will hate: Snow Leopard is 64-bit-only. (From what I understand, those early minis used 32-bit CoreDuos, not the C2Ds of the current mini; so they are SOL.)
.............


Is it 64-bit only or is 64-bit an optional feature?

Suggests here that it is optional --> http://www.apple.com/macosx/specs.html

[edit] - just saw above someone got it working on an older Core Solo machine, will make my housemate happy, he has an old MacBook Pro ...

#134
mitch_de

mitch_de

    InsanelyMacaholic

  • Local Moderators
  • 2,880 posts
  • Gender:Male
  • Location:Stuttgart / Germany

Is it 64-bit only or is 64-bit an optional feature?

Suggests here that it is optional --> http://www.apple.com/macosx/specs.html

[edit] - just saw above someone got it working on an older Core Solo machine, will make my housemate happy, he has an old MacBook Pro ...


Yes, it can set (at boottime by key or kernel flag) for 32 Bit also.


Does A380 need an special (DIMITRY) kernel or does the normal works on an vanilla system.
I ask because A354 worked and now i get very early (i think kernel problem. no driver problem) an KP.

#135
guest048

guest048

    InsanelyMac Protégé

  • Members
  • Pip
  • 15 posts
  • Gender:Male
Spoiler


#136
kitmac

kitmac

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 209 posts
  • Gender:Male
dude @ http://osx86.fujilives.com/

says to use his [b]261OSInstall.mpkg - OSInstall.mpkg
and replace it in the installation dvd.

Will this still work for 10A380 ????

edit: found the new package on the green demon


Anyone know if ALC888 works on Snow Leo?????????????

#137
bigpoppa206

bigpoppa206

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 474 posts
  • Gender:Male
  • Location:Seattle, WA USA Earth
No luck yet on a Gigabyte GA-EP45C-UD3R...sigh. Get's loaded to desktop and kernel panic.

#138
booger_sniffer5000

booger_sniffer5000

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 778 posts
  • Gender:Male
  • Location:US
  • Interests:OSx86 (duh)
I'm doing something wrong, boot loader refuses to load the vanilla kernel (on a Core 2 Duo), and KP's when loading the legacy kernel. I'm almost certain it's a bootloader problem, even though I'm using the modified PC EFI v9, but Chameleon 2 gives me the same results. Can anybody possibly point me to the install files for PC EFI v9 to manually install it?

EDIT: Nevermind, I used this boot file and it booted 10a380 just fine :( http://is.gd/jcgq

#139
masri01

masri01

    InsanelyMac Protégé

  • Members
  • Pip
  • 26 posts

Nice job, way to go!


Thanks UserX. Finally got Snow Leopard to work stably.

Also for those people who are using ALC889a.

ALC889a Kext Fix - ALC889a Snow Leopard
;)

#140
geo afa

geo afa

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts
i got kernel panic and corrupted bios too... for acpi something!!!

with gigabyte ep35-ds3l.

any solution?????

thanks





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy