Jump to content

ALC888 on GA-EP43-DS3L - Works nearly best but...


  • This topic is locked This topic is locked
9 replies to this topic

#1
tommix1968

tommix1968

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
My Problem is sometimes its "plopping" out of the speaker before sound comes. Seems that my ALC888 is sleeping and would be awaked because of sound...

Anyone an idea whats wrong?

The rest runs best (look screenshot). I use the HDAPatcher with the codecdump from Linux and AppleHDA.kext and HDAEnabler.kext.


Attached File  Bild_1.jpg   22.32KB   131 downloads

#2
rootmentor

rootmentor

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
some problem here.
Anyone got fix?

#3
U.C.

U.C.

    The Leopard Roars

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 2,080 posts
  • Gender:Male
  • Location:God's Green Earth
  • Interests:Everything Apple, Computers, Movies
Give VoodooHDA a go. Works very well on this board.

#4
Automatic_Mac

Automatic_Mac

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
I couldn't get VoodooHD to work, U.C. I'd get sound controls appearing but the system profiler reported no installed audio hardware and I couldn't get a peep out of my speakers.

What I have since got working are the 1.6.2a37 kexts by Taruga (I think)

http://www.mediafire...php?mndcdymtguy

Edit: This link is dead for some reason.

You can try the 1.5.7a24 ones here: http://www.mediafire...php?midnjn2to5u instead

Anyway I found this solution in this thread: http://www.insanelym...hp/t157269.html

After a few failed attempts I was able to use kext helper to install the files and get at least 2.1 audio out and mic in. I can't test 5.1 because I don't have a 5.1 set up, also the front audio ports do not work. It's worth noting that kext helper only worked for me when I set a password, a strange bug.


U.C I would be very interested to know how you got voodooHDA working, I am a complete noob and sadly explaining solutions to noobs is not one of OSx86's strengths!

EDIT: U.C I've also made a Noob's guide for the GA EP43 DS3L Mobo, written by a noob. I haven't posted it yet because I'm worried it's filled with mistakes and not much use to anyone... Anyway I bet i'm not the only GA EP43 DS3L owner interested to see the setup you (and experienced user) are running.

#5
121fred

121fred

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 110 posts

I couldn't get VoodooHD to work, U.C. I'd get sound controls appearing but the system profiler reported no installed audio hardware and I couldn't get a peep out of my speakers.

What I have since got working are the 1.6.2a37 kexts by Taruga (I think)

http://www.mediafire...php?mndcdymtguy

Edit: This link is dead for some reason.

You can try the 1.5.7a24 ones here: http://www.mediafire...php?midnjn2to5u instead

Anyway I found this solution in this thread: http://www.insanelym...hp/t157269.html

After a few failed attempts I was able to use kext helper to install the files and get at least 2.1 audio out and mic in. I can't test 5.1 because I don't have a 5.1 set up, also the front audio ports do not work. It's worth noting that kext helper only worked for me when I set a password, a strange bug.


U.C I would be very interested to know how you got voodooHDA working, I am a complete noob and sadly explaining solutions to noobs is not one of OSx86's strengths!

EDIT: U.C I've also made a Noob's guide for the GA EP43 DS3L Mobo, written by a noob. I haven't posted it yet because I'm worried it's filled with mistakes and not much use to anyone... Anyway I bet i'm not the only GA EP43 DS3L owner interested to see the setup you (and experienced user) are running.


Hi

Can you up the 1.6 files to mediafire or similar

Thanks

#6
Automatic_Mac

Automatic_Mac

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts

Hi

Can you up the 1.6 files to mediafire or similar

Thanks



Sure

http://www.mediafire...php?dn2vnuz5qhi

I've also attached it to this post.

I hope it works, let us know.

Attached Files



#7
121fred

121fred

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 110 posts

Sure

http://www.mediafire...php?dn2vnuz5qhi

I've also attached it to this post.

I hope it works, let us know.



Thanks Automatic, I've been using voodoohda and all I did to get it working was remove applehda but it does go strange after sleeo at times so I'll give this a try.

Cheers

#8
Automatic_Mac

Automatic_Mac

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts

Thanks Automatic, I've been using voodoohda and all I did to get it working was remove applehda but it does go strange after sleeo at times so I'll give this a try.

Cheers



No problem,

Off topic, but can you tell me how exactly you got sleep working? Assuming you have the GA EP43 Mobo. Each time I put my computer to sleep I never get it to wake without it rebooting.

#9
121fred

121fred

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 110 posts

No problem,

Off topic, but can you tell me how exactly you got sleep working? Assuming you have the GA EP43 Mobo. Each time I put my computer to sleep I never get it to wake without it rebooting.


Just installed 10.5.8 update and sound works fine with 1.6.2a37 kexts. Sleep used to work with 10.5.7 but now the same as you won't wake without reboot.

#10
forrestsun

forrestsun

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts

Sure

http://www.mediafire...php?dn2vnuz5qhi

I've also attached it to this post.

I hope it works, let us know.


Hi, Just want to say thanks, a big Thanks!, For posting this driver (and the original creator of the driver). Have been using Voodoo with no digital sound then I tried this, Bang! Now I have a perfect sound (analog and digital, and the digital sounds much better and clear for me setup).

Btw, I am a ALC888S on an Asus MB, with built-in SPDIF out. Thanks!





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy