Jump to content

[GUIDE] Dell XPS 1730 - OSX 10.5.7 (QE/CI)

- - - - -

  • Please log in to reply
14 replies to this topic

#1
normanbates

normanbates

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
  • Gender:Male
  • Location:Germany
Dell XPS 1730 Leopard Guide (10.5.7)

Hello,
i got now finally everything working on my 1730 (except restart/shutdown/sleep and WLAN)
And i want to tell you how i did it:

What works?
GFX: nVIDIA Geforce 8800M GTX with QE/CI @ 1920x1200x32 (Drivers needed)
LAN: Broadcom 57xx (Drivers needed)
SOUND: Sigmatel 9228 (Drivers needed)
MEDIA KEYS: Mute, Vol+, Vol-, Next-Track (works OOB)
TOUCHPAD: Synaptics (works OOB)
WEBCAM: Logitech 2.0 MP (works OOB)
BLUETOOTH: Dell TrueMobile 355 Bluetooth Module (works OOB)

What doesnt work?
- Restart/Shutdown (You have to shutdown by Power Button)
- Sleep (No Reaction)
- DVI-Output (OSX hangs if i connect to it)
- Logitech Gamepanel (Doesnt connect if i install the software)
- WLAN Card Intel 4965
- RAID Mode not supported you have to use ATA or AHCI Mode

What do I need before i install?
(Only if you cant connect to the Internet with another PC)

- Combo Pack 10.5.7 Update Installer Link
- Universal OSX86 Installer Link
- Broadcom 57xx Installer (Attachment below)

OSX Version/Distribution
I have tested many distributions like Kalyway, iAtkos and iPC.
But he only one that works for me without kernel panic is:
iATKOS 4.0

BIOS Settings
You can leave default settings. Only setting you got to change is AHCI to ATA.
After Update to 10.5.7 you can switch back to AHCI.

OSX Installation
- Boot your iAtkos DVD
- Make your OSX Partition (MBR/GUI)
- You have to check the options [Stock Kernel 9.4.0] and [Darwin Bootloader] (nothing else)
- Thats the first part

OSX Post-Installation

PART 1: Universal OSX86 Installer
- First you have to download "Universal OSX86 Installer" Link
-Choose you HD to apply
-Check the "Apply kext package" box
-Check the "Set Native Boot Resolution to:" and change the values to "1920x1200"
-Check the "Install PC_EFI v9 Chameleon Edition 1.0.12" box
-Click on "Install"
-Reboot

PART 2: 10.5.7 Combo Update
-Install the 10.5.7 Combo Update. Link
-Reboot
-Dont be worry if your Laptop restarts on the first boot.
-You should now see Version 10.5.7 in you "About your MAC" Window

PART 3: PS2 Keyboard (FIX)
-After the update to 10.5.7 you cant use the Laptop keyboard anymore.
-Plugin an external USB Keyboard.
-Install the "10.5.7 RepairPack" Link
-Select only "Additional Kexts" / "ApplePS2kexts.10.5.7.ready"
-Reboot and the keyboard should work now.

PART 4: Broadcom 57xx Installer (Wired LAN)
-Run the Installer.
-You should now be able to use the Internet.

PART 5: nVIDIA 8800M GTX Graphics Driver (nvDarwin 1.2.5)
- Run the Installer. Link
- Choose "512 MB" Driver.
- Reboot

PART 6: Sigmatel 9228 Sound Driver
- Install AppleHDA.kext
- Install HDAEnabler.kext
- Delete "AppleAzaliaAudio.kext" in your "/System/Library/Extensions" Folder
- Repair permissions.
- Reboot

I hope I can help you out with your 1730.
Thanks goes to macgirl and wingrunr21.

Attached Files



#2
MaxWeb

MaxWeb

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
Excellent , Going to have a go on my system, Can i dual boot with this method ?

Many thanks

MaxWeb

#3
normanbates

normanbates

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
  • Gender:Male
  • Location:Germany

Excellent , Going to have a go on my system, Can i dual boot with this method ?

Many thanks

MaxWeb


Dualboot is no problem with Chameleon if you make one partition OSX and the other Windows.

#4
ATKJEDI

ATKJEDI

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
Thank you for the walkthrough, mine is all up and running, only diff on my build was I used iATKOS v7 DVD
Also the Touchpad didnt work untill loading the 10.5.7 RepairPack

I also have a the intell wireless N adapter and installed it with
PROSet/Wireless 4965a/g/n OS X 10.5 (http://code.google.com/p/iwidarwin/)
Additional info on the driver
http://www.insanelym...showtopic=84072

Also by removing any nVidia Kext and doing a custom EFI string with "OSx86 Tools" I was able to get DVI working and no reboot\powerdown issue...... But lost QE :-(

#5
vjmindlab

vjmindlab

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts

Thank you for the walkthrough, mine is all up and running, only diff on my build was I used iATKOS v7 DVD
Also the Touchpad didnt work untill loading the 10.5.7 RepairPack

I also have a the intell wireless N adapter and installed it with
PROSet/Wireless 4965a/g/n OS X 10.5 (http://code.google.com/p/iwidarwin/)
Additional info on the driver
http://www.insanelym...showtopic=84072

Also by removing any nVidia Kext and doing a custom EFI string with "OSx86 Tools" I was able to get DVI working and no reboot\powerdown issue...... But lost QE :-(




Would you mind sharing your EFI string i would really appreciate if i could the dvi and power issue on my xps 1730 thanks in advance

#6
ATKJEDI

ATKJEDI

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts

Would you mind sharing your EFI string i would really appreciate if i could the dvi and power issue on my xps 1730 thanks in advance


I used osx86tools and did a custom GeForce GFX String, Specified 512 Mem. 1920x1200x32 and DVI-I DVI-I

#7
jcoleman414

jcoleman414

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts

Thank you for the walkthrough, mine is all up and running, only diff on my build was I used iATKOS v7 DVD
Also the Touchpad didnt work untill loading the 10.5.7 RepairPack

I also have a the intell wireless N adapter and installed it with
PROSet/Wireless 4965a/g/n OS X 10.5 (http://code.google.com/p/iwidarwin/)
Additional info on the driver
http://www.insanelym...showtopic=84072

Also by removing any nVidia Kext and doing a custom EFI string with "OSx86 Tools" I was able to get DVI working and no reboot\powerdown issue...... But lost QE :-(


Would you mind explaining this more I am very very knew to OS X and Mac. I am testing this out on my 1730 to see if this is something that would work for me in the long run.
Thank you very much for your help in advance

#8
ATKJEDI

ATKJEDI

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts

Would you mind explaining this more I am very very knew to OS X and Mac. I am testing this out on my 1730 to see if this is something that would work for me in the long run.
Thank you very much for your help in advance


Which part you looking for assist with?

Most info I found by searching this forum :-) thanks guys!!

on the wifi, its flakey at best, I was only able to get it to connect unsecured, and even then had issues getting an IP, stuck to physical connections.

#9
unixsyadm

unixsyadm

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
Works great!!! I got everything to work except the keyboard. Any tips, on what I should do?

#10
jcoleman414

jcoleman414

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
Have you tried part 3 the keyboard fix

#11
manor

manor

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 318 posts
  • Gender:Male
hi all
i like to install snow leopard
ple help me
thanks for all information
Dell XPS M1730 / Intel 965 Chipset / Intel Mobile Core2Duo 2.5 GHz (6MB Cache) / 8GB DDR667 RAM DualChannel /
Dual nVidia 8700M GTX SLI 2x512 MB / Sigmatel STAC9228X / Dual-Layer DVD-RW / 2x 200GB Seagate Momentus /
Dell Wireless 1505 WLAN Card / Dell TrueMobile 355 Bluetooth Module

#12
JaE-V

JaE-V

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 933 posts
  • Gender:Male
  • Location:Texas
SLI working? Really? hmmm

#13
Mehroz

Mehroz

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts
  • Gender:Male
  • Location:Pakistan
Links dead... please someone re-upload. =|
btw, is it possible to follow this guide to install Leopard and then upgrade to Snow Leopard like you do on a mac?
thanks.

P.S. I got the files from somewhere else, thanks for this great tutorial!

#14
0SCAR

0SCAR

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
Yeah, a friend of mine has a Dell XPS. He will be very pleasent with this guide. Thanx!

#15
JaE-V

JaE-V

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 933 posts
  • Gender:Male
  • Location:Texas
Testing...nvDarwin





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy