Jump to content

Cmedia 8738


  • Please log in to reply
226 replies to this topic

#101
coccolino_dbro

coccolino_dbro

    InsanelyMac Protégé

  • Members
  • Pip
  • 36 posts
  • Gender:Male
  • Location:Targoviste, Romania

I have compiled dogbert's CMI8738PCIAudioDriver.kext from source with XCode 2.4.1, and it works. I briefly looked into the source, and it looks safe and open source to me.

GENERIC CMI8738 DRIVER ---- ONLY FOR OSX86 Tiger 10.4.9 !!!
* For other versions compile from source *

INSTALLATION:
0. login as root ^_^
1. Unpack CMI8738PCIAudioDriver.kext to /tmp/ for example
2. Do
cd /System/Library/Extensions/
cp -r /tmp/CMI8738PCIAudioDriver.kext .
chmod -R 755 CMI8738PCIAudioDriver.kext
chown -R root:wheel CMI8738PCIAudioDriver.kext
3. Reboot -OR- try to load manually with: kextload CMI8738PCIAudioDriver.kext (Card info should be printed)

Driver provided here is for educational purposes only, without any warranty. Please support Apple by bying real Mac!


Just tried this on 10.4.10 (mac.nub.1)foramotherboardintegratedcmi8738anditworks.
Therewasnoneedtocompilefromsource(I couldn't have done it, anyway, since I don't have xcode).Justcopiedthekextto/System/Library/Extensions,runthosecommandsandloadedit. I have only stereo output (no mic), but that's all I need.

#102
willymx70

willymx70

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
Thanks Blagec for the file and thanks coccolino_dbro to try it in 10.4.10. I have sound with this file and method in 10.4.9 and 10.4.10 (without recompiled).
I use a PCI 5.1 ch card with CMI8738 (the one w/2 outputs).

Thank you all !!!
MWTB-DLTR.

#103
swaine

swaine

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
Does any of the drivers for 8738 have midi working?

#104
robot8254

robot8254

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
OSX 10.4.7 + CMI8738 PCI install download kext

22com_CMI8738AudioEngine is not compatible with its superclass, 13IOAudioEngine superclass changed?
kextload: a link/load error occured for kernel extension CMI8738PCIAudioDriver.kext
load failed for extension CMI8738PCIAudioDriver.kext
(run kextload with -t for diagnostic output)

Is there CMI8738PCIAudioDriver for 10.4.7? anyboby get it mail to me,thanks!!!!
mymail:robot8254@yahoo.com.cn
thanks!!!!

#105
zc_au

zc_au

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts
  • Gender:Male
  • Location:south australia
is there an release of this driver for OS X 10.5 ?

#106
BlackCH

BlackCH

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,613 posts
  • Gender:Male
  • Location:BCN

I have compiled dogbert's CMI8738PCIAudioDriver.kext from source with XCode 2.4.1, and it works. I briefly looked into the source, and it looks safe and open source to me.

GENERIC CMI8738 DRIVER ---- ONLY FOR OSX86 Tiger 10.4.9 !!!
* For other versions compile from source *

INSTALLATION:
0. login as root :D
1. Unpack CMI8738PCIAudioDriver.kext to /tmp/ for example
2. Do
cd /System/Library/Extensions/
cp -r /tmp/CMI8738PCIAudioDriver.kext .
chmod -R 755 CMI8738PCIAudioDriver.kext
chown -R root:wheel CMI8738PCIAudioDriver.kext
3. Reboot -OR- try to load manually with: kextload CMI8738PCIAudioDriver.kext (Card info should be printed)

Driver provided here is for educational purposes only, without any warranty. Please support Apple by bying real Mac!


works here on 10.4.11... thanx

#107
xpertvision

xpertvision

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 220 posts

You're not alone. I also have problem getting any sound of my cmi9739a-chip. The chip is detected succesfully and the appleac97driver-module loads without problems but there is no sound playback :(


me too...

i have Cmedia 9761A onboard sound card

#108
Krazubu

Krazubu

    InsanelyMac Legend

  • Retired
  • 874 posts
I just recompiled this old driver from Dogbert for 10.5.3, no idea if it still works.

It's for 8738/8768 cards, maybe some other models work too.

Attached Files



#109
paskaal

paskaal

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
Hi, i'm totally new to Mac. I have installed Kalyway perfectly, the only problem is that my sound isn't working. I downloaded this driver and put the kext file in my System/Library/Extensions directory. How do i have to run the install.sh file? If i copy it's content and paste it into Terminal it doesn't work. Can anybody help me? :)

#110
Xargon

Xargon

    InsanelyMac Protégé

  • Members
  • Pip
  • 43 posts

Hi, i'm totally new to Mac. I have installed Kalyway perfectly, the only problem is that my sound isn't working. I downloaded this driver and put the kext file in my System/Library/Extensions directory. How do i have to run the install.sh file? If i copy it's content and paste it into Terminal it doesn't work. Can anybody help me? :)

The same for me :(

#111
nervouschimp

nervouschimp

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 127 posts

The same for me ;)


Just use Kext Helper, it's in the "kool softs" folder in applications, assuming you installed the extras. That should do it for you.

#112
nervouschimp

nervouschimp

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 127 posts

I just recompiled this old driver from Dogbert for 10.5.3, no idea if it still works.

It's for 8738/8768 cards, maybe some other models work too.



Hey thanks! This is working great on 10.5.3 with a Turtle Beach Riviera PCI card! Ignored the installer script and just dropped it on kext helper.

#113
Krazubu

Krazubu

    InsanelyMac Legend

  • Retired
  • 874 posts
Cool :P

#114
asskick

asskick

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
  • Gender:Male
  • Location:Makati, Philippines

I would like to thank dogbert for the work done on the CMi-8738 driver.
I now have sound!! Awesome Thanks! :)


please send me a copy of the driver and the driver installation guide. xo I've been sound-less for a month looking for the CMI 8738 6ch driver.

#115
banhong

banhong

    InsanelyMac Protégé

  • Members
  • Pip
  • 35 posts
  • Location:Thailand
Confirm kext is work well in 10.5.3

#116
RnKstle

RnKstle

    InsanelyMac Protégé

  • Members
  • Pip
  • 30 posts
  • Gender:Male
  • Location:El Salvador, Santa Tecla
  • Interests:Mac
Yes! The Kext works with Leo 10 5 3... no news about the sound in on this chip?

#117
dooododoo

dooododoo

    InsanelyMac Protégé

  • Members
  • Pip
  • 41 posts
5.1 pass thru doesn't work on my diamond 7.1 ddl xs sound card via spdif. any suggestions?

#118
Kotman

Kotman

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
2 Krazubu

Big thanks for the driver! Perfectly works on 10.5.2 Kalyway (vanilla kernel).

Goog luck!!!

#119
johnniecarcinogen

johnniecarcinogen

    Yellow Box

  • Gurus
  • 746 posts
  • Gender:Male

I just recompiled this old driver from Dogbert for 10.5.3, no idea if it still works.

It's for 8738/8768 cards, maybe some other models work too.


Works nicely with my HT Striker 7.1 card (CMI8770) on 10.5.4.

I'm using the SPDIF coax out but only getting 2 channels.

#120
DarkUser89

DarkUser89

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 305 posts
  • Gender:Male
  • Location:Germany / Saarbrücken

I just recompiled this old driver from Dogbert for 10.5.3, no idea if it still works.

It's for 8738/8768 cards, maybe some other models work too.


works perfect on 10.5.4 and Terratec Aureon 5.1 Fun PCI (8738)
OnBoard audio Disable !





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy