Jump to content

New ALC861-VD AppleHDA HDEF audio driver


  • Please log in to reply
16 replies to this topic

#1
Andy Vandijck

Andy Vandijck

    InsanelyMac Deity

  • Coders
  • 1,693 posts
  • Gender:Male
  • Location:Tienen
  • Interests:Programming stuff for Mac OS X...
    Hacking...
    Hard rock (also really big Metallica...
I was so annoyed by the fact that hdapatcher couldn't make a driver mod out of my codec dump that I created a custom one myself...
The new driver supports:
- Internal (built-in) microphone
- External microphone
- Internal (built-in) speakers
- External speakers
It should work for all ALC861-VD cards... (matches to class rather than vendor...)
You can get the new driver from:
http://rapidshare.co...LC861VD_Leo.zip

New version:
- Jack auto detection
- Fixed assertion errors
Download from:
http://rapidshare.co...leHDA_Fixed.zip

I've also devised a solution which doesn't require HDAEnabler for allow AppleHDA to attach properly...
It involves modding the DSDT (renaming "AZLA" or "AZAL" to "HDEF" for enabling it to be shown in System Profiler) and a little EFI string...
<?xml version="1.0" encoding="UTF-8"?>
  <!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
  <plist version="1.0">
  <dict>
	  <key>PciRoot(0x1)/Pci(0x14,0x2)</key>
	  <dict>
		  <key>PinConfigurations</key>
		  <string></string>
		  <key>built-in</key>
		  <string>0x01</string>
		  <key>layout-id</key>
		  <string>0x0000000c</string>
	  </dict>
  </dict>
  </plist>
Replace Pci(0x14,0x2) with the numbers listed in IORegistryExplorer behind the device name (@X).
If it is on a bridge, change it like this: Pci(0x2,0x0)/Pci(0x1,0x2)...
If there is only one number listed, the second is 0x0.

Little piece of proof:
Posted Image

#2
Konami®

Konami®

    InsanelyMac Legend

  • Donators
  • 956 posts
  • Gender:Male
  • Location:Pennsylvania
That's wonderful Andy, I don't have this device, but is nice to see you making improvement in this audio device.

#3
Eddie94

Eddie94

    iDeneb Team Member

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,067 posts
  • Gender:Male
  • Location:Italy
thanks for the driver.
there are some issues:
1)In my laptop the mic doesn't work, i tried to up the volume and use all 2 the tipe of mic.it doesn't work.
2)headphone work correctly but after some time the suond stops and go in veeeeeery low volume.For having normal volume i have to reselct the outpout.
thanks for the drivers.
ps:with the speakers is the sam as the headphones:(

#4
Andy Vandijck

Andy Vandijck

    InsanelyMac Deity

  • Coders
  • 1,693 posts
  • Gender:Male
  • Location:Tienen
  • Interests:Programming stuff for Mac OS X...
    Hacking...
    Hard rock (also really big Metallica...

thanks for the driver.
there are some issues:
1)In my laptop the mic doesn't work, i tried to up the volume and use all 2 the tipe of mic.it doesn't work.
2)headphone work correctly but after some time the suond stops and go in veeeeeery low volume.For having normal volume i have to reselct the outpout.
thanks for the drivers.
ps:with the speakers is the sam as the headphones:(

Too bad... perhaps some ALC861-VD compatibles...
Could you install VoodooHDA and use the bundled getdump utility for your codec dump?
I'd like to see if there are differences... (and adjust accordingly)

#5
Andy Vandijck

Andy Vandijck

    InsanelyMac Deity

  • Coders
  • 1,693 posts
  • Gender:Male
  • Location:Tienen
  • Interests:Programming stuff for Mac OS X...
    Hacking...
    Hard rock (also really big Metallica...

thanks for the driver.
there are some issues:
1)In my laptop the mic doesn't work, i tried to up the volume and use all 2 the tipe of mic.it doesn't work.
2)headphone work correctly but after some time the suond stops and go in veeeeeery low volume.For having normal volume i have to reselct the outpout.
thanks for the drivers.
ps:with the speakers is the sam as the headphones:(

I've done some checking...
The sound does become more silent after about a minute but only after switching outputs...
If however I set the output and reboot...
It stays working perfectly untill the next output change...
Microphone also currently doesn't work yet for me...
I'm analyzing why this is...
At least there is allready a workaround (but no fix yet) for issue 2...
That Voodoo codec dump would really help as it shows all the outputs and connections
If you don't have the needed utilities and VoodooHDA, let me know...

#6
Eddie94

Eddie94

    iDeneb Team Member

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,067 posts
  • Gender:Male
  • Location:Italy
my linux codec dump HERE(post 40).
if i want to use the headphones i have to reboot?
ps:i need the mic!
if you can fix the mic try to fix it and i will try for headphones and mic!
thanks!

#7
mkoo

mkoo

    InsanelyMac Protégé

  • Members
  • Pip
  • 33 posts
I have a Travelmate with Realtek HDA audio. Azalia was working ok for output only.
I've removed Azalia and put VodooHDA. Well.. output working as before, still no input device though i have multiple input devices listed on "input" tab.

Regards.

#8
Andy Vandijck

Andy Vandijck

    InsanelyMac Deity

  • Coders
  • 1,693 posts
  • Gender:Male
  • Location:Tienen
  • Interests:Programming stuff for Mac OS X...
    Hacking...
    Hard rock (also really big Metallica...

my linux codec dump HERE(post 40).
if i want to use the headphones i have to reboot?
ps:i need the mic!
if you can fix the mic try to fix it and i will try for headphones and mic!
thanks!

OK very good...
I'll try to fix up the mic...
I've found a discrepancy in the mic's boost volume...
It seems to be set to 1 where Apple tends to set the value of "boost" mostly to 3...
It could be it is working but not having enough amp to process the signal correct...
I'm working on it though...
I'll convert that Linux codec dump into an svg image showing the nodes on the card (Easier to adapt driver).
I'll get back to you when it works...

#9
来去如风

来去如风

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
I am waitting for this!

#10
Andy Vandijck

Andy Vandijck

    InsanelyMac Deity

  • Coders
  • 1,693 posts
  • Gender:Male
  • Location:Tienen
  • Interests:Programming stuff for Mac OS X...
    Hacking...
    Hard rock (also really big Metallica...

my linux codec dump HERE(post 40).
if i want to use the headphones i have to reboot?
ps:i need the mic!
if you can fix the mic try to fix it and i will try for headphones and mic!
thanks!

I've done some more tests...
If you switch to headphones before plugging them in... it works fine... (no reduction in volume)
If you switch back to internal with headphones plugged in next unplugging them after switch... fine too...
It has to do with the codec activation being autodetected I think... the ALC861-VD tends to mute internal with external plugged in and vice-versa...
Tests on microphone (external) shows it to at least for a time do some movement...
I'll continue testing on various amplification, boost and filtering settings...
Your pathmap of the mic is the same as mine... it is the external mic you need...
Lets hope I can succeed in fixing this last little issue thus...

#11
Eddie94

Eddie94

    iDeneb Team Member

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,067 posts
  • Gender:Male
  • Location:Italy

I've done some more tests...
If you switch to headphones before plugging them in... it works fine... (no reduction in volume)
If you switch back to internal with headphones plugged in next unplugging them after switch... fine too...

YEAH!IT works, i can listen Stone and CoB in my headphones :D , i will wait for the mic!

#12
Eddie94

Eddie94

    iDeneb Team Member

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,067 posts
  • Gender:Male
  • Location:Italy
Andy, some good news?

#13
aliasa_anderson

aliasa_anderson

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 171 posts

I've done some more tests...
If you switch to headphones before plugging them in... it works fine... (no reduction in volume)
If you switch back to internal with headphones plugged in next unplugging them after switch... fine too...
It has to do with the codec activation being autodetected I think... the ALC861-VD tends to mute internal with external plugged in and vice-versa...
Tests on microphone (external) shows it to at least for a time do some movement...
I'll continue testing on various amplification, boost and filtering settings...
Your pathmap of the mic is the same as mine... it is the external mic you need...
Lets hope I can succeed in fixing this last little issue thus...


Hi Andy,

Just wanted to update you that VoodooHDA.kext is out,its opensource so maybe you can get some more ideas from there or help improve it. :D

#14
aliasa_anderson

aliasa_anderson

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 171 posts

I've also devised a solution which doesn't require HDAEnabler for allow AppleHDA to attach properly...
It involves modding the DSDT (renaming "AZLA" or "AZAL" to "HDEF" for enabling it to be shown in System Profiler) and a little EFI string...



Hi Andy,
Could you please advise me on this.
I need to mod only my audio device ,so it is possible to use DSDT for audio device only(leaving other things as it is).

#15
Slice

Slice

    InsanelyMacaholic

  • Local Moderators
  • 3,192 posts
  • Gender:Male
  • Location:Moscow

Download Driver From Here


Download New Drivers For Free

Both links contains only virus...
:)

#16
Zprood

Zprood

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 252 posts
  • Gender:Male
  • Location:CHN

I was so annoyed by the fact that hdapatcher couldn't make a driver mod out of my codec dump that I created a custom one myself...
The new driver supports:
- Internal (built-in) microphone
- External microphone
- Internal (built-in) speakers
- External speakers
It should work for all ALC861-VD cards... (matches to class rather than vendor...)
You can get the new driver from:
http://rapidshare.co...LC861VD_Leo.zip

New version:
- Jack auto detection
- Fixed assertion errors
Download from:
http://rapidshare.co...leHDA_Fixed.zip

I've also devised a solution which doesn't require HDAEnabler for allow AppleHDA to attach properly...
It involves modding the DSDT (renaming "AZLA" or "AZAL" to "HDEF" for enabling it to be shown in System Profiler) and a little EFI string...

<?xml version="1.0" encoding="UTF-8"?>
  <!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
  <plist version="1.0">
  <dict>
	  <key>PciRoot(0x1)/Pci(0x14,0x2)</key>
	  <dict>
		  <key>PinConfigurations</key>
		  <string></string>
		  <key>built-in</key>
		  <string>0x01</string>
		  <key>layout-id</key>
		  <string>0x0000000c</string>
	  </dict>
  </dict>
  </plist>
Replace Pci(0x14,0x2) with the numbers listed in IORegistryExplorer behind the device name (@X).
If it is on a bridge, change it like this: Pci(0x2,0x0)/Pci(0x1,0x2)...
If there is only one number listed, the second is 0x0.

Little piece of proof:
Posted Image




Hi man.Thank for your nice job.Now i update the 10.6.3,and i still use VoodooHDA.kext.But i also have ALC861-VD(ALC862)audio card ,i download the kext you made and install it,everything works perfect but the earphone ,when i get it on my PC ,it does not work .And i add EFI string in the com.apple.boot.plist,modify dsdt.dsl .Here is my Ubuntu Live CD code-dump and dsdt and the PciRoot is PciRoot(0x0)/Pci(0x1b,0x0) ,I hope you can help me .Thank you in advance.
Attached File  codec_dump.txt   8.44KB   12 downloads

Attached File  dsdt.dsl.zip   21.91KB   14 downloads

#17
ytrox

ytrox

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 502 posts
  • Gender:Male
  • Location:Italy
HI anv, how did you got auto-detection?





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy