Jump to content

Gigabyte T1028M As a Netbook Tablet Mac?


  • Please log in to reply
31 replies to this topic

#1
Legolover64

Legolover64

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
Hey all,

I am pretty much hooked on getting the Gigabyte Touchnote T1028M tablet netbook. It's got everything I need, and it's pretty darn affordable.

However, I'm very comfortable with OS X, and I was wondering how possible it would be to get a Hackintosh running on this machine? I cannot get anyone full specs at the moment, but I do have this page from UMPCPortal;

http://www.umpcporta.....8M TouchNote/

This is the M912 thread from this very forum:

http://www.insanelym...mp;#entry934881

If anyone has any ideas/suggestions, please don't hesitate to post them!

As far as OS X on an Atom goes, are people's experiences generally positive? I'm going to be running XCode and Terminal on this machine a lot, doing development work, as well as tablet interface testing. Do Atoms boot fast? Will this netbook sleep well (maybe depends on the device)? How about purchasing a solid state disk: can anyone recommend me a good manufacturer/model that works well with OS X?

And for installation methods, what seems to work best for this type of solution? I have a Leopard disk, so I guess I could try Boot-132, but I also have the MSIWindOSX image. Which would work better? What are the pros and cons of each?

Thanks in advance!

#2
Synaesthesia

Synaesthesia

    InsanelyMacaholic

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,168 posts
  • Gender:Male
  • Location:South Africa
It should work, but I don't know about everything - ethernet, sound, sleep etc. Use the MSIWindOSX Image, it's probably the easiest.

Atoms are not the fastest processors in the world, but you can use them for development.

#3
Legolover64

Legolover64

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
Thanks for the response! I have several more questions for anyone who can comment:

1) Will MSIWindOSX allow me to do Software Update? I want to be able to get the latest and greatest OS.
2) How do I know if the onboard wifi will work? Is "Atheros" good or bad? If it doesn't work, can I take an old MacBook and gut its Airport card? Will this include a bluetooth module on that PCIe card?
3) What are the good SSD manufacturers for drives that can actually sleep?

#4
robertadam

robertadam

    InsanelyMac Protégé

  • Members
  • Pip
  • 15 posts
  • Gender:Male
  • Location:Eire
Hi, got T1028 working with Leo4all 10.5.4 and did to .5 , just go with dafault option.


Most important thing is you can have a touchscreen from http://home.eeti.com.../eg/drivers.htm and its for free ;)

QE working also with 950 driver,but have problem with sound, system can see this as a hd out-with no sound anyway, was trying audieee way, no results, i am on voodo kernel as i know it. can anybody turn a light for me? a little...:unsure:

Ps. Cant update system to .6, will go thru and after restert will newer stop restarting, so fast so i cant even see whats is wrong with it, any ideas? just asking :D Thanks for such a great forum, and people around :D

#5
Cherimoya

Cherimoya

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts

Hi, got T1028 working with Leo4all 10.5.4 and did to .5 , just go with dafault option.


Most important thing is you can have a touchscreen from http://home.eeti.com.../eg/drivers.htm and its for free :)

QE working also with 950 driver,but have problem with sound, system can see this as a hd out-with no sound anyway, was trying audieee way, no results, i am on voodo kernel as i know it. can anybody turn a light for me? a little... :tomato:

Ps. Cant update system to .6, will go thru and after restert will newer stop restarting, so fast so i cant even see whats is wrong with it, any ideas? just asking :angel: Thanks for such a great forum, and people around :P


Well you're further on than me. This is my fourth Hackint0sh project and I've never had so many problems.

I can't get the DVD to load at all - it fails with the message about not getting control of the USB bus from BIOS - I've tried three different distros all of which load on my Wind

I tried the HDD from my Wind - just constantly reboots

The T1028 won't boot at all from a USB stick.

The BIOS is crappy with virtually no parameters to change.

So I'm stuck - any pointers ?

(It's a really cool machine, BTW, even with XP!)

#6
Cherimoya

Cherimoya

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
I finally managed to get a minimal install working by installing it as an external drive on my Wind and then swapping it with the internal drive.

Using iAtkos 10.5.5 with Voodoo kernal and Chameleon

Now I need to see if i can get everything working.

#7
robertadam

robertadam

    InsanelyMac Protégé

  • Members
  • Pip
  • 15 posts
  • Gender:Male
  • Location:Eire

Well you're further on than me. This is my fourth Hackint0sh project and I've never had so many problems.

I can't get the DVD to load at all - it fails with the message about not getting control of the USB bus from BIOS - I've tried three different distros all of which load on my Wind

I tried the HDD from my Wind - just constantly reboots

The T1028 won't boot at all from a USB stick.

The BIOS is crappy with virtually no parameters to change.

So I'm stuck - any pointers ?

(It's a really cool machine, BTW, even with XP!)




Try Leo4all its a only distro working for me with no usb dvd problems.Its a 10.5.4 distro, then just get a modified .5 package, go Voodoo after this, update kext,install 950ea video driver(dont remember exact name, there is only 2 of them) and u have fully working 10.5.5 distro with no sound,cam and wifi.Got 10.5.6 working with every updates, but this is a little tricky.Let me know if u r still in project, will post more updates.Cheers

#8
Cherimoya

Cherimoya

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
Yes I'm still at it but haven't had much time this week.

I am making some progress; ethernet, USB (new IOUSBFamily kext) and graphics (inc CI/QX) are now all working.

Do you have working Fn keys ? - I think I have a problem with the WiFi and my 3G card not powering on.

#9
robertadam

robertadam

    InsanelyMac Protégé

  • Members
  • Pip
  • 15 posts
  • Gender:Male
  • Location:Eire

Yes I'm still at it but haven't had much time this week.

I am making some progress; ethernet, USB (new IOUSBFamily kext) and graphics (inc CI/QX) are now all working.

Do you have working Fn keys ? - I think I have a problem with the WiFi and my 3G card not powering on.





yes fn keys will work as a control goes from bios not a system so everything except wi fi will work, have no 3g so cant really say anything about.As i said will sudgest u to go with leo4all, no problem up to 10.5.5, with 10.5.6 need to work from terminal, just a couple days ago tried .7.... no comment so far eh.Have U got any solution for sound?System can see this as hd out , volume works but no sound in any way, even from output ;) may go wit hardware mod, just get a usb mini sound card for 3 euro and try it, or will wait for some progress with soft... will see.now just need to swap wifi for some dell and I will have the nicest osx tablet :P cheers

Ps. if u go with leo, just make sure u tick USB2.0 and Powermanagement-Laptops, no need any driver for BT, just press fn once installed system and will come to life :)

#10
Cherimoya

Cherimoya

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
My plan is to get as much working as possible and then to do a clean install - I'll probably use Leo for that.

Anyway, the good news is I got sound partially working with the VoodooHDA kext - speakers and headphone jack both work and automatically switch when the headphones are plugged in. Mic doesn't see to be working although it is recognized and seems to register some input but not enough to hear back.

I also got my 3G card working by modding a Huawei kect with the vendor and device id.

All in all, it's getting to be pretty useable now. :P

#11
robertadam

robertadam

    InsanelyMac Protégé

  • Members
  • Pip
  • 15 posts
  • Gender:Male
  • Location:Eire

My plan is to get as much working as possible and then to do a clean install - I'll probably use Leo for that.

Anyway, the good news is I got sound partially working with the VoodooHDA kext - speakers and headphone jack both work and automatically switch when the headphones are plugged in. Mic doesn't see to be working although it is recognized and seems to register some input but not enough to hear back.

I also got my 3G card working by modding a Huawei kect with the vendor and device id.

All in all, it's getting to be pretty useable now. :)



cant get sound, was trying everything, only hd audio in profile but no sound :( this is the last thing for me to do, no need for cam ok will try something this afternoon( instead of going for disco ehhh whats wrong with me ;)




ok got sound working- me idiot- forgot to remove azalia :) just need to swap for wi fi and everything working, can control with a finger or two:) nice and soft touchscreen :) LOL

#12
Cherimoya

Cherimoya

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
I swapped in a Dell Wifi Card so now that's working. The two problems were

1) The atheros card is a half length card and what I think is a heat sink protrudes into the area where a full length card goes. I isolated the back of the Dell Card and put it on top which seems to work ok. A half length card would be better

2) On my set up the Fn key is not sending a power on to the WiFi card. I solved this by taping Pin 20 to force power on. I can switch it on and off using the airport control in the menu bar.

If you weren't using a 3G PCI card, you could potentially put the WiFi card in that slot - this does power on and off via the Fn keys for me.

So like you I'm pretty happy with it now. Safari 4 seems made for a touch screen which makes me wonder what's coming from Apple ;)

#13
robertadam

robertadam

    InsanelyMac Protégé

  • Members
  • Pip
  • 15 posts
  • Gender:Male
  • Location:Eire
:D enjoy Your mac tablet sensibly :)

#14
Legolover64

Legolover64

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
Wow, I'm surprised all this progress has been made!

Any way to do Boot-132 for this, or is Leo4All still the best option? What kind of battery do people get? Anyone rocking 10.5.7? Camera working?

If anyone can let me know all the kexts I'd need, I'm assuming WiFi is probably a crapshoot...

Thanks again!

#15
robertadam

robertadam

    InsanelyMac Protégé

  • Members
  • Pip
  • 15 posts
  • Gender:Male
  • Location:Eire

Wow, I'm surprised all this progress has been made!

Any way to do Boot-132 for this, or is Leo4All still the best option? What kind of battery do people get? Anyone rocking 10.5.7? Camera working?

If anyone can let me know all the kexts I'd need, I'm assuming WiFi is probably a crapshoot...

Thanks again!





Ok so- 10.5.7 Is working with some new kexts, no cam :) affraid my friend but the rest of hardware is rockin... :) updated to the latest soft via upd site,using 4 cell battery, never went to Boot-123 have a big brother AMD so always was with leo in touch,and of course no Atheros driver at the moment,PM me if u need a kext or two :blink:

#16
Legolover64

Legolover64

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts

Ok so- 10.5.7 Is working with some new kexts, no cam :( affraid my friend but the rest of hardware is rockin... :) updated to the latest soft via upd site,using 4 cell battery, never went to Boot-123 have a big brother AMD so always was with leo in touch,and of course no Atheros driver at the moment,PM me if u need a kext or two :)


Awesome, thanks for the update! I'm assuming the update from 10.5.X to 10.5.7 on Leo4All is pretty idiot-proof hopefully? I am currently in the process of... obtaining it, but that's a pretty slow process unfortunately. Hopefully it'll be done shortly so I can attempt to install it!

I would try Boot-132, but alas, I lent my Leopard Family Pack disk out to a friend, and that was the last I saw of it :). I will try and contact someone, I hope the process would be as simple with Boot-132?

As far as ACPI goes, does it sleep? If I replace the HDD with an SSD, will it still sleep? I bought an SSD for this computer, and I'd really like to use it. What's the install footprint of OS X? Do the speakers, headphone jack, mic jack and microphone all work? All the fn keys? VGA out? Does the SDHC slot work? Bluetooth? Multitouch on the trackpad (two and three fingers?) If I switch out the WiFi with an Airport card from a MacBook or a Dell card, will the toggle still work? The hardware toggle, I mean. Does numloc work? Do all the USB ports work? What does the "lock" switch do? How about the "Smart Panel" button? Is there any way to interpret that with USB Overdrive or something? Does ExpressCard work?

Sorry for all the questions! I just want to make sure that everything will work. I think I may take you up on that kext offer, expect a possible PM from me shortly :).

Thanks again guys!

#17
Legolover64

Legolover64

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
Ugh, on Leo4All version 3, I'm stuck on "Still waiting for root device." Any tips for BIOS stuff? I'm using an IOMEGA CD/DVD drive, who knows...

#18
robertadam

robertadam

    InsanelyMac Protégé

  • Members
  • Pip
  • 15 posts
  • Gender:Male
  • Location:Eire

Ugh, on Leo4All version 3, I'm stuck on "Still waiting for root device." Any tips for BIOS stuff? I'm using an IOMEGA CD/DVD drive, who knows...



hmmm strange have an external lg dvd and no problem try go to bios and in advance>ide configuration>legacy/native if this wont work


try to get new bios firmware, just google t1028 bios seems like only change is from sata to ide combined mode, this may help.let me know about progress will send you some kexts after.cheers

#19
Legolover64

Legolover64

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
I'm downloading the F04 BIOS now, but the only changes (as per Gigabyte's site) seem to be "Support Multi KB language" so I don't know how much that will help? What version are you running robertadam?

Also, when you told me to switch between legacy/native, which one is yours set to? I am confused about which setting I should use. I am getting another USB CD/DVD drive today, and I found a newer Leo4All (it calls itself "version 5") that I'm downloading to hopefully get it to work. I was unable to find the version you mentioned.

With Legacy AND Native I get "Still waiting for root device" so I am very confused now.

Thanks for all your help!

#20
robertadam

robertadam

    InsanelyMac Protégé

  • Members
  • Pip
  • 15 posts
  • Gender:Male
  • Location:Eire

I'm downloading the F04 BIOS now, but the only changes (as per Gigabyte's site) seem to be "Support Multi KB language" so I don't know how much that will help? What version are you running robertadam?

Also, when you told me to switch between legacy/native, which one is yours set to? I am confused about which setting I should use. I am getting another USB CD/DVD drive today, and I found a newer Leo4All (it calls itself "version 5") that I'm downloading to hopefully get it to work. I was unable to find the version you mentioned.

With Legacy AND Native I get "Still waiting for root device" so I am very confused now.

Thanks for all your help!

as i aid the only ver. of leo working for ma was 10.5.4 and nothing after , even newer leo itself, i am on native, ide mode at the moment,strange becouse leo was working before update also, but just try it, will post u some stuff so just keep an eye on mailbox :(





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   Web hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy