Jump to content

VoodooHDA


  • Please log in to reply
363 replies to this topic

#261
BlueL

BlueL

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
ok, so I have a somewhat similar problem with my audio....
When I was running Leopard 10.5.7, both the AppleHDA and VoodooHDA had good output, volume sliders worked, but no inputs... ;)
Then I upgraded to Snow Leopard 10.6.3, and now I have even more sound kext problems. I used VoodooHDA 0.2.2 and the sound output works, but nothing else - no volume controls, no inputs, nothing else... I tried the 0.2.61 / 0.2.62 mods and I can adjust the sliders, but no sound comes out. The inputs work fine, well the mic in does anyway....
So my thing is I need to know how I need to mod which drivers to make all of the following happen:
a ) sound output (goes w/o saying)
b ) volume sliders to work correctly
c ) mic input to work as well
So if there was some way I could pluck the output portion of the 0.2.2 driver and replace only that portion and merge it with 0.2.6x I'd be in good shape.

My audio dump is attached if anyone would take a look and point me in the right direction that'd be great! Oh, BTW, my audio hardware is on-board IDC 92HD202/6 the HDMI output is disabled via Bios (mobo ECS GF8200a v1.0 w latest fw). That leaves 4 analog output jacks (8ch) and mic-in line-in at the rear; front headphone jack and front mic input as well.

PLS pls help! I've worked on this problem feverishly for over 2 days w no progress. Just lots of KP's and reboots.

Attached Files



#262
hackintosh7

hackintosh7

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
Hi,

Are there any VoodooHDA kexts that work for the Acer Aspire 8930-6442. I am trying to configure Snow Leopard 10.6.3 and I have had some luck getting sound to work. My built-in mic is not recognized nor is the full 5.1 surround sound. I can get the front speakers to work.

I'd be grateful for any help.

#263
BlueL

BlueL

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts

ok, so I have a somewhat similar problem with my audio....
When I was running Leopard 10.5.7, both the AppleHDA and VoodooHDA had good output, volume sliders worked, but no inputs... :unsure:
Then I upgraded to Snow Leopard 10.6.3, and now I have even more sound kext problems. I used VoodooHDA 0.2.2 and the sound output works, but nothing else - no volume controls, no inputs, nothing else... I tried the 0.2.61 / 0.2.62 mods and I can adjust the sliders, but no sound comes out. The inputs work fine, well the mic in does anyway....
So my thing is I need to know how I need to mod which drivers to make all of the following happen:
a ) sound output (goes w/o saying)
b ) volume sliders to work correctly
c ) mic input to work as well
So if there was some way I could pluck the output portion of the 0.2.2 driver and replace only that portion and merge it with 0.2.6x I'd be in good shape.

My audio dump is attached if anyone would take a look and point me in the right direction that'd be great! Oh, BTW, my audio hardware is on-board IDC 92HD202/6 the HDMI output is disabled via Bios (mobo ECS GF8200a v1.0 w latest fw). That leaves 4 analog output jacks (8ch) and mic-in line-in at the rear; front headphone jack and front mic input as well.

PLS pls help! I've worked on this problem feverishly for over 2 days w no progress. Just lots of KP's and reboots.


Update to my own posting, so someone can find some useful info... The auto detect function on 0.2.61 seems to be a little flaky, but this is what I've done to make it work. Using bootloader Chameleon RC5 Pre11 seemed to bring the devices to recognition, but when I don't have sound still I just plug any ol' thing into my front panel inputs (headphones/front mic), wait a few mins and then unplug again... This usually fixes the audio jack detection and the rear outputs begin to work along with rear mic input. Hope this little trick works for some of you out there as well... not exactly sure why, but it does.
... now if I could only figure out why the slides don't work (except inside system preference - sound) I'll be a very happy camper. Neither my keyboard shortcuts nor the tray icon volume slider works as of yet. When I find out why, I'll let you know.

#264
sirbow2

sirbow2

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 728 posts
  • Gender:Male
has anyone found a fix for a alcxxx that will only play sound correctly if the mouse is being moved consantly?

#265
TheDon

TheDon

    InsanelyMac Protégé

  • Members
  • PipPip
  • 98 posts
Whats the fix for the crackly noise with the audio?

#266
exiva

exiva

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
I'm having issues with VoodooHDA 0.2.61 on 10.6.2 and I'm having a problem with audio crackling fading in and out. I've got a getdump as well as a copy of my Info.plist attached.

Also when I start my machine up, after chameleon loads until the OS loads my Microphone input goes to maximum, with monitor enabled, so I endup getting extreme feedback. This also happens after I wake up the machine. How can I fix this as well?

My machine is an Asus 900a, Intel Atom.

Attached File  audio_dump.txt   28.4KB   30 downloads
Attached File  Info.plist.txt   3.69KB   28 downloads

#267
jwebb

jwebb

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts
Hello

I am using VoodooHDA w Prefpane, and I want to change the iMix setting permanently, or write an AppleScript which will change the setting on startup. Is that possible?

#268
TimeShift

TimeShift

    InsanelyMac Protégé

  • Members
  • PipPip
  • 96 posts
  • Gender:Male
  • Location:Porto Alegre, RS - Brazil
The Voodoo posted on that googlecode website is old.

I've downloaded 0.2.52 and my sound is working great on a P5Q-E

#269
Shazu

Shazu

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts
Anyone know if this works with Auzentech X-Fi Prelude 7.1 PCI card? :P

#270
drule

drule

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 147 posts
Well my audio was working for a bit, but started 'gapping' out for the past day and has now gone completely. At first I thought it may be the sound chip (stac9220/3 on D945GCZ ICH7 mb) because it was gone in Windows as well. But I remembered that I had to change the cable plug positions from their original layout to get it in OSX, so I put them back to their regular plugs and it was working in WinXP.

So .... anybody have a STAC9220 or STAC9223 hacked AppleHDA or VoodooHDA kext? :)

#271
Arths

Arths

    InsanelyMac Protégé

  • Members
  • PipPip
  • 97 posts
  • Gender:Male
  • Location:France
Hey, my front panel plugs cannot be plugged on my MB. So on Windows I disabled checking of them and rear plugs work. But is it possible to do the same with OSX? Disabling Front plugs, using only rear? :(
Thanks :)

#272
Riby

Riby

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
Hi! I just installed my Snow Leopard and tried to get sounds working. I tried to install VoodooHDA (tried both versions), but the ##### just tells me that it can't use the extension and that it's installed wrong. What should I do? My mobo is Asus P7P55D.

#273
steenamaroo

steenamaroo

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 115 posts
  • Gender:Male
  • Location:U.K.
  • Interests:Audio Production.
you should chmod+chown the kext, then load it.


just to let everyone know, i have a working vostro1500 stac9205 voodoohda now, WITH digital out,

so if anyone needs that, shout me...


quick question tho.....

does anyone know if encoded digital passthrough is possible with spdif and voodoohda?

i had it working with applehda in leopard ( outputs showed as "Built-in Digital Output" and "Built-in Digital Output (encoded)" in VLC.

I've even changed the snow leopard device name "SPDIF out (orange)" to "Built-in Digital Output" incase that was related, but still no sign of encoded out....

thanks in advance everyone!

#274
ogr

ogr

    InsanelyMac Protégé

  • Members
  • PipPip
  • 60 posts
Hello, i have a MSI GT640 laptop and there is a alc888s sound card i gues becouse the drivers are named ALC888s,
so far i tried every VoodooHda kext from oldest to latest without luck , the latest gives me 4 HDMI audio outputs but no sound.Could someone please help me with this Problem , i would be veeery greatfull

Regards Oliver

#275
Biovital

Biovital

    InsanelyMac Protégé

  • Members
  • Pip
  • 49 posts
I asked this earlier way way back but no one has answered so I'll try again: Does anyone have SPDIF-out working with ALC888 on a gigabyte GA-P35-DS3L or even SPDIF on ALC888 on any other mobo? Analog out works fine, but I cannot get any sound thru SPDIF. I can hear a slight hiss whenever I play one of the sound effects in the Sound options in Preferences.

I have a Logitech Z680, and I hooked up a DVD player with SPDIF out and it works, so I dont think its the Logitech itself. But I would really really like to get SPDIF out working.

#276
Biovital

Biovital

    InsanelyMac Protégé

  • Members
  • Pip
  • 49 posts
Whoa. I just plugged in my spdif again, and I'm getting audio. However it is extremely distorted. And I only get audio thru itunes, quicktime and imovie. Dont get any thru Safari or Firefox when on youtube or something. Also the sound effects in Sound Preferences dont play. They play fine when Im using analog connection, but for some reason I'm only getting the center speaker.

edit:

IT WORKS!

HAHAHA, glorious sound again! Ok, the sound cracking/distortion was absoutely terrible. But on a hunch I went to Audio MIDI setup in Apps/Utils and played around with some settings. I had it set on 2-CH 32bit. I keep the frequency to 48khz, and changed the 2-CH 32bit to 2-CH 16bit. Et Voila, beautiful sound thru Itunes, Imovie, Quicktime, basically all audio.

So if you're getting horrid cracking/distortion make SURE you set the output to a frequency/bitrate your ALC allows.

Attached Files



#277
steenamaroo

steenamaroo

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 115 posts
  • Gender:Male
  • Location:U.K.
  • Interests:Audio Production.
congrats!

when you go to audio midi setup,,,

go to where you have the option for 16 bit and 24 bit...


is there an option for 'encoded digital output'?


thanks!

#278
Biovital

Biovital

    InsanelyMac Protégé

  • Members
  • Pip
  • 49 posts
Sorry but no, at least not for me. I attached a screenshot of what it looks like for me.

#279
steenamaroo

steenamaroo

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 115 posts
  • Gender:Male
  • Location:U.K.
  • Interests:Audio Production.
damn,,,that's a shame :D


i've been trying to get encoded output for weeks now......it's just not happening.


i've even put my pin configs into dsdt.....duno if there's any point, but system profiler reports everything perfectly + voodoohda works perfectly...

BUT NO encoded output :P:(


i wish i could get applehda to work instead.......at least i know encoded output works with it.....

but i've never been able to get any sound at all with applehda on the laptop.

#280
re3

re3

    InsanelyMac Protégé

  • Members
  • Pip
  • 30 posts
When i update 10.6.4 is possible for me change the volume with the key and the sound level adjust automatically when i log in... sry for my bad english
i'm using VoodooHDA 2.6.2 take from here http://www.nawcom.co...x86/files/10.6/





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy