Jump to content

Realtek ALC1200 ICH10 working kext on Yosemite 10.10 from 10.6+

realtek alc1200 mountain lion kext audio dsdt snow leopard

  • Please log in to reply
571 replies to this topic

#461
nervegrind3r

nervegrind3r

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts
hey all, could really use some help. I did my nl install using this guide p5q install, and everything works but sleep and of course, my sound. After I installed, I successfully updated to 10.6.5. Then I tried to get sound working but have had no luck. I have read this entire thread, and tried every kext combination, but I cannot get any sound to work. The closest I get is for Intel high Definition audio with ID:12 to be listed, which was mentioned several times in this thread, but never with a working solution. Please see the attachments below. Im at a loss unless sound is just not compatible with 10.6.5 and my pq5-em mobo. Rest of my specs are in signature. I saw a few people posted their dsdt.aml file (just rename from txt to aml), so I attached that as well. If someone can help, it would really be appreciated.

thanks all!

Attached Files



#462
long59502

long59502

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
thank you i'm from china

#463
protivakid

protivakid

    InsanelyMac Protégé

  • Members
  • Pip
  • 19 posts
I CAN NOT get this to work on my P6T SE as far as audio goes! I installed Snow Leopard 10.6.0 then ran the updates to 10.6.5 afterwards trying to install these kexts using kexthelper and other methods ALL DAY! Which file of the downloads listed on page 1 do I need and what is the step by step to get them into 10.6.5? Thanks ;). PS In system profiler I get "Audio ID: 12" currently.

#464
Roman_77

Roman_77

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
Hi all!
I have M-Audio Audophile 2496 on ASUS P5Q with drivers from http://www.audio-evo...on.com/drivers/. Everything is OK!

The question is: is it possible to have both M-Audio Audiphile 2496 and integrated audio working? I try kext from this topic but no success.

Any advice?

Thanx,
Roman

#465
Jemmyuk

Jemmyuk

    InsanelyMac Protégé

  • Members
  • Pip
  • 22 posts

A fast way...
fireup your termial and digit:
sudo perl -pi -e 's|\x85\x08\xec\x10|\x88\x08\xec\x10|g' /System/Library/Extensions/AppleHDA.kext/Contents/MacOS/AppleHDA
Credits to aschar on projectosx.

Also I use this in my P6T SE (ALC1200)

Device (HDEF)        {            Name (_ADR, 0x001B0000)            Method (_DSM, 4, NotSerialized)            {                Store (Package (0x10)                    {                        "subsystem-id",                         Buffer (0x04)                        {                            0xA0, 0x00, 0x00, 0x00                        },                         "subsystem-vendor-id",                         Buffer (0x04)                        {                            0x6B, 0x10, 0x00, 0x00                        },                         "codec-id",                         Buffer (0x04)                        {                            0x88, 0x08, 0xEC, 0x10                        },                         "layout-id",                         Buffer (0x04)                        {                            0x0C, 0x00, 0x00, 0x00                        },                         "device-type",                         Buffer (0x08)                        {                            "ALC1200"                        },                         "model",                         Buffer (0x10)                        {                            "Realtek ALC1200"                        },                         "built-in",                         Buffer (One)                        {                            0x00                        },                         "PinConfigurations",                         Buffer (Zero) {}                    }, Local0)                DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))                Return (Local0)            }        }

OR SSDT version for new bootloader..
DefinitionBlock ("SSDT-4.aml", "SSDT", 1, "APPLE", "HDEF", 0x00001000){    External (DTGP, MethodObj)    // 1 Arguments    External (\_SB_.PCI0, DeviceObj)    Scope (\_SB.PCI0)    {        Device (HDEF)        {            Name (_ADR, 0x001B0000)            Method (_DSM, 4, NotSerialized)            {                Store (Package (0x10)                    {                        "subsystem-id",                         Buffer (0x04)                        {                            0xA0, 0x00, 0x00, 0x00                        },                         "subsystem-vendor-id",                         Buffer (0x04)                        {                            0x6B, 0x10, 0x00, 0x00                        },                         "codec-id",                         Buffer (0x04)                        {                            0x88, 0x08, 0xEC, 0x10                        },                         "layout-id",                         Buffer (0x04)                        {                            0x0C, 0x00, 0x00, 0x00                        },                         "device-type",                         Buffer (0x08)                        {                            "ALC1200"                        },                         "model",                         Buffer (0x10)                        {                            "Realtek ALC1200"                        },                         "built-in",                         Buffer (One)                        {                            0x00                        },                         "PinConfigurations",                         Buffer (Zero) {}                    }, Local0)                DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))                Return (Local0)            }        }    }}

Of course the Legacy in /Extra/Extensions/

Fabio

Edit

The P6T Deluxe have a AD2000b



Hi Fabio

I wanted to ask you. I have a working sound in stereo on Asus P6TSE using the AppleHDA kext. I am on 10.6.5 now. Will I be able to get 5.1 or 7.1 surround sound via analog connections using your method or does it only work with digital output. My surround sound system has 5.1 analog surround using 3 3.5 mm connectors which work brilliantly with windows installed on same system but only get 2 speakers output on mac.

Thanks

Jemmy

#466
Akamatsu

Akamatsu

    InsanelyMac Protégé

  • Members
  • PipPip
  • 55 posts
  • Gender:Male
  • Location:Sachsen
@nervegrind3r

test the 10.6.0/10.6.1 driver for the ALC 1200
GL

Attached Files



#467
ExodusNirvana

ExodusNirvana

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 8 posts
I installed the kext in the 2nd method but no sound through the HDMI (using my TV for audio and monitor here...)

I'm using the Radeon 4830 on a P5Q Pro with ALC1200...Snow Leopard 10.6.5

Any suggestions?

#468
TatesMan

TatesMan

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
  • Gender:Male
Does the the 10.6.3 kext works on 10.6.6?

#469
maumi1987

maumi1987

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts
@tatesman: i made the update yesterday and sound is still working. the update hasn't overwritten the applehda.kext, so i needn't reinstall sound driver. in my case, sounds working better than before, because a little feature i missed is working again.

#470
orionquest

orionquest

    InsanelyMac Protégé

  • Members
  • Pip
  • 25 posts
Hi great driver. I have a P6T and was wondering if the rest of the 1/8 outs will be supported? I have surround sound speakers which need the 3 outs to directly play 5.1 sound.

Thanks

oq

#471
TatesMan

TatesMan

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
  • Gender:Male

@tatesman: i made the update yesterday and sound is still working. the update hasn't overwritten the applehda.kext, so i needn't reinstall sound driver. in my case, sounds working better than before, because a little feature i missed is working again.

Thanks a lot!

I can confirm that the 1063 kext works fine on 10.6.6!

#472
Tony-B.

Tony-B.

    InsanelyMac Protégé

  • Members
  • PipPip
  • 62 posts
  • Gender:Male
  • Location:Italy - Vicenza
I'm not able to run this kext in my computer, whant can I try?

#473
Scorxcho

Scorxcho

    InsanelyMac Protégé

  • Members
  • Pip
  • 35 posts
  • Gender:Male
Hey I just wanted to say great job, and keep up the great work!

But I have ALC1200, have tried both methods, and it will not work! :D

The sound finally shows up, but when I try to play any type of sound, no output happens...

Any ideas?

Thanks

#474
xpertvision

xpertvision

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 220 posts

I installed the kext in the 2nd method but no sound through the HDMI (using my TV for audio and monitor here...)

I'm using the Radeon 4830 on a P5Q Pro with ALC1200...Snow Leopard 10.6.5

Any suggestions?



yes , your soundcard have nothing to do with that problem

when you connect HDMI cable its your graphic card that makes the sound (HD RADEON cards have a soundcard incorporated , in windows you can see that in sound properties)

try to fix your graphic card kext for a better one

#475
Justin6920G

Justin6920G

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
Can't figure out for the life of me whats wrong. I am getting the slider but no sound. Profiler says there is no hardware even though I can pick which port is used for output.



Using an ASUS M4A79 Deluxe. It also claims to be an ALC1200 on the ASUS site but in Windows DEV is 0888?

#476
pauℓzurrr.

pauℓzurrr.

    Paul

  • Members
  • PipPipPipPipPipPipPip
  • 552 posts
  • Gender:Male
  • Location:Amsterdam

hey all, could really use some help. I did my nl install using this guide p5q install, and everything works but sleep and of course, my sound. After I installed, I successfully updated to 10.6.5. Then I tried to get sound working but have had no luck. I have read this entire thread, and tried every kext combination, but I cannot get any sound to work. The closest I get is for Intel high Definition audio with ID:12 to be listed, which was mentioned several times in this thread, but never with a working solution. Please see the attachments below. Im at a loss unless sound is just not compatible with 10.6.5 and my pq5-em mobo. Rest of my specs are in signature. I saw a few people posted their dsdt.aml file (just rename from txt to aml), so I attached that as well. If someone can help, it would really be appreciated.

thanks all!


I'm having the same problem! Does this kext work with 10.6.6?

#477
acehigh

acehigh

    InsanelyMac Protégé

  • Members
  • Pip
  • 15 posts

Thanks a lot!

I can confirm that the 1063 kext works fine on 10.6.6!


The 1063 kext works also on 10.6.7!

#478
mathq

mathq

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 212 posts
  • Gender:Male
  • Location:Quebec
I have that card

00:1b.0 Audio device [0403]: Intel Corporation 82801JD/DO (ICH10 Family) HD Audio Controller [8086:3a6e] (rev 02)

Which I think is an ALC1200 but I can't get it to work.
Any help?

Thank you

PS: It is a Asus P5QL-VM Do motherboard

#479
wolodya

wolodya

    InsanelyMac Protégé

  • Members
  • Pip
  • 36 posts

I have that card

00:1b.0 Audio device [0403]: Intel Corporation 82801JD/DO (ICH10 Family) HD Audio Controller [8086:3a6e] (rev 02)

Which I think is an ALC1200 but I can't get it to work.
Any help?

Thank you

PS: It is a Asus P5QL-VM Do motherboard

Attached File  AppleHDA.kext.zip   1.49MB   254 downloads

#480
PhillOS

PhillOS

    InsanelyMac Protégé

  • Members
  • Pip
  • 18 posts
Im still struggeling to get this working.

Specs: Vanilla Snow Leopard updated to 10.6.7
on P6T SE with i7 920, and a GTX295

Here's a list of the kext's i currently have in S/L/E

[codebox]ACard62xxM.kext
ACard68xxM.kext
ACard671xSCSI.kext
ACard6280ATA.kext
ACard6885M.kext
ACard67162.kext
Accusys6xxxx.kext
ALF.kext
Apple_iSight.kext
Apple16X50Serial.kext
AppleACPIPlatform.kext
AppleAHCIPort.kext
AppleAPIC.kext
AppleBacklight.kext
AppleBluetoothMultitouch.kext
AppleBMC.kext
AppleEFIRuntime.kext
AppleFileSystemDriver.kext
AppleFSCompressionTypeZlib.kext
AppleGraphicsControl.kext
AppleGraphicsPowerManagement.kext
AppleHDA.kext
AppleHIDKeyboard.kext
AppleHIDMouse.kext
AppleHPET.kext
AppleHWSensor.kext
AppleIntelCPUPowerManagement.kext
AppleIntelCPUPowerManagementClient.kext
AppleIntelGMA950.kext
AppleIntelGMA950GA.plugin
AppleIntelGMA950GLDriver.bundle
AppleIntelGMA950VADriver.bundle
AppleIntelGMAX3100.kext
AppleIntelGMAX3100FB.kext
AppleIntelGMAX3100GA.plugin
AppleIntelGMAX3100GLDriver.bundle
AppleIntelGMAX3100VADriver.bundle
AppleIntelHDGraphics.kext
AppleIntelHDGraphicsFB.kext
AppleIntelHDGraphicsGA.plugin
AppleIntelHDGraphicsGLDriver.bundle
AppleIntelHDGraphicsVADriver.bundle
AppleIntelIntegratedFramebuffer.kext
AppleIRController.kext
AppleKeyswitch.kext
AppleLPC.kext
AppleLSIFusionMPT.kext
AppleMatch.kext
AppleMCCSControl.kext
AppleMCEDriver.kext
AppleMCP89RootPortPM.kext
AppleMIDIFWDriver.plugin
AppleMIDIIACDriver.plugin
AppleMIDIRTPDriver.plugin
AppleMIDIUSBDriver.plugin
AppleMikeyHIDDriver.kext
AppleMobileDevice.kext
AppleMultitouchDriver.kext
AppleOnboardDisplay.kext
ApplePlatformEnabler.kext
AppleProfileFamily.kext
AppleRAID.kext
AppleRAIDCard.kext
AppleRTC.kext
AppleSDXC.kext
AppleSEP.kext
AppleSmartBatteryManager.kext
AppleSMBIOS.kext
AppleSMBusController.kext
AppleSMBusPCI.kext
AppleSMC.kext
AppleSMCLMU.kext
AppleStorageDrivers.kext
AppleTyMCEDriver.kext
AppleUpstreamUserClient.kext
AppleUSBDisplays.kext
AppleUSBEthernetHost.kext
AppleUSBMultitouch.kext
AppleUSBTopCase.kext
AppleVADriver.bundle
AppleXsanFilter.kext
ArcMSR.kext
ATI1300Controller.kext
ATI1600Controller.kext
ATI1900Controller.kext
ATI2400Controller.kext
ATI2600Controller.kext
ATI3800Controller.kext
ATI4600Controller.kext
ATI4800Controller.kext
ATI5000Controller.kext
ATIFramebuffer.kext
ATIRadeonX1000.kext
ATIRadeonX1000GA.plugin
ATIRadeonX1000GLDriver.bundle
ATIRadeonX1000VADriver.bundle
ATIRadeonX2000.kext
ATIRadeonX2000GA.plugin
ATIRadeonX2000GLDriver.bundle
ATIRadeonX2000VADriver.bundle
ATIRadeonX3000.kext
ATIRadeonX3000GA.plugin
ATIRadeonX3000GLDriver.bundle
ATIRadeonX3000VADriver.bundle
ATISupport.kext
ATTOCelerityFC.kext
ATTOCelerityFC8.kext
ATTOExpressPCI4.kext
ATTOExpressSASHBA.kext
ATTOExpressSASHBA2.kext
ATTOExpressSASRAID.kext
autofs.kext
BJUSBLoad.kext
BootCache.kext
CalDigitHDProDrv.kext
cd9660.kext
cddafs.kext
CellPhoneHelper.kext
Dont Steal Mac OS X.kext
DSACL.ppp
DSAuth.ppp
DVFamily.bundle
EAP-KRB.ppp
EAP-RSA.ppp
EAP-TLS.ppp
EPSONUSBPrintClass.kext
exfat.kext
GeForce.kext
GeForce7xxxGLDriver.bundle
GeForceGA.plugin
GeForceGLDriver.bundle
GeForceVADriver.bundle
HighPointIOP.kext
HighPointRR.kext
hp_designjet_series.kext
hp_Deskjet_io_enabler.kext
hp_Inkjet_io_enabler.kext
hp_Inkjet1_io_enabler.kext
hp_Inkjet3_io_enabler.kext
hp_Inkjet4_io_enabler.kext
hp_Inkjet5_io_enabler.kext
hp_Inkjet8_io_enabler.kext
hp_io_printerclassdriver_enabler.kext
hp_Laserjet_io_enabler.kext
hp_Officejet_io_enabler.kext
hp_Photosmart_io_enabler.kext
hp_PhotosmartPro_io_enabler.kext
hp_qc_io_enabler.kext
ICAFWKodakProDriver.kext
ImmersionForceFeedback.kext
IO80211Family.kext
IOACPIFamily.kext
IOAHCIFamily.kext
IOATAFamily.kext
IOBDStorageFamily.kext
IOBluetoothFamily.kext
IOBluetoothHIDDriver.kext
IOCDStorageFamily.kext
IODVDStorageFamily.kext
IOFireWireAVC.kext
IOFireWireFamily.kext
IOFireWireIP.kext
IOFireWireSBP2.kext
IOFireWireSerialBusProtocolTransport.kext
IOGraphicsFamily.kext
IOHDIXController.kext
IOHIDFamily.kext
IONDRVSupport.kext
IONetworkingFamily.kext
IOPCIFamily.kext
IOPlatformPluginFamily.kext
IOSCSIArchitectureModelFamily.kext
IOSCSIParallelFamily.kext
IOSerialFamily.kext
IOSMBusFamily.kext
IOStorageFamily.kext
IOStreamFamily.kext
IOSurface.kext
IOUSBFamily.kext
IOUSBMassStorageClass.kext
IOVideoFamily.kext
iPodDriver.kext
iTunesPhoneDriver.kext
JMicronATA.kext
L2TP.ppp
LexmarkUSBMerge.kext
LogitechForceFeedback.kext
mcxalr.kext
msdosfs.kext
ntfs.kext
NVDANV40Hal.kext
NVDANV50Hal.kext
NVDAResman.kext
NVSMU.kext
OSvKernDSPLib.kext
PPP.kext
PPPoE.ppp
PPPSerial.ppp
PPTP.ppp
Quarantine.kext
Radius.ppp
Sandbox.kext
SMARTLib.plugin
smbfs.kext
SMCMotionSensor.kext
SoftRAID.kext
System.kext
TMSafetyNet.kext
udf.kext
ufs.kext
webcontentfilter.kext
webdav_fs.kext[/codebox]

The AppleHDA in there is the one from the first post in this thread.

Im using the ALC1200_1063 from the first post. I
1. Deleted kext's containing 'audio' in their name
2. Used kext-helper to install the appleHDA in S/L/E
3. Rebooted, and no device showing up.

Tried a dozen times now, still no luck. I've also tried rebuilding my caches and permissions a couple of time after install of the kext. What am i doing wrong?





Also tagged with one or more of these keywords: realtek, alc1200, mountain lion, kext, audio, dsdt, snow leopard

  Topic Stats Last Post Info

2 user(s) are reading this topic

0 members, 2 guests, 0 anonymous users

© 2015 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy