Jump to content

Realtek ALC1200 ICH10 working kext on Mavericks 10.9 and even ML, L and SL

realtek alc1200 mountain lion kext audio dsdt snow leopard

  • Please log in to reply
557 replies to this topic

#21
kome

kome

    InsanelyMac Protégé

  • Members
  • Pip
  • 30 posts
Oh sorry there is an issue

from my P5Q-Pro mobo, it comes with the coaxial SPDIF output so, it is not a optical digital output. So I can;t get the digital out functioning as the kext I guess was being modified to with optical output, is that any chance to create a version that suit for ALC2000 with coaxial digital output interface?

thanks

#22
marionez

marionez

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 425 posts
This ALC1200 can't suite with ALC2000, that has different codec dump.
If you want to give me a codec dump we can try to create a driver that suite with ALC2000: http://www.insanelym...php/t46378.html

Don't care about what is written in about this mac ;)

I'm testing coax spdif out and works very well... :P

#23
kome

kome

    InsanelyMac Protégé

  • Members
  • Pip
  • 30 posts

This ALC1200 can't suite with ALC2000, that has different codec dump.
If you want to give me a codec dump we can try to create a driver that suite with ALC2000: http://www.insanelym...php/t46378.html

Don't care about what is written in about this mac :P



sorry That was a typo, should be ALC1200, i have p5q pro as wel

not sure why mine one is not working....

thanks for your help,

#24
marionez

marionez

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 425 posts
Yes it works, in this moment I'm playing mp3 with iTunes on the Digital Output (you've to choose this in system preferences - sound preferences - output), connected the ALC1200 spdif out on my external usb audio card spdif in, and with garageband I'm monitoring the usb audio card output, quite difficult to explain, but works very well... :P

#25
kome

kome

    InsanelyMac Protégé

  • Members
  • Pip
  • 30 posts
thanks I things i got some setting wrong in my receiver. Working now. Great work!

#26
marionez

marionez

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 425 posts
Ok... anyway ALC2000 doesn't seem to exist. :P

deadpxl about 8 channel, if you see in your output sound preference, you have line out, headphone, then there's another line out, that's the ORANGE plug and it works, but you can't use this at the same time of first line out (as I know).

#27
Slyrfecso

Slyrfecso

    InsanelyMac Protégé

  • Members
  • PipPip
  • 63 posts
Nice Marionez, thet you tryed the digital output.
Please try DTS music in WAV.
You can dowload it form my server:
fecso.dyndns.org/Rihanna - Don't Stop The Music.zip


I can explain it to you, Realtek ALC1200 chipset is so good as M-Audio Transit!!!

Good work...

#28
kome

kome

    InsanelyMac Protégé

  • Members
  • Pip
  • 30 posts

Ok... anyway ALC2000 doesn't seem to exist. :P

deadpxl about 8 channel, if you see in your output sound preference, you have line out, headphone, then there's another line out, that's the ORANGE plug and it works, but you can't use this at the same time of first line out (as I know).



but seems I can't output DTS/(not tried dolby yet).....from vlc or the dvd player... any clue?

#29
Good Day

Good Day

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts
Marionez, great work! Thank you.

Still can not get it working on my EFI Partition.
Backuped and removed AppleHDA.kext from /S/L/E.
Placed your kexts into Extensions folder of my EFI partition, updated perms, created Extensions.mkext.
After reboot, System Profiler shows Device ID, Audio ID and nil Available Devices.

Any ideas?

Mobo: Asus P6T(regular)
ICH10R Chipset
10.5.6 Vanilla Install

Thanks for your work.

#30
marionez

marionez

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 425 posts
Kome here vlc spdif out works, to have DTS working I think you must have a DTS compatible sound system. Anyway I don't think that could be a driver related problem, maybe OSx or sound system.

Good Day, it's strange, firstly you would try deleting again AppleHDA ALC1200fix HDAEnabler and check if you have some other injector (alcinjector azalia) and audio patch installed in your extensions folder, that's very probable.
At the end if you can't figure out, you should have some different codec dump, here's how to have: http://www.insanelym...php/t46378.html
I can't assure I can create a working driver, you can try, it's even quite strange you've an ALC1200 with a different codec dump, I noticed some differences between some ALC1200 I read on internet, but they're minor differences.

#31
Slyrfecso

Slyrfecso

    InsanelyMac Protégé

  • Members
  • PipPip
  • 63 posts
Nice Marionez, thet you tryed the digital output.
Please try DTS music in WAV.
You can download it from my server:
fecso.dyndns.org/Rihanna - Don't Stop The Music.zip


I can explain it to you, Realtek ALC1200 chipset is so good as M-Audio Transit!!!

Good work...

#32
kome

kome

    InsanelyMac Protégé

  • Members
  • Pip
  • 30 posts

Kome here vlc spdif out works, to have DTS working I think you must have a DTS compatible sound system. Anyway I don't think that could be a driver related problem, maybe OSx or sound system.



thanks guess so , should be something related to setting of programs. Though I am pretty sure my receiver able to detect different surround coding system.

#33
marionez

marionez

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 425 posts
Mmh I tested even with dts from vlc and here works.

Here are some samples: http://www.diatonis....ds_dts_ac3.html

Fecso I tried that wav, iTunes doesn't play here, there's a lot of noise!
Vlc plays it perfectly, so I don't think it's the driver, but I can't really know which is the problem with iTunes.

#34
Good Day

Good Day

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts
marionez, thank you
will give it a try and post results

#35
Slyrfecso

Slyrfecso

    InsanelyMac Protégé

  • Members
  • PipPip
  • 63 posts
Thx.

My idea is: iTunes detect the soundcard connection with soundsystems, and if is digital, then DTS go out.
I think iTunes not well recognized by.
iTunes can play DTS music on G5.

Here is apple link:
support.apple.com/kb/TA47850?viewlocale=en_US


Thank you for everything!
I will play with VLC:)

#36
Good Day

Good Day

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts
marionez, any ideas please?

dumped using slax

here are Taruga's patcher output:

AppleHDA Patcher - 2006/2007 by Taruga v1.20


* Patching AppleHDA.kext to 0x10ec0888 Done
* Checking AppleHDA for patch Done
0001f4a0 cmpl $0x10ec0888,%eax
00020584 cmpl $0x10ec0888,%eax
* Checking for SPDIF Out Detected
* Checking for SPDIF In Not Detected
* Using the following nodes in pathmap

Back Mic: 9 34 24
Line In : 8 35 26
Speaker : 20 12 2
Headphone: 27 38 37
Spdif Out: 30 6

* Copying new config to destination Done
* Repairing Permissions Done
* Deleting Extensions Cache Done

** Done patching - You can reboot now **

moved AppleHDA from /S/L/E to EFI, fixed perms etc etc

rebooted with -v -f

System Profiler says:

Intel High Definition Audio:

Device ID: 0x10438357
Audio ID: 12
Available Devices:


Thank You

#37
marionez

marionez

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 425 posts
I need the codec dump it's a text from the alsa linux driver where there are verbs. attach it, I'll work on it later... :)
Something like this (mine) http://www.insanelym...p...st&id=48298

#38
iPhoneiac

iPhoneiac

    InsanelyMac Protégé

  • Members
  • Pip
  • 44 posts

Potentially stupid observation (in that I am stupid):

Can you control digital volume at the source? I have some high end audio gear and volume can only be controlled at the amp because there is no way to 'reduce' a digital signal, it is either on or off. It's not like analog.

Again I am not sure of how it works on pc's because I don't have gear to test.
Network now comes back after sleep, absolutely OUTSTANDING and a big THANK YOU!!!!

It may have even fixed the random shut down issue. I was able to recreate the shut down problem by doing sleep, wake up, shut down. Now it seems to work fine but I will confirm after some more tests.

Cheers!


Had over 10 shutdowns with no issues. This is THE sleep fix.

#39
Good Day

Good Day

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts

I need the codec dump it's a text from the alsa linux driver where there are verbs. attach it, I'll work on it later... ;)
Something like this (mine) http://www.insanelym...p...st&id=48298


sigh, my mobo's specs says it is an ALC1200
dump instead says it is an 888

marionez, please see it attached
thank you

Attached Files



#40
marionez

marionez

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 425 posts
Yes you have an ALC888, in fact you even got a different device ID! :P
Try searching for an ALC888 driver on the forum, I think it already exists.

I've made a version with spdif RCA (coax) connection in "about this mac", I put it on post#1

iPhoneiac I think this can really solve that issue ;)





Also tagged with one or more of these keywords: realtek, alc1200, mountain lion, kext, audio, dsdt, snow leopard


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy