Jump to content

The easiest way to install Nvidia 9400 GT


  • Please log in to reply
15 replies to this topic

#1
Subrat Nayak

Subrat Nayak

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
I tried many hour searching for drivers for my new XFX NVIDIA 9400 GT [512 MB]. I installed iDeneb v1.4 [10.5.6] and tried every nvidia drive on the installation but failed. Also tried Injectors and other things available here but failed. After that I hear about adding EFI string in OSx86 tool but it say about 'apple script Error'. So finally I do these steps and these are very simple....

1. Install any OSX86 distro [10.5.6]
2. Dont Select any nVidia driver at Beginning.
3. Go to this Link and download the Installer for the NVIDIA 9 Series Drivers and Install it. But Do not Restart
4. Open OSx86 tool.Posted Image
5. Click on Add EFI Strings/Boot Flag and open it Posted Image
6. now do these steps:-
a. Click GFX String [On upper Left]
b. On Graphics Card, Drop down the list and choose Custom Geforce [should be at very last]
c. On the box Type 'nVidia Geforce 9400 GT'
d. Select your cards Memory and click OK
e. Now this stpe is Important. Here you have to choose the right output of your card. to get this got to the your cards manufacture website and see the configuration of your graphics card and find your display output or see on the box or its manual. [Like I have XFX 9400 GT 512 Mb so i go to thispage]
f. Now look at the Hexadecimal EFI String (Device Properties) and copy all that written in the box. open a text editor and copy this. match both to satisfy that you copy exactly same. Now close Disk utilities.
7. Go to your leopard installation drive and Open Library/Preference/System Configuration and copy 'com.apple.Boot.plist' file to desktop.
8. Go to your Desktop and open the file you just copied with text edit: It should look like this:-

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple Computer//DTD PLIST 1.0//EN" "http://www.apple.com...yList-1.0.dtd">
<plist version="1.0">
<dict>
<key>Kernel</key>
<string>mach_kernel</string>
<key>Kernel Flags</key>
<string></string>
<key>Timeout</key>
<string>5</string>
<key>device-properties</key>
<string></string>

IF any line miss the add them.
9. Now at the last line in between <string></string> add the HEX characters you copied from OSx86 tool [STPE-6] so it look like this

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple Computer//DTD PLIST 1.0//EN" "http://www.apple.com...yList-1.0.dtd">
<plist version="1.0">
<dict>
<key>Kernel</key>
<string>mach_kernel</string>
<key>Kernel Flags</key>
<string></string>
<key>Timeout</key>
<string>5</string>
<key>device-properties</key>
<string>6c0200000100000001000000600200000d00000002010c00d041030a0000000001010600000b0
01060000007fff04000e0000004e00560050004d0000002000000001000000000000000000000000
00000000000000000000000000000220000005600520041004d002c0074006f00740061006c00730
69007a006500000008000000000000201c0000006400650076006900630065005f00740079007000
50000000f0000004e5644412c506172656e740e0000006e0061006d00650000000b0000006469737
6c617922000000400030002c006400650076006900630065005f00740079007000650000000b0000
0646973706c617922000000400031002c006400650076006900630065005f0074007900700065000
000b000000646973706c6179100000006d006f00640065006c0000001a0000006e56696469612047
5666f726365203934303020475420000000400031002c0063006f006d00700061007400690062006
00650000000e0000004e5644412c4e564d616314000000400030002c006e0061006d006500000012
000004e5644412c446973706c61792d4114000000400031002c006e0061006d00650000001200000
4e5644412c446973706c61792d4220000000400030002c0063006f006d0070006100740069006200
c00650000000e0000004e5644412c4e564d6163100000004e0056004300410050000000180000000
000000000003000c00000000000007000000001e00000072006f006d002d00720065007600690073
069006f006e0000002e0000006e5669646961204765666f7263652039343030204754204f70656e4
4c20456e67696e65205b4546495d</string>
</dict>
</plist>

10. Now save this. And open terminal and type

cd ~/Desktop/
sudo chown -R root:wheel com.apple.Boot.plist
"Give your Password"
sudo chmod -R 755 com.apple.Boot.plist

11. Now close terminal and copy the desktop file to Library/Preference/System Configuration and replace it by iving your password.

12. Now Reboot. You going to see your leopard booting with graphics driver.

My machine Spec
AMD Athlon X2 6000 Dual Core 3.0 Ghz
Asus M2N68-AM motherboard
XFX Nvidia 9400 GT
2GB+1GB 800 MHz RAM
160 GB SATA HDD

Here Is mine
Posted Image

Let me know if this helps you. And yes One more thing my Onboard ALC662 Audio Driver is not workin [i choose everything] can anyone let me know that the cheep external USB Audio drivers are working on Leopard......or any other help on this. Thanks.....


#2
mieze245

mieze245

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
we will see how this works on vanilla install with device ID 0x0641, GeForce 9400 GT 1024 ram...
cannot get QE up will try reload tonight

#3
comito

comito

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
Hi all, insanes Hack people :-D

I tried across your guide to set my PNY GeForce 5400 GT 512 video Card. First of all thanks :-)
But I have a problem: the resolution isn't correct. Max resolution is 1360*768, anyway my monitor (Acer v193HQ) support 1366*768.
At the boot promp my Hackintosh says: VESA NVIDIA 14MB (!) but after, System Profiler recognize correctly the video card (QE supported, name, vRam, etc.). So, it exist the possibilty to set correctly the video resolution?
Thanks in advance.

My configuration:
Motherboard: M2N68-VM
Processor: AMD Athlon™ 64 X2 Dual Core Processor 5600+
RAM: 4GB 667
video card: PNY 9400GT with two DVI output
Monitor: Acer v193hq VGA input
Video adapter: DVI-VGA
(correctly setted in osxTools efi string)

#4
ChiefChief

ChiefChief

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
Nice directions. Screenshots even!

For the audio have you tried the AppleHDA patcher? That's what worked for me.

#5
jeancarlosc

jeancarlosc

    InsanelyMac Protégé

  • Members
  • Pip
  • 15 posts
Follow the steps to restart the system but the screen freezes

#6
elfdood

elfdood

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 102 posts
I have a mobo with the 662 chipset and nothing worked, so for giggles I tried the VoodooHDA kext and voila, it worked..

Have u tried that one?

#7
degel3030

degel3030

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts
I just wanted to say thanks, the directions weren't perfect but it worked, I'm not enjoying dual screen 1680x1050 goodness

Thanks again

#8
abbeyrolled

abbeyrolled

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
So I tried this method and it locked up at the boot screen. I had to reinstall from scratch. Anyone got any ideas? I'm dying to get my PNY 9400 GT 1gb card working!

#9
tonik23

tonik23

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
anyone tried on SL yet?

I have nVidia 9400 GT 1gb

#10
Exebat

Exebat

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
Is it possible to get any other file hosting link? rapidshare is always full..

//Exebat

#11
Theonebusman

Theonebusman

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts
I used this way to install my bfg 9400 gt 1gb and it worked perfectly

#12
Ramagno

Ramagno

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts

5. Click on Add EFI Strings/Boot Flag and open it

When I click there a window opens saying

AppleScript Error
Can’t make "0" into type boolean. (-1700)

I'm a total noob. Any ideas?
Thanks!

#13
Gatzs

Gatzs

    InsanelyMac Protégé

  • Members
  • Pip
  • 14 posts

we will see how this works on vanilla install with device ID 0x0641, GeForce 9400 GT 1024 ram...
cannot get QE up will try reload tonight


hi guys!
i got QE (device ID 0x0641, Sparkle GeForce 9400 GT 1024 ram DVI+VGA) in iPC 10.5.6 but i cannot get it in SL 10.6.3 atm. I'm downloading update 10.6.4 and after install i'll try with NVENABLER.KEXT (www.kexts.com).
Maybe.......
I hope!!

HARDWARE CONFIGURATION:
Gigabyte G41M-ES2L
CPU E6300
2x2GB DDR2 800MHz

#14
skullangel

skullangel

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
I've restart the computer accidently
how to fix it?

#15
dothacker

dothacker

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 813 posts
  • Gender:Male
  • Location:Garland, TX
Here's the easiest way to use 9400 GT on SL...

Install iATKOS S3 v2
choose Chameleon RC5 Bootloader
choose Graphics enabler
then, drivers for your hardware...

That's it ;)

#16
Vienen

Vienen

    InsanelyMac Protégé

  • Members
  • Pip
  • 28 posts
NVKush worked for me on Leopard. Didn't work on Snow Leopard. I'll try this method and let you know if it worked or not.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy