Jump to content

How to get AR5006EG / AR5007EG atheros wlan working and sound for Acer Aspire 4720z

- - - - -

  • Please log in to reply
86 replies to this topic

#61
Doraemon

Doraemon

    InsanelyMac Protégé

  • Members
  • Pip
  • 47 posts
  • Gender:Male
I'm trying to get wireless working under Snow Leopard with my Eee PC 900HA. Does anyone have any suggestions?

#62
amartey

amartey

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts

Atheros Minipci Wireless Network Card and
Realtech / Intel HD Audio Guide


(specefically on Acer Aspire 4720z running iATKOS 5i leo 10.5.6 but should be applicable for any with
similar devices)

AR5006EG / AR5007EG (device vendor ids: 168cx001c)

Wireless:

1) (why this is different from every other guide and what NEWBS don't know!) Install Chun Nan's latest leopard IOPCMCIfamily.kext, IOPCIfamily and IONetworkingfamily.kext(s). My IOPCMCIfamily, then the other two come from Marvel and Yukon that I got from the Acer Aspire One guide. They're in my attachments. Install.
2) Get kismac
3) Download and install Io80211family v 2.1.2 (see attached) (should already have <string>168cx1c</string> in AirportAtheros.kext/Info.plist)
4) You should have a working fan icon (make sure you check show wireless icon in System Preferences/Network
5) Open kismac, scan under "Airport Extreme Passive Mode" (Add in Preferences/Devices)
6) Should show networks in Kismac. If not, open network preferences and some wifi airport windows it will.
7) Stop kismac after a few seconds of exhaustive search (until you stop the open networks will not show under fan icon).
8) Join a network under the Airport Fan icon
9) Close kismac
10) You now have a working Atheros AR5006EG / AR5007EG* card!!! (vendor ids 168cx001c)

*Windows 7 Beta / Vista recognizes Atheros vendor id 168cx001c as AR5007EG. Whether or not it truly is, I don't know. Under Ubuntu 8.10 and iATKOS DPCI manager it says AR5006EG. And AirPort atheros gives it vendor ids of 168cx428 (even though in the Airportatheros.kext/info.plist it says "<string>168cx1c</string>". I don't know why. 3-07-09: Also noticed that the pc freezes sometimes on wifi, IDK y. Generally I'm guessing it has to do with my Intel Powermanagement tweaks, but IDK. Could be overload of the processor. Will keep you posted. This guide works with iATKOS 5i updated to Leo 10.5.6. I don't know about other Hackintoshes so keep me posted. Should work. Watch out for updates they can replace these kexts which are critical to your wifi. Specefically Airport Client update 004-2009, I think. If you install that you may have to reinstall these kexts.

Sound:

1) Install either (or both, it doesn't matter) ACL268installers
2) Install HDAEnabler (or AppleHDA i forget what its in my zips) with Kexthelper
3) Whether or not you run the spanish HDApatcher doesn't matter, sound will work. Switch between headphones and internal speakers with System Preferences/Sound
4) You now have working sound!! Realtech / Intel High Definition Audio (Acer Asipre 4720z)*

* 3-19-2009: Thanks to DetosX, ALC268_B gives a working automatic switch between headphones and internal speakers. Still looking for working shutdown/restart fix.
** 3/11/09 Working shutdown and restart with clean install on Leo 10.5.5 iATKOS 5i and installing my ALC268s but nonworking wireless.

Generally this info has been posted elsewhere, but my guide is different because most newbs don't know about Chun Nan's IOPCI kexts, and that they are critical to get a working PCI Atheros card since the card is dependent upon the PCI bus for communication. I found that info in a little known post, obscure, someplace and figured Id post a guide. If this helps you let me know! And if its retarded or supplementary feel free to delete! I will post this with attachments to the genius bar soon and probably Uphuck forums too in the near future. If you have any problems feel free to message me and I will try to help you. Rebranding the 168c 001c isn't a must. Besides you avoid likely bricking problems or having to buy a new wireless card.

Mo 3-23-09
The Working_Wireless_and_Sound.zips are the original kext files posted natively with this guide while the ar5007(6)eg...zips are a split 7z archive I compiled in order to address more recent problems brought up by users. In order to extract, remove the zip extension and use either 7-zip in Ubuntu/Wine or Windows or Stuffitexpander in MacOS.

Th 3-19-09

Note for users who are having difficulty getting their AR5006(7)EG to work: Does your airport icon show and is it turned on? Can you scan networks? Chun Nan's drivers should be platform independent so the solution should work on kalyway, idebneb and others.

Possible solutions for users with troubles:
(these should be implemented along with the instructions in this guide)

a) Make SURE that your atheros card IS attached to a pci bus for communication or this solution will be null.
:) MAKE SURE that your device vendor ids are 168cx001c. If it isn't search your vendor ids and download THAT wlan driver/fix, not this one.
c) Try editing the info.plist in atherosairport.kext to read <string>168cx428</sting> that may help.
d) Make SURE that you update to Leo 10.5.6 at mac's download site and have it running that kernel not toh, voodoo, or others. I have working wireless on my Acer running iATKOS 5i updated to 10.5.6 with ALC268_B sound. You have to make sure you update to 10.5.6. If you don't (and just run from iATKOS 5i 10.5.5 or w/e) it will just show a running fan icon but kismac won't find anything. And make sure you're running that kernel, not the one native to your install disk. Use OSX86Utils to install the kernel and kexts independtly.
e) download the latest AirportAtheros update (I think its 2009) and install
f) Install IOPCMCI, IONet, PCcard, IO80211 from my new ar5007(6)eg_wlan_168x001c_kexts_and_kernel.7z that I uploaded. You will have to try the others each one at a time, or all at once. Take off the .zip extensions and use 7zip to extract. I don't know what system you're running so it may cause a crash.
g) Switch kernels. Use OSX86 utils to insall my mach_kernel to your system (back up your running kernel as you may have to repair) and install system.kext as well.
h) Try switching to a vanilla kernel and then updating or vice versa.
i) Goto Chun Nan's Mediafire site (link on bottom) and try installing some of those kexts too
j) If you have a bad kismac scan, alternate installing the new kexts (specifically ionetwork, io80211fam, iopmcmia, iopcifam) with the old. I know that if I'm running Marvel or Yukon or Chunnan and have no scanned/found networks with kismac by installing the new ones with kexthelper i can get a good scan on the next boot or vicaversa.

Plz when posting tell me which of these u have tried and how it went so that I can take out nonworking solutions and highlight good ones.

I've uploaded my presently running kexts that I think may be relevant as I think that they may be different from Chunnan, Marvel and Yukon. Most of these probably are not relevant to the problems some users are having, but I think that most of them are.

Update 3-23 : Please reread my wireless guide if you are having problems connecting to a network after a good kismac scan as it has been updated.

Please don't just download; post results. And when asking for help plz also post your system make and model, and relevant wlan make and model and device vendor ids as outputted by either Windows XP/Vista/7 Device Manager or Ubuntu/Linux/Terminal LSPCI. Thank you. Also plz make sure that you have given my guide a good once-through read so that you are not being redundent.



Sources:

Acer Aspire One Guide:
http://www.insanelymac.com/forum/index.php?showtopic=96552&pid=689371&mode=threaded&start=#entry689371
AppleHDA ALC268 Shutdown Issues Solved! * :
http://www.insanelymac.com/forum/index.php?showtopic=96434&st=80&start=80
Chun Nan's IOPCI Guide:
http://www.insanelymac.com/forum/index.php?showtopic=81036&st=840
Chun Nan's MediaFire ** :
http://www.mediafire.com/chunnan
New ALC861VD ALC268...:
http://www.insanelym...p...aded&start=


*Not so, it doesn't work for me, Acer Aspire 4720z running iATKOS 5i updated to Leo 10.5.6
**if you have Tiger you'll have to download the Tiger IOPMCI from MediaFire.
Chun Nan's other kexts may prove useful to you also. I noticed my power meter turn on (and stay on) after installing some, but installing more than what I said to in this guide may result in an unstable system or kernel panic (specefically APCIRuntime or ACPIPS2Nub). Feel free to use them, but be aware. When I had a working power meter and wireless both, the system would boot properly once and everything would be working, but every boot after that would be a kernel panic. I will try to figure out how to get the Power meter on too and post a complete guide.


thanks a zillion, the instructions work for me on my Compaq Presario cq60 145EI. I am only left with the video driver, it is a mobile intel 4 series chip. it sees intel cantiga when it boots up. i will need help if anyone got it working, i need the resolution 1280x900 or so, mine is wide resolution.

#63
Xandu

Xandu

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
Hello,

I have a Atheros 5007EG 168x001c , I'm using iDeneb_v1.6_1058_Lite_Edition

Hardware ID PCI\VEN_168C&DEV_001C&SUBSYS_7128144F&REV_01
Driver Description Atheros AR5007EG Wireless Network Adapter
PCI Device Atheros AR5006X Wireless Network Adapter


I followed the guide and installed the kexts: IOPCMCIAfamily.kext, IOPCIfamily and IONetworkingfamily.kext(s)

And

Io80211family v 2.1.2

But the OS won't boot, it brings up a DISABLED sign on top of the Apple Logo, also I don't see the fan icon when I install. I used the kext installer in the package.

So any help?

Thanks.

#64
mamouth

mamouth

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
  • Gender:Male

Hello,

I have a Atheros 5007EG 168x001c , I'm using iDeneb_v1.6_1058_Lite_Edition

Hardware ID PCI\VEN_168C&DEV_001C&SUBSYS_7128144F&REV_01
Driver Description Atheros AR5007EG Wireless Network Adapter
PCI Device Atheros AR5006X Wireless Network Adapter


I followed the guide and installed the kexts: IOPCMCIAfamily.kext, IOPCIfamily and IONetworkingfamily.kext(s)

And

Io80211family v 2.1.2

But the OS won't boot, it brings up a DISABLED sign on top of the Apple Logo, also I don't see the fan icon when I install. I used the kext installer in the package.

So any help?

Thanks.

Humm sometime its because mac isn't able to find a head to the computer (a monitor) try plug one in


Or when you're going before enter click something like down arrow then put -x -v and if it fail again (you hard drive will stop working, and no more information will come) take a picture and upload it here.. 

#65
Xi54

Xi54

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts
Didn't work. I have an Acer 3680 with atheros AR5BXB63 and no networks show up under the wireless icon in the menu OR KisMAC.

#66
MrComputerWhiz

MrComputerWhiz

    InsanelyMac Protégé

  • Members
  • Pip
  • 22 posts
  • Gender:Male
  • Location:Kansas
Ok i installed and i have you same device id. for the Ar5006Eg
I rebooted it detected new network. but thats as far as i can get..
It wont turn on via airport. it keeps saying turn aiport on. if i click it, it does nothhing
ive tried several reboots


Snow leopard server 10.6.2
In 32 bit mode

#67
dsa93

dsa93

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
  • Gender:Male
  • Location:Italy;Rome
hi,i'italian and i've tried to follow the tutorial by jasballz,i installed all kext,airport is now active but the cirle is yellow and i cannot see any network in airport and in kismac.In kismac i enabled airport extreme card passive mode and tried to scan,but no network finded :D
please help me!I need the wifi because my pc not have ethernet!

#68
iGH

iGH

    InsanelyMac Protégé

  • Members
  • Pip
  • 28 posts
Can´t unzip wtf??

#69
iGH

iGH

    InsanelyMac Protégé

  • Members
  • Pip
  • 28 posts

Can´t unzip wtf??


Got it work under OS X :D :D :D

But now, the KisMAC keeps just "scanning" And I´m not 100% sure is this the right driver for my PC, here is a pic:

Posted Image

#70
Cataclysm_

Cataclysm_

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
  • Gender:Male
  • Location:127.0.0.1
Thank you very much for the guide, it worked for my Toshiba L300 Laptop, but after a restart it's not finding any networks.
Using iAtkos i5, and looking forward for a solution.
Thanks.

#71
Murashi

Murashi

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
Hello everyone,

With this methode my wifi found my router but i can't connect. It says someting with the timelimit. What i do wrong. Can everyone help me.

Later.

Edit:
Router have WPA.

#72
grandslamjmh

grandslamjmh

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts

Atheros Minipci Wireless Network Card and
Realtech / Intel HD Audio Guide


(specefically on Acer Aspire 4720z running iATKOS 5i leo 10.5.6 but should be applicable for any with
similar devices)

AR5006EG / AR5007EG (device vendor ids: 168cx001c)

Wireless:

1) (why this is different from every other guide and what NEWBS don't know!) Install Chun Nan's latest leopard IOPCMCIfamily.kext, IOPCIfamily and IONetworkingfamily.kext(s). My IOPCMCIfamily, then the other two come from Marvel and Yukon that I got from the Acer Aspire One guide. They're in my attachments. Install.
2) Get kismac
3) Download and install Io80211family v 2.1.2 (see attached) (should already have <string>168cx1c</string> in AirportAtheros.kext/Info.plist)
4) You should have a working fan icon (make sure you check show wireless icon in System Preferences/Network
5) Open kismac, scan under "Airport Extreme Passive Mode" (Add in Preferences/Devices)
6) Should show networks in Kismac. If not, open network preferences and some wifi airport windows it will.
7) Stop kismac after a few seconds of exhaustive search (until you stop the open networks will not show under fan icon).
8) Join a network under the Airport Fan icon
9) Close kismac
10) You now have a working Atheros AR5006EG / AR5007EG* card!!! (vendor ids 168cx001c)


Nice work. Does anyone know how i can boot my laptop without having to insert my flash drive at the apple boot screen for it to continue to load.

USB support is disabled in my bios. when i start my laptop and run -v it stops at IOAPIC: Version 0x21 Vectors 0:23

when i plug in my flash drive or any other usb device, it continues to load

anything would be great on how i dont have to do this every time?

#73
Bogi011

Bogi011

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
I have,I think, the same problem as the guy I qoted. I am a newb, so maybe I did something I shouldn't have. I didn't know how to install kexts so I used kext helper b7, and installed the first 3 kexts from the guide(IOPCMCIfamily,IOPCIfamily,IONetworkingfamily). I posted what shows up on my screen, I hope you can see. How do I boot now? It doesnt even boot from iDeneb CD

I get the following after installing the first 3 kexts on bootup:
"Failed to load extension com.apple.driver.AppleACPIPCI"
"Couldn't alloc class "AppleACPIPCI"
using iPC 10.5.6, clean install on 4720z.
I installed all the 3 kexts at the same time, is there a problem with that?

Posted Image

#74
Bogi011

Bogi011

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
Just an update on my problem... iDeneb CD didn't run, but now I managed to get it running. I noticed that there is an option to run Terminal from it. Can I use that Terminal to delete those kexts from my HDD and what commands should I write in it to do that?

#75
MADCreations

MADCreations

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
  • Gender:Male
  • Location:The netherlands
  • Interests:Programming and development of Hardware and Software
Will this work with a mini pci e vard (Atheros AR5007 802.11b/g WiFi Adapter)

#76
Malthuss

Malthuss

    InsanelyMac Protégé

  • Members
  • Pip
  • 15 posts
10.6.2 not work help me..

#77
hatim5691

hatim5691

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
plz solution for 10.6

#78
luigirez1

luigirez1

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 6 posts
Well, now I can't boot. Any Help? My Photos are attached.

Attached Files



#79
mrc

mrc

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts

Many many Thanks Jasballz for the great effort you have made. I was searching for this fix for a long long time. It works for me too. I have LG RD400 laptop which is having a lot of compatibility issue with Leopard (OSX). First of all, my keyboard was not working, but later on fixed with Chunan ApplePS2Controller.kext. No sound, later on fixed by AppleHDA patcher. No network, fixed by adding vendor id, device id in AppleYukon2.kext. Now, Airport working with the patch available here in this topic.

Great Work. Now, our dream for Atheros 5007eg comes true.



Hi!

could you please explain more about the way you solved all the problems? I have the same laptop and i have only solved the keyboard and sound problems on snow leopard :\
I will be thankfull if you could upload all the files you used
Have you tried Snow leo?
Which leopard release are you using?
Thankyou

#80
Bladyle

Bladyle

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
Can someone tried it on snow leopard? Is it working?





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy