Jump to content

ATI Radeon HD4350 PCIe


  • Please log in to reply
242 replies to this topic

#201
George20

George20

    InsanelyMac Protégé

  • Members
  • Pip
  • 14 posts
Did you get green apple or any lags? Because i'm about to buy this card :wacko:

#202
CoKoSun

CoKoSun

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts

10.6.5 Delta Update
Giga-byte ATI HD4350 512M

Guide:

Chameleon2_RC5

GraphicsEnabler=Yes

Add 0x954f1002 /S/L/E/ATI4600Controller.kext/Contents/info.plist=>IOPCIMatch
Add 0x954f1002 /S/L/E/ATIRadeonX2000.kext/Contents/info.plist=>IOPCIMatch

Remove /S/L/E/ATI4500Controller.kext

restart

QE/CI !
1680x1050 !
Enjoy :tomato:


DVI / VGA / HDMI???

#203
ANARCHiNTOSH

ANARCHiNTOSH

    Loldermort!!!!

  • Members
  • PipPipPipPip
  • 221 posts

10.6.5 Delta Update
Giga-byte ATI HD4350 512M

Guide:

Chameleon2_RC5

GraphicsEnabler=Yes

Add 0x954f1002 /S/L/E/ATI4600Controller.kext/Contents/info.plist=>IOPCIMatch
Add 0x954f1002 /S/L/E/ATIRadeonX2000.kext/Contents/info.plist=>IOPCIMatch

Remove /S/L/E/ATI4500Controller.kext

restart

QE/CI !
1680x1050 !
Enjoy :thumbsup_anim:

what chameleon build is this? prerelease 6?

UPDATE:
on my osx experimenting partition i installed 10.6.5 Delta, boot file and did the other steps.
It worked on my Asus HD 4350 Silent. 2048x1152 resolution, QE/CI, DVI
VGA and dual monitors didnt work for me
Green apple and opengl green is still there do you know how to fix it?

#204
everymatic

everymatic

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts

what chameleon build is this? prerelease 6?

UPDATE:
on my osx experimenting partition i installed 10.6.5 Delta, boot file and did the other steps.
It worked on my Asus HD 4350 Silent. 2048x1152 resolution, QE/CI, DVI
VGA and dual monitors didnt work for me
Green apple and opengl green is still there do you know how to fix it?




Is there anyone who's managed to get dual monitors working with this card AT ALL?

#205
ryudo423

ryudo423

    InsanelyMac Protégé

  • Members
  • PipPip
  • 79 posts
has anyone had any success with 10.6.4.. i updated on an experimental partition and was able to boot.. but was stuck at one resolution and had no QE/CI..... I like being up to date but it seems like development on this card has died ;)

#206
ANARCHiNTOSH

ANARCHiNTOSH

    Loldermort!!!!

  • Members
  • PipPipPipPip
  • 221 posts

has anyone had any success with 10.6.4.. i updated on an experimental partition and was able to boot.. but was stuck at one resolution and had no QE/CI..... I like being up to date but it seems like development on this card has died :)

guide post here
its best to stay on 10.6.3, the 10.6.4 method isnt as great
however, 10.6.5 will be as well supported as 10.6.3 thanks to Chameleon RC5, and xmedik for posting it.
so when 10.6.5 comes out proper, use that and follow the guide post for how to get it working.

#207
ytrox

ytrox

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 501 posts
  • Gender:Male
  • Location:Italy
with 10.6.5 beta update we still have the green apple? (for me 10.6.2 is the best solution...)

#208
ytrox

ytrox

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 501 posts
  • Gender:Male
  • Location:Italy

Did you get green apple or any lags? Because i'm about to buy this card :wacko:


I don't recommend to buy this card. 5000 series are better now. multiple monitors are much more supported

#209
dawntodon

dawntodon

    InsanelyMac Protégé

  • Members
  • Pip
  • 49 posts

10.6.5 Delta Update
Giga-byte ATI HD4350 512M

Guide:

Chameleon2_RC5

GraphicsEnabler=Yes

Add 0x954f1002 /S/L/E/ATI4600Controller.kext/Contents/info.plist=>IOPCIMatch
Add 0x954f1002 /S/L/E/ATIRadeonX2000.kext/Contents/info.plist=>IOPCIMatch

Remove /S/L/E/ATI4500Controller.kext

restart

QE/CI !
1680x1050 !
Enjoy :)


Thanks. I used this method, chameleon 2 rc5, graphicsenabler=yes,addition of device ids to both plists, and with the 10.6.5 delta update. I'm still at 10.6.4 and unfortunately, I can't get qe/ci activated with the res stuck at 1440x1050, when I had 1920x1080 before. Any advice on getting it to work on 10.6.4? Thanks!

#210
ANARCHiNTOSH

ANARCHiNTOSH

    Loldermort!!!!

  • Members
  • PipPipPipPip
  • 221 posts

Thanks. I used this method, chameleon 2 rc5, graphicsenabler=yes,addition of device ids to both plists, and with the 10.6.5 delta update. I'm still at 10.6.4 and unfortunately, I can't get qe/ci activated with the res stuck at 1440x1050, when I had 1920x1080 before. Any advice on getting it to work on 10.6.4? Thanks!

i hate to keep constantly posting about the guide post, but it has methods for 10.6.2 to 10.6.5.
support for 10.6.4 works, but its a bit of a lame hack that i invented. it involves using ati kexts from 10.6.3.
however, if you don't really need 10.6.4, wait for 10.6.5 final, which is just around the corner, and then use Chameleon RC5 and device-id in 4600controller (what XMedik posted).

#211
dawntodon

dawntodon

    InsanelyMac Protégé

  • Members
  • Pip
  • 49 posts

i hate to keep constantly posting about the guide post, but it has methods for 10.6.2 to 10.6.5.
support for 10.6.4 works, but its a bit of a lame hack that i invented. it involves using ati kexts from 10.6.3.
however, if you don't really need 10.6.4, wait for 10.6.5 final, which is just around the corner, and then use Chameleon RC5 and device-id in 4600controller (what XMedik posted).


Thanks for both the guide and the prompt response. I've failed to mention that I did refer to your guide for 10.6.4 and for 10.6.5 (using the beta update) and both resulted in a black screen. If I remove the ATI kexts from /S/L/E, then I get video again (generic graphic kexts?). As far as ports go, I tried to use a direct HDMI connection as well as a HDMI->DVI adapter. I'll try with 10.6.3 once I can download the combo update (Apple's site seems to be under maintenance right now).

Two things that I'm concerned about: 1) neither the DVI nor the HDMI port will work with the method in the guide but only the VGA port; 2) the specific card that I have, an MSI R4350 HD512H , is different enough from the other cards reported here.

With what I've reported, hopefully there's something obvious I'm missing here?

#212
ANARCHiNTOSH

ANARCHiNTOSH

    Loldermort!!!!

  • Members
  • PipPipPipPip
  • 221 posts

Thanks for both the guide and the prompt response. I've failed to mention that I did refer to your guide for 10.6.4 and for 10.6.5 (using the beta update) and both resulted in a black screen. If I remove the ATI kexts from /S/L/E, then I get video again (generic graphic kexts?). As far as ports go, I tried to use a direct HDMI connection as well as a HDMI->DVI adapter. I'll try with 10.6.3 once I can download the combo update (Apple's site seems to be under maintenance right now).

Two things that I'm concerned about: 1) neither the DVI nor the HDMI port will work with the method in the guide but only the VGA port; 2) the specific card that I have, an MSI R4350 HD512H , is different enough from the other cards reported here.

With what I've reported, hopefully there's something obvious I'm missing here?

hmm, i dont know. its likely your card thats causing the problem.
other users experimented with dsdt and had success.... also some users reported that the methods in the guide didn't work for them. it might be worth looking at alternative methods...

#213
dawntodon

dawntodon

    InsanelyMac Protégé

  • Members
  • Pip
  • 49 posts

hmm, i dont know. its likely your card thats causing the problem.
other users experimented with dsdt and had success.... also some users reported that the methods in the guide didn't work for them. it might be worth looking at alternative methods...


Thanks! I was just about to give up and was writing this right as my computer was loading after I tried the "Chinese approach", which I'm guessing wasn't meant as being lightly suggested but strongly advised. And lo and behold, it works! I have the green apple which is fine.

A few questions: how would I go about updating from 10.6.0 to 10.6.3 without triggering a kernel panic due to the ATIRadeonx2000.kext that gets installed? My way of getting around this was moving the file out of /s/l/e from finder as the combo update was installing it. And why aren't the kexts in the Chinese method recommended in the instructions for 10.6.4 and 10.6.5?

again. thanks for your help throughout all this.

#214
ryudo423

ryudo423

    InsanelyMac Protégé

  • Members
  • PipPip
  • 79 posts

Thanks! I was just about to give up and was writing this right as my computer was loading after I tried the "Chinese approach", which I'm guessing wasn't meant as being lightly suggested but strongly advised. And lo and behold, it works! I have the green apple which is fine.

A few questions: how would I go about updating from 10.6.0 to 10.6.3 without triggering a kernel panic due to the ATIRadeonx2000.kext that gets installed? My way of getting around this was moving the file out of /s/l/e from finder as the combo update was installing it. And why aren't the kexts in the Chinese method recommended in the instructions for 10.6.4 and 10.6.5?

again. thanks for your help throughout all this.


Hey would you mind explaining exactly what you did to get full resolution and Qe/Ci in 10.6.4? ive added the chinese kexts along with the 10.6.3.. fixed permissions and am still stuck at one resolution.. I tried applying the netkas exoctic cards package and i get a blue screen flashing back and forth between light and dark blue lol.

Also: in 10.6.3 i have full qe/ci but my resolutions are odd... My normal is 1440 x 900 but the closest i can get is
1344 x1008 and then 1400 x 1050?? any ideas? thanks guys

#215
ANARCHiNTOSH

ANARCHiNTOSH

    Loldermort!!!!

  • Members
  • PipPipPipPip
  • 221 posts

Thanks! I was just about to give up and was writing this right as my computer was loading after I tried the "Chinese approach", which I'm guessing wasn't meant as being lightly suggested but strongly advised. And lo and behold, it works! I have the green apple which is fine.

A few questions: how would I go about updating from 10.6.0 to 10.6.3 without triggering a kernel panic due to the ATIRadeonx2000.kext that gets installed? My way of getting around this was moving the file out of /s/l/e from finder as the combo update was installing it. And why aren't the kexts in the Chinese method recommended in the instructions for 10.6.4 and 10.6.5?

again. thanks for your help throughout all this.

1) booting in safe mode and updating might work, but generally the idea of combo updates is to install them right after the original snow leopard disk, rather than booting into 10.6.0 and then installing it from that...

2)as far as i remember, chinese method gave a KP in 10.6.4 and 10.6.5
also, 10.6.5 method provides much faster performance than any methods so far, [i think] due to it using 4600controller rather than 4500controller. so i recommend not bothering with 10.6.4

@ryudo
could try method of just ATI4350.Fix.kext in /E/E/
the performance drop is barely noticable

#216
someone1

someone1

    InsanelyMac Protégé

  • Members
  • Pip
  • 14 posts
Hi All,
I have Giga-byte ATI HD4350 512M but could not get it works correctly.
I did as "¡FØRWARD BRAVE ATi 4350s!" post, chinese method but failed. When I reboot with -v, it seems hang at the last phase of DOS screen-like and could not get into graphical mode. I waited 30 minutes but getting no luck, have to turn it off by holding down power button.
I install OSX 10.6.3 using iAtkos.S3.10.6.3.ver.2

My mobo is Gigabyte P55 - USB3L

Please help me to get it works

Update: it's hung at:
"NTFS drive 3.2 [Flags:R/W]"
"NTFS volume name WIN7, version 3.1"

#217
DavidAnberlin

DavidAnberlin

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
Hey guys ,OSX 10.6.5 is came out today....download it and let the hacking move on.Am really hoping it will improve on the graphics for this dumb card.

#218
ANARCHiNTOSH

ANARCHiNTOSH

    Loldermort!!!!

  • Members
  • PipPipPipPip
  • 221 posts
@DavidAnberlin
move with the times ;) the hacking was moving on when 10.6.5 was in beta
if you'd bothered to check the guide or read xmedik's post in the last page

10.6.5 working really well, graphics performance is noticably better in XBMC and other graphical apps.
Could be because we are now using the controller kext of ATI4600 rather than ATI4500, or could be C2RC5's improved graphicsenabler.
I've made ATI4350.Fix.v2.kext injector so you dont have add your device-id.
Visit the guide post for a full debriefing.

#219
DavidAnberlin

DavidAnberlin

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
i really appreciate your work and dedication ANARCHiNTOSH...I did try out the delta update but it didnt go so well with my rig so i reverted back to 10.6.4...i have a sapphire 4350 1gb card.I get KPs but didn't have time to tinker with the kext and plists...when i get time i'll give the full update another run and see how it goes.Cheers.

#220
ANARCHiNTOSH

ANARCHiNTOSH

    Loldermort!!!!

  • Members
  • PipPipPipPip
  • 221 posts
@davidanberlin
no probs, new method for 10.6.5 complete with easy injector kext has been posted
i really reccommend the 10.6.5 update to everyone, C2RC5 is amazing
graphics performance is much faster





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy