Jump to content

ATi Radeon X1650 Users, Success Stories!


  • Please log in to reply
9 replies to this topic

Poll: Is your X1650 working with QE/CI and Resolution Change? (74 member(s) have cast votes)

Is your X1650 working with QE/CI and Resolution Change?

  1. Yes (28 votes [37.84%])

    Percentage of vote: 37.84%

  2. No (46 votes [62.16%])

    Percentage of vote: 62.16%

Vote Guests cannot vote

#1
Tista

Tista

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts
  • Gender:Male
  • Location:Jakarta
UPDATE: 26 September 2009, Kexts Download link below

I was frustrated at first when I tried to install drivers for my GeCube X1650 Pro 512 MB PCIe (71c6). I tried every method I could find in this forum and still it didn't work out perfectly. So I tried mix matching different methods and my nightmares went away. I'm calling every X1650 users to come here and tell us your success story to help others cause I can see that different people have different success story with this particular graphic card.

The spec for the rig I used are:
ASUS P5LD2-X / GBL Motherboard
Intel Core2Duo 2.4 GHz
Vanilla 9.6.0 Kernel
2 GB single slot DDR2 Kingston memory
GeCube X1650 Pro 512 MB PCIe (71c6) -> Using DVI2VGA Adapter
PS2 Keyboard & Mouse
ASUS DVD-RW drive
160 GB Hitachi SATA Drive (Vista & XP)
40 GB Seagate Baracude 7200 rpm IDE (Leo 10.5.6)

I'll go first:

0. Used a DVI2VGA adapter for my card.
1. Clean install of Kalyway 10.5.2. DO NOT INSTALL ATI video drivers.
2. Installed Leopard Graphics Update by manually downloading from Apple's website.
3. Upgraded to 10.5.6 by using Netkas' howto. Don't worry, even though it's titled for 10.5.3, it'll work just fine.
4. Removed all ATi kexts except ATINDRV.kext, ATIRadeonX1000.kext, ATIRadeonX1000GA.plugin, ATIRadeonX1000GLDriver.bundle, ATIRadeonX1000VADriver.bundle and ATIRNDRV.kext.
5. Installed this kext pack (only for 71c6 and 10.5.6 Leo).

The following 3 steps are edited excerpts from kozlowski's original post on another thread.

6. Copied files "ATIRadeonX1000.kext","ATIRadeonX1000GA.plugin","ATIRadeonX1000GLDriver.bundle" from /System/Library/Extensions to my desktop.
7. Showed contents of "ATIRadeonX1000.kext", went into /Contents/ and edit the file Info.plist. The line under IOPCIMatch have lots of other device ids. Removed the other device ids and inserted my own 0x71c61002.
8. Showed contents of "ATIRadeonX1000GA.plugin", edited "Info.plist" with TextEdit, edited 2 strings in the following format: 100271C0-0000-0000-0000-000a27898d3e and replaced the 71c0 with 71c6 on both. Save the file.

9. Used Kext Helper to copy the 3 files back and repaired permissions.
10. Used the Extension Repair app to repaired permissions again and flushed the cache.
11. Reboot


After I rebooted, it looked like it was hanging but I realized afterwards it was because I haven't applied the restart patch for my motherboard. I pressed the reset button and it booted straight into the desktop. I saw that it was still in 1024x768. Checked System Profiler and boy it was relieving. QE & CI were perfect and went into System Preferences / Display to be more excited when all the resolutions were all there!

Here's my System Profiler:
Attached File  Picture_2.jpg   69.73KB   853 downloads

There you go guys, hope this helps!

Kexts Download Link: http://www.sendspace.com/file/dy4w0d

Mirror 1: http://www.mediafire...04e75f6e8ebb871

Mirror 2: http://rapidshare.co...0_Kext.zip.html

Mirror 3: http://www.easy-shar... X1650 Kext.zip

Mirror 4: http://www.megaupload.com/?d=SCJB1MFO

Mirror 5: http://www.filefacto..._X1650_Kext_zip

Mirror 6: http://www.slingfile...file/2ZoxP3y34H

Mirror 7: http://drop.io/x1650kexts

Please post a mirror if you can, let everyone enjoy the kexts :)

#2
mac_mother

mac_mother

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts
Seem works very good at ATI X1650 Pro with RV530 Chipset (0x71c6) ... but still suck at ATI X1650 Pro with RV535 Chipset (0x71c7) .. i have Gecube Ati x1650 pro ( 512 PCIe ) 0x71c7 with no luck even try all da fakin method .. btw congrats for u success

PS : Orang batak yah ? HAHAHAHAHA :D

#3
DJ24966

DJ24966

    InsanelyMac Protégé

  • Members
  • Pip
  • 45 posts
  • Gender:Male
  • Location:USA
  • Interests:Technology, Video Games, Sports, The ladies come first tho.
I'm using the X1650 Pro 0x71c1 and have only been able to change my resolution, no methods I have found have enabled any other goodies. Wish I could get it fixed.

#4
DJ24966

DJ24966

    InsanelyMac Protégé

  • Members
  • Pip
  • 45 posts
  • Gender:Male
  • Location:USA
  • Interests:Technology, Video Games, Sports, The ladies come first tho.
Okay, I had problems before when copying files to the extensions folder where i would get a message saying I did not have permission to do what I wanted. So I went into the folder and took every file i was trying to replace and backed them up to the desktop, then moved them from the extension folder to the trash bin.

Used these drivers: http://redirectingat...0_71c1.zip.html

Here is my result: http://i41.tinypic.com/10cklk3.png

I'm happy to say, so far so good!!!

I'm installing WoW right now, so we shall see how that goes ;)

#5
gica69

gica69

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
Hey Tista I tried to download the kext for 71c6 and 10.5.6 only but it takes me to neverland,can you please post them where they could be downloaded easier,thanks in advance.

#6
mac_mother

mac_mother

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts
Ok my unsuccess stories lol
Im use kalyway 5.1 with graphics update for 5.2 by apple
and install modbin's packaged x1650 agp/pcie ... check permissions .. repaired .. and remove kext caches ... Reboot
i got full artifacts on whole of my screen but desktop environment still load and i got all resolutions and can change its.
But no CI/QE support ... Reboot

Put all kexts from Modbins 71c7 Working Fix for 5.2 .. repaired all permissions .. remove kext caches .. Reboot
After Restart :

- Got screen msg "Can not load ATY_WORMY.kext at ATINDRV.kext contents plugins"

- But I got CI/QE and Rotation Enable support ... but screen resolutions back to default 1024 X 768 plus mouse tearing .. and cant change it.

- Can't use OpenGL apps

- I thought probs at ATY_WORMY.kext inside ATINDRV contents plugin .. so i repair permission for that kext .. remove kext caches and ... Reboot

- I Got THE BLACK SCREEN YAY !! ... rebooooooooooot by reset button LOL :D
- I remove ATY_WORMY.kext as single user
- I got my CI/QE rotation back 1024 x 768 still .. with glitch and mouse tearing all openGL apps Crashed .. except xbench .. but after xbench mouse pointer disappear and screen full of artifacts.

- Ok this stupid question .. What the heck happen with ATY_WORMY.kext at ATINDRV.kext contents plugin ? It does influence with OpenGLframework ?

My Specs :
Motherboard : Gigabyte GA-G31m-S2C ( G31 chipset )
Proccesor : Intel Dual Core 2.2 GHz
RAM : 2 GB

GPU : ATI X1650-Pro PCIe 16X / 512 VRAM (1 GB hyper memory support at WindowsXP ) device ID : 71C7 (RV535 chipset)

Many thanks for all kext develops

#7
Tista

Tista

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts
  • Gender:Male
  • Location:Jakarta

Hey Tista I tried to download the kext for 71c6 and 10.5.6 only but it takes me to neverland,can you please post them where they could be downloaded easier,thanks in advance.

I uploaded the kext for Device ID 71c6 and Leo 10.5.6 to this URL:
http://bango29.com/x...6.leo10.5.6.zip

Cheers

Ok my unsuccess stories lol
Im use kalyway 5.1 with graphics update for 5.2 by apple
and install modbin's packaged x1650 agp/pcie ... check permissions .. repaired .. and remove kext caches ... Reboot
i got full artifacts on whole of my screen but desktop environment still load and i got all resolutions and can change its.
But no CI/QE support ... Reboot

Put all kexts from Modbins 71c7 Working Fix for 5.2 .. repaired all permissions .. remove kext caches .. Reboot
After Restart :

- Got screen msg "Can not load ATY_WORMY.kext at ATINDRV.kext contents plugins"

- But I got CI/QE and Rotation Enable support ... but screen resolutions back to default 1024 X 768 plus mouse tearing .. and cant change it.

- Can't use OpenGL apps

- I thought probs at ATY_WORMY.kext inside ATINDRV contents plugin .. so i repair permission for that kext .. remove kext caches and ... Reboot

- I Got THE BLACK SCREEN YAY !! ... rebooooooooooot by reset button LOL :rolleyes:
- I remove ATY_WORMY.kext as single user
- I got my CI/QE rotation back 1024 x 768 still .. with glitch and mouse tearing all openGL apps Crashed .. except xbench .. but after xbench mouse pointer disappear and screen full of artifacts.

- Ok this stupid question .. What the heck happen with ATY_WORMY.kext at ATINDRV.kext contents plugin ? It does influence with OpenGLframework ?

My Specs :
Motherboard : Gigabyte GA-G31m-S2C ( G31 chipset )
Proccesor : Intel Dual Core 2.2 GHz
RAM : 2 GB

GPU : ATI X1650-Pro PCIe 16X / 512 VRAM (1 GB hyper memory support at WindowsXP ) device ID : 71C7 (RV535 chipset)

Many thanks for all kext develops


Have you tried using DVI2VGA adapter?

#8
mac_mother

mac_mother

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts

Have you tried using DVI2VGA adapter?


Hell yes .. still with no luck lol .. the weird things if not load ATY_WORMY.kext .. CI/QE support but resolution stuck at 1024 X 768 with mouse tearing :) *straching butt

#9
Khaled Jamal

Khaled Jamal

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts
Thank you!! it worked for me !
Running MAC OS X 10.5.8 and I have radeon x1650 PCIe 256 MB, Vendor:ATI (0x1002) Device ID:0x71c6. What i did was that i started with downloading these drivers "71c6 hxxp://rapidshare.com/files/67198875/MacLovin_ATi__71c6__Installer_OSX86_10.5.zip.html" and then started from step no 6 !

6. Copied files "ATIRadeonX1000.kext","ATIRadeonX1000GA.plugin","ATIRadeonX1000GLDriver.bundle" from /System/Library/Extensions to my desktop.
7. Showed contents of "ATIRadeonX1000.kext", went into /Contents/ and edit the file Info.plist. The line under IOPCIMatch have lots of other device ids. Removed the other device ids and inserted my own 0x71c61002.
8. Showed contents of "ATIRadeonX1000GA.plugin", edited "Info.plist" with TextEdit, edited 2 strings in the following format: 100271C0-0000-0000-0000-000a27898d3e and replaced the 71c0 with 71c6 on both. Save the file.

9. Used Kext Helper to copy the 3 files back and repaired permissions.
10. Used the Extension Repair app to repaired permissions again and flushed the cache.
11. Reboot

#10
Tista

Tista

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts
  • Gender:Male
  • Location:Jakarta
UPDATE with the kexts zipped and uploaded to various places...add your own mirror if possible please...

The kexts are working perfectly in my current install of 10.5.6 and 10.5.8..





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2015 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy