Jump to content

Success ! Audio - nForce 730i Motherboard with IPC OSX86 ppf5 Installed


  • Please log in to reply
6 replies to this topic

#1
winktinkler

winktinkler

    InsanelyMac Protégé

  • Members
  • Pip
  • 42 posts
:D .... I probably look like this emoticon by now, have been at this for 'days' ......

Cannot get ANY audio to work on Nvidia 730i nForce Motherboard OSX86 iPC PPF5 10.5.6

Would love some help ?

BTW... All of the contributors: Thanks for this distribution, I had spent weeks without success with many other distros, until the PPF5 version came out. Thanks pcwiz and all involved in past work.

Trying to get Audio working ... Have spent probably 50 hours over the last week plus, trying everything I have been able to find on web forums, patching, reinstalling full system, entering my device Id / manufacturer ID in some of the kexts and/or files suggested. see below.

Nvidia 730i nForce Motherboard (Realtek Drivers for WinXP and WinVista both work great on separate hard disk installs)

Onboard Audio
Azalia High-Definition audio
Supports 8-channel audio
Supports S/PDIF output
Supports Jack-Sensing function


Vendor ID 10de
Device 0ac0 MCP79
Class ID 0403

address I have tried (see below) 0x10de0ac0

also have tried (reversed ?) 0x0ac010de (my mistake I think..)


This is a relatively new motherboard (to my knowledge on market since october 08 only, even has HDMI and both optical as well as coaxial SPDIF rear outputs, as above list)

OSX86 Beta Final iPCOSX86 DVD patched thru PPF5 *(see below for my installation settings and choices)

Have installed this distro NUMEROUS times, all installs successful -- never get audio, never get Audio Output and Input settings to show a 'device' present in System Profiler.

In each of the installations have tried 'single' Audio Chipset, including Azalia, and most other ALxxx variations, ADxxx and AppleHDA versions, even legacy versions.

On some installs (I think Azalia or ALC888 variants) system profiler shows an Intel HD Audio and a decimal or hex listing etc. but no audio, nor device showing in the Sound settins Output-Input panels

On a couple of installs, I chose NO AUDIO chipset, and tried patching the Linux dump (see below pasted at bottom or in other post in this forum with dump attached) then rebooting. no luck

Have tried entering the Hex id's for my 'multimedia device' (based on screen during bootup process
in text mode for Manufacturer ID and Device ID (editing the plist files in azalia and azalia controller with vendorID + subsystem pci match and following instructions etc.)

using different methods on web (Taruga, AppleHDA, etc.)

Have tried Linux Dump of the Audio Onboard Device (see pasted below) ... which is detected as AL888 on Linux LIVECD using Sabayon latest version of latter (HOWEVER even in the Linux bootup, do not get audio working,??? it is ALC888 dump) ..Wonder why? Even Linux distro must not be detecting correctly, I guess.

Have taken the Linux dump and used the AppleHDAPatcher utility inside of my OSX86 installation, 'straight' as dumped, drag-drop onto patcher, reboot system, no audio working. The installer dir report success and detected SPDIF etc. output etc.

Have tried editing the linux dump, and changing the 'id hex code' for address to the one my system reports, will not patch. says invalid ID or something like that

Have tried manual edits methods based on Taruga, changing the plist addresses from the defaults based on Azalia same as above reported by my system, no luck

Have audio working on this motherboard in separate hard disk installations of Windows XP Pro 64 Bit, as well as Windows Vista Ultimate 64 Bit Perfectly. The windows drivers for HD are Realtek HD Audio drivers provided with the MOBO or downloaded from Nforce site.

The device ID's reported by windows (both versions ..) are the same I listed above (from bootup devices screen id's etc. )

--------------------------------------------

INSTALLATION SETTINGS AND CHOICES Used for IPC OSX86 PPF5

BIOS SATA TO AHCI

have disabled onboard Video GPU (nVIDIA 9300) since using Nvidia Nforce 8500GT PciEx video
card although will install even if not disabled, and System profiler reports both video 'cards' ...

-v cpus=1 required for installation to take place

choose default install pack ... vanilla kernel default, no othe kernel chosen

choose nvidia inject 2.1.0 1 GB Vram inject (for 8500GT card)

chipset jMicron IDE ATA chosen

audio ONBOARD AUDIO ( in BIOS settings have tried INTERNAL AND EXTERNAL AUDIO CODECS SELECTED

Versus

ONLY EXTERNAL AUDIO CODEC SELECTED ... INSTALLS FINE either way BUT NO AUDIO)

as noted above, have tried just about every KEXT for audio listed (only one at a time) with multiple clean
reinstallations ... no luck


Choose fixes ACPI
CPUS=1
-v VERBOSE fix

choose SMB APPLE 800 (although will work with or without this chosen, have tried multiple times, no difference)



install all programs on distro except AMD specific ones



Reboot, and on first start use -v -f as per directions from pcwiz information


-------------------------------------------------------

Paste of Linux Codec Dump from my system using LiveCD SAbayon Linux distribution latest version)


Codec: Realtek ALC888
Address: 0
Vendor Id: 0x10ec0888
Subsystem Id: 0x10ec0000
Revision Id: 0x100202
No Modem Function Group found
Default PCM:
rates [0x560]: 44100 48000 96000 192000
bits [0xe]: 16 20 24
formats [0x1]: PCM
Default Amp-In caps: N/A
Default Amp-Out caps: N/A
GPIO: io=2, o=0, i=0, unsolicited=1, wake=1
IO[0]: enable=0, dir=0, wake=0, sticky=0, data=0
IO[1]: enable=0, dir=0, wake=0, sticky=0, data=0
Node 0x02 [Audio Output] wcaps 0x411: Stereo
Converter: stream=0, channel=0
PCM:
rates [0x560]: 44100 48000 96000 192000
bits [0xe]: 16 20 24
formats [0x1]: PCM
Power: setting=D0, actual=D0
Node 0x03 [Audio Output] wcaps 0x411: Stereo
Converter: stream=0, channel=0
PCM:
rates [0x560]: 44100 48000 96000 192000
bits [0xe]: 16 20 24
formats [0x1]: PCM
Power: setting=D0, actual=D0
Node 0x04 [Audio Output] wcaps 0x411: Stereo
Converter: stream=0, channel=0
PCM:
rates [0x560]: 44100 48000 96000 192000
bits [0xe]: 16 20 24
formats [0x1]: PCM
Power: setting=D0, actual=D0
Node 0x05 [Audio Output] wcaps 0x411: Stereo
Converter: stream=0, channel=0
PCM:
rates [0x560]: 44100 48000 96000 192000
bits [0xe]: 16 20 24
formats [0x1]: PCM
Power: setting=D0, actual=D0
Node 0x06 [Audio Output] wcaps 0x611: Stereo Digital
Converter: stream=0, channel=0
Digital:
Digital category: 0x0
PCM:
rates [0x5e0]: 44100 48000 88200 96000 192000
bits [0xe]: 16 20 24
formats [0x1]: PCM
Power: setting=D0, actual=D0
Node 0x07 [Vendor Defined Widget] wcaps 0xf00000: Mono
Node 0x08 [Audio Input] wcaps 0x10051b: Stereo Amp-In
Amp-In caps: ofs=0x0b, nsteps=0x1f, stepsize=0x05, mute=1
Amp-In vals: [0x00 0x00]
Converter: stream=0, channel=0
SDI-Select: 0
PCM:
rates [0x560]: 44100 48000 96000 192000
bits [0xe]: 16 20 24
formats [0x1]: PCM
Power: setting=D0, actual=D0
Connection: 1
0x23
Node 0x09 [Audio Input] wcaps 0x10051b: Stereo Amp-In
Amp-In caps: ofs=0x0b, nsteps=0x1f, stepsize=0x05, mute=1
Amp-In vals: [0x00 0x00]
Converter: stream=0, channel=0
SDI-Select: 0
PCM:
rates [0x560]: 44100 48000 96000 192000
bits [0xe]: 16 20 24
formats [0x1]: PCM
Power: setting=D0, actual=D0
Connection: 1
0x22
Node 0x0a [Audio Input] wcaps 0x100711: Stereo Digital
Converter: stream=0, channel=0
SDI-Select: 0
Digital:
Digital category: 0x0
PCM:
rates [0x560]: 44100 48000 96000 192000
bits [0xe]: 16 20 24
formats [0x1]: PCM
Power: setting=D0, actual=D0
Connection: 1
0x1f
Node 0x0b [Audio Mixer] wcaps 0x20010b: Stereo Amp-In
Amp-In caps: ofs=0x17, nsteps=0x1f, stepsize=0x05, mute=1
Amp-In vals: [0x80 0x80] [0x80 0x80] [0x80 0x80] [0x80 0x80] [0x80 0x80] [0x80 0x80] [0x80 0x80] [0x80 0x80] [0x80 0x80] [0x80 0x80]
Connection: 10
0x18 0x19 0x1a 0x1b 0x1c 0x1d 0x14 0x15 0x16 0x17
Node 0x0c [Audio Mixer] wcaps 0x20010f: Stereo Amp-In Amp-Out
Amp-In caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
Amp-In vals: [0x00 0x00] [0x00 0x00]
Amp-Out caps: ofs=0x1f, nsteps=0x1f, stepsize=0x05, mute=0
Amp-Out vals: [0x00 0x00]
Connection: 2
0x02 0x0b
Node 0x0d [Audio Mixer] wcaps 0x20010f: Stereo Amp-In Amp-Out
Amp-In caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
Amp-In vals: [0x00 0x00] [0x00 0x00]
Amp-Out caps: ofs=0x1f, nsteps=0x1f, stepsize=0x05, mute=0
Amp-Out vals: [0x00 0x00]
Connection: 2
0x03 0x0b
Node 0x0e [Audio Mixer] wcaps 0x20010f: Stereo Amp-In Amp-Out
Amp-In caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
Amp-In vals: [0x00 0x00] [0x00 0x00]
Amp-Out caps: ofs=0x1f, nsteps=0x1f, stepsize=0x05, mute=0
Amp-Out vals: [0x00 0x00]
Connection: 2
0x04 0x0b
Node 0x0f [Audio Mixer] wcaps 0x20010f: Stereo Amp-In Amp-Out
Amp-In caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
Amp-In vals: [0x00 0x00] [0x00 0x00]
Amp-Out caps: ofs=0x1f, nsteps=0x1f, stepsize=0x05, mute=0
Amp-Out vals: [0x00 0x00]
Connection: 2
0x05 0x0b
Node 0x10 [Audio Output] wcaps 0x611: Stereo Digital
Converter: stream=0, channel=0
Digital:
Digital category: 0x0
PCM:
rates [0x5e0]: 44100 48000 88200 96000 192000
bits [0xe]: 16 20 24
formats [0x1]: PCM
Power: setting=D0, actual=D0
Node 0x11 [Pin Complex] wcaps 0x400780: Mono Digital
Pincap 0x0814: OUT Detect
Pin Default 0x411110f0: [N/A] Speaker at Ext Rear
Conn = 1/8, Color = Black
DefAssociation = 0xf, Sequence = 0x0
Pin-ctls: 0x00:
Unsolicited: tag=00, enabled=0
Power: setting=D0, actual=D0
Connection: 1
0x10
Node 0x12 [Pin Complex] wcaps 0x400401: Stereo
Pincap 0x0820: IN
Pin Default 0x411111f0: [N/A] Speaker at Ext Rear
Conn = 1/8, Color = Black
DefAssociation = 0xf, Sequence = 0x0
Misc = NO_PRESENCE
Pin-ctls: 0x00:
Power: setting=D0, actual=D0
Node 0x13 [Vendor Defined Widget] wcaps 0xf00000: Mono
Node 0x14 [Pin Complex] wcaps 0x40058f: Stereo Amp-In Amp-Out
Amp-In caps: ofs=0x00, nsteps=0x03, stepsize=0x27, mute=0
Amp-In vals: [0x00 0x00]
Amp-Out caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
Amp-Out vals: [0x00 0x00]
Pincap 0x083e: IN OUT HP Detect Trigger
Pin Default 0x01014410: [Jack] Line Out at Ext Rear
Conn = 1/8, Color = Green
DefAssociation = 0x1, Sequence = 0x0
Pin-ctls: 0x40: OUT
Unsolicited: tag=00, enabled=0
Power: setting=D0, actual=D0
Connection: 5
0x0c* 0x0d 0x0e 0x0f 0x26
Node 0x15 [Pin Complex] wcaps 0x40058f: Stereo Amp-In Amp-Out
Amp-In caps: ofs=0x00, nsteps=0x03, stepsize=0x27, mute=0
Amp-In vals: [0x00 0x00]
Amp-Out caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
Amp-Out vals: [0x00 0x00]
Pincap 0x083e: IN OUT HP Detect Trigger
Pin Default 0x01011412: [Jack] Line Out at Ext Rear
Conn = 1/8, Color = Black
DefAssociation = 0x1, Sequence = 0x2
Pin-ctls: 0xc0: OUT HP
Unsolicited: tag=04, enabled=1
Power: setting=D0, actual=D0
Connection: 5
0x0c* 0x0d 0x0e 0x0f 0x26
Node 0x16 [Pin Complex] wcaps 0x40058f: Stereo Amp-In Amp-Out
Amp-In caps: ofs=0x00, nsteps=0x03, stepsize=0x27, mute=0
Amp-In vals: [0x00 0x00]
Amp-Out caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
Amp-Out vals: [0x00 0x00]
Pincap 0x0836: IN OUT Detect Trigger
Pin Default 0x01016411: [Jack] Line Out at Ext Rear
Conn = 1/8, Color = Orange
DefAssociation = 0x1, Sequence = 0x1
Pin-ctls: 0x40: OUT
Unsolicited: tag=00, enabled=0
Power: setting=D0, actual=D0
Connection: 5
0x0c 0x0d 0x0e* 0x0f 0x26
Node 0x17 [Pin Complex] wcaps 0x40058f: Stereo Amp-In Amp-Out
Amp-In caps: ofs=0x00, nsteps=0x03, stepsize=0x27, mute=0
Amp-In vals: [0x00 0x00]
Amp-Out caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
Amp-Out vals: [0x00 0x00]
Pincap 0x0836: IN OUT Detect Trigger
Pin Default 0x01012414: [Jack] Line Out at Ext Rear
Conn = 1/8, Color = Grey
DefAssociation = 0x1, Sequence = 0x4
Pin-ctls: 0x40: OUT
Unsolicited: tag=00, enabled=0
Power: setting=D0, actual=D0
Connection: 5
0x0c 0x0d 0x0e 0x0f* 0x26
Node 0x18 [Pin Complex] wcaps 0x40058f: Stereo Amp-In Amp-Out
Amp-In caps: ofs=0x00, nsteps=0x03, stepsize=0x27, mute=0
Amp-In vals: [0x00 0x00]
Amp-Out caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
Amp-Out vals: [0x80 0x80]
Pincap 0x08373e: IN OUT HP Detect Trigger
Vref caps: HIZ 50 GRD 80 100
Pin Default 0x01a19c40: [Jack] Mic at Ext Rear
Conn = 1/8, Color = Pink
DefAssociation = 0x4, Sequence = 0x0
Pin-ctls: 0x24: IN VREF_80
Unsolicited: tag=00, enabled=0
Power: setting=D0, actual=D0
Connection: 5
0x0c* 0x0d 0x0e 0x0f 0x26
Node 0x19 [Pin Complex] wcaps 0x40058f: Stereo Amp-In Amp-Out
Amp-In caps: ofs=0x00, nsteps=0x03, stepsize=0x27, mute=0
Amp-In vals: [0x00 0x00]
Amp-Out caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
Amp-Out vals: [0x80 0x80]
Pincap 0x08373e: IN OUT HP Detect Trigger
Vref caps: HIZ 50 GRD 80 100
Pin Default 0x02a19c50: [Jack] Mic at Ext Front
Conn = 1/8, Color = Pink
DefAssociation = 0x5, Sequence = 0x0
Pin-ctls: 0x24: IN VREF_80
Unsolicited: tag=00, enabled=0
Power: setting=D0, actual=D0
Connection: 5
0x0c* 0x0d 0x0e 0x0f 0x26
Node 0x1a [Pin Complex] wcaps 0x40058f: Stereo Amp-In Amp-Out
Amp-In caps: ofs=0x00, nsteps=0x03, stepsize=0x27, mute=0
Amp-In vals: [0x00 0x00]
Amp-Out caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
Amp-Out vals: [0x80 0x80]
Pincap 0x08373e: IN OUT HP Detect Trigger
Vref caps: HIZ 50 GRD 80 100
Pin Default 0x0181344f: [Jack] Line In at Ext Rear
Conn = 1/8, Color = Blue
DefAssociation = 0x4, Sequence = 0xf
Pin-ctls: 0x20: IN VREF_HIZ
Unsolicited: tag=00, enabled=0
Power: setting=D0, actual=D0
Connection: 5
0x0c* 0x0d 0x0e 0x0f 0x26
Node 0x1b [Pin Complex] wcaps 0x40058f: Stereo Amp-In Amp-Out
Amp-In caps: ofs=0x00, nsteps=0x03, stepsize=0x27, mute=0
Amp-In vals: [0x00 0x00]
Amp-Out caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
Amp-Out vals: [0x80 0x80]
Pincap 0x08373e: IN OUT HP Detect Trigger
Vref caps: HIZ 50 GRD 80 100
Pin Default 0x02014c20: [Jack] Line Out at Ext Front
Conn = 1/8, Color = Green
DefAssociation = 0x2, Sequence = 0x0
Pin-ctls: 0x00: VREF_HIZ
Unsolicited: tag=00, enabled=0
Power: setting=D0, actual=D0
Connection: 5
0x0c* 0x0d 0x0e 0x0f 0x26
Node 0x1c [Pin Complex] wcaps 0x400481: Stereo
Pincap 0x0824: IN Detect
Pin Default 0x411111f0: [N/A] Speaker at Ext Rear
Conn = 1/8, Color = Black
DefAssociation = 0xf, Sequence = 0x0
Misc = NO_PRESENCE
Pin-ctls: 0x00:
Unsolicited: tag=00, enabled=0
Power: setting=D0, actual=D0
Node 0x1d [Pin Complex] wcaps 0x400400: Mono
Pincap 0x0820: IN
Pin Default 0x4005e601: [N/A] Line Out at Ext N/A
Conn = Optical, Color = White
DefAssociation = 0x0, Sequence = 0x1
Pin-ctls: 0x00:
Power: setting=D0, actual=D0
Node 0x1e [Pin Complex] wcaps 0x400780: Mono Digital
Pincap 0x0814: OUT Detect
Pin Default 0x014b2130: [Jack] SPDIF Out at Ext Rear
Conn = Comb, Color = Grey
DefAssociation = 0x3, Sequence = 0x0
Misc = NO_PRESENCE
Pin-ctls: 0x00:
Unsolicited: tag=00, enabled=0
Power: setting=D0, actual=D0
Connection: 1
0x06
Node 0x1f [Pin Complex] wcaps 0x400680: Mono Digital
Pincap 0x0824: IN Detect
Pin Default 0x01c46160: [Jack] SPDIF In at Ext Rear
Conn = RCA, Color = Orange
DefAssociation = 0x6, Sequence = 0x0
Misc = NO_PRESENCE
Pin-ctls: 0x00:
Unsolicited: tag=00, enabled=0
Power: setting=D0, actual=D0
Node 0x20 [Vendor Defined Widget] wcaps 0xf00040: Mono
Processing caps: benign=0, ncoeff=25
Node 0x21 [Vendor Defined Widget] wcaps 0xf00000: Mono
Node 0x22 [Audio Mixer] wcaps 0x20010b: Stereo Amp-In
Amp-In caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
Amp-In vals: [0x00 0x00] [0x00 0x00] [0x00 0x00] [0x80 0x80] [0x00 0x00] [0x80 0x80] [0x80 0x80] [0x80 0x80] [0x80 0x80] [0x80 0x80] [0x80 0x80] [0x80 0x80]
Connection: 12
0x18 0x19 0x1a 0x1b 0x1c 0x1d 0x14 0x15 0x16 0x17 0x0b 0x12
Node 0x23 [Audio Mixer] wcaps 0x20010b: Stereo Amp-In
Amp-In caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
Amp-In vals: [0x00 0x00] [0x00 0x00] [0x00 0x00] [0x80 0x80] [0x00 0x00] [0x80 0x80] [0x80 0x80] [0x80 0x80] [0x80 0x80] [0x80 0x80] [0x80 0x80]
Connection: 11
0x18 0x19 0x1a 0x1b 0x1c 0x1d 0x14 0x15 0x16 0x17 0x0b
Node 0x24 [Vendor Defined Widget] wcaps 0xf00000: Mono
Node 0x25 [Audio Output] wcaps 0x411: Stereo
Converter: stream=0, channel=0
PCM:
rates [0x560]: 44100 48000 96000 192000
bits [0xe]: 16 20 24
formats [0x1]: PCM
Power: setting=D0, actual=D0
Node 0x26 [Audio Mixer] wcaps 0x20010f: Stereo Amp-In Amp-Out
Amp-In caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
Amp-In vals: [0x00 0x00] [0x00 0x00]
Amp-Out caps: ofs=0x1f, nsteps=0x1f, stepsize=0x05, mute=0
Amp-Out vals: [0x00 0x00]
Connection: 2
0x25 0x0b

#2
potenuse

potenuse

    InsanelyMac Protégé

  • Members
  • Pip
  • 28 posts
Thanks for the very complete post. Here's one idea straight off the bat. If sound is not working in Linux, there is not much point in using that codec dump with Taruga (it is patching the same nodes used by linux). I have had some problems with linux codec dumps and finally succeeded with the Mandriva Live CD which has the latest ALSA drivers. If you can get sound working with Mandriva, redo a linux dump and see if you can manually patch AppleHDA using those values and Munky's or TheKing's tutes.

#3
winktinkler

winktinkler

    InsanelyMac Protégé

  • Members
  • Pip
  • 42 posts

Thanks for the very complete post. Here's one idea straight off the bat. If sound is not working in Linux, there is not much point in using that codec dump with Taruga (it is patching the same nodes used by linux). I have had some problems with linux codec dumps and finally succeeded with the Mandriva Live CD which has the latest ALSA drivers. If you can get sound working with Mandriva, redo a linux dump and see if you can manually patch AppleHDA using those values and Munky's or TheKing's tutes.



Thanks for your evaluation and reply

Will try this tonight

will check those tutorials (again) I have read so many different links / posts / threads / methods / on this subject I can't keep them straight ...

#4
winktinkler

winktinkler

    InsanelyMac Protégé

  • Members
  • Pip
  • 42 posts

Thanks for your evaluation and reply

Will try this tonight

will check those tutorials (again) I have read so many different links / posts / threads / methods / on this subject I can't keep them straight ...


Success ! ! ! !

Audio now working .... 2 channel using Azalia audio ...

see post in the blog site below ...

Thanks to all who have worked on solutions

google Warp's Logbook or warp101.blogspot or hot-to-get-azalia-hd-audio-working for my post and very helpful blog site for other helpful suggestions and information

Pasted below is what I did to get it working ... 2 channel Audio, Line OUT only, HD Audio

-------------------

How To Get AppleAzaliaAudio WorkingNvidia Nforce 730i Chipset   Motherboard  Delete Extensions.mkext                   Delete AppleHDA.kext if installed    (backup first) Copy AppleAzaliaAudio.kext to working folder on Desktop and backup Open Info.plist in AppleAzaliaAudio.kext Edit by adding    entry  0x10deffff    in line below (already placed first in this example) <key>IOHDAudioCodecVendorID</key>                                    <string>0x10deffff 0x10ecffff 0x14f1ffff 0x11d4ffff 0x434dffff 0x8384ffff</string>  Save as Info.plist, replace Continue into the Plugins folder Open Info.plist in the AppleAzaliaController.kext add (first item on list   0ac010de    in place shown below  (first item)     <key>IOPCIPrimaryMatch</key>                                    <string>0x0ac010de 0x26688086 0x27d88086 0x284b8086 0x32881106 0x026c10de 0x037110de 0x03e410de 0x03f010de 0x044a10de 0x044b10de 0x437b1002 0x43831002 0x75021039</string> Save as Info.plist again, replacing inside kext archive  Install the kext (using kexthelper application, easy install, drag and drop whole kext inside ... ------double check, delete Extensions.mkext again if it has been recreated Repair permissions with OSX86 Tools, deleting all caches, etc. Reboot with -f option Reboot again..Check System Settings, Audio, will no longer be Greyed Out and now have OUTPUT option and working audio.   Sorry no Input still ..
Paste of Linux Codec Dump from my system using LiveCD SAbayon Linux distribution latest version)Codec: Realtek ALC888Address: 0Vendor Id: 0x10ec0888Subsystem Id: 0x10ec0000Revision Id: 0x100202No Modem Function Group foundDefault PCM:rates [0x560]: 44100 48000 96000 192000bits [0xe]: 16 20 24formats [0x1]: PCMDefault Amp-In caps: N/ADefault Amp-Out caps: N/AGPIO: io=2, o=0, i=0, unsolicited=1, wake=1IO[0]: enable=0, dir=0, wake=0, sticky=0, data=0IO[1]: enable=0, dir=0, wake=0, sticky=0, data=0Node 0x02 [Audio Output] wcaps 0x411: StereoConverter: stream=0, channel=0PCM:rates [0x560]: 44100 48000 96000 192000bits [0xe]: 16 20 24formats [0x1]: PCMPower: setting=D0, actual=D0Node 0x03 [Audio Output] wcaps 0x411: StereoConverter: stream=0, channel=0PCM:rates [0x560]: 44100 48000 96000 192000bits [0xe]: 16 20 24formats [0x1]: PCMPower: setting=D0, actual=D0Node 0x04 [Audio Output] wcaps 0x411: StereoConverter: stream=0, channel=0PCM:rates [0x560]: 44100 48000 96000 192000bits [0xe]: 16 20 24formats [0x1]: PCMPower: setting=D0, actual=D0Node 0x05 [Audio Output] wcaps 0x411: StereoConverter: stream=0, channel=0PCM:rates [0x560]: 44100 48000 96000 192000bits [0xe]: 16 20 24formats [0x1]: PCMPower: setting=D0, actual=D0Node 0x06 [Audio Output] wcaps 0x611: Stereo DigitalConverter: stream=0, channel=0Digital:Digital category: 0x0PCM:rates [0x5e0]: 44100 48000 88200 96000 192000bits [0xe]: 16 20 24formats [0x1]: PCMPower: setting=D0, actual=D0Node 0x07 [Vendor Defined Widget] wcaps 0xf00000: MonoNode 0x08 [Audio Input] wcaps 0x10051b: Stereo Amp-InAmp-In caps: ofs=0x0b, nsteps=0x1f, stepsize=0x05, mute=1Amp-In vals: [0x00 0x00]Converter: stream=0, channel=0SDI-Select: 0PCM:rates [0x560]: 44100 48000 96000 192000bits [0xe]: 16 20 24formats [0x1]: PCMPower: setting=D0, actual=D0Connection: 10x23Node 0x09 [Audio Input] wcaps 0x10051b: Stereo Amp-InAmp-In caps: ofs=0x0b, nsteps=0x1f, stepsize=0x05, mute=1Amp-In vals: [0x00 0x00]Converter: stream=0, channel=0SDI-Select: 0PCM:rates [0x560]: 44100 48000 96000 192000bits [0xe]: 16 20 24formats [0x1]: PCMPower: setting=D0, actual=D0Connection: 10x22Node 0x0a [Audio Input] wcaps 0x100711: Stereo DigitalConverter: stream=0, channel=0SDI-Select: 0Digital:Digital category: 0x0PCM:rates [0x560]: 44100 48000 96000 192000bits [0xe]: 16 20 24formats [0x1]: PCMPower: setting=D0, actual=D0Connection: 10x1fNode 0x0b [Audio Mixer] wcaps 0x20010b: Stereo Amp-InAmp-In caps: ofs=0x17, nsteps=0x1f, stepsize=0x05, mute=1Amp-In vals: [0x80 0x80] [0x80 0x80] [0x80 0x80] [0x80 0x80] [0x80 0x80] [0x80 0x80] [0x80 0x80] [0x80 0x80] [0x80 0x80] [0x80 0x80]Connection: 100x18 0x19 0x1a 0x1b 0x1c 0x1d 0x14 0x15 0x16 0x17Node 0x0c [Audio Mixer] wcaps 0x20010f: Stereo Amp-In Amp-OutAmp-In caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1Amp-In vals: [0x00 0x00] [0x00 0x00]Amp-Out caps: ofs=0x1f, nsteps=0x1f, stepsize=0x05, mute=0Amp-Out vals: [0x00 0x00]Connection: 20x02 0x0bNode 0x0d [Audio Mixer] wcaps 0x20010f: Stereo Amp-In Amp-OutAmp-In caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1Amp-In vals: [0x00 0x00] [0x00 0x00]Amp-Out caps: ofs=0x1f, nsteps=0x1f, stepsize=0x05, mute=0Amp-Out vals: [0x00 0x00]Connection: 20x03 0x0bNode 0x0e [Audio Mixer] wcaps 0x20010f: Stereo Amp-In Amp-OutAmp-In caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1Amp-In vals: [0x00 0x00] [0x00 0x00]Amp-Out caps: ofs=0x1f, nsteps=0x1f, stepsize=0x05, mute=0Amp-Out vals: [0x00 0x00]Connection: 20x04 0x0bNode 0x0f [Audio Mixer] wcaps 0x20010f: Stereo Amp-In Amp-OutAmp-In caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1Amp-In vals: [0x00 0x00] [0x00 0x00]Amp-Out caps: ofs=0x1f, nsteps=0x1f, stepsize=0x05, mute=0Amp-Out vals: [0x00 0x00]Connection: 20x05 0x0bNode 0x10 [Audio Output] wcaps 0x611: Stereo DigitalConverter: stream=0, channel=0Digital:Digital category: 0x0PCM:rates [0x5e0]: 44100 48000 88200 96000 192000bits [0xe]: 16 20 24formats [0x1]: PCMPower: setting=D0, actual=D0Node 0x11 [Pin Complex] wcaps 0x400780: Mono DigitalPincap 0x0814: OUT DetectPin Default 0x411110f0: [N/A] Speaker at Ext RearConn = 1/8, Color = BlackDefAssociation = 0xf, Sequence = 0x0Pin-ctls: 0x00:Unsolicited: tag=00, enabled=0Power: setting=D0, actual=D0Connection: 10x10Node 0x12 [Pin Complex] wcaps 0x400401: StereoPincap 0x0820: INPin Default 0x411111f0: [N/A] Speaker at Ext RearConn = 1/8, Color = BlackDefAssociation = 0xf, Sequence = 0x0Misc = NO_PRESENCEPin-ctls: 0x00:Power: setting=D0, actual=D0Node 0x13 [Vendor Defined Widget] wcaps 0xf00000: MonoNode 0x14 [Pin Complex] wcaps 0x40058f: Stereo Amp-In Amp-OutAmp-In caps: ofs=0x00, nsteps=0x03, stepsize=0x27, mute=0Amp-In vals: [0x00 0x00]Amp-Out caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1Amp-Out vals: [0x00 0x00]Pincap 0x083e: IN OUT HP Detect TriggerPin Default 0x01014410: [Jack] Line Out at Ext RearConn = 1/8, Color = GreenDefAssociation = 0x1, Sequence = 0x0Pin-ctls: 0x40: OUTUnsolicited: tag=00, enabled=0Power: setting=D0, actual=D0Connection: 50x0c* 0x0d 0x0e 0x0f 0x26Node 0x15 [Pin Complex] wcaps 0x40058f: Stereo Amp-In Amp-OutAmp-In caps: ofs=0x00, nsteps=0x03, stepsize=0x27, mute=0Amp-In vals: [0x00 0x00]Amp-Out caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1Amp-Out vals: [0x00 0x00]Pincap 0x083e: IN OUT HP Detect TriggerPin Default 0x01011412: [Jack] Line Out at Ext RearConn = 1/8, Color = BlackDefAssociation = 0x1, Sequence = 0x2Pin-ctls: 0xc0: OUT HPUnsolicited: tag=04, enabled=1Power: setting=D0, actual=D0Connection: 50x0c* 0x0d 0x0e 0x0f 0x26Node 0x16 [Pin Complex] wcaps 0x40058f: Stereo Amp-In Amp-OutAmp-In caps: ofs=0x00, nsteps=0x03, stepsize=0x27, mute=0Amp-In vals: [0x00 0x00]Amp-Out caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1Amp-Out vals: [0x00 0x00]Pincap 0x0836: IN OUT Detect TriggerPin Default 0x01016411: [Jack] Line Out at Ext RearConn = 1/8, Color = OrangeDefAssociation = 0x1, Sequence = 0x1Pin-ctls: 0x40: OUTUnsolicited: tag=00, enabled=0Power: setting=D0, actual=D0Connection: 50x0c 0x0d 0x0e* 0x0f 0x26Node 0x17 [Pin Complex] wcaps 0x40058f: Stereo Amp-In Amp-OutAmp-In caps: ofs=0x00, nsteps=0x03, stepsize=0x27, mute=0Amp-In vals: [0x00 0x00]Amp-Out caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1Amp-Out vals: [0x00 0x00]Pincap 0x0836: IN OUT Detect TriggerPin Default 0x01012414: [Jack] Line Out at Ext RearConn = 1/8, Color = GreyDefAssociation = 0x1, Sequence = 0x4Pin-ctls: 0x40: OUTUnsolicited: tag=00, enabled=0Power: setting=D0, actual=D0Connection: 50x0c 0x0d 0x0e 0x0f* 0x26Node 0x18 [Pin Complex] wcaps 0x40058f: Stereo Amp-In Amp-OutAmp-In caps: ofs=0x00, nsteps=0x03, stepsize=0x27, mute=0Amp-In vals: [0x00 0x00]Amp-Out caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1Amp-Out vals: [0x80 0x80]Pincap 0x08373e: IN OUT HP Detect TriggerVref caps: HIZ 50 GRD 80 100Pin Default 0x01a19c40: [Jack] Mic at Ext RearConn = 1/8, Color = PinkDefAssociation = 0x4, Sequence = 0x0Pin-ctls: 0x24: IN VREF_80Unsolicited: tag=00, enabled=0Power: setting=D0, actual=D0Connection: 50x0c* 0x0d 0x0e 0x0f 0x26Node 0x19 [Pin Complex] wcaps 0x40058f: Stereo Amp-In Amp-OutAmp-In caps: ofs=0x00, nsteps=0x03, stepsize=0x27, mute=0Amp-In vals: [0x00 0x00]Amp-Out caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1Amp-Out vals: [0x80 0x80]Pincap 0x08373e: IN OUT HP Detect TriggerVref caps: HIZ 50 GRD 80 100Pin Default 0x02a19c50: [Jack] Mic at Ext FrontConn = 1/8, Color = PinkDefAssociation = 0x5, Sequence = 0x0Pin-ctls: 0x24: IN VREF_80Unsolicited: tag=00, enabled=0Power: setting=D0, actual=D0Connection: 50x0c* 0x0d 0x0e 0x0f 0x26Node 0x1a [Pin Complex] wcaps 0x40058f: Stereo Amp-In Amp-OutAmp-In caps: ofs=0x00, nsteps=0x03, stepsize=0x27, mute=0Amp-In vals: [0x00 0x00]Amp-Out caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1Amp-Out vals: [0x80 0x80]Pincap 0x08373e: IN OUT HP Detect TriggerVref caps: HIZ 50 GRD 80 100Pin Default 0x0181344f: [Jack] Line In at Ext RearConn = 1/8, Color = BlueDefAssociation = 0x4, Sequence = 0xfPin-ctls: 0x20: IN VREF_HIZUnsolicited: tag=00, enabled=0Power: setting=D0, actual=D0Connection: 50x0c* 0x0d 0x0e 0x0f 0x26Node 0x1b [Pin Complex] wcaps 0x40058f: Stereo Amp-In Amp-OutAmp-In caps: ofs=0x00, nsteps=0x03, stepsize=0x27, mute=0Amp-In vals: [0x00 0x00]Amp-Out caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1Amp-Out vals: [0x80 0x80]Pincap 0x08373e: IN OUT HP Detect TriggerVref caps: HIZ 50 GRD 80 100Pin Default 0x02014c20: [Jack] Line Out at Ext FrontConn = 1/8, Color = GreenDefAssociation = 0x2, Sequence = 0x0Pin-ctls: 0x00: VREF_HIZUnsolicited: tag=00, enabled=0Power: setting=D0, actual=D0Connection: 50x0c* 0x0d 0x0e 0x0f 0x26Node 0x1c [Pin Complex] wcaps 0x400481: StereoPincap 0x0824: IN DetectPin Default 0x411111f0: [N/A] Speaker at Ext RearConn = 1/8, Color = BlackDefAssociation = 0xf, Sequence = 0x0Misc = NO_PRESENCEPin-ctls: 0x00:Unsolicited: tag=00, enabled=0Power: setting=D0, actual=D0Node 0x1d [Pin Complex] wcaps 0x400400: MonoPincap 0x0820: INPin Default 0x4005e601: [N/A] Line Out at Ext N/AConn = Optical, Color = WhiteDefAssociation = 0x0, Sequence = 0x1Pin-ctls: 0x00:Power: setting=D0, actual=D0Node 0x1e [Pin Complex] wcaps 0x400780: Mono DigitalPincap 0x0814: OUT DetectPin Default 0x014b2130: [Jack] SPDIF Out at Ext RearConn = Comb, Color = GreyDefAssociation = 0x3, Sequence = 0x0Misc = NO_PRESENCEPin-ctls: 0x00:Unsolicited: tag=00, enabled=0Power: setting=D0, actual=D0Connection: 10x06Node 0x1f [Pin Complex] wcaps 0x400680: Mono DigitalPincap 0x0824: IN DetectPin Default 0x01c46160: [Jack] SPDIF In at Ext RearConn = RCA, Color = OrangeDefAssociation = 0x6, Sequence = 0x0Misc = NO_PRESENCEPin-ctls: 0x00:Unsolicited: tag=00, enabled=0Power: setting=D0, actual=D0Node 0x20 [Vendor Defined Widget] wcaps 0xf00040: MonoProcessing caps: benign=0, ncoeff=25Node 0x21 [Vendor Defined Widget] wcaps 0xf00000: MonoNode 0x22 [Audio Mixer] wcaps 0x20010b: Stereo Amp-InAmp-In caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1Amp-In vals: [0x00 0x00] [0x00 0x00] [0x00 0x00] [0x80 0x80] [0x00 0x00] [0x80 0x80] [0x80 0x80] [0x80 0x80] [0x80 0x80] [0x80 0x80] [0x80 0x80] [0x80 0x80]Connection: 120x18 0x19 0x1a 0x1b 0x1c 0x1d 0x14 0x15 0x16 0x17 0x0b 0x12Node 0x23 [Audio Mixer] wcaps 0x20010b: Stereo Amp-InAmp-In caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1Amp-In vals: [0x00 0x00] [0x00 0x00] [0x00 0x00] [0x80 0x80] [0x00 0x00] [0x80 0x80] [0x80 0x80] [0x80 0x80] [0x80 0x80] [0x80 0x80] [0x80 0x80]Connection: 110x18 0x19 0x1a 0x1b 0x1c 0x1d 0x14 0x15 0x16 0x17 0x0bNode 0x24 [Vendor Defined Widget] wcaps 0xf00000: MonoNode 0x25 [Audio Output] wcaps 0x411: StereoConverter: stream=0, channel=0PCM:rates [0x560]: 44100 48000 96000 192000bits [0xe]: 16 20 24formats [0x1]: PCMPower: setting=D0, actual=D0Node 0x26 [Audio Mixer] wcaps 0x20010f: Stereo Amp-In Amp-OutAmp-In caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1Amp-In vals: [0x00 0x00] [0x00 0x00]Amp-Out caps: ofs=0x1f, nsteps=0x1f, stepsize=0x05, mute=0Amp-Out vals: [0x00 0x00]Connection: 20x25 0x0b


#5
holyfield

holyfield

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 243 posts
  • Gender:Male
  • Location:Europe
Congratulations! :thumbsdown_anim:

What you think if you add your long dumps as attachement in text file or another option is add it inside codebox? Codebox is very useful as its keeps post short and add scrollable box with your code or dump and so on. Its just hard to scroll those long dumps!

Otherwise, good to hear about your success!

#6
winktinkler

winktinkler

    InsanelyMac Protégé

  • Members
  • Pip
  • 42 posts

Congratulations! :rolleyes:

What you think if you add your long dumps as attachement in text file or another option is add it inside codebox? Codebox is very useful as its keeps post short and add scrollable box with your code or dump and so on. Its just hard to scroll those long dumps!

Otherwise, good to hear about your success!



thanks for your suggestion I did not know how to used codeboxes, and figured it out

#7
cags12

cags12

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
Hello winktinkler

i have the same chipset than you but an msi one. Well, i followed your indications to install mac that i found in your blog, and everything works great including the audio.
BUT (i hate to say it) i can´t boot without the cpus=1 flag, when i go into system profiler an also cpu-x it shows 1 core and 4 threads (i have Intel core 2 quad 9550), i tried override the DSDT removing the aliases and patching it all, but i still with the problem. i know you have a quad core too, then i ask you if you can use your 4 cores? cpu-x tells you 4 cores? did you do something that helped you to use all your cores?
im a kind of desperate heheh

Thnaks in advance!!





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy