Jump to content

Intel PRO/100 VE NIC


  • Please log in to reply
329 replies to this topic

#281
StarDust123

StarDust123

    InsanelyMac Protégé

  • Members
  • Pip
  • 20 posts
  • Gender:Male
  • Location:Minnesota
i am running a core 2 duo on this and it is clocked at 2.13 GHz and do I install Chameleon 2.0 after OSx or before?

#282
Azimutz

Azimutz

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 759 posts
  • Gender:Male
  • Location:Almadan - Pt.
  • Interests:At the moment, OSx86.. In general, music, audiophile, computers.. to much to mention...
We'll talk more in private.. we are out of topic already. You have machine to run Snow 64 bit, vanilla kernel (untouched) and 2 kexts,
fakesmc.lext and Disabler.kext. This is just to boot and install. Graphics most probably work with Chameleon's Graphics Enabler. Network
will work.. you're good :hysterical:
Chameleon, 2.0 RC4 or a dev version from the repository. There are some on this topic:
http://www.insanelym...howtopic=201902
or if you want to see what's keeping me busy atm:
http://forum.voodoop...pic,1227.0.html

Later...

#283
Slus

Slus

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts
@Azimutz Alright well that didnt work....

First of all, I downloaded the kext on post 266. inside the zip file its a bunch of files that i need to compile with xcode but there is this folder where there is an actual intel8522x.kext file so I used that one.

Second you told me to put it in /Extra/Extensions which means my harddrive then the extar folder then the extensions folder... the thing is I didnt have a Extensions folder in my Extra folder. I have one in the /System/Library/extensions. (in there there is IONetworkingFamily.kext) What I did is I created a folder named Extensions in /Extra and put the kext in there... used the terminal command and rebooted... it didnt work



Third, what i did next is put the intel8522x kext in /System/Library and another in /System/Library/IONetworkingFamily/whatever/plugins redid the terminal commands and rebooted and still nothing......



Anybody have a fix for this?

#284
Azimutz

Azimutz

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 759 posts
  • Gender:Male
  • Location:Almadan - Pt.
  • Interests:At the moment, OSx86.. In general, music, audiophile, computers.. to much to mention...
Sorry @Slus, i forgot to mention you have to add to /Extra/Extension also IONetworkingFamily.kext, it's needed as dependency.
Remove the stuff you did to /S/L and /S/L/E.. you don't just put files in those folders, they have to be installed properly and kests don't go on S/L!
Copy IONetworkingFamily.kext from /S/L/E and remove the "Plugins" folder inside, you don't need it on /E/E, just IONetworkingFamily.kext+AppleIntel8522x.kext. Run the command again and reboot.
This stuff is on my guide... most of it ;) no time to update it now.

#285
getteen

getteen

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts

>> At First write down your device ID and vender ID.
>> Now open Terminal.app and type in the following line and press Enter key.

sudo vi /System/Library/Extensions/IONetworkingFamily.kext/Contents/PlugIns/AppleIntel8255x.kext/Contents/Info.plist

>> you will be prompted to enter your password. do it.

>> press 'J' key to move down your cursor and you will find something like the following.

<key>IOPCIMatch</key>
<string>0x10518086 0x10508086 0x10298086 0x10308086&amp;0xfff0ffff 0x12098086 0x12278086 0x12288086 0x12298086 0x24498086 0x24598086 0x245d8086 0x10918086 0x10608086&amp;0xfff0ffff</string>

>> In vi mode you can move your cursor up and down, or right and left using J(down), K(up), H(left) and L(right) keys.

>> insert your device ID and venderID somewhere else. mine is 0x10928086, eg, my deviceID is 1092 and venderID is 8086.
>> to insert, press 'I' key and now you are in inserting mode, now write your ID. If done, then press 'ESC' key to exit from inserting mode.
>> If all went good, its time to save. write ':wq!' to save and exit vi mode.
>> if something went wrong, use 'X' key to delete letters or write ':q!' to quit vi mode unsaved.

>> now, write the following line on Terminal.app to clear kext cache.

rm /System/Library/Extensions.*

>> Quit the Termunal.app.
>> Open DiskUtility, and perform permission repair.
>> Reboot your machine.



Hi where do i find my device id and my vender id?

#286
Azimutz

Azimutz

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 759 posts
  • Gender:Male
  • Location:Almadan - Pt.
  • Interests:At the moment, OSx86.. In general, music, audiophile, computers.. to much to mention...
Check my guide. It's all explained there...

#287
AntonioRove

AntonioRove

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts

Check my guide. It's all explained there...



Thank you for guide.

#288
Jrveteran

Jrveteran

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts
  • Gender:Male
  • Location:Jamaica
ok am the 1 of many new menber here and i am experimenting with the mac os's now i recently installed the tiger 10.4.8 and it was successfull, i installed it on a intel pent 4, processor 1.70 ghz, with 512 memory it is speedy an everything except the network card wont show up all am seeing is serial port, and in the network pref its red meaning it not connected, i came her and i found alot a different ideas an thing i used post #2 and nothing worked, i used number 10 still nothing so i stop and read around an search for other things on my windows same system but different HD and i foung this post i used it and it gave me the network for the Tiger 10.4.8 this pic has all the instrustions and ill upload the fine too.

MUST WORN YOU THAT IT MESSES WITH A FEW THINGS TOO LIKE SOUND AND PSP AND 3 MORE THINGS, SO USE AT OWN RISK, ANYTHING YOU SEE WITH CAUTION ICON AFTER DISK UTITILITY VERICATION IS RUN CAN BE RESOLVED ON THE SITE.

Attached Files



#289
Azimutz

Azimutz

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 759 posts
  • Gender:Male
  • Location:Almadan - Pt.
  • Interests:At the moment, OSx86.. In general, music, audiophile, computers.. to much to mention...
@AntonioRove, your welcome ;) Sorry it is a "bit hidden" but, i really don't have time to maintain it properly atm so, better leave it as is.

#290
frankolo

frankolo

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 238 posts

Check my guide. It's all explained there...


Only a question..


Your guide (thanks) is valid with iDeneb v1.5.1 10.5.7?

I'd like to fix this problme.. :wacko:

#291
frankolo

frankolo

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 238 posts
I have to boot everytime with -f?

#292
brew

brew

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts

I modified AppleIntel8255x.kext (10.5.8) to work on 10.6, 32/64bit.

Binary & Source:

http://www.mediafire.com/?abayrhdhjhe


Nice... Did the trick for my SnowLeopard 10.6.3
Thanks!!!

#293
fifalover

fifalover

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
can any body tell me in desktop pc or motherboards wifi are avilable or not?
FIFA WORLD CUP 2010

#294
Azimutz

Azimutz

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 759 posts
  • Gender:Male
  • Location:Almadan - Pt.
  • Interests:At the moment, OSx86.. In general, music, audiophile, computers.. to much to mention...
@frankolo,
sorry for the late reply, only now i received new post notification :(
Yep, system or installer is irrelevant for the guide! It's only about the driver and hardware.
What's the device id?
Were are you loading the driver from? If Extra/Extensions try Extra/Extensions.mkext. I had that problem on Leo,
needed to edit OSBundleRequired on info.plist. If it's not that i'm not sure..

#295
Jrveteran

Jrveteran

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts
  • Gender:Male
  • Location:Jamaica
just download unzip and install the kext helper use it to install the kexts, enter your pass word and select the easy install menu it will do all the work all you need to do is wait till its finished and reboot your computer (Mac) lol then you will be good to go, please wownload the two pictures to know what i mean

#296
iTAG

iTAG

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts
that dint work for me also

#297
Braddman

Braddman

    InsanelyMac Protégé

  • Members
  • PipPip
  • 65 posts

@frankolo,
sorry for the late reply, only now i received new post notification :angry:
Yep, system or installer is irrelevant for the guide! It's only about the driver and hardware.
What's the device id?
Were are you loading the driver from? If Extra/Extensions try Extra/Extensions.mkext. I had that problem on Leo,
needed to edit OSBundleRequired on info.plist. If it's not that i'm not sure..


Hey brother-



I haven't tried your guide yet, but man am I having issues. I'm using a HP dx2300 with the built in Intel lan, and I used the kext in the first few posts to try to get it working. After repeating the steps a few times, voila, it worked all of a sudden. Then I got the stupid idea to update airport from software update and it said cable unplugged after that. I never got it working again so I reinstalled 10.5.6 ideneb and never got it working after that either, it never recognized the ethernet adapter again even after I repeated the exact same steps I did the first time. I just don't get it.



I'm going to try your guide but does anyone have a fresh IONetworkingFamily.kext they can send me or upload?

#298
Azimutz

Azimutz

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 759 posts
  • Gender:Male
  • Location:Almadan - Pt.
  • Interests:At the moment, OSx86.. In general, music, audiophile, computers.. to much to mention...
@Braddman, try the guide and use the AppleIntel8255x.kext i posted there. Then you can ask all the questions in the world ;)

#299
Braddman

Braddman

    InsanelyMac Protégé

  • Members
  • PipPip
  • 65 posts

@Braddman, try the guide and use the AppleIntel8255x.kext i posted there. Then you can ask all the questions in the world :P


OK I tried following the guide but got lost at one point, here's what I did.

-Copied IONetworkingFamily.kext to the desktop (from SLE because I didn't have any other ones.)

-Checked inside, no AppleIntel8255x.kext, so I used one I had that had previously worked. Copied that into IONetworkingFamily.kext inside the PlugIns folder.

-Edited the info.plist inside that kext and removed all strings but my correct ID (0x27dc8086) which worked once before.

-Saved info.plist



That's where I got lost. You said something about an EXTRA folder in the guide, I wasn't sure what to do, so I copied the modified IONetworkingFamily.kext back to S\L\E and then tried both Kext Helper and the terminal to install it. Using terminal, it said the kext was already loaded.

Rebooted, still nothing. Can you help?



Edit- Just checked, which driver are you referring to in your guide?

#300
Braddman

Braddman

    InsanelyMac Protégé

  • Members
  • PipPip
  • 65 posts
OK Edit--



I don't have an Extra folder, that's what was losing me...SO..I did the following:



If it doesn't work or you want to use the kexts in S/L/E, edit in both IONF and AI8255x info.plist, the string in the
key OSBundleRequired like this:

before
<key>OSBundleRequired</key>
<string>Network-Root</string>

after
<key>OSBundleRequired</key>
<string>Root</string>


Now..I'm ready to put the kext in Extensions. Do I copy the kext file over THEN run KextHelper on it, or just run Kext Helper, drag the kext into it from the desktop and be done?





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy