Jump to content

[GUIDA] Broadcom 5787M con i kext di nobb1x


  • Please log in to reply
15 replies to this topic

#1
razorbac

razorbac

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 158 posts
  • Gender:Male
  • Location:Torino
Allora, visto che ho trovato tanta gente (sia qui che nei forum internazionali) che sclera per far girare la scheda ethernet Broadcom 5787M spero di dare una mano.

REQUISITI MINIMI:
CHE SIA CHIARO DA SUBITO: QUESTA GUIDA E TESTATA E FUNZIONANTE PER LA SCHEDA BROADCOM5787M 14e4:1693 E NON PER ALTRE!!!! quindi non provate su altre schede broacom se non sapete quello che state facendo.

INSTALLAZIONE:
Ok are we go!!!
Prima di tutto procuratevi il paccheto dei kext di nobb1x da qui
Poi procedete alla disinstallazione di eventuali precedenti kext che avete usato per le prove (tipo broadcom 5751/5701). Ora che siete pronti installate il kext "AppleBCM5758MEthernet.kext" contenuto nel pacchetto, con kexthelper o da terminale, come preferite.
Una volta fatto ciò prendete la cartella "start_promisc" che trovate nel pacchetto che avete scaricato sopra e trascinatela in /Library/StartupItems (mi raccomando NON /System/library... ma solo /Library...) poi aprite il file "start_promisc" che si trova all'interno con il text edit (destro-->apri con...) e troverete due variabili chiamate "INTF" e "KEXTPATH", dovrebbero essere gia apposto ma se di fianco alle due variabili on c'è scritto nulla modificatele così: "INTF=en1" e "KEXTPATH=/System/Library/Extensions/AppleBCM5787MEthernet.kext".
Dopodichè aprite il terminale e digitate:
-sudo -s
-password: vostra password
-sudo chmod -R 755 /Library/StertupItems/Stert_Promisc
-sudo chown -R root:wheel /Library/StertupItems/Stert_Promisc
Chiudete il terminale e riavviate e se tutto e andato bene in preferenze network dovrebbe vedervi la scheda ethernet e potrete collegarvi tranquillamente.

EVENTUALI PROBLEMI:

Se la scheda appare ma non riuscite a connettervi provate così:
-Andate in /Library/StertupItems/Stert_Promisc e fate due click sul file start_promisc si aprira il terminale e macinera per meno di mezzo secondo. dopodichè riprovate ad aprire il vostro browser.
-Se anche facendo come detto sopra non funziona, a pc accesso staccate il cavo lan e riattaccatelo dopo una decina di secondi.
-se persino così non funziona riavviate senza cavo lan, seguite la prima opzione con il cavo la scollegato, attacate il cavo lan. (al liite dopo averlo riattaccato riusate la prima soluzione).
-se anche così non funziona non vi resta che piangere ochiedere aito a qualcuno più bravo di me :wacko:

NUOVO: se non vi funziona provate con questo script: script Grazie a djtzn per la segnalazione e a magnat2 per la creazione

Spero che questa piccola guida vi sia utilie com lo è stata a me.

Specifico che io mi sono limitato a tradure le istruzioni di nobb1x e che non mi assumo nessuna responsabilità per evntuali problemi al vostro pc.

è la prima guida che posto in vita mia quindi se ci sono errori o migliorie che posso apportare sono benaccetti i cosigli

#2
Djtzn

Djtzn

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 164 posts
  • Gender:Male
  • Location:Carassai, Italia
  • Interests:Musica<br />Musica<br />Musica<br />Musica<br />Computer<br...
grazie razorbac ma ancora non riesco a farla funzionare...in compenso però non so come mi vede la atheros come airport ma neanche quella funziona

#3
razorbac

razorbac

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 158 posts
  • Gender:Male
  • Location:Torino
ma sei sicuro che sia prorpio la broadcom 5787M con il codice che ho scritto sopra...
per il wifi invece è una cosa strana che sia apparso all'improvviso cmq prova a dare un okkiata qui http://forum.insanel...showtopic=33089

per la broadcom dai ancora un occhiata qui se no proprio non saprei che fare http://forum.insanel...howtopic=127903

#4
Djtzn

Djtzn

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 164 posts
  • Gender:Male
  • Location:Carassai, Italia
  • Interests:Musica<br />Musica<br />Musica<br />Musica<br />Computer<br...
ok ora funziona perfettamente
mi ha aiutato questo script http://forum.insanel...mp;#entry916658

#5
razorbac

razorbac

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 158 posts
  • Gender:Male
  • Location:Torino
Ottimo sono contento :) sono addirittura finito in una firma wow XD

#6
Djtzn

Djtzn

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 164 posts
  • Gender:Male
  • Location:Carassai, Italia
  • Interests:Musica<br />Musica<br />Musica<br />Musica<br />Computer<br...
siccome per far funzionare la scheda bisogna far sempre ricorso a questo script l'ho messo tra le applicazioni in avvio automatico...
l'unico problema è che lo script (secondo me:non ne capisco niente) non ha un comando di chiusura e rimane aperto fino a quando non fai "uscita forzata"

che comando bisogna dare allo script per farlo chiudere?
(allego il codice dello script)
do shell script "sudo tcpdump -i en1"password"youradminpassword"with administrator privileges
do shell script "sudo tcpdump -i en1" password"youradminpassword"with administrator privileges

tell aplication "Finder"
activate
clean up Finder window id 68 by name
close Finder window 1

end tell


#7
frtommy

frtommy

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 420 posts
  • Gender:Male
  • Location:Italy
Ciao Razorbac...
Ho acquistato da meno di un mese il tuo stesso notebook.
Devo dire che con grande {censored} ho preso un notebook pienamente supportato dal Leo.

Mi domandavo che versione hai installato te.
Io ho installato una Iatkos 10.5.5

Scheda Video x3100, OTB.
Dopo ho installato con lo script trovato nella Kalyway 10.5.2 lo script per far funzionare il WIFI broadcom.

Poi dato che non funzionava il plug verde per l'uscita audio, ho usato l'installer 1 alc268 poi installato con kexthelper il file HDAenabler ( se non ricordo male il nome è quello ) e così facendo funziona la scelta di usare gli altoparlanti interni del notebook sia l'uscita per metterci cuffie o casse.

Pultroppo dopo questa installazione ho perso la possibilità di entrare in alcuni menu del System Preferences, ad esempio quello per modificare la tastiera. Cioè dove si può scegliere quale taasto assegnare al pulsante mela command etc...
Cioè ci clicco per entrare e poi rimane in loading perenne senza visualizzare niente.

La Lan devo provare per bene, perch con il promisc mi è andata una volta sola, poi al riavvio seguente no. Ora non sò se è perchè dovevo scollegare il cavo ogni riavvio o spegnimento o perchè non và + per un mistero dell'informatica, cmq io non la uso.
Però un mio amico con il mio solito portatile è costretto a lanciare il comando da terminale ogni volta.
Poco male, però mi piaceva risolvere...
Ora proverò anche con la tua guida.

Scusa se sono andato un pò OT, ma mi piacerebbe avere la tua opinione sui mie errori e sulla tua versione di Leo. Visto che abbiamo il solito portatile e vorrei farlo funzionare alla perfezione pure io :)
E soprattutto sei l'unico italiano. Perchè fino a ieri scrivevo nel topic dell'extensa 5220 ma in inglese...

Grazie mille in anticipo.
Ciaooo.

#8
razorbac

razorbac

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 158 posts
  • Gender:Male
  • Location:Torino
Beh dunque per l'audio puoi usare i kext ke ho min firma ke hanno anke l'auto sensing, per la lan spero che la mia guida ti dia una mano, mentre per il problema delle preferenze di sistema è strano a me non è mai capitato. se vuoi un consiglio formatta e passa alla ideneb 10.5.5 che va benissimo e poi usa questo pacchetto di kext (sono quelli che uso sul mio extensa 5220 attualmente)

Sono divisi in 2 xke se no il forum non me li fa uploadare

Attached Files



#9
frtommy

frtommy

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 420 posts
  • Gender:Male
  • Location:Italy
Ciao Razorbac.
Grazie mille per la risposta velocissima...
Ti ho inviato anhce un PM.
Ciaooo.

#10
Djtzn

Djtzn

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 164 posts
  • Gender:Male
  • Location:Carassai, Italia
  • Interests:Musica<br />Musica<br />Musica<br />Musica<br />Computer<br...
nessuno sa come fare quello script?

#11
razorbac

razorbac

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 158 posts
  • Gender:Male
  • Location:Torino
no effettivamente anke a me si blocca, ma poco problema subito dopo averlo eseguito faccio destro uscita forzata e vai liscoliscio

#12
frtommy

frtommy

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 420 posts
  • Gender:Male
  • Location:Italy
Confermo...Anche a me si blocca...l'ho provato a usare sull'Extensa 5220 di un mio amico che si collega con LAN, e si bloccava...
Sul mio invece non l'ho mai provato perchè uso il WIFI, e se una volta dovessi usare LAN bè inserisco il comando in terminale...
Certamente se fosse tutto automatizzato sarebbe + bello.
Cmq per la cronoca ormai mi fossilizzerò sulla Iatkos. Visto che la Ideneb non mi funziona ....Bah? misteri dell'informatica.

Non sò se avevo domandato, ma qualcuno ha aggiornato a 10.5.6?

Ciaoooo.

#13
razorbac

razorbac

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 158 posts
  • Gender:Male
  • Location:Torino
No nn ancora perchè sembra che porti più difetti che vantaggi... ma soprattutto tutti parlano di come aggiornare i pc con almeno un dual core noi sfigati con il celeron nn c'è lo spiega nessuno ;)

#14
frtommy

frtommy

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 420 posts
  • Gender:Male
  • Location:Italy

No nn ancora perchè sembra che porti più difetti che vantaggi... ma soprattutto tutti parlano di come aggiornare i pc con almeno un dual core noi sfigati con il celeron nn c'è lo spiega nessuno :)


Aggiorno, installata ieri la Ideneb 1.4 10.5.6
Logicamente da installazione pulita.
Tutto funzionante, la scheda video stranamente non andava il QE allora ho installato i driver pkg presenti nella iatkos 10.5.5 con pacifist e la scheda video ora supporta anche il QE.

Sembra che la batteria regga una 20ina di minuti in +. Però devo ancora testarla...
Ciao Razo...

#15
Blame73

Blame73

    InsanelyMac Protégé

  • Donators
  • 69 posts
  • Gender:Male
  • Location:Italy

Dopodich� aprite il terminale e digitate:
-sudo -s
-password: vostra password
-sudo chmod -R 755 /Library/StertupItems/Stert_Promisc
-sudo chown -R root:wheel /Library/StertupItems/Stert_Promisc


Ciao,
solo una piccola precisazione:

bisogna scrivere:
sudo chmod -R 755 /Library/StartupItems/Start_Promisc
sudo chown -R root:wheel /Library/StartupItems/Start_Promisc

:censored2:

#16
iAndry

iAndry

    InsanelyMac Protégé

  • Members
  • Pip
  • 29 posts
Ciao scusa ti ho mandato anche un MP ^^ mi avresti voglia di spiegrami come istallare il Wireless?? please ho provato di tutto :)

PS ho il tuo stesso pc





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   Web hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy