Jump to content

[How to] Have sound on all of your speakers.


  • Please log in to reply
54 replies to this topic

#1
macgirl

macgirl

    Stargate's Pharaoh

  • Retired
  • 7,612 posts
  • Gender:Female
  • Location:Mexico City
  • Interests:Techie gadgets
Ok you have more than 2 speakers but few movies and songs are 5.1 and you wish to have Speaker fill excitment :P

Before you begin you need to download and install XCode (at least its Audio Applications) Soundflower: linky original maker: http://www.cycling74...ads/soundflower

Soundflower is a system extension (or kext) that allows applications to pass audio to other applications.

Reboot and begin with Auio Midi Setup and add an Agregate Device (Audio Menu or with Command-Shift-A keys)
put all you speakers there and one of the soundflower devices (when it is installed it will show on your Sound Decives as Soundflower(2ch) and Soundflower(16ch)
Attached File  Picture_1.png   146.97KB   4067 downloads
EDIT:
But check that all of your outputs has the same frequency, if they don't have it they wont add outputs

Now Open AU Lab (it is located in /Developer/Applications/Audio) and add as many outputs as you have (each one can handle 1 to 7 speakers) I chose stereo in this example, see:
Attached File  Picture_2.png   51.22KB   2146 downloads
Then add an input:
Attached File  Picture_3.png   53.89KB   1019 downloads
Now select your agregate device in the Audio Device drop menu:
Attached File  Picture_4.png   68.15KB   1535 downloads
Then time pass to the "Input Channels" tab and select the SoundFlower you attach to the Agregate Device:
Attached File  Picture_5.png   57.18KB   1072 downloads
Then a new window appears with this:
Attached File  Picture_6.png   148.64KB   1193 downloads
Select the little numbers on the left of the Audio 1 slider so they appear on the output sliders.
Now, double click on the "Output 1" title and select your agregate device in the drop down menu:
Attached File  Picture_7.png   181.12KB   1144 downloads Attached File  Picture_8.png   172.85KB   839 downloads
Optionally you can add buses (2 for stereo of course), I did this before without the bus thing ant it worked, but there is something different in the sound, I will investigate this later.
Attached File  Picture_9.png   146.3KB   755 downloads
Finally you end with this:
Attached File  Picture_A.png   210.8KB   1019 downloads
You can save this setup with any name.

But in order to make this work you need to select the soundflower device as your output:
Attached File  Picture_b.png   137.48KB   1453 downloads
Remember that Au Lab needs to be running in order to all this work togetther.

With this I can have 6 speaker of my ALC888 plus 8 of my Audigy and another 8 with my Sonica Theater :)

22 speakers = party time:
:)
Enjoy.

#2
Vis

Vis

    InsanelyMac Protégé

  • Members
  • PipPip
  • 66 posts
Lot of detail there, thanks.

I'm curious if this would work for me. I have a 5.1 setup but no 5.1 (which isnt fixable at the present apparently.) so my sound comes out of just two of my speakers.I wouldn't mind getting the other 3 speakers to work though for listening to music, etc. Does this guide only work with digital output? My current setup is 3 co-ax analog ones but I can probably get a cheap spdif cable if the guide calls for it.

#3
fredouille

fredouille

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,192 posts
  • Location:GROVILLE du Nord
Thanks !
it's a pity that I haven't seen it before to test it for the new year party at home !
best wishes
fred

#4
lamune

lamune

    InsanelyMac Protégé

  • Members
  • Pip
  • 18 posts
  • Gender:Male
  • Location:USA
Absolutely awesome guide, finally got 5.1 on my ALC888 =DD
thanks alot macgirl

#5
skull1

skull1

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
i can't get this to work. Should this be paired to a specific kext or codec dump? I'm currently using my own codec dump from my Fedora 9 install.

#6
danroj

danroj

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 481 posts
  • Gender:Male
  • Location:Colombia
work with sound card stac9228 ?

#7
macgirl

macgirl

    Stargate's Pharaoh

  • Retired
  • 7,612 posts
  • Gender:Female
  • Location:Mexico City
  • Interests:Techie gadgets
@skull1 No specific kexts, just a soundcard with several outputs

@danroj sure, you can have internal speakers plus 2 output jacks.

#8
cernst

cernst

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
Thanks macgirl, that works perfectly.

What about the other aggregate device?
Is this a normal aggregate device, to which you manually switch if you watch dvd for example?

#9
macgirl

macgirl

    Stargate's Pharaoh

  • Retired
  • 7,612 posts
  • Gender:Female
  • Location:Mexico City
  • Interests:Techie gadgets
Yes I created one for stereo on all speakers and another for 5.1 output, since I don't have 5.1 on iTunes music I use stereo but in all my speakers, and use 5.1 with 5.1 movies.

#10
starobrno1

starobrno1

    InsanelyMac Legend

  • Banned
  • PipPipPipPipPipPipPip
  • 930 posts
  • Gender:Male
This sounds great but when I told people I succesfully managed to make an aggreagate device out of all my soundcards my Delta 44, Phonic firefly and my Saffire Pro 10I/0 getting a whole bunch of inputs and outputs avaliable for Logic studio Pro 8 some guy said well thats great but its well known aggreagate device doesnt work so good so you will get phaseout problems. Does it work ok for you? I mean its hackmacs were talking about here and maby this phaseout problem are only happening in real macs?

#11
cernst

cernst

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
What is the function of buses in AU Lab?

As I can hear, it only makes the output louder and you have the possibility, to add extra effects.

Do you already have any idea?

#12
macgirl

macgirl

    Stargate's Pharaoh

  • Retired
  • 7,612 posts
  • Gender:Female
  • Location:Mexico City
  • Interests:Techie gadgets
I really don't know about the phase out problems. I gues using this for profesional work is not the best option.

As I said the first time I did it I didn't add the buses, and it worked, then when finally want to write the guide I found another guide that includes these buses and I gave a try, I hear some differences but don't know what is really happening.

#13
Johnnie Foxtrott

Johnnie Foxtrott

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
Hi macgirl,

if I followed your tutorial but only see this:

Posted Image

This is my setup:

Posted Image


Maybe you know what I'm doing wrong? I have got the Audigy 2ZS.

EDIT: I lately recognized that I can't uninstall soundflower (EXC_BAD_INSTRUCTION (SIGILL)) - wtf?

#14
macgirl

macgirl

    Stargate's Pharaoh

  • Retired
  • 7,612 posts
  • Gender:Female
  • Location:Mexico City
  • Interests:Techie gadgets
You need to select the sound card in order to the agregate device has outputs, see:
Attached File  Picture_7.jpg   71.02KB   510 downloads

#15
Johnnie Foxtrott

Johnnie Foxtrott

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
Hm thx for the reply, but how can I get xcode without registering at apple? I didn't find it in my System lol

#16
VCH888

VCH888

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 585 posts
Thank you for your guideline, especially pictures.

#17
downlord

downlord

    InsanelyMac Greek

  • Members
  • PipPipPip
  • 142 posts
  • Gender:Male
  • Location:Lisboa
Nice. Will try.

thank you

#18
dan0ne

dan0ne

    InsanelyMac Protégé

  • Members
  • PipPip
  • 50 posts
Works great with Audigy2 ZS! Thank you so much!!
Can it be that the sound is better than under Windows? I believe that it is clearer!
Here some Pics:
Posted Image
Posted Image

#19
kikko088

kikko088

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 251 posts
hello at all, exucese me for my english i try to follow this thread but when i select Soundflower there isn't any sound, all mute.
I upload my configuration, there is some one that can help me?


Posted Image
Posted Image


I have an alc 882


kikko088

#20
Oxtie

Oxtie

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 351 posts
hmmm, Sound flower output starts distorting after few minutes for me, Is it happening with anyone with 10k2 chip??? I'm talking about listening to music continuously for 1 hour or more (ofcourse you will notice distortion a lot earlier).

closing and reopening AU Lab + .trak file solves it (more like reloading). Am i the only one with this?





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   Web hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy