Jump to content

Dual Monitor Question: How can I disable the second monitor without unplugging it?


  • Please log in to reply
8 replies to this topic

#1
prodeguerriero

prodeguerriero

    InsanelyMac Protégé

  • Members
  • PipPip
  • 91 posts
  • Gender:Male
  • Location:Milano, Italy
Hi guys. I'm working on a Dual Screen setup with my machine. In windows, I have the chance to turn on and off the option to extend the desktop on one of the monitors. This way, if I don't need the second one, I disable it and turn it off.

In leopard, it seems I can't do so. If I turn off the monitor, which is the "extension" one, the OS keeps seeing it and behaves like it is still working. This means that I can't use Expos settings on that side of the screen and, worse, if I have left any window on the other side (it happens if you use spaces) i can't reach it anymore. The only way to fix this is to unplug the monitor. Even if this is a very easy thing to do on the MacBook, it is not on a Desktop machine.

Is there any way to fix this? It seems weird to me that Apple could have overseen such a small but important feature.

Cheers

#2
Maik-

Maik-

    InsanelyMac Protégé

  • Members
  • Pip
  • 25 posts
If you have the monitor thing in the menubar, there should be an option "detect monitors" (not sure about the translation), try that after unplugging.

#3
prodeguerriero

prodeguerriero

    InsanelyMac Protégé

  • Members
  • PipPip
  • 91 posts
  • Gender:Male
  • Location:Milano, Italy

If you have the monitor thing in the menubar, there should be an option "detect monitors" (not sure about the translation), try that after unplugging.


My issue is that I don't want to unplug the monitor, I'd like to enable/disable it via Leopard. It's kind of a pain in the butt having to unplug it every time. :D

#4
Adrian Fogge

Adrian Fogge

    InsanelyMac Legend

  • Donators
  • 794 posts
I have a very shocking suggestion for you...

You could press the power button on the second monitor.

~Adrian

#5
Astronomy

Astronomy

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts

I have a very shocking suggestion for you...

You could press the power button on the second monitor.

~Adrian


... /sigh...

Head into your System Preferences, and from there click "Displays" from the "Hardware" section. On your primary display you should see some resolution/color options (as well as on the secondary display). Click the "Arrangement" tab at the top and toward the bottom you will see a checkbox entitled "Mirror Displays". Tick this check-box and your extended-desktop will be disabled and you can simply switch the secondary screen off. Hope this helps.

Also: To help speed this process up to allow you to do this on-the-fly, head into the "Display" tab on your primary display. Check the box on the right side toward the bottom entitled "Show displays in menu bar". This will place an Icon to the left of your clock allowing you to turn mirroring on and off. From my short testing of this I have found mirroring being disabled to put some of the windows back the way I had them before switching it on, but nothing you should have an issue with since you seem to only want extended desktop some of the time (I have to have it on always or I go into a complex).

If this does not solve your particular problem, feel free to PM me about it and I will definitely attempt to find a working solution for you >.< (possibly a simple apple-script could do this).

#6
nieldm

nieldm

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
Hi there. May I ask if this was ever resolved? I have a related problem which is the most annoying thing. One time, as a test, several months ago, I connected my external PC monitor to my Powerbook (Leopard 10.5.6) DVI port. Now the settings will not go away and I have this "void" off to the right of my screen (or top, bottom or left depending on the arrangement) where it is assuming the second monitor is. If I hit F7 the screen switches to the "external" monitor. Often I have "lost" apps over there that I have to drag half was to the left then switch back to LCD.

I have tried a lot of things. Deleting the windowserver.plist file from /Library/Preferences, editing it to remove all references of the external display, Detect Display and so on. The best is with Mirror Displays, but that has the effect of causing the LCD, set to 1280x854, to have a couple of inches of black space around the edge of the screen. The phantom external display is set to TV with a max resolution of 1024x768 and looks terrible on my LCD.

System Profiler shows the external display as present, irrespective of the state of the windowserver.plist file, indicating it is getting it's information from somewhere else.....

I simply want to remove all reference to the external display but am at a total loss as to how I can achieve this. Can anyone help?

I would PAY for this information!!

Thanks
Marc

#7
gauvins

gauvins

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts

Hi guys. I'm working on a Dual Screen setup with my machine. In windows, I have the chance to turn on and off the option to extend the desktop on one of the monitors. This way, if I don't need the second one, I disable it and turn it off.

In leopard, it seems I can't do so. If I turn off the monitor, which is the "extension" one, the OS keeps seeing it and behaves like it is still working. This means that I can't use Expos settings on that side of the screen and, worse, if I have left any window on the other side (it happens if you use spaces) i can't reach it anymore. The only way to fix this is to unplug the monitor. Even if this is a very easy thing to do on the MacBook, it is not on a Desktop machine.

Is there any way to fix this? It seems weird to me that Apple could have overseen such a small but important feature.


Same thing here (a Cintiq used occasionally, and a 30" display as main monitor). None of the suggestions work. Mirroring "might" have been workaround if the Cintiq could support 2560x1600, but it doesn't.

Not trivial because from time to time I lose a window on the (ghost) Cintiq. It forces me either to go blindly fishing or turn the Cintiq on, drag the window on my main monitor and then turn the Cintiq back off.

Other than disabling the extended desktop, forcing windows to move to the main monitor (where the menu bar is located) would do just fine for me.

#8
Kludge420

Kludge420

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts

I have a very shocking suggestion for you...

You could press the power button on the second monitor.

~Adrian


I have a very shocking suggestion for you...

If you can't be bothered to read the question and don't have an answer keep your pie hole shut.

The answer is: SwitchResX

Once installed you have to enable the "enable/disable" context menu item in its system pane configuration settings. Then you can right click on the desktop of the monitor and chose the "Display is active" option. To re-enable the monitor click on the ScreenResX icon on the menu bar and click on "Display is active" again.

#9
prodeguerriero

prodeguerriero

    InsanelyMac Protégé

  • Members
  • PipPip
  • 91 posts
  • Gender:Male
  • Location:Milano, Italy

I have a very shocking suggestion for you...

If you can't be bothered to read the question and don't have an answer keep your pie hole shut.

The answer is: SwitchResX

Once installed you have to enable the "enable/disable" context menu item in its system pane configuration settings. Then you can right click on the desktop of the monitor and chose the "Display is active" option. To re-enable the monitor click on the ScreenResX icon on the menu bar and click on "Display is active" again.


Thanks mate! I'll try it!

And thanks to all of those who gave a smart a useful suggestion. :unsure:





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   Web hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy