Jump to content

[GUIDA] QE/CI CON ATI 2400PRO 2400XT 2600PRO 2600XT


  • Please log in to reply
76 replies to this topic

#21

  • Guests

Sono arrivato al punto 7..
il kext ATIRadeonX2000 che editor lo devo aprire per inserire l'id della mia scheda?

Grazie ;)

Sposti il kext sulla scrivania, click col tasto destro e scegli mostra contenuto del pacchetto. Clicca 2 volte col sinistro su Contents. Apri info.plist con textedit.

Quando hai modificato il kext, salva ed installalo con kexthelper (prima di installarlo con kexthelper, cancella quello in /System/Library/Extensions, se c' rimasto).

In bocca al lupo.

Se non dovesse funzionare, mi hanno segnalato che anche il secondo metodo, pi semplice, va con le 2600.

Ciao, Giorgio.

#22
Alessandro91

Alessandro91

    InsanelyMac Protégé

  • Members
  • PipPip
  • 88 posts
Ho fatto tutta la procedura..adesso nella sezione monitor in preferenze di sistema ho anche varie risoluzioni ma non riesco a trovare quella pi adatta al mio schermo.
Come faccio a vedere se l'ho installato correttamente?

In informazioni sul mio Mac mi dice che ho la ATI Radeon HD 2400 XT :D che non la mia scheda :)

Grazie :)

Ps
Provo il secondo metodo

#23

  • Guests

Ho fatto tutta la procedura..adesso nella sezione monitor in preferenze di sistema ho anche varie risoluzioni ma non riesco a trovare quella pi adatta al mio schermo.
Come faccio a vedere se l'ho installato correttamente?

In informazioni sul mio Mac mi dice che ho la ATI Radeon HD 2400 XT :D che non la mia scheda :)

Grazie :)

Ps
Provo il secondo metodo



No, non provare il secondo metodo, va tutto bene!!!!!!!!!!!!!!!!. Il fatto che ti dica 2400XT solo un fatto estetico, poi quando ho tempo te lo spiego. Guarda solo se hai Quartz Extreme attivato.

Non provare l'altro metodo, altrimenti combini un casino, bisogna prima cancellare delle cose, rischi di inchiodare il PC.

Poi non dire che non lo sapevi.

#24
Alessandro91

Alessandro91

    InsanelyMac Protégé

  • Members
  • PipPip
  • 88 posts

No, non provare il secondo metodo, va tutto bene!!!!!!!!!!!!!!!!. Il fatto che ti dica 2400XT solo un fatto estetico, poi quando ho tempo te lo spiego. Guarda solo se hai Quartz Extreme attivato.

Non provare l'altro metodo, altrimenti combini un casino, bisogna prima cancellare delle cose, rischi di inchiodare il PC.

Poi non dire che non lo sapevi.


L'ho letto troppo tardi questo post. Comunque per fortuna il secondo metodo ha funzionato ed ho ora anche il nome della mia scheda. L'unica incorrettezza l"XT" in quanto la mia una PRO ma se dici che solo un fatto estetico deduco che vada bene cos :D

Purtroppo mi dice Quartz Extreme:Non Supportata ed anche la risoluzione non corretta..
Che faccio?

Grazie ancora ;)

#25
clipt81

clipt81

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,808 posts
  • Gender:Male
  • Location:Palermo
  • Interests:NOTEBOOK: HP Pavilion DV9695el <br />Leopard retail 10.5.5<br />CPU: Intel Core2...
grazie giorgio della spiegazione...
sei stato chiarissimo ;)...

#26

  • Guests

L'ho letto troppo tardi questo post. Comunque per fortuna il secondo metodo ha funzionato ed ho ora anche il nome della mia scheda. L'unica incorrettezza l"XT" in quanto la mia una PRO ma se dici che solo un fatto estetico deduco che vada bene cos :D

Purtroppo mi dice Quartz Extreme:Non Supportata ed anche la risoluzione non corretta..
Che faccio?

Grazie ancora ;)


Quindi non va bene.

Quando hai provato il secondo metodo, hai tolto l'EFI string dal com.apple.Boot.plist?

Hai cancellato ATIRadeonX2000.kext e gli altri relativi ad ATI?

Col primo metodo, anche se ti diceva 2400XT, Quartz Extreme era atttivato?

#27
Alessandro91

Alessandro91

    InsanelyMac Protégé

  • Members
  • PipPip
  • 88 posts

Quindi non va bene.

Quando hai provato il secondo metodo, hai tolto l'EFI string dal com.apple.Boot.plist?

Hai cancellato ATIRadeonX2000.kext e gli altri relativi ad ATI?

Col primo metodo, anche se ti diceva 2400XT, Quartz Extreme era atttivato?


Non lo s, sinceramente non lo avevo guardato.
Comunque nel secondo metodo ho fatto quello scritto nella guida..nient'altro..quindi non ho cancellato nulla ne tolto l'efi string dalcom.apple.Boot.plist.
Mi s che mi conviene rifare il primo metodo e guardare se va :unsure:

#28

  • Guests

Non lo s, sinceramente non lo avevo guardato.
Comunque nel secondo metodo ho fatto quello scritto nella guida..nient'altro..quindi non ho cancellato nulla ne tolto l'efi string dalcom.apple.Boot.plist.
Mi s che mi conviene rifare il primo metodo e guardare se va :censored2:

Prima che tu vada avanti bisogna che tu abbia qualche concetto di base.

Per far funzionare una scheda video in Mac OSX occorrono 2 cose: i driver e gli injector.

Il driver nel nostro caso ATIRadeonX2000.kext (ovviamente diverso nei 2 metodi) e l'injector EFI string nel primo caso e Natit.kext nel secondo. NON SI POSSONO UTILIZZARE 2 Injector contemporaneamente, per cui se vuoi veder funzionare il secondo metodo devi cancellare la EFI string, e se vuoi far andare il primo eliminare Natit.kext. Inoltre per ottenere Quartz Extreme ci si appoggia su OpenGL.Framework, diverso tra i due metodi. Per cui a questo punto hai fatto talmente tanta confusione che non credo tu riesca a farne andare nessuno dei 2. E' per questo che nel primo post in neretto c' scritto di NON installare alcun driver video se si vogliono applicare i 2 metodi: sottinteso che sceltone uno si va avanti con quello.

Gi che ci siamo chiariamo la questione del modello di scheda grafica visualizzato da System Profiler.

La EFI string del primo metodo ottenuta dall'info.plist modificato di una 2400XT ed stata scritta perch indichi come modello la 2400XT (infatti appare 2400XT qualsiasi scheda venga impiegata sia 2400 pro o XT sia 2600 pro o XT); siccome un injector in grado di "inizializzare" il driver per tutte e 4 le schede, funziona con tutte: il driver, con dentro l'id della scheda che possiedi che determina la funzionalit della stessa: anche se indicata come 2400XT funzioner con la propria GPU, al proprio clock e con tutte le caratteristiche tecniche specifiche. Per questo solo un fattore estetico.

Efistudio non fa altro che tradurre in esadecimale le informazioni contenute in quell'info.plist originariamente destinato ad una 2400XT.

Spero di essere stato chiaro e che ti sia convinto che le nozioni di base servono per poter utilizzare correttamente gli strumenti messi a disposizione dal Sistema Operativo.

Ciao, Giorgio

#29
Alessandro91

Alessandro91

    InsanelyMac Protégé

  • Members
  • PipPip
  • 88 posts
Sei stato chiarissimo, davvero :)
Adesso ho la situazione pi chiara. Avevo intenzione di procedere cos:
- cancellare i file inseriti dal secondo pacchetto.
- installare il primo pacchetto 9f23.
- riparo i permessi-
- procedo con il primo metodo seguendo nuovamente la guida.

Che ne dici? O basta semplicemente che elimino l'EFI string, o Natit.kext?
Grazie ancora per l'aiuto e per la gentilezza :)

#30

  • Guests

Sei stato chiarissimo, davvero :)
Adesso ho la situazione pi chiara. Avevo intenzione di procedere cos:
- cancellare i file inseriti dal secondo pacchetto.
- installare il primo pacchetto 9f23.
- riparo i permessi-
- procedo con il primo metodo seguendo nuovamente la guida.

Che ne dici? O basta semplicemente che elimino l'EFI string, o Natit.kext?
Grazie ancora per l'aiuto e per la gentilezza :)

Procederei come hai detto tu, cancellando tutto. Elimina anche EFI string da com.apple.Boot.plist e reinstallala.

In bocca a lupo. Buon Natale a te e famiglia, Giorgio.

#31
Alessandro91

Alessandro91

    InsanelyMac Protégé

  • Members
  • PipPip
  • 88 posts
Ho fatto danno. Ho cancellato i files, sono andato ad aprire il package ma non si avviava e quindi ho deciso di spengere il pc. Adesso non parte pi, si blocca al caricamento con la schermata della mela e la rotellina che gira. Vi scrivo da windows ora.
Come faccio a ripristinare? :P

Grazie..Buon Natale anche a te ;)

#32

  • Guests

Ho fatto danno. Ho cancellato i files, sono andato ad aprire il package ma non si avviava e quindi ho deciso di spengere il pc. Adesso non parte pi, si blocca al caricamento con la schermata della mela e la rotellina che gira. Vi scrivo da windows ora.
Come faccio a ripristinare? :)

Grazie..Buon Natale anche a te :)

Reinstalli, troppo caos coi kexts

Auguri anche a te.

#33
Alessandro91

Alessandro91

    InsanelyMac Protégé

  • Members
  • PipPip
  • 88 posts

Reinstalli, troppo caos coi kexts

Auguri anche a te.


Tutto l'OS? :(

#34

  • Guests
Purtroppo si

#35
Alessandro91

Alessandro91

    InsanelyMac Protégé

  • Members
  • PipPip
  • 88 posts

Purtroppo si


Reinstallato ;)

#36
Alessandro91

Alessandro91

    InsanelyMac Protégé

  • Members
  • PipPip
  • 88 posts
un mistero questa scheda video.
Ho installato seguendo il punto due della guida il pacchetto e al riavvio il QE era supportato. Porto a termine la guida e al riavvio il QE non supportato.
Cosa faccio?..

Grazie

#37
clipt81

clipt81

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,808 posts
  • Gender:Male
  • Location:Palermo
  • Interests:NOTEBOOK: HP Pavilion DV9695el <br />Leopard retail 10.5.5<br />CPU: Intel Core2...
se gi il qe lo avevi attivo nn dovevi proseguire oltre....
perch lo hai fatto??? lo scopo della guida attivare QE/CI, ma se riesci prima fermati, no????

#38
Alex57

Alex57

    InsanelyMac Protégé

  • Members
  • PipPip
  • 57 posts
oh alleluia sono riuscito a trovare una guida e qualcuno che potrebbe aiutarmi.
allora: Giorgio chiedo a te dato che la guida e tua e spero riesci ad aiutarmi.. ho una ATI Radeon HD2350 che se non erro una derivata della 2400 (non ne sono sicuro)
ho provato il 2 procedimento ma non ci sono riuscito, volevo provare anke il primo ma meglio evitare prima ke sputtano tutto xD
preferisco chiedere a esperti in campo mac prima di fare qualche casino.
potresti spiegarmi cosa devo fare? perch se voglio emulare un OS come winzozz su mac non posso ;)

ps. sono entrato da poco in campo mac

se puo servire ecco info su grafica/monitor:

Monitor:

Tipo: Monitor
Bus: PCIe
Larghezza Lane PCIe: x16
VRAM (totale): 256 MB
Fornitore: ATI (0x1002)
ID dispositivo: 0x94c7
ID revisione: 0x0000
Informazioni su estensione Kernel: Nessun Kext caricato
Monitor:
Monitor:
Risoluzione: 1024 x 768
Profondit: Colore 32-bit
Core Image: Software
Monitor principale: S
Mirror: Spento
Online: S
Quartz Extreme: Non Supportata

spero puoi aiutarmi e scusa il disturbo :)


#39
Alessandro91

Alessandro91

    InsanelyMac Protégé

  • Members
  • PipPip
  • 88 posts

se gi il qe lo avevi attivo nn dovevi proseguire oltre....
perch lo hai fatto??? lo scopo della guida attivare QE/CI, ma se riesci prima fermati, no????


Perch ancora nn sono riuscito a trovare la risoluzione adatta per il mio monitor e speravo che si aggiustasse tutto.
:lol:

#40

  • Guests

se gi il qe lo avevi attivo nn dovevi proseguire oltre....
perch lo hai fatto??? lo scopo della guida attivare QE/CI, ma se riesci prima fermati, no????



Giustissimo, Clipt; lo stesso discorso che ho fatto a 2 utenti che ho aiutato per PM, uno italiano e d uno del Forum internazionale, anche loro avevano ottenuto QE/CI al 2 passaggio con delle 2600: ovviamente ho consigliato di fermarsi: evidentemente le 2600 vanno benone con il framebuffer Iago e non hanno nessun bisogno del Megalodon.

Ad alex57: purtroppo non ho esperienza sulla 2350 (posto solo i risultati testati personalmente da me, come sulle 2400, o da utenti fidati, come per le 2600, per adesso nessuna notizia della 2350).

Inoltre chi ottiene un successo con schede di questa guida sarebbe meglio che postasse anche sul Topic specifico delle schede video, per poter aiutare altri con gli stessi problemi.

Saluti, Giorgio.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy