Jump to content

›› Voodoo XNU Kernel is now Released


  • Please log in to reply
560 replies to this topic

Poll: Voodoo kernel release (1279 member(s) have cast votes)

Has Voodoo kernel been working well for you?

  1. Yes (1066 votes [83.35%])

    Percentage of vote: 83.35%

  2. No (213 votes [16.65%])

    Percentage of vote: 16.65%

On which processor do you use this kernel?

  1. Intel (849 votes [65.16%])

    Percentage of vote: 65.16%

  2. AMD (454 votes [34.84%])

    Percentage of vote: 34.84%

Did you use the installer or installed manually?

  1. Manually (397 votes [31.04%])

    Percentage of vote: 31.04%

  2. Installer, worked well (782 votes [61.14%])

    Percentage of vote: 61.14%

  3. Installer, but didn't work well (100 votes [7.82%])

    Percentage of vote: 7.82%

Vote Guests cannot vote

#541
Schwinn555

Schwinn555

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 151 posts
Azimutz, followed your info and it's now running your 9.8 kernel. All seems fine. Odd how they locked it on that one kernel.
I see I now have the infamous com.apple.don't stealmac osx.kext must be from using the Apple Mac OSX combo download for 10.5.8. I normally wait for a fixed file. I'm guessing remembering I should toss the above .kext? Doesn't seem to be doing any harm but does show up in the log files as being present. thanks for your help & the file.

#542
Azimutz

Azimutz

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 759 posts
  • Gender:Male
  • Location:Almadan - Pt.
  • Interests:At the moment, OSx86.. In general, music, audiophile, computers.. to much to mention...
Ok, nice ;) So, no problems with network and mouse?
You shouldn't have "Dont Steal Mac OS X.kext" loaded!! How did you checked that? hum.. the kernel keeps it from loading unless you disable "kext blacklisting" and it's not disabled on you Boot.plist.
AppleHWSensor.kext and AppleIntelCPUPowerManagement.kext are also blocked.
Go to System Profiler->Extensions or better.. open Terminal and type: kextstat
..if you don't see those kexts there, they are not loaded.
Anyway, i don't use the blacklist thing.. i only block AppleIntelCPUPowerManagement.kext and i don't have problems with those kexts loaded. But, that's me.. on your system maybe different.. only you can determine that.

About the "custom" thing.. it must point to another file or something. That must have been set by iAtkos installer, i think?!
Check the "readme" on iAtkos for something on it.. i really don't know nothing about that. That's the problem about using "distros" and not knowing what they do!

Check these things and pm me.. i'll give you some tips if you want/need ;)
See ya

#543
skn

skn

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 214 posts
  • Gender:Male

p.s.: Don't ask me for diff file because i don't know how to do it ;) and really, it would only show you my name and Apple's updates.


That's the easiest part: :D

Let's say the original files are in the "kernel.original" directory and your modified files in the "kernel.azimutz" directory. Just type:

$ diff -Naur kernel.original kernel.azimutz >patch.diff


That's it!

By the way, it would be nice if you provided the patch/sources in order to comply with APSL license, even if the changes are minimal.

Thanks for your kernel!!!

#544
Azimutz

Azimutz

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 759 posts
  • Gender:Male
  • Location:Almadan - Pt.
  • Interests:At the moment, OSx86.. In general, music, audiophile, computers.. to much to mention...
Hi skn.. you're right :) i've been messing with it yesterday, it's almost done. I do got into some troubles but, i think you tip is going to help. I didn't got to the -naur part. Thanks for that, very much!
Probably will post them today... let's see if i can stay awake :)

Hey, no need to thank.. it's not really mine. For me it's just Voodoo updated ;)

EDIT: diff added :)

#545
skn

skn

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 214 posts
  • Gender:Male

Thanks for that, very much!


You are welcome Azimutz! :D And thanks again for the patches!

#546
dj nitehawk

dj nitehawk

    InsanelyMac Protégé

  • Members
  • PipPip
  • 96 posts
omg 10.6 kernel source has been released:

http://www.opensourc.../xnu-1456.1.26/

can we haz voodookernel for snow leo pleeeeeeaze?

keep up the good work!!!

#547
jwebb

jwebb

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts
Attached File  IMG_0231.JPG   867KB   118 downloads
Here is my kernel panic screen.
Happened when i was downloading a dmg file. It just finished and started to mount.

anyway

I have more luck with alpha3 release. Works just fine.

edit: Ugh, no sleep...
Trying to solve problem with 9.5 kernel by installing different seatbelt.kext.
brb
:)

#548
jwebb

jwebb

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts

edit: Ugh, no sleep...
Trying to solve problem with 9.5 kernel by installing different seatbelt.kext.


Solved. :)

#549
ptesone

ptesone

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 231 posts
Had to revert back to 9.5 kernel to install iLife '09 and Xcode 3.0, other than the kernel panics from those and VMWare, it ran great. . .

I'm using a retail install with ChameleonRC2 on the EFI

#550
Bekenn

Bekenn

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
The Voodoo 1.0 release (9.5 kernel) seems to be causing my machine to spontaneously reboot during startup.

I'm using an Asus M4A79T Deluxe motherboard with a Phenom II 955 and DDR3 memory. I started by installing LawlessPPC (10.5.4) (after patching it with the SB700 kexts). Once that was up and running (and before doing anything else), I installed the Voodoo kernel using the installation package. On rebooting, the machine just reboots during startup, fairly soon in the process.

I've also tried installing iPC, iATKOS, and iDeneb releases with the same issue (that is, the install DVD reboots during startup -- I never managed to get into the installer with these releases).

Any ideas?

#551
andrewq2

andrewq2

    InsanelyMac Protégé

  • Members
  • PipPip
  • 98 posts

The Voodoo 1.0 release (9.5 kernel) seems to be causing my machine to spontaneously reboot during startup.

I'm using an Asus M4A79T Deluxe motherboard with a Phenom II 955 and DDR3 memory. I started by installing LawlessPPC (10.5.4) (after patching it with the SB700 kexts). Once that was up and running (and before doing anything else), I installed the Voodoo kernel using the installation package. On rebooting, the machine just reboots during startup, fairly soon in the process.

I've also tried installing iPC, iATKOS, and iDeneb releases with the same issue (that is, the install DVD reboots during startup -- I never managed to get into the installer with these releases).

Any ideas?


You are tring to install a 10.5.5 kernel on a 10.5.4 system, update to 10.5.5 to use voodoo 9.5

#552
svencux

svencux

    InsanelyMac Protégé

  • Members
  • PipPip
  • 50 posts
  • Location:Germany

Solved. :)


he jwebb,

how did you solve the sleep issue ?
I do have same issue. Other than that alle is fine.

#553
nmarques

nmarques

    InsanelyMac Protégé

  • Members
  • Pip
  • 25 posts
If there is the need to help in translations from documentation to Portuguese (Portugal) I can help with those. I've done in the past the translations of linux kernel video devices documentation and I also was in charge of the old PLUG (Portuguese Linux Users Group) Documentation (PLUG doesn't exist anynome, now it's just linux.pt).

Drop me a message.

#554
gorrit

gorrit

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts
I have 10.5.6 installed, and when I am using the StageXNU 9.4.0 kernel my nVidia Geforce 6600 PCI works fine (with everything enabled etc) but when I switch to the Voodoo 9.5.0 kernel, my graphics card doesn't work. Has anyone else experienced this?

#555
kocoman

kocoman

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 325 posts

I have 10.5.6 installed, and when I am using the StageXNU 9.4.0 kernel my nVidia Geforce 6600 PCI works fine (with everything enabled etc) but when I switch to the Voodoo 9.5.0 kernel, my graphics card doesn't work. Has anyone else experienced this?


"how" does it not work? no acceleration?

#556
TheVamp

TheVamp

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
Great work. ==b
Thanks a lot

#557
mucha

mucha

    InsanelyMac Protégé

  • Members
  • Pip
  • 26 posts
  • Gender:Male
i want to post my little contributions, it's a patch fixing the kernel panic
Local Apic Error , ESR 64\n"@/sourcecache/xnu/xnu-1228.15.4/osmfk/i386/lapic.c
that occur when booting without the cpus=1 boot flags in Pavilion dv6 and dv7 Series Laptops.
This is a BIOS bug specific to those serie and may be some other Models too !
unlike the Apocolypse fix that just redirect the output message for the error which is still there with this patch there is no more error.

Some explanation:
I have discovered that's the error ESR 64 is due to improper setting for LVT_INT0 and LVT_INT1 (32-bit registre of LVT Local Vector Table in the Local apic,
you can found the reference in Intel® 64 and IA-32 Architectures Software Developer’s Manual Volume 3A: System Programming Guide, Part 1, Chapter 10.5: Handling Local Interrupts, available for free download from intel website)
LVT_INT0, LVT_INT1 are both reported as being Vector=0x00, Delivery Mode=Fixed, Polarity=Hight, Trigger Mode=Edge, Mask=1 for ExtINT and 0 for NMI
browsing throught some apic source code for Linux, OpenSolaris and FreeBSD i have found that
Trigger Mode should be set to ExtINT for LVT_INT0 and to NMI for LVT_INT1.
i have added the proper setting in the lapic_configure() function of the lapic.c file
in the attachement you have the patched lapic.c and the diff file against the original lapic.c
NB: lapic.c file is from xnu-1228.15.4 source code for Leopard 10.5.8
and here is the link for a patched kernel for leopard 10.5.8 (for testing purpose)
[codebox]http://www.megaupload.com/?d=8HA6VVI9[/codebox]

Attached Files



#558
0CLY450

0CLY450

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
please help me!

i'm trying to install OSx 10.5.6 on my laptop Toshiba Satellite L505D with windows 7 installed. partitions already created.
after reboot i get this panic attack. i've read HCl wikis and i know my processor is not listed. is there a workaround?

Laptop specs:

AMD athlon x2 QL-65 64bit 2.1ghz
3gb ram
SSE(1,2,3)
insyde H20 1.40 bios.
ATI HD3100

i tried using cpus=1 and acpi=off but i still get the Local APIC error.

Attached Files



#559
james21

james21

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 5 posts
How do you install these patches?

#560
Recon 023

Recon 023

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts
Voodoo kernel 1 for leo works fine with my Pentium D. I'm wating for snow now





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy