Jump to content

Photoshop CS4 OpenGL Performance


  • Please log in to reply
18 replies to this topic

#1
B612

B612

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 463 posts
Hey guys.
Have you noticed about Photoshop CS4 having performance issues with 256 Mb NVidia GPU?
The images don't refresh properly, they get black, they return normal after clicking out of their frame, they become difficult to work with, unless you deselect "use OpenGL", from the Preferences of Photoshop CS4.

Well, my MacBook Pro has also 256 Mb of GPU, but it works perfect. This means that the issue I'm having with my desktop PC may depend on NATIT.kext, or on the EFI strings I inserted in com.apple.boot.plist.

Does anybody know how to solve this?
Thank you!

(PS: you can see my specs from my signature).

#2
Synaesthesia

Synaesthesia

    InsanelyMacaholic

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,168 posts
  • Gender:Male
  • Location:South Africa
Um, just a thought here. If you are using EFI strings, you can remove Natit.kext, I mean, you either run one or the other...not both. So try removing Natit.kext + rebuilding your extensions....

#3
B612

B612

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 463 posts

Um, just a thought here. If you are using EFI strings, you can remove Natit.kext, I mean, you either run one or the other...not both. So try removing Natit.kext + rebuilding your extensions....


It's not that. :(
I've tried the three options:
1) Only Natit.kext;
2) Only EFI Strings;
3) Both

But nothing has changed. I saw on the Net that I'm not the only one having this problem with Photoshop CS4. The others have "solved" it by just disabling OpenGL drawing, but there must be another way to solve this issue!
Other ideas? :)

#4
B612

B612

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 463 posts
up

#5
Lukather

Lukather

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts
  • Gender:Male
B612, I have no ideas... I have same problem with my NVidia 7600 series video card... :)

#6
inimicus

inimicus

    Drunk and Angry Slurs in 31 Flavors

  • Members
  • PipPipPipPipPipPip
  • 473 posts
  • Gender:Male
  • Location:Sacramento, CA
Ditto. Transformations do not happen on the canvas... I can only see the transform in real time in the preview window.

#7
B612

B612

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 463 posts
I think we should try to find a kext other than Natit or EFI strings, to produce better QE performance.
So far, no success. I've tried NVdarwin, NVkush, NVinject, but all of these kexts gave me no QE at all.
Please keep us updated if you have any results.

#8
Lukather

Lukather

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts
  • Gender:Male
Hmm... Sometimes I think the best solution would be to buy a new (full compatible) video card...

#9
rhyguy

rhyguy

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 204 posts
I have an 8600gt 256mb Nvidia card, and using efi strings in 10.5.6, i have no problems with photoshop cs4

it might just be your card

#10
B612

B612

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 463 posts

Hmm... Sometimes I think the best solution would be to buy a new (full compatible) video card...


That would not be a solution. That would be surrender...
If I have to buy a new card, I would first solve this problem and then buy a new one, after I'm satisfied.

#11
jricks92

jricks92

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 104 posts
  • Gender:Male
  • Location:Up the street
a NVidia 8800 GTS 320mb card is only like $75 on ebay. Thats where i got mine and it works fantastic with the entire CS4 Suite. Its very fast too! with openmark i get about 3200fps.

#12
Lukather

Lukather

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts
  • Gender:Male

I have an 8600gt 256mb Nvidia card, and using efi strings in 10.5.6, i have no problems with photoshop cs4

it might just be your card


Yes, it is for my younger brother and for him work perfect...

#13
socate

socate

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
Hi All,

In the image attached it's described the solution. This setting work perfect for me!

don't forget to restart photoshop before test!

Attached Files



#14
B612

B612

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 463 posts

Hi All,

In the image attached it's described the solution. This setting work perfect for me!

don't forget to restart photoshop before test!


Thank you so much. You saved my Photoshop CS4! :rolleyes:

#15
lord_muad_dib

lord_muad_dib

    InsanelyMacaholic

  • Retired
  • 3,398 posts
  • Gender:Male
  • Location:italy
maybe it's something missing on nvidia 7 series gpu, i have to test it on mine too

#16
gabby

gabby

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts

Hi All,

In the image attached it's described the solution. This setting work perfect for me!

don't forget to restart photoshop before test!



Thanks, work fine for me.

#17
Aquar1us

Aquar1us

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts

Hi All,

In the image attached it's described the solution. This setting work perfect for me!

don't forget to restart photoshop before test!


Hey, that's great, this problem had been causing me a few headaches, I can now put the painkillers away :(

#18
remrk

remrk

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts

Hi All,

In the image attached it's described the solution. This setting work perfect for me!

don't forget to restart photoshop before test!


thank you ...thank you..thank you

#19
mcloverkazh

mcloverkazh

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
Socate, thnx!!





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy