Jump to content

Atheros AR5007 working but not perfect. Heres the guide.


  • Please log in to reply
429 replies to this topic

#281
mimminito

mimminito

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
thanks ;) will give it a go soon. now to get trackpad sorted again!

#282
jy371

jy371

    InsanelyMac Protégé

  • Members
  • Pip
  • 43 posts

Hi,
Well, it has to be .......... There is actually a couple of ways to lower down CPU temperature & one of it is using VoodooPower by Superhai. It provide speedstep functionality.
Good luck. :)
kizwan

kizwan,

Thank you very much for the information that let me know more about my installation.
Indeed, I have DSDT patched and IntelCPUPowerManagement works fine. Only at cold boot, it may cause kernel panic and/or no fan running. Reboot with -f can ratify the issue.

#283
shoesy

shoesy

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
Seriously guys - just replace the damn card! Its really easy to do, airport just works, no kismac! I really would recommend it. Follow tnkgrls instructional video and you are all set.

As they say accross the pond - just my 2c worth. at the current exchange rate that works out at around 2 penneth.

#284
DennisDee

DennisDee

    InsanelyMac Protégé

  • Members
  • Pip
  • 22 posts
Hi @ all

Will this guide help me with my Atheros AR8121/AR8113/AR8114 PCI-E Ethernet Controller wich i have on my notebook Acer 6930? I have iPC 10.5.6 distro on my notebook, dual boot with Vista.

#285
microsnakey

microsnakey

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 5 posts
I am a real osx n00b (only installed it today) on my a150.
How come I cant extract the a150 drivers zip

#286
HaTaX

HaTaX

    InsanelyMac Protégé

  • Members
  • Pip
  • 36 posts
Noticed it doesn't extract using the archive utility either, use another extractor like unrarx or pacifist to extract it instead.

#287
HaTaX

HaTaX

    InsanelyMac Protégé

  • Members
  • Pip
  • 36 posts

hi guys thank you very much for your work
got an acer aspire one a150X
iatkos 10.5.6

wlan works perfect now with kismac scan first

THX to All of you worked on it :D


Perhaps you could post the kexts you're currently using and which kernel you're on as well? Been fighting with an iATKOS v5 install updated to 10.5.6 that is using the 9.5.0 Voodoo Kernel. Also if it's of any help, this setup guide was followed:
http://www.aspireone...a686c082dc2d3dc

Anyway, tried all the kexts and when scanning if something does come up, it's an odd <any ssid> entry that just fills up with packets, but is not finding any SSIDs..

Would love to see the Acer One users start posting their working configs and kexts!

#288
l_uke

l_uke

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts

Anyway, tried all the kexts and when scanning if something does come up, it's an odd <any ssid> entry that just fills up with packets, but is not finding any SSIDs..

I have exactly same situation ;)

#289
Guldan

Guldan

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
  • Gender:Male
  • Location:Finland
i got Acer one and did exactly what is read at the begining of this topic and i used same kext + i edited com.apple.boot.plist and added -f there like this:

<key> Kernel </ key>
<string> mach_kernel </ string>
<key> Kernel Flags </ key>
<string>-f </ string>

everything is working perfectly; booting, first opening KisMac -> scan and after that i choose wifi connection.

I got xxx 10.5.5 with ppf1,2,3 and speedkernel. i will try next week new xxx 10.5.6 with ppf1 and voodoo kernel, hope i get wifi working again :)

#290
walterav

walterav

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 209 posts
Kismac method:

Kismac ships with its own driver if i'm not mistaken. There must be a kext file 'or serveral' within the app package of kismac...
This is the driver we need! Is it possible to extract the right kext from the kismac package and put it in system library extensions, or script the thing to load from a different place during boot or unload the thing during shutdown?

Therefore we might not need to load kismac etc... can anyone try this?

copy kext in desktop folder "kismacextract", in terminal go to desktop folder "kismacextract"
chown -R 0:0 *
chmod -r 755 *
kextload xxxxkismac.kext ?

#291
MacKing

MacKing

    InsanelyMac Protégé

  • Members
  • Pip
  • 28 posts
  • Gender:Male
  • Location:Malta, Europe
Hi guys I got this card by mistake (the AR5007EG) on this ASUS F3Jc and it is working quite good. But I have a weird problem... This is that I cannot connect to unsecured (no password required) networks.. while connecting to WEP/WAP enabled networks is not a problem, apart from that everything works fine, ad-hoc, internet sharing through airport...

Is anyone else having the same situation?

#292
The Jack of Clubs

The Jack of Clubs

    InsanelyMac Protégé

  • Members
  • Pip
  • 47 posts
anybody know how or if this can work on 10.5.6 with vanila kernel (9.6.0)?

edit: nevermind i figured out what my problem was. i needed to go into system prefs first and it comes up with a message basically saying "hit apply" to get it enabled and it works after that. i feel a bit of a tard.

#293
The Jack of Clubs

The Jack of Clubs

    InsanelyMac Protégé

  • Members
  • Pip
  • 47 posts
it worked but only worked one time. i cant get it to connect again. i tried reloading the kext and doing all the repair things and booting with -f and nothing is working. the menu bar item keeps saying no airport installed and i hitting the turn on button in sys prefs isnt working. kismac isnt pulling up anything on scans. dunno what im doing wrong.

#294
MacKing

MacKing

    InsanelyMac Protégé

  • Members
  • Pip
  • 28 posts
  • Gender:Male
  • Location:Malta, Europe

it worked but only worked one time. i cant get it to connect again. i tried reloading the kext and doing all the repair things and booting with -f and nothing is working. the menu bar item keeps saying no airport installed and i hitting the turn on button in sys prefs isnt working. kismac isnt pulling up anything on scans. dunno what im doing wrong.


Sometimes it does that also for me... where kismac starts to hang and sometimes doesn;t detect any wireless routers (when I am pretty sure that there is)... What I do I just restart until it works...(sometimes even 4 restarts after each other) so don't give up immediately

#295
daptrader

daptrader

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
Nice this just worked on my Acer AOA 110. Thanks a million guys!

#296
Guldan

Guldan

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
  • Gender:Male
  • Location:Finland
Ok, now i have tested xxx 10.5.6 + ppf1 and voodoo 9.5 v1.0 kernel... and i didnt succeed to get wifi working. i think problem is that u cant use extreme airport update, case it is only for 10.5.5 version mac os. so i tryend edit vendor id and many differend IO80211Family.kext's etc...

i will try now new istallation with TOH sleep kernel... lets see if i have to go back to 10.5.5 :S

#297
MacKing

MacKing

    InsanelyMac Protégé

  • Members
  • Pip
  • 28 posts
  • Gender:Male
  • Location:Malta, Europe
Hey Guys, after one week trying to get the AR5007EG to work on unsecured networks I gave up and went to a Dell computer store and got a DW1940 (Broadcom 4311a/b/g). I installed this new card and my laptop immediately is having a full airport extreme experience with Leopard 10.5.6...

Also I would like to report that the softkey of turning on wifi/bluetooth works flawless.

#298
The Jack of Clubs

The Jack of Clubs

    InsanelyMac Protégé

  • Members
  • Pip
  • 47 posts
where did you get your card from? think ima just void the warranty and switch out the cards.

#299
MacKing

MacKing

    InsanelyMac Protégé

  • Members
  • Pip
  • 28 posts
  • Gender:Male
  • Location:Malta, Europe

where did you get your card from? think ima just void the warranty and switch out the cards.


I got this card from Malta...from our Dell Agent. You can either choose a DW1390 or DW1490 the difference is DW1390 is b/g and DW1490 is a/b/g. Both of them run on Broadcom 4311 chipset. Or else if you don't would like a card with a brand name just check on ebay for a Broadcom 4311. A good product and seller check this link below:

http://cgi.ebay.co.u...Vie...s=I&otn=1

#300
Zetsubou

Zetsubou

    InsanelyMac Protégé

  • Members
  • Pip
  • 37 posts
well i had my card working on my AAO, but after a restart or two it has stopped working
Install with 10.5.6 with voodoo kernel.
Anyone tell me if i would have better luck with 10.5.5?





1 user(s) are reading this topic

1 members, 0 guests, 0 anonymous users


© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy